]> git.pld-linux.org Git - packages/thunderbird.git/blame - thunderbird.spec
- removed obsolete patches
[packages/thunderbird.git] / thunderbird.spec
CommitLineData
c4ddd260 1# TODO:
283702b9 2# - build with system mozldap
c4ddd260 3#
44be9ed4 4# Conditional builds
3366507a 5%bcond_with gtk3 # GTK+ 3.x instead of 2.x
44be9ed4 6%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 7%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 8%bcond_with xulrunner # system xulrunner
765a3a27 9%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
a97d3356
JR
10# - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
11%bcond_with shared_js # shared libmozjs library [broken]
88149483 12
f4114a7f 13%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
14%undefine crashreporter
15%endif
16
62096d2c 17%define nspr_ver 4.10.6
3a30e2d7 18%define nss_ver 3.19.2.1
44be9ed4 19
62096d2c 20%define xulrunner_ver 2:31.3.0
4f34f106 21
7d981f69
ER
22%if %{without xulrunner}
23# The actual sqlite version (see RHBZ#480989):
24%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25%endif
26
cae5b55b
JR
27Summary: Thunderbird - email client
28Summary(pl.UTF-8): Thunderbird - klient poczty
29Name: thunderbird
7a5e9406
JR
30Version: 45.8.0
31Release: 0.1
3366507a 32License: MPL v2.0
2d289b25 33Group: X11/Applications/Mail
cae5b55b 34Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/%{name}-%{version}.source.tar.xz
7a5e9406 35# Source0-md5: 4e04b1618273f946f00f8ea547578895
44be9ed4 36Source4: %{name}.desktop
37Source5: %{name}.sh
4b2ee400 38Patch2: prefs.patch
f53f9bcd 39Patch6: no-subshell.patch
f53f9bcd 40Patch8: enable-addons.patch
7a5e9406 41Patch9: mozilla-1269171-badalloc.patch
cae5b55b 42URL: http://www.mozilla.org/projects/thunderbird/
6458b220 43BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 44BuildRequires: alsa-lib-devel
44be9ed4 45BuildRequires: automake
51a3b6db 46BuildRequires: bzip2-devel
e820c55e
JB
47BuildRequires: cairo-devel >= 1.10
48BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 49BuildRequires: freetype-devel >= 1:2.1.8
6f32f966 50BuildRequires: glib2-devel >= 1:2.20
d0b96b40
JR
51BuildRequires: gstreamer0.10-devel
52BuildRequires: gstreamer0.10-plugins-base-devel
3366507a
JB
53%{!?with_gtk3:BuildRequires: gtk+2-devel >= 2:2.14}
54%{?with_gtk3:BuildRequires: gtk+3-devel >= 3.0.0}
5e9bb798 55BuildRequires: hunspell-devel
44be9ed4 56BuildRequires: libIDL-devel >= 0.8.0
d0b96b40 57BuildRequires: libevent-devel
9b89aca5 58BuildRequires: libicu-devel >= 50.1
51a3b6db 59BuildRequires: libiw-devel
e82da7a1 60# requires libjpeg-turbo implementing at least libjpeg 6b API
44be9ed4 61BuildRequires: libjpeg-devel >= 6b
e82da7a1 62BuildRequires: libjpeg-turbo-devel
e820c55e 63BuildRequires: libpng-devel >= 1.4.1
44be9ed4 64BuildRequires: libstdc++-devel
cae5b55b 65BuildRequires: libvpx-devel >= 1.3.0
d0b96b40 66BuildRequires: mozldap-devel
f4114a7f
ER
67BuildRequires: nspr-devel >= 1:%{nspr_ver}
68BuildRequires: nss-devel >= 1:%{nss_ver}
62096d2c 69BuildRequires: pango-devel >= 1:1.22.0
e820c55e 70BuildRequires: perl-base >= 1:5.6
1c62cadb 71BuildRequires: pkgconfig
e820c55e 72BuildRequires: python >= 1:2.5
cae5b55b 73BuildRequires: python-virtualenv
44be9ed4 74BuildRequires: sed >= 4.0
62096d2c 75BuildRequires: sqlite3-devel >= 3.8.4.2
1c62cadb 76BuildRequires: startup-notification-devel >= 0.8
ffb12c8e 77BuildRequires: virtualenv
44be9ed4 78BuildRequires: xorg-lib-libXext-devel
44be9ed4 79BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 80BuildRequires: xorg-lib-libXt-devel
5745d706 81BuildRequires: yasm
1c62cadb 82BuildRequires: zip
7d981f69 83%if %{with xulrunner}
62096d2c 84BuildRequires: xulrunner-devel < 2:32
cae5b55b 85BuildRequires: xulrunner-devel >= %{xulrunner_ver}
7d981f69 86%else
6f32f966 87Requires: glib2 >= 1:2.20
3366507a
JB
88%{!?with_gtk3:Requires: gtk+2 >= 2:2.14}
89%{?with_gtk3:Requires: gtk+3 >= 3.0.0}
62096d2c 90Requires: libvpx >= 1.3.0
44be9ed4 91Requires: myspell-common
f4114a7f
ER
92Requires: nspr >= 1:%{nspr_ver}
93Requires: nss >= 1:%{nss_ver}
62096d2c 94Requires: pango >= 1:1.22.0
4b6bc367 95Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 96%endif
4f34f106
ER
97Requires(post): mktemp >= 1.5-18
98%if %{with xulrunner}
99%requires_eq_to xulrunner xulrunner-devel
100%endif
e82da7a1 101Requires: libjpeg-turbo
44be9ed4 102Obsoletes: mozilla-thunderbird
103Obsoletes: mozilla-thunderbird-dictionary-en-US
cae5b55b 104Conflicts: thunderbird-lang-resources < %{version}
44be9ed4 105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
9e366f18
AM
107%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
108
cae5b55b 109# firefox/thunderbird/seamonkey provide their own versions
44be9ed4 110%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
111%if %{without xulrunner}
112# we don't want these to satisfy packages depending on xulrunner
6f32f966 113%define _noautoprov libmozalloc.so libmozjs.so libxul.so
44be9ed4 114# and as we don't provide them, don't require either
6f32f966 115%define _noautoreq libmozalloc.so libmozjs.so libxul.so
fb7d4f06 116%endif
44be9ed4 117
7a5e9406 118%define topdir %{_builddir}/thunderbird-%{version}
9e7875fc
ER
119%define objdir %{topdir}/obj-%{_target_cpu}
120
44be9ed4 121%description
cae5b55b 122Thunderbird is an open-source, fast and portable email client.
44be9ed4 123
124%description -l pl.UTF-8
cae5b55b 125Thunderbird jest mającym otwarte źródła, szybkim i przenośnym klientem
6b327de6 126poczty.
44be9ed4 127
6578c165 128%package addon-lightning
cae5b55b
JR
129Summary: An integrated calendar for Thunderbird
130Summary(pl.UTF-8): Zintegrowany kalendarz dla Thunderbird
6578c165 131License: MPL 1.1 or GPL v2+ or LGPL v2.1+
132Group: Applications/Networking
133Requires: %{name} = %{version}-%{release}
134
135%description addon-lightning
cae5b55b 136Lightning is an calendar extension to Thunderbird email client.
6578c165 137
138%description addon-lightning -l pl.UTF-8
cae5b55b 139Lightning to rozszerzenie do klienta poczty Thunderbird dodające
6578c165 140funkcjonalność kalendarza.
141
44be9ed4 142%prep
cae5b55b 143%setup -q
f53f9bcd 144%patch2 -p1
983562b1 145%patch6 -p1
f53f9bcd 146%patch8 -p1
7a5e9406 147%patch9 -p1
d0b96b40 148
44be9ed4 149%build
fbac75ca 150cat << EOF > .mozconfig
9e7875fc 151mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 152
fac7e24d 153export CFLAGS="%{rpmcflags}"
73d54cb2 154export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
155
156%if %{with crashreporter}
157export MOZ_DEBUG_SYMBOLS=1
158%endif
159
59c5a0e8 160# Options for 'configure' (same as command-line options).
44be9ed4 161ac_add_options --prefix=%{_prefix}
162ac_add_options --exec-prefix=%{_exec_prefix}
163ac_add_options --bindir=%{_bindir}
164ac_add_options --sbindir=%{_sbindir}
165ac_add_options --sysconfdir=%{_sysconfdir}
166ac_add_options --datadir=%{_datadir}
167ac_add_options --includedir=%{_includedir}
168ac_add_options --libdir=%{_libdir}
169ac_add_options --libexecdir=%{_libexecdir}
170ac_add_options --localstatedir=%{_localstatedir}
171ac_add_options --sharedstatedir=%{_sharedstatedir}
172ac_add_options --mandir=%{_mandir}
173ac_add_options --infodir=%{_infodir}
174%if %{?debug:1}0
59c5a0e8 175ac_add_options --disable-optimize
44be9ed4 176ac_add_options --enable-debug
177ac_add_options --enable-debug-modules
59c5a0e8
SP
178ac_add_options --enable-debugger-info-modules
179ac_add_options --enable-crash-on-assert
44be9ed4 180%else
181ac_add_options --disable-debug
182ac_add_options --disable-debug-modules
59c5a0e8
SP
183ac_add_options --disable-logging
184ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 185%endif
88149483
ER
186ac_add_options --disable-strip
187ac_add_options --disable-strip-libs
44be9ed4 188%if %{with tests}
189ac_add_options --enable-tests
190%else
191ac_add_options --disable-tests
192%endif
3366507a
JB
193%if %{with lightning}
194ac_add_options --enable-calendar
44be9ed4 195%else
3366507a 196ac_add_options --disable-calendar
44be9ed4 197%endif
765a3a27
ER
198%if %{with crashreporter}
199ac_add_options --enable-crashreporter
200%else
59c5a0e8 201ac_add_options --disable-crashreporter
765a3a27 202%endif
d0b96b40 203ac_add_options --disable-elf-dynstr-gc
59e5e620 204ac_add_options --disable-elf-hack
3366507a
JB
205ac_add_options --disable-gnomeui
206ac_add_options --disable-gnomevfs
44be9ed4 207ac_add_options --disable-installer
d0b96b40 208ac_add_options --disable-javaxpcom
3366507a 209ac_add_options --disable-profilesharing
88149483 210ac_add_options --disable-updater
3366507a
JB
211ac_add_options --disable-xterm-updates
212ac_add_options --enable-application=mail
44be9ed4 213ac_add_options --enable-crypto
3366507a
JB
214ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
215ac_add_options --enable-gio
216%if %{with ldap}
217ac_add_options --enable-ldap
218ac_add_options --with-system-ldap
219%else
220ac_add_options --disable-ldap
221%endif
d0b96b40 222ac_add_options --enable-libxul
44be9ed4 223ac_add_options --enable-pango
3366507a 224ac_add_options --enable-postscript
a97d3356 225%{?with_shared_js:ac_add_options --enable-shared-js}
3366507a 226ac_add_options --enable-single-profile
88149483 227ac_add_options --enable-startup-notification
44be9ed4 228ac_add_options --enable-system-cairo
5e9bb798 229ac_add_options --enable-system-hunspell
7d981f69 230ac_add_options --enable-system-sqlite
3366507a
JB
231ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
232ac_add_options --with-distribution-id=org.pld-linux
88149483 233%if %{with xulrunner}
d0b96b40 234ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
3366507a 235ac_add_options --with-system-libxul
88149483
ER
236%endif
237ac_add_options --with-pthreads
238ac_add_options --with-system-bz2
d0b96b40 239ac_add_options --with-system-ffi
9b89aca5 240ac_add_options --with-system-icu
44be9ed4 241ac_add_options --with-system-jpeg
d0b96b40
JR
242ac_add_options --with-system-libevent
243ac_add_options --with-system-libvpx
44be9ed4 244ac_add_options --with-system-nspr
245ac_add_options --with-system-nss
246ac_add_options --with-system-png
247ac_add_options --with-system-zlib
44be9ed4 248EOF
249
d0b96b40 250mkdir -p %{objdir}/config
7a5e9406 251ln -sf %{topdir}/mozilla/config/*.mk %{objdir}/config
d0b96b40 252
90e998ba 253%{__make} -j1 -f client.mk build \
d076d93e 254 STRIP="/bin/true" \
765a3a27 255 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d0b96b40 256 installdir=%{_libdir}/%{name} \
de09c00d 257 XLIBS="-lX11 -lXt" \
d076d93e 258 CC="%{__cc}" \
44be9ed4 259 CXX="%{__cxx}"
260
765a3a27
ER
261%if %{with crashreporter}
262# create debuginfo for crash-stats.mozilla.com
263%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
264%endif
265
44be9ed4 266%install
267rm -rf $RPM_BUILD_ROOT
765a3a27 268install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 269
9e7875fc 270cd %{objdir}
ecf04393 271%{__make} -C mail/installer stage-package \
44be9ed4 272 DESTDIR=$RPM_BUILD_ROOT \
d0b96b40 273 installdir=%{_libdir}/%{name} \
44be9ed4 274 PKG_SKIP_STRIP=1
275
cae5b55b 276cp -a dist/thunderbird/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
d0b96b40 277
9b40a2c3
JB
278%if %{with xulrunner}
279# needed to find mozilla runtime
280ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
281%endif
cae5b55b 282
9b40a2c3 283# Enable crash reporter for Thunderbird application
765a3a27
ER
284%if %{with crashreporter}
285%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
286
287# Add debuginfo for crash-stats.mozilla.com
51a3b6db 288install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
3a30e2d7 289cp -a dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
290%endif
291
44be9ed4 292# move arch independant ones to datadir
eca54e0f 293mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
eca54e0f 294ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
44be9ed4 295
c6ec3c1c
ER
296# dir for arch independant extensions besides arch dependant extensions
297# see mozilla/xpcom/build/nsXULAppAPI.h
298# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
299install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
300
73d54cb2 301%if %{without xulrunner}
63d8f5c3 302%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 303ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
73d54cb2 304%endif
e6bc19b3 305
cae5b55b
JR
306#%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
307# -e "s|%MOZ_APP_DISPLAYNAME%|Thunderbird|" \
308# %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/thunderbird
0889474f 309
cae5b55b 310%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/thunderbird
44be9ed4 311ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
312ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
313
d0b96b40 314cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
44be9ed4 315
e8f4ba81 316# files created by regxpcom -register in post
52fc61e6
ER
317touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
318touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
319cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
320#!/bin/sh
321umask 022
322# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
323# dangerous if you run this with sudo with keep_env += HOME
324# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
325t=$(mktemp -d)
d50a2a28 326%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
cae5b55b 327TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/thunderbird -register
e8f4ba81
ER
328rm -rf $t
329EOF
330chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 331
283702b9 332# mozldap
d0b96b40
JR
333%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
334%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
283702b9 335
44be9ed4 336%clean
337rm -rf $RPM_BUILD_ROOT
338
339%pretrans
340if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
341 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
342fi
eca54e0f 343for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 344 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
345 install -d %{_datadir}/%{name}
346 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
347 fi
348done
349exit 0
350
e8f4ba81
ER
351%post
352%{_libdir}/%{name}/register || :
353
44be9ed4 354%files
355%defattr(644,root,root,755)
cae5b55b 356%attr(755,root,root) %{_bindir}/thunderbird
44be9ed4 357%attr(755,root,root) %{_bindir}/mozilla-thunderbird
358%attr(755,root,root) %{_bindir}/thunderbird
359%dir %{_libdir}/%{name}
765a3a27 360%{_libdir}/%{name}/application.ini
6b327de6
JB
361%{_libdir}/%{name}/blocklist.xml
362%{_libdir}/%{name}/chrome.manifest
44be9ed4 363%dir %{_libdir}/%{name}/components
6b327de6 364%{_libdir}/%{name}/components/components.manifest
73d54cb2
JB
365%attr(755,root,root) %{_libdir}/%{name}/*.sh
366%attr(755,root,root) %{_libdir}/%{name}/*-bin
cae5b55b 367%attr(755,root,root) %{_libdir}/%{name}/thunderbird
73d54cb2 368%attr(755,root,root) %{_libdir}/%{name}/register
d0b96b40 369%{_libdir}/%{name}/omni.ja
73d54cb2 370%if %{without xulrunner}
a367af64 371%{_libdir}/%{name}/dependentlibs.list
73d54cb2 372%{_libdir}/%{name}/platform.ini
73d54cb2 373%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 374%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
a97d3356 375%{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
0516fc42 376%attr(755,root,root) %{_libdir}/%{name}/libxul.so
cf62736e 377%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 378%endif
44be9ed4 379
380# symlinks
381%{_libdir}/%{name}/chrome
382%{_libdir}/%{name}/defaults
44be9ed4 383%{_libdir}/%{name}/isp
eca54e0f 384%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
385%if %{with xulrunner}
386%{_libdir}/%{name}/xulrunner
387%else
73d54cb2 388%{_libdir}/%{name}/dictionaries
73d54cb2 389%endif
44be9ed4 390
cae5b55b
JR
391%{_pixmapsdir}/thunderbird.png
392%{_desktopdir}/thunderbird.desktop
44be9ed4 393
394%dir %{_datadir}/%{name}
3a30e2d7
JR
395%dir %{_libdir}/%{name}/distribution
396%dir %{_libdir}/%{name}/distribution/extensions
eca54e0f 397%{_datadir}/%{name}/extensions
eca54e0f 398%{_datadir}/%{name}/searchplugins
44be9ed4 399
765a3a27
ER
400%if %{with crashreporter}
401%attr(755,root,root) %{_libdir}/%{name}/crashreporter
402%{_libdir}/%{name}/crashreporter.ini
403%{_libdir}/%{name}/Throbber-small.gif
404%endif
405
44be9ed4 406%dir %{_libdir}/%{name}/extensions
407%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 408
52fc61e6
ER
409# files created by regxpcom -register
410%ghost %{_libdir}/%{name}/components/compreg.dat
411%ghost %{_libdir}/%{name}/components/xpti.dat
412
cae5b55b 413%{_iconsdir}/hicolor/*/apps/thunderbird.*
d0b96b40 414
6578c165 415%if %{with lightning}
416%files addon-lightning
417%defattr(644,root,root,755)
3a30e2d7
JR
418%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
419%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/app.ini
420%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.jar
421%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
422%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
423%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
424%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
425%attr(755,root,root) %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
426%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
427%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*manifest
428%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
429%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
430%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
431%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones
432%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones/zones.json
6578c165 433%endif
This page took 0.199986 seconds and 4 git commands to generate.