]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- fixed branding tarball (I hope)
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - fix icedove (building) and installing nss/nspr libs!
283702b9 4# - build with system mozldap
91bac034
ER
5# - about dialog broken:
6#XML Parsing Error: undefined entity
7#Location: chrome://messenger/content/aboutDialog.xul
8#Line Number 27, Column 37: <description id="copyright">&logoTrademark;</description>
9#------------------------------------^
c4ddd260 10#
44be9ed4 11# Conditional builds
12%bcond_without enigmail # don't build enigmail - GPG/PGP support
13%bcond_without gnomeui # disable gnomeui support
14%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
15%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
16%bcond_without ldap # disable e-mail address lookups in LDAP directories
6578c165 17%bcond_without lightning # disable sunbird calendar
765a3a27
ER
18%bcond_with xulrunner # build with xulrunner
19%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 20
44be9ed4 21%if %{without gnome}
22%undefine with_gnomeui
23%undefine with_gnomevfs
24%endif
88149483 25
765a3a27
ER
26%if %{?_enable_debug_packages} != 1
27%undefine crashreporter
28%endif
29
f4aadbdb 30%define enigmail_ver 1.1.2
44be9ed4 31
7d981f69
ER
32%if %{without xulrunner}
33# The actual sqlite version (see RHBZ#480989):
34%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
35%endif
36
44be9ed4 37Summary: Icedove - email client
38Summary(pl.UTF-8): Icedove - klient poczty
39Name: icedove
ecf04393 40Version: 3.1.2
765a3a27 41Release: 0.10
44be9ed4 42License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 43Group: X11/Applications/Networking
cadfb931 44Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
ecf04393 45# Source0-md5: 48e80576a7af70e64d30a5162364525a
44be9ed4 46Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
f4aadbdb 47# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
44be9ed4 48Source2: %{name}-branding.tar.bz2
fff49dda 49# Source2-md5: 85fdf877e2f1bc41329d8086ef5cf0f1
44be9ed4 50Source3: %{name}-rm_nonfree.sh
51Source4: %{name}.desktop
52Source5: %{name}.sh
44be9ed4 53Patch0: %{name}-branding.patch
faa5c89d
SP
54Patch1: %{name}-enigmail-shared.patch
55Patch2: %{name}-gcc.patch
56Patch3: %{name}-fonts.patch
57Patch4: %{name}-install.patch
5e9bb798 58Patch5: %{name}-hunspell.patch
faa5c89d 59Patch6: %{name}-prefs.patch
9a743685 60Patch7: system-mozldap.patch
a85e0ecb 61Patch8: %{name}-makefile.patch
ca336c77 62Patch9: %{name}-libpng.patch
ccc206fe 63Patch10: %{name}-extensiondir.patch
765a3a27 64Patch11: crashreporter.patch
4922c320 65URL: http://www.pld-linux.org/Packages/Icedove
44be9ed4 66%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
67BuildRequires: automake
68BuildRequires: freetype-devel >= 1:2.1.8
69%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
70BuildRequires: gtk+2-devel >= 1:2.0.0
5e9bb798 71BuildRequires: hunspell-devel
44be9ed4 72BuildRequires: libIDL-devel >= 0.8.0
73%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
74%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
75BuildRequires: libjpeg-devel >= 6b
76BuildRequires: libpng-devel >= 1.2.0
77BuildRequires: libstdc++-devel
cadfb931
SP
78BuildRequires: nspr-devel >= 1:4.8
79BuildRequires: nss-devel >= 1:3.12.0
44be9ed4 80BuildRequires: pango-devel >= 1:1.1.0
1c62cadb 81BuildRequires: pkgconfig
44be9ed4 82BuildRequires: sed >= 4.0
4b6bc367 83BuildRequires: sqlite3-devel >= 3.6.22
1c62cadb 84BuildRequires: startup-notification-devel >= 0.8
44be9ed4 85BuildRequires: xorg-lib-libXext-devel
44be9ed4 86BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 87BuildRequires: xorg-lib-libXt-devel
1c62cadb 88BuildRequires: zip
7d981f69
ER
89%if %{with xulrunner}
90%else
44be9ed4 91Requires: myspell-common
92Requires: nspr >= 1:4.6.1
93Requires: nss >= 1:3.11.3
4b6bc367 94Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 95%endif
44be9ed4 96Obsoletes: mozilla-thunderbird
97Obsoletes: mozilla-thunderbird-dictionary-en-US
98BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
9e366f18
AM
100%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
101
44be9ed4 102# iceweasel/icedove/iceape provide their own versions
103%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
104%define _noautoprovfiles %{_libdir}/%{name}/components
105# we don't want these to satisfy xulrunner-devel
5ac9187e 106%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
44be9ed4 107# and as we don't provide them, don't require either
5ac9187e 108%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
44be9ed4 109
110%description
111Icedove is an open-source,fast and portable email client.
112
113%description -l pl.UTF-8
114Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
115
6578c165 116%package addon-lightning
117Summary: An integrated calendar for Icedove
118Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
119License: MPL 1.1 or GPL v2+ or LGPL v2.1+
120Group: Applications/Networking
121Requires: %{name} = %{version}-%{release}
122
123%description addon-lightning
124Lightning is an calendar extension to Icedove email client.
125
126%description addon-lightning -l pl.UTF-8
127Lightning to rozszerzenie do klienta poczty Icedove dodające
128funkcjonalność kalendarza.
129
44be9ed4 130%package addon-enigmail
131Summary: Extension for the authentication and encryption features provided by GnuPG
132Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
133License: MPL/LGPL
134Group: Applications/Networking
135URL: http://enigmail.mozdev.org/
cd056caa 136Requires: %{name} = %{version}-%{release}
d076d93e 137Requires: gnupg
75991bbb 138Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 139
140%description addon-enigmail
c5e06599 141Enigmail is an extension to the Icedove mail client which allows users
142to access the authentication and encryption features provided by
143GnuPG.
44be9ed4 144
145Main Features:
146- Encrypt/sign mail when sending, decrypt/authenticate received mail
147- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
148- Per-Account based encryption and signing defaults
149- Per-Recipient rules for automated key selection, and
150 enabling/disabling encryption and signing
151- OpenPGP key management interface
152
153%description addon-enigmail -l pl.UTF-8
c5e06599 154Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
155użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
156przez GnuPG.
44be9ed4 157
158Główne możliwości:
159- szyfrowanie/podpisywanie poczty przy wysyłaniu,
160 odszyfrowywanie/uwierzytelnianie poczty odebranej
161- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
162- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
163- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
164 podpisywania dla każdego adresata
165- interfejs do zarządzania kluczami OpenPGP
166
167%prep
983562b1 168%setup -qc
a85e0ecb 169mv -f comm-1.9.2 mozilla
983562b1 170%setup -q -T -D -a2
171cd mozilla
44be9ed4 172%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
173/bin/sh %{SOURCE3}
983562b1 174%patch0 -p1
faa5c89d
SP
175%{?with_enigmail:%patch1 -p1}
176%patch2 -p1
4ccc2157 177%patch3 -p1
faa5c89d 178%patch4 -p1
5e9bb798 179%patch5 -p1
983562b1 180%patch6 -p1
9a743685 181%patch7 -p1
a85e0ecb 182%patch8 -p0
ca336c77 183%patch9 -p0
ccc206fe 184%patch10 -p2
765a3a27 185%patch11 -p2
44be9ed4 186
187%build
983562b1 188cd mozilla
cadfb931
SP
189cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
190cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
44be9ed4 191cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
192
9a743685
ER
193install -d libxul-sdk
194ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 195
fbac75ca 196cat << EOF > .mozconfig
cb0e4412
SP
197mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
198
8c107b4e
ER
199export CFLAGS="%{rpmcflags}"
200export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
201
202%if %{with crashreporter}
203export MOZ_DEBUG_SYMBOLS=1
204%endif
205
59c5a0e8 206# Options for 'configure' (same as command-line options).
44be9ed4 207ac_add_options --prefix=%{_prefix}
208ac_add_options --exec-prefix=%{_exec_prefix}
209ac_add_options --bindir=%{_bindir}
210ac_add_options --sbindir=%{_sbindir}
211ac_add_options --sysconfdir=%{_sysconfdir}
212ac_add_options --datadir=%{_datadir}
213ac_add_options --includedir=%{_includedir}
214ac_add_options --libdir=%{_libdir}
215ac_add_options --libexecdir=%{_libexecdir}
216ac_add_options --localstatedir=%{_localstatedir}
217ac_add_options --sharedstatedir=%{_sharedstatedir}
218ac_add_options --mandir=%{_mandir}
219ac_add_options --infodir=%{_infodir}
220%if %{?debug:1}0
59c5a0e8 221ac_add_options --disable-optimize
44be9ed4 222ac_add_options --enable-debug
223ac_add_options --enable-debug-modules
59c5a0e8
SP
224ac_add_options --enable-debugger-info-modules
225ac_add_options --enable-crash-on-assert
44be9ed4 226%else
227ac_add_options --disable-debug
228ac_add_options --disable-debug-modules
59c5a0e8
SP
229ac_add_options --disable-logging
230ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 231%endif
88149483
ER
232ac_add_options --disable-strip
233ac_add_options --disable-strip-libs
44be9ed4 234%if %{with tests}
235ac_add_options --enable-tests
236%else
237ac_add_options --disable-tests
238%endif
239%if %{with gnomeui}
240ac_add_options --enable-gnomeui
241%else
242ac_add_options --disable-gnomeui
243%endif
244%if %{with gnomevfs}
245ac_add_options --enable-gnomevfs
246%else
247ac_add_options --disable-gnomevfs
248%endif
249%if %{with ldap}
250ac_add_options --enable-ldap
9a743685 251ac_add_options --with-system-ldap
44be9ed4 252%else
253ac_add_options --disable-ldap
254%endif
765a3a27
ER
255%if %{with crashreporter}
256ac_add_options --enable-crashreporter
257%else
59c5a0e8 258ac_add_options --disable-crashreporter
765a3a27 259%endif
59c5a0e8 260ac_add_options --disable-xterm-updates
59c5a0e8 261ac_add_options --enable-postscript
d076d93e 262%if %{with lightning}
cb0e4412 263ac_add_options --enable-calendar
d076d93e
SP
264%else
265ac_add_options --disable-calendar
266%endif
44be9ed4 267ac_add_options --disable-installer
268ac_add_options --disable-jsd
88149483 269ac_add_options --disable-updater
44be9ed4 270ac_add_options --disable-xprint
cadfb931
SP
271ac_add_options --disable-permissions
272ac_add_options --disable-pref-extensions
44be9ed4 273ac_add_options --enable-canvas
274ac_add_options --enable-crypto
44be9ed4 275ac_add_options --enable-mathml
44be9ed4 276ac_add_options --enable-pango
277ac_add_options --enable-reorder
88149483
ER
278ac_add_options --enable-startup-notification
279ac_add_options --enable-svg
44be9ed4 280ac_add_options --enable-system-cairo
5e9bb798 281ac_add_options --enable-system-hunspell
7d981f69 282ac_add_options --enable-system-sqlite
44be9ed4 283ac_add_options --enable-xft
cadfb931
SP
284ac_add_options --enable-application=mail
285ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 286ac_add_options --enable-xinerama
88149483
ER
287ac_add_options --with-distribution-id=org.pld-linux
288ac_add_options --with-branding=icedove/branding
289%if %{with xulrunner}
fbac75ca
ER
290ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
291ac_add_options --enable-shared
292%else
293ac_add_options --enable-static
88149483
ER
294%endif
295ac_add_options --with-pthreads
296ac_add_options --with-system-bz2
44be9ed4 297ac_add_options --with-system-jpeg
298ac_add_options --with-system-nspr
299ac_add_options --with-system-nss
300ac_add_options --with-system-png
301ac_add_options --with-system-zlib
44be9ed4 302ac_add_options --enable-single-profile
303ac_add_options --disable-profilesharing
44be9ed4 304ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
305EOF
306
90e998ba 307%{__make} -j1 -f client.mk build \
d076d93e 308 STRIP="/bin/true" \
765a3a27 309 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 310 CC="%{__cc}" \
44be9ed4 311 CXX="%{__cxx}"
312
765a3a27
ER
313%if %{with crashreporter}
314# create debuginfo for crash-stats.mozilla.com
315%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
316%endif
317
44be9ed4 318%if %{with enigmail}
ecf04393 319top=$(pwd)
59c5a0e8 320cd mailnews/extensions/enigmail
ecf04393
ER
321./makemake -r -o $top/obj-%{_target_cpu}
322%{__make} -C $top/obj-%{_target_cpu}/mailnews/extensions/enigmail \
d076d93e
SP
323 STRIP="/bin/true" \
324 CC="%{__cc}" \
325 CXX="%{__cxx}"
44be9ed4 326%endif
327
328%install
329rm -rf $RPM_BUILD_ROOT
765a3a27 330install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 331
ecf04393
ER
332cd mozilla/obj-%{_target_cpu}
333%{__make} -C mail/installer stage-package \
44be9ed4 334 DESTDIR=$RPM_BUILD_ROOT \
335 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
336 PKG_SKIP_STRIP=1
337
765a3a27
ER
338# Enable crash reporter for Firefox application
339%if %{with crashreporter}
340%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
341
342# Add debuginfo for crash-stats.mozilla.com
343mkdir -p $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
344cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
345%endif
346
ecf04393
ER
347# copy manually lightning files, somewhy they are not installed by make
348cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
349 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
350 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
351
44be9ed4 352# move arch independant ones to datadir
353mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
354mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
355mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
44be9ed4 356mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 357mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 358mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
359ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
360ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
361ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
44be9ed4 362ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 363ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 364ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
365
366rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
367ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
368
369%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
370ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
371ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
372
293928f3 373cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
765a3a27 374cp -a ../icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 375
52fc61e6
ER
376# files created by regxpcom -register
377touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
378touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
379
44be9ed4 380%if %{with enigmail}
283702b9
ER
381ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
382install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6
ER
383cd mozilla/dist/bin
384cp -rfLp chrome/enigmail.jar $ext_dir/chrome
385cp -rfLp chrome/enigmime.jar $ext_dir/chrome
386cp -rfLp components/enig* $ext_dir/components
387cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 388cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
389cp -rfLp components/ipc.xpt $ext_dir/components
390cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
391cd -
392cp -a ../mailnews/extensions/enigmail/package/install.rdf $ext_dir
f6a43e2f 393cp -a ../mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 394%endif
395
9a743685
ER
396# remove unecessary stuff
397rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
293928f3 398rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
f3b6d696 399rm $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 400
9a743685 401# never package these
283702b9
ER
402# nss
403rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
404# nspr
405rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9
ER
406# mozldap
407rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
408
44be9ed4 409%clean
410rm -rf $RPM_BUILD_ROOT
411
412%pretrans
413if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
414 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
415fi
9e097178 416for d in chrome defaults greprefs icons isp modules res; do
44be9ed4 417 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
418 install -d %{_datadir}/%{name}
419 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
420 fi
421done
422exit 0
423
424%files
425%defattr(644,root,root,755)
426%attr(755,root,root) %{_bindir}/icedove
427%attr(755,root,root) %{_bindir}/mozilla-thunderbird
428%attr(755,root,root) %{_bindir}/thunderbird
429%dir %{_libdir}/%{name}
765a3a27
ER
430%{_libdir}/%{name}/application.ini
431%{_libdir}/%{name}/platform.ini
44be9ed4 432%dir %{_libdir}/%{name}/components
433%attr(755,root,root) %{_libdir}/%{name}/components/*.so
434%{_libdir}/%{name}/components/*.js
435%{_libdir}/%{name}/components/*.xpt
283702b9
ER
436%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
437%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
438%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
44be9ed4 439%attr(755,root,root) %{_libdir}/%{name}/*.sh
440%attr(755,root,root) %{_libdir}/%{name}/*-bin
441%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 442%attr(755,root,root) %{_libdir}/%{name}/icedove
44be9ed4 443
444# symlinks
445%{_libdir}/%{name}/chrome
446%{_libdir}/%{name}/defaults
447%{_libdir}/%{name}/dictionaries
448%{_libdir}/%{name}/greprefs
44be9ed4 449%{_libdir}/%{name}/isp
9e097178 450%{_libdir}/%{name}/modules
44be9ed4 451%{_libdir}/%{name}/res
452
293928f3 453%{_pixmapsdir}/*.png
44be9ed4 454%{_desktopdir}/*.desktop
455
456%dir %{_datadir}/%{name}
457%{_datadir}/%{name}/chrome
458%{_datadir}/%{name}/defaults
459%{_datadir}/%{name}/greprefs
44be9ed4 460%{_datadir}/%{name}/isp
9e097178 461%{_datadir}/%{name}/modules
44be9ed4 462%{_datadir}/%{name}/res
463
765a3a27
ER
464%if %{with crashreporter}
465%attr(755,root,root) %{_libdir}/%{name}/crashreporter
466%{_libdir}/%{name}/crashreporter.ini
467%{_libdir}/%{name}/Throbber-small.gif
468%endif
469
44be9ed4 470%dir %{_libdir}/%{name}/extensions
471%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 472
52fc61e6
ER
473# files created by regxpcom -register
474%ghost %{_libdir}/%{name}/components/compreg.dat
475%ghost %{_libdir}/%{name}/components/xpti.dat
476
6578c165 477%if %{with lightning}
478%files addon-lightning
479%defattr(644,root,root,755)
f3b6d696
ER
480%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
481%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
482%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
483%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
484%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
485%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
486%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
487%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
488%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
489%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
490%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
491%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
492
6578c165 493%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
494%endif
44be9ed4 495
496%if %{with enigmail}
497%files addon-enigmail
498%defattr(644,root,root,755)
f6a43e2f
ER
499%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
500%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
501%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
502%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
503%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
504%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
505%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
506%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
507%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 508%endif
This page took 0.235983 seconds and 4 git commands to generate.