]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- dropped obsolete gcc patch
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
f4114a7f 11%bcond_without xulrunner # build with xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
6864d0a2 22%define enigmail_ver 1.3.5
af42cf6d
JB
23%define nspr_ver 4.8.8
24%define nss_ver 3.12.10
44be9ed4 25
224cf96a 26# convert thunderbird release number to platform version: 9.0.x -> 9.0.x
6864d0a2
AZ
27%define xulrunner_main 10.0
28%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#10.0})
4f34f106 29
7d981f69
ER
30%if %{without xulrunner}
31# The actual sqlite version (see RHBZ#480989):
32%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33%endif
34
44be9ed4 35Summary: Icedove - email client
36Summary(pl.UTF-8): Icedove - klient poczty
37Name: icedove
1a166995 38Version: 10.0.2
eca54e0f 39Release: 3
44be9ed4 40License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 41Group: X11/Applications/Networking
cadfb931 42Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
1a166995 43# Source0-md5: 624bef982d7ac610b1175737d9905150
44be9ed4 44Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
6864d0a2 45# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
44be9ed4 46Source2: %{name}-branding.tar.bz2
c105f759 47# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 48Source3: %{name}-rm_nonfree.sh
49Source4: %{name}.desktop
50Source5: %{name}.sh
44be9ed4 51Patch0: %{name}-branding.patch
faa5c89d 52Patch1: %{name}-enigmail-shared.patch
faa5c89d
SP
53Patch3: %{name}-fonts.patch
54Patch4: %{name}-install.patch
5e9bb798 55Patch5: %{name}-hunspell.patch
faa5c89d 56Patch6: %{name}-prefs.patch
9a743685 57Patch7: system-mozldap.patch
a85e0ecb 58Patch8: %{name}-makefile.patch
86ad1c27 59
ccc206fe 60Patch10: %{name}-extensiondir.patch
765a3a27 61Patch11: crashreporter.patch
268e7766 62Patch12: no-subshell.patch
5745d706 63URL: http://www.pld-linux.org/Packages/Icedove
6458b220 64BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 65BuildRequires: alsa-lib-devel
44be9ed4 66BuildRequires: automake
51a3b6db 67BuildRequires: bzip2-devel
e820c55e
JB
68BuildRequires: cairo-devel >= 1.10
69BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 70BuildRequires: freetype-devel >= 1:2.1.8
6458b220 71BuildRequires: glib2-devel >= 2.0
e820c55e 72BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 73BuildRequires: hunspell-devel
44be9ed4 74BuildRequires: libIDL-devel >= 0.8.0
6458b220 75%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 76%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 77%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 78BuildRequires: libiw-devel
44be9ed4 79BuildRequires: libjpeg-devel >= 6b
51a3b6db 80BuildRequires: libnotify-devel >= 0.4
e820c55e 81BuildRequires: libpng-devel >= 1.4.1
44be9ed4 82BuildRequires: libstdc++-devel
f4114a7f
ER
83BuildRequires: nspr-devel >= 1:%{nspr_ver}
84BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 85BuildRequires: pango-devel >= 1:1.1.0
e820c55e 86BuildRequires: perl-base >= 1:5.6
1c62cadb 87BuildRequires: pkgconfig
e820c55e 88BuildRequires: python >= 1:2.5
44be9ed4 89BuildRequires: sed >= 4.0
9d1bfad8 90BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 91BuildRequires: startup-notification-devel >= 0.8
44be9ed4 92BuildRequires: xorg-lib-libXext-devel
44be9ed4 93BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 94BuildRequires: xorg-lib-libXt-devel
5745d706 95BuildRequires: yasm
1c62cadb 96BuildRequires: zip
7d981f69 97%if %{with xulrunner}
4f34f106 98BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 99%else
44be9ed4 100Requires: myspell-common
f4114a7f
ER
101Requires: nspr >= 1:%{nspr_ver}
102Requires: nss >= 1:%{nss_ver}
4b6bc367 103Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 104%endif
4f34f106
ER
105Requires(post): mktemp >= 1.5-18
106%if %{with xulrunner}
107%requires_eq_to xulrunner xulrunner-devel
108%endif
44be9ed4 109Obsoletes: mozilla-thunderbird
110Obsoletes: mozilla-thunderbird-dictionary-en-US
111BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
9e366f18
AM
113%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
114
44be9ed4 115# iceweasel/icedove/iceape provide their own versions
44be9ed4 116%define _noautoprovfiles %{_libdir}/%{name}/components
117# we don't want these to satisfy xulrunner-devel
224cf96a 118%define _noautoprov libmozjs.so libxpcom.so libxul.so
44be9ed4 119# and as we don't provide them, don't require either
224cf96a 120%define _noautoreq libmozjs.so libxpcom.so libxul.so
44be9ed4 121
9e7875fc
ER
122%define topdir %{_builddir}/%{name}-%{version}
123%define objdir %{topdir}/obj-%{_target_cpu}
124
44be9ed4 125%description
6b327de6 126Icedove is an open-source, fast and portable email client.
44be9ed4 127
128%description -l pl.UTF-8
6b327de6
JB
129Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
130poczty.
44be9ed4 131
6578c165 132%package addon-lightning
133Summary: An integrated calendar for Icedove
134Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
135License: MPL 1.1 or GPL v2+ or LGPL v2.1+
136Group: Applications/Networking
137Requires: %{name} = %{version}-%{release}
138
139%description addon-lightning
140Lightning is an calendar extension to Icedove email client.
141
142%description addon-lightning -l pl.UTF-8
143Lightning to rozszerzenie do klienta poczty Icedove dodające
144funkcjonalność kalendarza.
145
44be9ed4 146%package addon-enigmail
147Summary: Extension for the authentication and encryption features provided by GnuPG
148Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
149License: MPL/LGPL
150Group: Applications/Networking
151URL: http://enigmail.mozdev.org/
cd056caa 152Requires: %{name} = %{version}-%{release}
d076d93e 153Requires: gnupg
75991bbb 154Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 155
156%description addon-enigmail
c5e06599 157Enigmail is an extension to the Icedove mail client which allows users
158to access the authentication and encryption features provided by
159GnuPG.
44be9ed4 160
161Main Features:
162- Encrypt/sign mail when sending, decrypt/authenticate received mail
163- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
164- Per-Account based encryption and signing defaults
165- Per-Recipient rules for automated key selection, and
166 enabling/disabling encryption and signing
167- OpenPGP key management interface
168
169%description addon-enigmail -l pl.UTF-8
c5e06599 170Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
171użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
172przez GnuPG.
44be9ed4 173
174Główne możliwości:
175- szyfrowanie/podpisywanie poczty przy wysyłaniu,
176 odszyfrowywanie/uwierzytelnianie poczty odebranej
177- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
178- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
179- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
180 podpisywania dla każdego adresata
181- interfejs do zarządzania kluczami OpenPGP
182
183%prep
983562b1 184%setup -qc
f4114a7f 185mv comm-release mozilla
983562b1 186%setup -q -T -D -a2
187cd mozilla
1c70899a 188%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 189/bin/sh %{SOURCE3}
983562b1 190%patch0 -p1
faa5c89d 191%{?with_enigmail:%patch1 -p1}
4ccc2157 192%patch3 -p1
faa5c89d 193%patch4 -p1
983562b1 194%patch6 -p1
9a743685 195%patch7 -p1
f4114a7f 196%patch8 -p2
ccc206fe 197%patch10 -p2
765a3a27 198%patch11 -p2
268e7766 199%patch12 -p1
44be9ed4 200
201%build
983562b1 202cd mozilla
cadfb931
SP
203cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
204cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 205cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 206
9a743685
ER
207install -d libxul-sdk
208ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 209
fbac75ca 210cat << EOF > .mozconfig
9e7875fc 211mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 212
5745d706 213export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
214export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
765a3a27
ER
215
216%if %{with crashreporter}
217export MOZ_DEBUG_SYMBOLS=1
218%endif
219
59c5a0e8 220# Options for 'configure' (same as command-line options).
44be9ed4 221ac_add_options --prefix=%{_prefix}
222ac_add_options --exec-prefix=%{_exec_prefix}
223ac_add_options --bindir=%{_bindir}
224ac_add_options --sbindir=%{_sbindir}
225ac_add_options --sysconfdir=%{_sysconfdir}
226ac_add_options --datadir=%{_datadir}
227ac_add_options --includedir=%{_includedir}
228ac_add_options --libdir=%{_libdir}
229ac_add_options --libexecdir=%{_libexecdir}
230ac_add_options --localstatedir=%{_localstatedir}
231ac_add_options --sharedstatedir=%{_sharedstatedir}
232ac_add_options --mandir=%{_mandir}
233ac_add_options --infodir=%{_infodir}
234%if %{?debug:1}0
59c5a0e8 235ac_add_options --disable-optimize
44be9ed4 236ac_add_options --enable-debug
237ac_add_options --enable-debug-modules
59c5a0e8
SP
238ac_add_options --enable-debugger-info-modules
239ac_add_options --enable-crash-on-assert
44be9ed4 240%else
241ac_add_options --disable-debug
242ac_add_options --disable-debug-modules
59c5a0e8
SP
243ac_add_options --disable-logging
244ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 245%endif
88149483
ER
246ac_add_options --disable-strip
247ac_add_options --disable-strip-libs
44be9ed4 248%if %{with tests}
249ac_add_options --enable-tests
250%else
251ac_add_options --disable-tests
252%endif
6458b220 253ac_add_options --enable-gio
44be9ed4 254%if %{with gnomeui}
255ac_add_options --enable-gnomeui
256%else
257ac_add_options --disable-gnomeui
258%endif
44be9ed4 259ac_add_options --disable-gnomevfs
44be9ed4 260%if %{with ldap}
261ac_add_options --enable-ldap
9a743685 262ac_add_options --with-system-ldap
44be9ed4 263%else
264ac_add_options --disable-ldap
265%endif
765a3a27
ER
266%if %{with crashreporter}
267ac_add_options --enable-crashreporter
268%else
59c5a0e8 269ac_add_options --disable-crashreporter
765a3a27 270%endif
59c5a0e8 271ac_add_options --disable-xterm-updates
59c5a0e8 272ac_add_options --enable-postscript
d076d93e 273%if %{with lightning}
cb0e4412 274ac_add_options --enable-calendar
d076d93e
SP
275%else
276ac_add_options --disable-calendar
277%endif
44be9ed4 278ac_add_options --disable-installer
279ac_add_options --disable-jsd
88149483 280ac_add_options --disable-updater
44be9ed4 281ac_add_options --disable-xprint
cadfb931
SP
282ac_add_options --disable-permissions
283ac_add_options --disable-pref-extensions
44be9ed4 284ac_add_options --enable-canvas
285ac_add_options --enable-crypto
44be9ed4 286ac_add_options --enable-mathml
44be9ed4 287ac_add_options --enable-pango
288ac_add_options --enable-reorder
88149483
ER
289ac_add_options --enable-startup-notification
290ac_add_options --enable-svg
44be9ed4 291ac_add_options --enable-system-cairo
5e9bb798 292ac_add_options --enable-system-hunspell
7d981f69 293ac_add_options --enable-system-sqlite
44be9ed4 294ac_add_options --enable-xft
cadfb931
SP
295ac_add_options --enable-application=mail
296ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 297ac_add_options --enable-xinerama
88149483
ER
298ac_add_options --with-distribution-id=org.pld-linux
299ac_add_options --with-branding=icedove/branding
300%if %{with xulrunner}
f4114a7f
ER
301#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
302ac_add_options --with-system-libxul
fbac75ca 303ac_add_options --enable-shared
f4114a7f 304ac_add_options --enable-libxul
fbac75ca 305%else
f4114a7f 306ac_add_options --disable-xul
88149483
ER
307%endif
308ac_add_options --with-pthreads
309ac_add_options --with-system-bz2
44be9ed4 310ac_add_options --with-system-jpeg
311ac_add_options --with-system-nspr
312ac_add_options --with-system-nss
313ac_add_options --with-system-png
314ac_add_options --with-system-zlib
44be9ed4 315ac_add_options --enable-single-profile
316ac_add_options --disable-profilesharing
44be9ed4 317ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
318EOF
319
90e998ba 320%{__make} -j1 -f client.mk build \
d076d93e 321 STRIP="/bin/true" \
765a3a27 322 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 323 CC="%{__cc}" \
44be9ed4 324 CXX="%{__cxx}"
325
765a3a27
ER
326%if %{with crashreporter}
327# create debuginfo for crash-stats.mozilla.com
328%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
329%endif
330
44be9ed4 331%if %{with enigmail}
59c5a0e8 332cd mailnews/extensions/enigmail
9e7875fc
ER
333./makemake -r -o %{objdir}
334%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
335 STRIP="/bin/true" \
336 CC="%{__cc}" \
337 CXX="%{__cxx}"
44be9ed4 338%endif
339
340%install
341rm -rf $RPM_BUILD_ROOT
765a3a27 342install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 343
9e7875fc 344cd %{objdir}
ecf04393 345%{__make} -C mail/installer stage-package \
44be9ed4 346 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 347 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 348 PKG_SKIP_STRIP=1
349
765a3a27
ER
350# Enable crash reporter for Firefox application
351%if %{with crashreporter}
352%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
353
354# Add debuginfo for crash-stats.mozilla.com
51a3b6db 355install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
356cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
357%endif
358
ecf04393
ER
359# copy manually lightning files, somewhy they are not installed by make
360cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
361 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
362 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
363
44be9ed4 364# move arch independant ones to datadir
365mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
366mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 367mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 368mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 369mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
eca54e0f 370mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 371ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
372ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 373ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 374ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 375ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
eca54e0f 376ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
44be9ed4 377
c6ec3c1c
ER
378# dir for arch independant extensions besides arch dependant extensions
379# see mozilla/xpcom/build/nsXULAppAPI.h
380# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
381install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
382
63d8f5c3 383%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 384ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
385
e6bc19b3
ER
386%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
387ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
388
44be9ed4 389%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
390ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
391ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
392
52f5507d
ER
393cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
394cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 395
e8f4ba81 396# files created by regxpcom -register in post
52fc61e6
ER
397touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
398touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
399cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
400#!/bin/sh
401umask 022
402# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
403# dangerous if you run this with sudo with keep_env += HOME
404# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
405t=$(mktemp -d)
d50a2a28 406%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
407TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
408rm -rf $t
409EOF
410chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 411
44be9ed4 412%if %{with enigmail}
283702b9
ER
413ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
414install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 415cd mozilla/dist/bin
0516fc42 416#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
417#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
418cp -rfLp components/enig* $ext_dir/components
419cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 420cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
421cp -rfLp components/ipc.xpt $ext_dir/components
422cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
423cd -
52f5507d
ER
424cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
425cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 426%endif
427
9a743685 428# remove unecessary stuff
9e402408 429#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
0516fc42 430#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
431#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 432
9cdc8923
ER
433# never package these. always remove
434# nss
435%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
436# nspr
437%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 438# mozldap
9cdc8923 439%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 440
44be9ed4 441%clean
442rm -rf $RPM_BUILD_ROOT
443
444%pretrans
445if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
446 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
447fi
eca54e0f 448for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 449 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
450 install -d %{_datadir}/%{name}
451 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
452 fi
453done
454exit 0
455
e8f4ba81
ER
456%post
457%{_libdir}/%{name}/register || :
458
44be9ed4 459%files
460%defattr(644,root,root,755)
461%attr(755,root,root) %{_bindir}/icedove
462%attr(755,root,root) %{_bindir}/mozilla-thunderbird
463%attr(755,root,root) %{_bindir}/thunderbird
464%dir %{_libdir}/%{name}
765a3a27
ER
465%{_libdir}/%{name}/application.ini
466%{_libdir}/%{name}/platform.ini
6b327de6
JB
467%{_libdir}/%{name}/blocklist.xml
468%{_libdir}/%{name}/chrome.manifest
469%{_libdir}/%{name}/greprefs.js
44be9ed4 470%dir %{_libdir}/%{name}/components
471%attr(755,root,root) %{_libdir}/%{name}/components/*.so
472%{_libdir}/%{name}/components/*.js
473%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
474%{_libdir}/%{name}/components/components.manifest
475%{_libdir}/%{name}/components/interfaces.manifest
0516fc42 476%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 477%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 478%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 479%attr(755,root,root) %{_libdir}/%{name}/*.sh
480%attr(755,root,root) %{_libdir}/%{name}/*-bin
481%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 482%attr(755,root,root) %{_libdir}/%{name}/icedove
cf62736e 483%attr(755,root,root) %{_libdir}/%{name}/plugin-container
e8f4ba81 484%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 485
486# symlinks
487%{_libdir}/%{name}/chrome
488%{_libdir}/%{name}/defaults
489%{_libdir}/%{name}/dictionaries
e6bc19b3 490%{_libdir}/%{name}/hyphenation
44be9ed4 491%{_libdir}/%{name}/isp
9e097178 492%{_libdir}/%{name}/modules
44be9ed4 493%{_libdir}/%{name}/res
eca54e0f 494%{_libdir}/%{name}/searchplugins
44be9ed4 495
224cf96a
JB
496%{_pixmapsdir}/icedove.png
497%{_desktopdir}/icedove.desktop
44be9ed4 498
499%dir %{_datadir}/%{name}
500%{_datadir}/%{name}/chrome
501%{_datadir}/%{name}/defaults
eca54e0f 502%{_datadir}/%{name}/extensions
44be9ed4 503%{_datadir}/%{name}/isp
9e097178 504%{_datadir}/%{name}/modules
44be9ed4 505%{_datadir}/%{name}/res
eca54e0f 506%{_datadir}/%{name}/searchplugins
44be9ed4 507
765a3a27
ER
508%if %{with crashreporter}
509%attr(755,root,root) %{_libdir}/%{name}/crashreporter
510%{_libdir}/%{name}/crashreporter.ini
511%{_libdir}/%{name}/Throbber-small.gif
512%endif
513
44be9ed4 514%dir %{_libdir}/%{name}/extensions
515%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 516
52fc61e6
ER
517# files created by regxpcom -register
518%ghost %{_libdir}/%{name}/components/compreg.dat
519%ghost %{_libdir}/%{name}/components/xpti.dat
520
6578c165 521%if %{with lightning}
522%files addon-lightning
523%defattr(644,root,root,755)
f3b6d696 524%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 525%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
526%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
527%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 528%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
529%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
530%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
531%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 532%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
533%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
534%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 538%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
539%endif
44be9ed4 540
541%if %{with enigmail}
542%files addon-enigmail
543%defattr(644,root,root,755)
f6a43e2f
ER
544%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
545%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
546%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
547%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
548%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
549%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
550%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
551%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
552%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 553%endif
This page took 0.190441 seconds and 4 git commands to generate.