]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- -fpermissive is needed to build with gcc 4.6+ which has become stricter
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - fix icedove (building) and installing nss/nspr libs!
283702b9 4# - build with system mozldap
c4ddd260 5#
44be9ed4 6# Conditional builds
7%bcond_without enigmail # don't build enigmail - GPG/PGP support
8%bcond_without gnomeui # disable gnomeui support
9%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
11%bcond_without ldap # disable e-mail address lookups in LDAP directories
6578c165 12%bcond_without lightning # disable sunbird calendar
765a3a27
ER
13%bcond_with xulrunner # build with xulrunner
14%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 15
44be9ed4 16%if %{without gnome}
17%undefine with_gnomeui
18%undefine with_gnomevfs
19%endif
88149483 20
765a3a27
ER
21%if %{?_enable_debug_packages} != 1
22%undefine crashreporter
23%endif
24
f4aadbdb 25%define enigmail_ver 1.1.2
44be9ed4 26
7d981f69
ER
27%if %{without xulrunner}
28# The actual sqlite version (see RHBZ#480989):
29%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
30%endif
31
44be9ed4 32Summary: Icedove - email client
33Summary(pl.UTF-8): Icedove - klient poczty
34Name: icedove
409bad54 35Version: 3.1.11
c6ec3c1c 36Release: 2
44be9ed4 37License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 38Group: X11/Applications/Networking
cadfb931 39Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
409bad54 40# Source0-md5: 25833b3f90925d96285630d22c85cd5c
44be9ed4 41Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
f4aadbdb 42# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
44be9ed4 43Source2: %{name}-branding.tar.bz2
c105f759 44# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 45Source3: %{name}-rm_nonfree.sh
46Source4: %{name}.desktop
47Source5: %{name}.sh
44be9ed4 48Patch0: %{name}-branding.patch
faa5c89d
SP
49Patch1: %{name}-enigmail-shared.patch
50Patch2: %{name}-gcc.patch
51Patch3: %{name}-fonts.patch
52Patch4: %{name}-install.patch
5e9bb798 53Patch5: %{name}-hunspell.patch
faa5c89d 54Patch6: %{name}-prefs.patch
9a743685 55Patch7: system-mozldap.patch
a85e0ecb 56Patch8: %{name}-makefile.patch
ca336c77 57Patch9: %{name}-libpng.patch
ccc206fe 58Patch10: %{name}-extensiondir.patch
765a3a27 59Patch11: crashreporter.patch
268e7766 60Patch12: no-subshell.patch
4922c320 61URL: http://www.pld-linux.org/Packages/Icedove
44be9ed4 62%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
51a3b6db 63BuildRequires: alsa-lib-devel
44be9ed4 64BuildRequires: automake
51a3b6db 65BuildRequires: bzip2-devel
44be9ed4 66BuildRequires: freetype-devel >= 1:2.1.8
67%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
68BuildRequires: gtk+2-devel >= 1:2.0.0
5e9bb798 69BuildRequires: hunspell-devel
44be9ed4 70BuildRequires: libIDL-devel >= 0.8.0
71%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 72%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 73%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 74BuildRequires: libiw-devel
44be9ed4 75BuildRequires: libjpeg-devel >= 6b
51a3b6db 76BuildRequires: libnotify-devel >= 0.4
44be9ed4 77BuildRequires: libpng-devel >= 1.2.0
78BuildRequires: libstdc++-devel
cadfb931
SP
79BuildRequires: nspr-devel >= 1:4.8
80BuildRequires: nss-devel >= 1:3.12.0
44be9ed4 81BuildRequires: pango-devel >= 1:1.1.0
1c62cadb 82BuildRequires: pkgconfig
44be9ed4 83BuildRequires: sed >= 4.0
9d1bfad8 84BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 85BuildRequires: startup-notification-devel >= 0.8
44be9ed4 86BuildRequires: xorg-lib-libXext-devel
44be9ed4 87BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 88BuildRequires: xorg-lib-libXt-devel
1c62cadb 89BuildRequires: zip
b1ced411 90Requires(post): mktemp >= 1.5-18
7d981f69
ER
91%if %{with xulrunner}
92%else
44be9ed4 93Requires: myspell-common
94Requires: nspr >= 1:4.6.1
95Requires: nss >= 1:3.11.3
4b6bc367 96Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 97%endif
44be9ed4 98Obsoletes: mozilla-thunderbird
99Obsoletes: mozilla-thunderbird-dictionary-en-US
100BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
9e366f18
AM
102%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
103
44be9ed4 104# iceweasel/icedove/iceape provide their own versions
c072808a 105%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 106%define _noautoprovfiles %{_libdir}/%{name}/components
107# we don't want these to satisfy xulrunner-devel
c072808a 108%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 109# and as we don't provide them, don't require either
c072808a 110%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 111
9e7875fc
ER
112%define topdir %{_builddir}/%{name}-%{version}
113%define objdir %{topdir}/obj-%{_target_cpu}
114
44be9ed4 115%description
116Icedove is an open-source,fast and portable email client.
117
118%description -l pl.UTF-8
119Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
120
6578c165 121%package addon-lightning
122Summary: An integrated calendar for Icedove
123Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
124License: MPL 1.1 or GPL v2+ or LGPL v2.1+
125Group: Applications/Networking
126Requires: %{name} = %{version}-%{release}
127
128%description addon-lightning
129Lightning is an calendar extension to Icedove email client.
130
131%description addon-lightning -l pl.UTF-8
132Lightning to rozszerzenie do klienta poczty Icedove dodające
133funkcjonalność kalendarza.
134
44be9ed4 135%package addon-enigmail
136Summary: Extension for the authentication and encryption features provided by GnuPG
137Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
138License: MPL/LGPL
139Group: Applications/Networking
140URL: http://enigmail.mozdev.org/
cd056caa 141Requires: %{name} = %{version}-%{release}
d076d93e 142Requires: gnupg
75991bbb 143Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 144
145%description addon-enigmail
c5e06599 146Enigmail is an extension to the Icedove mail client which allows users
147to access the authentication and encryption features provided by
148GnuPG.
44be9ed4 149
150Main Features:
151- Encrypt/sign mail when sending, decrypt/authenticate received mail
152- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
153- Per-Account based encryption and signing defaults
154- Per-Recipient rules for automated key selection, and
155 enabling/disabling encryption and signing
156- OpenPGP key management interface
157
158%description addon-enigmail -l pl.UTF-8
c5e06599 159Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
160użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
161przez GnuPG.
44be9ed4 162
163Główne możliwości:
164- szyfrowanie/podpisywanie poczty przy wysyłaniu,
165 odszyfrowywanie/uwierzytelnianie poczty odebranej
166- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
167- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
168- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
169 podpisywania dla każdego adresata
170- interfejs do zarządzania kluczami OpenPGP
171
172%prep
983562b1 173%setup -qc
a85e0ecb 174mv -f comm-1.9.2 mozilla
983562b1 175%setup -q -T -D -a2
176cd mozilla
1c70899a 177%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 178/bin/sh %{SOURCE3}
983562b1 179%patch0 -p1
faa5c89d
SP
180%{?with_enigmail:%patch1 -p1}
181%patch2 -p1
4ccc2157 182%patch3 -p1
faa5c89d 183%patch4 -p1
5e9bb798 184%patch5 -p1
983562b1 185%patch6 -p1
9a743685 186%patch7 -p1
a85e0ecb 187%patch8 -p0
ca336c77 188%patch9 -p0
ccc206fe 189%patch10 -p2
765a3a27 190%patch11 -p2
268e7766 191%patch12 -p1
44be9ed4 192
193%build
983562b1 194cd mozilla
cadfb931
SP
195cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
196cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
24c96b22 197cp -f %{_datadir}/automake/config.* directory/sdks/c-sdk/config/autoconf
44be9ed4 198
9a743685
ER
199install -d libxul-sdk
200ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 201
fbac75ca 202cat << EOF > .mozconfig
9e7875fc 203mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 204
52f5507d
ER
205export CFLAGS="%{rpmcflags} -fpermissive"
206export CXXFLAGS="%{rpmcflags} -fpermissive"
765a3a27
ER
207
208%if %{with crashreporter}
209export MOZ_DEBUG_SYMBOLS=1
210%endif
211
59c5a0e8 212# Options for 'configure' (same as command-line options).
44be9ed4 213ac_add_options --prefix=%{_prefix}
214ac_add_options --exec-prefix=%{_exec_prefix}
215ac_add_options --bindir=%{_bindir}
216ac_add_options --sbindir=%{_sbindir}
217ac_add_options --sysconfdir=%{_sysconfdir}
218ac_add_options --datadir=%{_datadir}
219ac_add_options --includedir=%{_includedir}
220ac_add_options --libdir=%{_libdir}
221ac_add_options --libexecdir=%{_libexecdir}
222ac_add_options --localstatedir=%{_localstatedir}
223ac_add_options --sharedstatedir=%{_sharedstatedir}
224ac_add_options --mandir=%{_mandir}
225ac_add_options --infodir=%{_infodir}
226%if %{?debug:1}0
59c5a0e8 227ac_add_options --disable-optimize
44be9ed4 228ac_add_options --enable-debug
229ac_add_options --enable-debug-modules
59c5a0e8
SP
230ac_add_options --enable-debugger-info-modules
231ac_add_options --enable-crash-on-assert
44be9ed4 232%else
233ac_add_options --disable-debug
234ac_add_options --disable-debug-modules
59c5a0e8
SP
235ac_add_options --disable-logging
236ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 237%endif
88149483
ER
238ac_add_options --disable-strip
239ac_add_options --disable-strip-libs
44be9ed4 240%if %{with tests}
241ac_add_options --enable-tests
242%else
243ac_add_options --disable-tests
244%endif
245%if %{with gnomeui}
246ac_add_options --enable-gnomeui
247%else
248ac_add_options --disable-gnomeui
249%endif
250%if %{with gnomevfs}
251ac_add_options --enable-gnomevfs
252%else
253ac_add_options --disable-gnomevfs
254%endif
255%if %{with ldap}
256ac_add_options --enable-ldap
9a743685 257ac_add_options --with-system-ldap
44be9ed4 258%else
259ac_add_options --disable-ldap
260%endif
765a3a27
ER
261%if %{with crashreporter}
262ac_add_options --enable-crashreporter
263%else
59c5a0e8 264ac_add_options --disable-crashreporter
765a3a27 265%endif
59c5a0e8 266ac_add_options --disable-xterm-updates
59c5a0e8 267ac_add_options --enable-postscript
d076d93e 268%if %{with lightning}
cb0e4412 269ac_add_options --enable-calendar
d076d93e
SP
270%else
271ac_add_options --disable-calendar
272%endif
44be9ed4 273ac_add_options --disable-installer
274ac_add_options --disable-jsd
88149483 275ac_add_options --disable-updater
44be9ed4 276ac_add_options --disable-xprint
cadfb931
SP
277ac_add_options --disable-permissions
278ac_add_options --disable-pref-extensions
44be9ed4 279ac_add_options --enable-canvas
280ac_add_options --enable-crypto
44be9ed4 281ac_add_options --enable-mathml
44be9ed4 282ac_add_options --enable-pango
283ac_add_options --enable-reorder
88149483
ER
284ac_add_options --enable-startup-notification
285ac_add_options --enable-svg
44be9ed4 286ac_add_options --enable-system-cairo
5e9bb798 287ac_add_options --enable-system-hunspell
7d981f69 288ac_add_options --enable-system-sqlite
44be9ed4 289ac_add_options --enable-xft
cadfb931
SP
290ac_add_options --enable-application=mail
291ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 292ac_add_options --enable-xinerama
88149483
ER
293ac_add_options --with-distribution-id=org.pld-linux
294ac_add_options --with-branding=icedove/branding
295%if %{with xulrunner}
fbac75ca
ER
296ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
297ac_add_options --enable-shared
298%else
299ac_add_options --enable-static
88149483
ER
300%endif
301ac_add_options --with-pthreads
302ac_add_options --with-system-bz2
44be9ed4 303ac_add_options --with-system-jpeg
304ac_add_options --with-system-nspr
305ac_add_options --with-system-nss
306ac_add_options --with-system-png
307ac_add_options --with-system-zlib
44be9ed4 308ac_add_options --enable-single-profile
309ac_add_options --disable-profilesharing
44be9ed4 310ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
311EOF
312
90e998ba 313%{__make} -j1 -f client.mk build \
d076d93e 314 STRIP="/bin/true" \
765a3a27 315 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 316 CC="%{__cc}" \
44be9ed4 317 CXX="%{__cxx}"
318
765a3a27
ER
319%if %{with crashreporter}
320# create debuginfo for crash-stats.mozilla.com
321%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
322%endif
323
44be9ed4 324%if %{with enigmail}
59c5a0e8 325cd mailnews/extensions/enigmail
9e7875fc
ER
326./makemake -r -o %{objdir}
327%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
328 STRIP="/bin/true" \
329 CC="%{__cc}" \
330 CXX="%{__cxx}"
44be9ed4 331%endif
332
333%install
334rm -rf $RPM_BUILD_ROOT
765a3a27 335install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 336
9e7875fc 337cd %{objdir}
ecf04393 338%{__make} -C mail/installer stage-package \
44be9ed4 339 DESTDIR=$RPM_BUILD_ROOT \
340 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
341 PKG_SKIP_STRIP=1
342
765a3a27
ER
343# Enable crash reporter for Firefox application
344%if %{with crashreporter}
345%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
346
347# Add debuginfo for crash-stats.mozilla.com
51a3b6db 348install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
349cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
350%endif
351
ecf04393
ER
352# copy manually lightning files, somewhy they are not installed by make
353cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
354 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
355 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
356
44be9ed4 357# move arch independant ones to datadir
358mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
359mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
360mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
44be9ed4 361mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 362mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 363mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
364ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
365ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
366ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
44be9ed4 367ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 368ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 369ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
370
c6ec3c1c
ER
371# dir for arch independant extensions besides arch dependant extensions
372# see mozilla/xpcom/build/nsXULAppAPI.h
373# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
374install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
375
63d8f5c3 376%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 377ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
378
379%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
380ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
381ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
382
52f5507d
ER
383cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
384cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 385
e8f4ba81 386# files created by regxpcom -register in post
52fc61e6
ER
387touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
388touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
389cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
390#!/bin/sh
391umask 022
392# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
393# dangerous if you run this with sudo with keep_env += HOME
394# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
395t=$(mktemp -d)
d50a2a28 396%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
397TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
398rm -rf $t
399EOF
400chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 401
44be9ed4 402%if %{with enigmail}
283702b9
ER
403ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
404install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6
ER
405cd mozilla/dist/bin
406cp -rfLp chrome/enigmail.jar $ext_dir/chrome
407cp -rfLp chrome/enigmime.jar $ext_dir/chrome
408cp -rfLp components/enig* $ext_dir/components
409cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 410cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
411cp -rfLp components/ipc.xpt $ext_dir/components
412cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
413cd -
52f5507d
ER
414cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
415cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 416%endif
417
9a743685 418# remove unecessary stuff
63d8f5c3 419%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
420%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
421%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 422
9cdc8923
ER
423# never package these. always remove
424# nss
425%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
426# nspr
427%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 428# mozldap
9cdc8923 429%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 430
44be9ed4 431%clean
432rm -rf $RPM_BUILD_ROOT
433
434%pretrans
435if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
436 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
437fi
9e097178 438for d in chrome defaults greprefs icons isp modules res; do
44be9ed4 439 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
440 install -d %{_datadir}/%{name}
441 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
442 fi
443done
444exit 0
445
e8f4ba81
ER
446%post
447%{_libdir}/%{name}/register || :
448
44be9ed4 449%files
450%defattr(644,root,root,755)
451%attr(755,root,root) %{_bindir}/icedove
452%attr(755,root,root) %{_bindir}/mozilla-thunderbird
453%attr(755,root,root) %{_bindir}/thunderbird
454%dir %{_libdir}/%{name}
765a3a27
ER
455%{_libdir}/%{name}/application.ini
456%{_libdir}/%{name}/platform.ini
44be9ed4 457%dir %{_libdir}/%{name}/components
458%attr(755,root,root) %{_libdir}/%{name}/components/*.so
459%{_libdir}/%{name}/components/*.js
460%{_libdir}/%{name}/components/*.xpt
283702b9
ER
461%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
462%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
463%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
44be9ed4 464%attr(755,root,root) %{_libdir}/%{name}/*.sh
465%attr(755,root,root) %{_libdir}/%{name}/*-bin
466%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 467%attr(755,root,root) %{_libdir}/%{name}/icedove
e8f4ba81 468%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 469
470# symlinks
471%{_libdir}/%{name}/chrome
472%{_libdir}/%{name}/defaults
473%{_libdir}/%{name}/dictionaries
474%{_libdir}/%{name}/greprefs
44be9ed4 475%{_libdir}/%{name}/isp
9e097178 476%{_libdir}/%{name}/modules
44be9ed4 477%{_libdir}/%{name}/res
478
293928f3 479%{_pixmapsdir}/*.png
44be9ed4 480%{_desktopdir}/*.desktop
481
482%dir %{_datadir}/%{name}
483%{_datadir}/%{name}/chrome
484%{_datadir}/%{name}/defaults
485%{_datadir}/%{name}/greprefs
44be9ed4 486%{_datadir}/%{name}/isp
9e097178 487%{_datadir}/%{name}/modules
44be9ed4 488%{_datadir}/%{name}/res
c6ec3c1c 489%{_datadir}/%{name}/extensions
44be9ed4 490
765a3a27
ER
491%if %{with crashreporter}
492%attr(755,root,root) %{_libdir}/%{name}/crashreporter
493%{_libdir}/%{name}/crashreporter.ini
494%{_libdir}/%{name}/Throbber-small.gif
495%endif
496
44be9ed4 497%dir %{_libdir}/%{name}/extensions
498%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 499
52fc61e6
ER
500# files created by regxpcom -register
501%ghost %{_libdir}/%{name}/components/compreg.dat
502%ghost %{_libdir}/%{name}/components/xpti.dat
503
6578c165 504%if %{with lightning}
505%files addon-lightning
506%defattr(644,root,root,755)
f3b6d696
ER
507%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
508%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
509%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
510%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
511%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
512%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
513%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
514%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
515%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
516%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
517%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
518%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
519
6578c165 520%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
521%endif
44be9ed4 522
523%if %{with enigmail}
524%files addon-enigmail
525%defattr(644,root,root,755)
f6a43e2f
ER
526%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
527%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
528%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
529%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
530%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
531%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
532%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
533%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
534%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 535%endif
This page took 0.188443 seconds and 4 git commands to generate.