]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- up to 6.0.2
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - fix icedove (building) and installing nss/nspr libs!
283702b9 4# - build with system mozldap
c4ddd260 5#
44be9ed4 6# Conditional builds
7%bcond_without enigmail # don't build enigmail - GPG/PGP support
8%bcond_without gnomeui # disable gnomeui support
9%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
11%bcond_without ldap # disable e-mail address lookups in LDAP directories
6578c165 12%bcond_without lightning # disable sunbird calendar
f4114a7f 13%bcond_without xulrunner # build with xulrunner
765a3a27 14%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 15
44be9ed4 16%if %{without gnome}
17%undefine with_gnomeui
18%undefine with_gnomevfs
19%endif
88149483 20
f4114a7f 21%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
22%undefine crashreporter
23%endif
24
f4114a7f
ER
25%define enigmail_ver 1.1.2
26%define nspr_ver 4.8.8
27%define nss_ver 3.12.10
44be9ed4 28
7d981f69
ER
29%if %{without xulrunner}
30# The actual sqlite version (see RHBZ#480989):
31%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
32%endif
33
44be9ed4 34Summary: Icedove - email client
35Summary(pl.UTF-8): Icedove - klient poczty
36Name: icedove
a61ac19b 37Version: 6.0.2
f4114a7f 38Release: 0.1
44be9ed4 39License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 40Group: X11/Applications/Networking
cadfb931 41Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
a61ac19b 42# Source0-md5: 917a667fe21cfd103092dbc23a112192
44be9ed4 43Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
f4aadbdb 44# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
44be9ed4 45Source2: %{name}-branding.tar.bz2
c105f759 46# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 47Source3: %{name}-rm_nonfree.sh
48Source4: %{name}.desktop
49Source5: %{name}.sh
44be9ed4 50Patch0: %{name}-branding.patch
faa5c89d
SP
51Patch1: %{name}-enigmail-shared.patch
52Patch2: %{name}-gcc.patch
53Patch3: %{name}-fonts.patch
54Patch4: %{name}-install.patch
5e9bb798 55Patch5: %{name}-hunspell.patch
faa5c89d 56Patch6: %{name}-prefs.patch
9a743685 57Patch7: system-mozldap.patch
a85e0ecb 58Patch8: %{name}-makefile.patch
ccc206fe 59Patch10: %{name}-extensiondir.patch
765a3a27 60Patch11: crashreporter.patch
268e7766 61Patch12: no-subshell.patch
4922c320 62URL: http://www.pld-linux.org/Packages/Icedove
44be9ed4 63%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
51a3b6db 64BuildRequires: alsa-lib-devel
44be9ed4 65BuildRequires: automake
51a3b6db 66BuildRequires: bzip2-devel
44be9ed4 67BuildRequires: freetype-devel >= 1:2.1.8
68%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
69BuildRequires: gtk+2-devel >= 1:2.0.0
5e9bb798 70BuildRequires: hunspell-devel
44be9ed4 71BuildRequires: libIDL-devel >= 0.8.0
72%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 73%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 74%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 75BuildRequires: libiw-devel
44be9ed4 76BuildRequires: libjpeg-devel >= 6b
51a3b6db 77BuildRequires: libnotify-devel >= 0.4
44be9ed4 78BuildRequires: libpng-devel >= 1.2.0
79BuildRequires: libstdc++-devel
f4114a7f
ER
80BuildRequires: nspr-devel >= 1:%{nspr_ver}
81BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 82BuildRequires: pango-devel >= 1:1.1.0
1c62cadb 83BuildRequires: pkgconfig
44be9ed4 84BuildRequires: sed >= 4.0
9d1bfad8 85BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 86BuildRequires: startup-notification-devel >= 0.8
44be9ed4 87BuildRequires: xorg-lib-libXext-devel
44be9ed4 88BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 89BuildRequires: xorg-lib-libXt-devel
1c62cadb 90BuildRequires: zip
b1ced411 91Requires(post): mktemp >= 1.5-18
7d981f69 92%if %{with xulrunner}
f6b6d331 93BuildRequires: xulrunner-devel
7d981f69 94%else
44be9ed4 95Requires: myspell-common
f4114a7f
ER
96Requires: nspr >= 1:%{nspr_ver}
97Requires: nss >= 1:%{nss_ver}
4b6bc367 98Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 99%endif
44be9ed4 100Obsoletes: mozilla-thunderbird
101Obsoletes: mozilla-thunderbird-dictionary-en-US
102BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
9e366f18
AM
104%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
105
44be9ed4 106# iceweasel/icedove/iceape provide their own versions
c072808a 107%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 108%define _noautoprovfiles %{_libdir}/%{name}/components
109# we don't want these to satisfy xulrunner-devel
c072808a 110%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 111# and as we don't provide them, don't require either
c072808a 112%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 113
9e7875fc
ER
114%define topdir %{_builddir}/%{name}-%{version}
115%define objdir %{topdir}/obj-%{_target_cpu}
116
44be9ed4 117%description
118Icedove is an open-source,fast and portable email client.
119
120%description -l pl.UTF-8
121Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
122
6578c165 123%package addon-lightning
124Summary: An integrated calendar for Icedove
125Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
126License: MPL 1.1 or GPL v2+ or LGPL v2.1+
127Group: Applications/Networking
128Requires: %{name} = %{version}-%{release}
129
130%description addon-lightning
131Lightning is an calendar extension to Icedove email client.
132
133%description addon-lightning -l pl.UTF-8
134Lightning to rozszerzenie do klienta poczty Icedove dodające
135funkcjonalność kalendarza.
136
44be9ed4 137%package addon-enigmail
138Summary: Extension for the authentication and encryption features provided by GnuPG
139Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
140License: MPL/LGPL
141Group: Applications/Networking
142URL: http://enigmail.mozdev.org/
cd056caa 143Requires: %{name} = %{version}-%{release}
d076d93e 144Requires: gnupg
75991bbb 145Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 146
147%description addon-enigmail
c5e06599 148Enigmail is an extension to the Icedove mail client which allows users
149to access the authentication and encryption features provided by
150GnuPG.
44be9ed4 151
152Main Features:
153- Encrypt/sign mail when sending, decrypt/authenticate received mail
154- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
155- Per-Account based encryption and signing defaults
156- Per-Recipient rules for automated key selection, and
157 enabling/disabling encryption and signing
158- OpenPGP key management interface
159
160%description addon-enigmail -l pl.UTF-8
c5e06599 161Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
162użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
163przez GnuPG.
44be9ed4 164
165Główne możliwości:
166- szyfrowanie/podpisywanie poczty przy wysyłaniu,
167 odszyfrowywanie/uwierzytelnianie poczty odebranej
168- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
169- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
170- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
171 podpisywania dla każdego adresata
172- interfejs do zarządzania kluczami OpenPGP
173
174%prep
983562b1 175%setup -qc
f4114a7f 176mv comm-release mozilla
983562b1 177%setup -q -T -D -a2
178cd mozilla
1c70899a 179%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 180/bin/sh %{SOURCE3}
983562b1 181%patch0 -p1
faa5c89d
SP
182%{?with_enigmail:%patch1 -p1}
183%patch2 -p1
4ccc2157 184%patch3 -p1
faa5c89d 185%patch4 -p1
5e9bb798 186%patch5 -p1
983562b1 187%patch6 -p1
9a743685 188%patch7 -p1
f4114a7f 189%patch8 -p2
ccc206fe 190%patch10 -p2
765a3a27 191%patch11 -p2
268e7766 192%patch12 -p1
44be9ed4 193
194%build
983562b1 195cd mozilla
cadfb931
SP
196cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
197cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 198cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 199
9a743685
ER
200install -d libxul-sdk
201ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 202
fbac75ca 203cat << EOF > .mozconfig
9e7875fc 204mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 205
52f5507d
ER
206export CFLAGS="%{rpmcflags} -fpermissive"
207export CXXFLAGS="%{rpmcflags} -fpermissive"
765a3a27
ER
208
209%if %{with crashreporter}
210export MOZ_DEBUG_SYMBOLS=1
211%endif
212
59c5a0e8 213# Options for 'configure' (same as command-line options).
44be9ed4 214ac_add_options --prefix=%{_prefix}
215ac_add_options --exec-prefix=%{_exec_prefix}
216ac_add_options --bindir=%{_bindir}
217ac_add_options --sbindir=%{_sbindir}
218ac_add_options --sysconfdir=%{_sysconfdir}
219ac_add_options --datadir=%{_datadir}
220ac_add_options --includedir=%{_includedir}
221ac_add_options --libdir=%{_libdir}
222ac_add_options --libexecdir=%{_libexecdir}
223ac_add_options --localstatedir=%{_localstatedir}
224ac_add_options --sharedstatedir=%{_sharedstatedir}
225ac_add_options --mandir=%{_mandir}
226ac_add_options --infodir=%{_infodir}
227%if %{?debug:1}0
59c5a0e8 228ac_add_options --disable-optimize
44be9ed4 229ac_add_options --enable-debug
230ac_add_options --enable-debug-modules
59c5a0e8
SP
231ac_add_options --enable-debugger-info-modules
232ac_add_options --enable-crash-on-assert
44be9ed4 233%else
234ac_add_options --disable-debug
235ac_add_options --disable-debug-modules
59c5a0e8
SP
236ac_add_options --disable-logging
237ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 238%endif
88149483
ER
239ac_add_options --disable-strip
240ac_add_options --disable-strip-libs
44be9ed4 241%if %{with tests}
242ac_add_options --enable-tests
243%else
244ac_add_options --disable-tests
245%endif
246%if %{with gnomeui}
247ac_add_options --enable-gnomeui
248%else
249ac_add_options --disable-gnomeui
250%endif
251%if %{with gnomevfs}
252ac_add_options --enable-gnomevfs
253%else
254ac_add_options --disable-gnomevfs
255%endif
256%if %{with ldap}
257ac_add_options --enable-ldap
9a743685 258ac_add_options --with-system-ldap
44be9ed4 259%else
260ac_add_options --disable-ldap
261%endif
765a3a27
ER
262%if %{with crashreporter}
263ac_add_options --enable-crashreporter
264%else
59c5a0e8 265ac_add_options --disable-crashreporter
765a3a27 266%endif
59c5a0e8 267ac_add_options --disable-xterm-updates
59c5a0e8 268ac_add_options --enable-postscript
d076d93e 269%if %{with lightning}
cb0e4412 270ac_add_options --enable-calendar
d076d93e
SP
271%else
272ac_add_options --disable-calendar
273%endif
44be9ed4 274ac_add_options --disable-installer
275ac_add_options --disable-jsd
88149483 276ac_add_options --disable-updater
44be9ed4 277ac_add_options --disable-xprint
cadfb931
SP
278ac_add_options --disable-permissions
279ac_add_options --disable-pref-extensions
44be9ed4 280ac_add_options --enable-canvas
281ac_add_options --enable-crypto
44be9ed4 282ac_add_options --enable-mathml
44be9ed4 283ac_add_options --enable-pango
284ac_add_options --enable-reorder
88149483
ER
285ac_add_options --enable-startup-notification
286ac_add_options --enable-svg
44be9ed4 287ac_add_options --enable-system-cairo
5e9bb798 288ac_add_options --enable-system-hunspell
7d981f69 289ac_add_options --enable-system-sqlite
44be9ed4 290ac_add_options --enable-xft
cadfb931
SP
291ac_add_options --enable-application=mail
292ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 293ac_add_options --enable-xinerama
88149483
ER
294ac_add_options --with-distribution-id=org.pld-linux
295ac_add_options --with-branding=icedove/branding
296%if %{with xulrunner}
f4114a7f
ER
297#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
298ac_add_options --with-system-libxul
fbac75ca 299ac_add_options --enable-shared
f4114a7f 300ac_add_options --enable-libxul
fbac75ca 301%else
f4114a7f 302ac_add_options --disable-xul
88149483
ER
303%endif
304ac_add_options --with-pthreads
305ac_add_options --with-system-bz2
44be9ed4 306ac_add_options --with-system-jpeg
307ac_add_options --with-system-nspr
308ac_add_options --with-system-nss
309ac_add_options --with-system-png
310ac_add_options --with-system-zlib
44be9ed4 311ac_add_options --enable-single-profile
312ac_add_options --disable-profilesharing
44be9ed4 313ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
314EOF
315
90e998ba 316%{__make} -j1 -f client.mk build \
d076d93e 317 STRIP="/bin/true" \
765a3a27 318 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 319 CC="%{__cc}" \
44be9ed4 320 CXX="%{__cxx}"
321
765a3a27
ER
322%if %{with crashreporter}
323# create debuginfo for crash-stats.mozilla.com
324%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
325%endif
326
44be9ed4 327%if %{with enigmail}
59c5a0e8 328cd mailnews/extensions/enigmail
9e7875fc
ER
329./makemake -r -o %{objdir}
330%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
331 STRIP="/bin/true" \
332 CC="%{__cc}" \
333 CXX="%{__cxx}"
44be9ed4 334%endif
335
336%install
337rm -rf $RPM_BUILD_ROOT
765a3a27 338install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 339
9e7875fc 340cd %{objdir}
ecf04393 341%{__make} -C mail/installer stage-package \
44be9ed4 342 DESTDIR=$RPM_BUILD_ROOT \
343 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
344 PKG_SKIP_STRIP=1
345
765a3a27
ER
346# Enable crash reporter for Firefox application
347%if %{with crashreporter}
348%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
349
350# Add debuginfo for crash-stats.mozilla.com
51a3b6db 351install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
352cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
353%endif
354
ecf04393
ER
355# copy manually lightning files, somewhy they are not installed by make
356cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
357 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
358 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
359
44be9ed4 360# move arch independant ones to datadir
361mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
362mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
363mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
44be9ed4 364mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 365mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 366mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
367ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
368ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
369ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
44be9ed4 370ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 371ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 372ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
373
c6ec3c1c
ER
374# dir for arch independant extensions besides arch dependant extensions
375# see mozilla/xpcom/build/nsXULAppAPI.h
376# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
377install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
378
63d8f5c3 379%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 380ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
381
382%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
383ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
384ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
385
52f5507d
ER
386cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
387cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 388
e8f4ba81 389# files created by regxpcom -register in post
52fc61e6
ER
390touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
391touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
392cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
393#!/bin/sh
394umask 022
395# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
396# dangerous if you run this with sudo with keep_env += HOME
397# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
398t=$(mktemp -d)
d50a2a28 399%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
400TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
401rm -rf $t
402EOF
403chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 404
44be9ed4 405%if %{with enigmail}
283702b9
ER
406ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
407install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6
ER
408cd mozilla/dist/bin
409cp -rfLp chrome/enigmail.jar $ext_dir/chrome
410cp -rfLp chrome/enigmime.jar $ext_dir/chrome
411cp -rfLp components/enig* $ext_dir/components
412cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 413cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
414cp -rfLp components/ipc.xpt $ext_dir/components
415cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
416cd -
52f5507d
ER
417cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
418cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 419%endif
420
9a743685 421# remove unecessary stuff
63d8f5c3 422%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
423%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
424%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 425
9cdc8923
ER
426# never package these. always remove
427# nss
428%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
429# nspr
430%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 431# mozldap
9cdc8923 432%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 433
44be9ed4 434%clean
435rm -rf $RPM_BUILD_ROOT
436
437%pretrans
438if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
439 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
440fi
9e097178 441for d in chrome defaults greprefs icons isp modules res; do
44be9ed4 442 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
443 install -d %{_datadir}/%{name}
444 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
445 fi
446done
447exit 0
448
e8f4ba81
ER
449%post
450%{_libdir}/%{name}/register || :
451
44be9ed4 452%files
453%defattr(644,root,root,755)
454%attr(755,root,root) %{_bindir}/icedove
455%attr(755,root,root) %{_bindir}/mozilla-thunderbird
456%attr(755,root,root) %{_bindir}/thunderbird
457%dir %{_libdir}/%{name}
765a3a27
ER
458%{_libdir}/%{name}/application.ini
459%{_libdir}/%{name}/platform.ini
44be9ed4 460%dir %{_libdir}/%{name}/components
461%attr(755,root,root) %{_libdir}/%{name}/components/*.so
462%{_libdir}/%{name}/components/*.js
463%{_libdir}/%{name}/components/*.xpt
283702b9
ER
464%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
465%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
466%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
44be9ed4 467%attr(755,root,root) %{_libdir}/%{name}/*.sh
468%attr(755,root,root) %{_libdir}/%{name}/*-bin
469%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 470%attr(755,root,root) %{_libdir}/%{name}/icedove
e8f4ba81 471%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 472
473# symlinks
474%{_libdir}/%{name}/chrome
475%{_libdir}/%{name}/defaults
476%{_libdir}/%{name}/dictionaries
477%{_libdir}/%{name}/greprefs
44be9ed4 478%{_libdir}/%{name}/isp
9e097178 479%{_libdir}/%{name}/modules
44be9ed4 480%{_libdir}/%{name}/res
481
293928f3 482%{_pixmapsdir}/*.png
44be9ed4 483%{_desktopdir}/*.desktop
484
485%dir %{_datadir}/%{name}
486%{_datadir}/%{name}/chrome
487%{_datadir}/%{name}/defaults
488%{_datadir}/%{name}/greprefs
44be9ed4 489%{_datadir}/%{name}/isp
9e097178 490%{_datadir}/%{name}/modules
44be9ed4 491%{_datadir}/%{name}/res
c6ec3c1c 492%{_datadir}/%{name}/extensions
44be9ed4 493
765a3a27
ER
494%if %{with crashreporter}
495%attr(755,root,root) %{_libdir}/%{name}/crashreporter
496%{_libdir}/%{name}/crashreporter.ini
497%{_libdir}/%{name}/Throbber-small.gif
498%endif
499
44be9ed4 500%dir %{_libdir}/%{name}/extensions
501%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 502
52fc61e6
ER
503# files created by regxpcom -register
504%ghost %{_libdir}/%{name}/components/compreg.dat
505%ghost %{_libdir}/%{name}/components/xpti.dat
506
6578c165 507%if %{with lightning}
508%files addon-lightning
509%defattr(644,root,root,755)
f3b6d696
ER
510%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
511%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
512%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
513%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
514%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
515%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
516%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
517%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
518%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
519%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
520%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
521%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
522
6578c165 523%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
524%endif
44be9ed4 525
526%if %{with enigmail}
527%files addon-enigmail
528%defattr(644,root,root,755)
f6a43e2f
ER
529%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
530%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
531%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
532%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
533%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
534%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
535%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
536%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
537%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 538%endif
This page took 0.159857 seconds and 4 git commands to generate.