]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- dropped obsolete gcc patch
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_without  xulrunner       # build with xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.3.5
23 %define         nspr_ver        4.8.8
24 %define         nss_ver         3.12.10
25
26 # convert thunderbird release number to platform version: 9.0.x -> 9.0.x
27 %define         xulrunner_main  10.0
28 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#10.0})
29
30 %if %{without xulrunner}
31 # The actual sqlite version (see RHBZ#480989):
32 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33 %endif
34
35 Summary:        Icedove - email client
36 Summary(pl.UTF-8):      Icedove - klient poczty
37 Name:           icedove
38 Version:        10.0.2
39 Release:        3
40 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
41 Group:          X11/Applications/Networking
42 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
43 # Source0-md5:  624bef982d7ac610b1175737d9905150
44 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
45 # Source1-md5:  1b008b0d106e238c11e4bead08126bc0
46 Source2:        %{name}-branding.tar.bz2
47 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
48 Source3:        %{name}-rm_nonfree.sh
49 Source4:        %{name}.desktop
50 Source5:        %{name}.sh
51 Patch0:         %{name}-branding.patch
52 Patch1:         %{name}-enigmail-shared.patch
53 Patch3:         %{name}-fonts.patch
54 Patch4:         %{name}-install.patch
55 Patch5:         %{name}-hunspell.patch
56 Patch6:         %{name}-prefs.patch
57 Patch7:         system-mozldap.patch
58 Patch8:         %{name}-makefile.patch
59
60 Patch10:        %{name}-extensiondir.patch
61 Patch11:        crashreporter.patch
62 Patch12:        no-subshell.patch
63 URL:            http://www.pld-linux.org/Packages/Icedove
64 BuildRequires:  GConf2-devel >= 1.2.1
65 BuildRequires:  alsa-lib-devel
66 BuildRequires:  automake
67 BuildRequires:  bzip2-devel
68 BuildRequires:  cairo-devel >= 1.10
69 BuildRequires:  dbus-glib-devel >= 0.60
70 BuildRequires:  freetype-devel >= 1:2.1.8
71 BuildRequires:  glib2-devel >= 2.0
72 BuildRequires:  gtk+2-devel >= 2:2.10.0
73 BuildRequires:  hunspell-devel
74 BuildRequires:  libIDL-devel >= 0.8.0
75 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
76 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
77 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
78 BuildRequires:  libiw-devel
79 BuildRequires:  libjpeg-devel >= 6b
80 BuildRequires:  libnotify-devel >= 0.4
81 BuildRequires:  libpng-devel >= 1.4.1
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
84 BuildRequires:  nss-devel >= 1:%{nss_ver}
85 BuildRequires:  pango-devel >= 1:1.1.0
86 BuildRequires:  perl-base >= 1:5.6
87 BuildRequires:  pkgconfig
88 BuildRequires:  python >= 1:2.5
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  sqlite3-devel >= 3.7.4
91 BuildRequires:  startup-notification-devel >= 0.8
92 BuildRequires:  xorg-lib-libXext-devel
93 BuildRequires:  xorg-lib-libXinerama-devel
94 BuildRequires:  xorg-lib-libXt-devel
95 BuildRequires:  yasm
96 BuildRequires:  zip
97 %if %{with xulrunner}
98 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
99 %else
100 Requires:       myspell-common
101 Requires:       nspr >= 1:%{nspr_ver}
102 Requires:       nss >= 1:%{nss_ver}
103 Requires:       sqlite3 >= %{sqlite_build_version}
104 %endif
105 Requires(post): mktemp >= 1.5-18
106 %if %{with xulrunner}
107 %requires_eq_to xulrunner xulrunner-devel
108 %endif
109 Obsoletes:      mozilla-thunderbird
110 Obsoletes:      mozilla-thunderbird-dictionary-en-US
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
114
115 # iceweasel/icedove/iceape provide their own versions
116 %define         _noautoprovfiles        %{_libdir}/%{name}/components
117 # we don't want these to satisfy xulrunner-devel
118 %define         _noautoprov             libmozjs.so libxpcom.so libxul.so
119 # and as we don't provide them, don't require either
120 %define         _noautoreq              libmozjs.so libxpcom.so libxul.so
121
122 %define         topdir          %{_builddir}/%{name}-%{version}
123 %define         objdir          %{topdir}/obj-%{_target_cpu}
124
125 %description
126 Icedove is an open-source, fast and portable email client.
127
128 %description -l pl.UTF-8
129 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
130 poczty.
131
132 %package addon-lightning
133 Summary:        An integrated calendar for Icedove
134 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
135 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
136 Group:          Applications/Networking
137 Requires:       %{name} = %{version}-%{release}
138
139 %description addon-lightning
140 Lightning is an calendar extension to Icedove email client.
141
142 %description addon-lightning -l pl.UTF-8
143 Lightning to rozszerzenie do klienta poczty Icedove dodające
144 funkcjonalność kalendarza.
145
146 %package addon-enigmail
147 Summary:        Extension for the authentication and encryption features provided by GnuPG
148 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
149 License:        MPL/LGPL
150 Group:          Applications/Networking
151 URL:            http://enigmail.mozdev.org/
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       gnupg
154 Obsoletes:      mozilla-thunderbird-addon-enigmail
155
156 %description addon-enigmail
157 Enigmail is an extension to the Icedove mail client which allows users
158 to access the authentication and encryption features provided by
159 GnuPG.
160
161 Main Features:
162 - Encrypt/sign mail when sending, decrypt/authenticate received mail
163 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
164 - Per-Account based encryption and signing defaults
165 - Per-Recipient rules for automated key selection, and
166   enabling/disabling encryption and signing
167 - OpenPGP key management interface
168
169 %description addon-enigmail -l pl.UTF-8
170 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
171 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
172 przez GnuPG.
173
174 Główne możliwości:
175 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
176   odszyfrowywanie/uwierzytelnianie poczty odebranej
177 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
178 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
179 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
180   podpisywania dla każdego adresata
181 - interfejs do zarządzania kluczami OpenPGP
182
183 %prep
184 %setup -qc
185 mv comm-release mozilla
186 %setup -q -T -D -a2
187 cd mozilla
188 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
189 /bin/sh %{SOURCE3}
190 %patch0 -p1
191 %{?with_enigmail:%patch1 -p1}
192 %patch3 -p1
193 %patch4 -p1
194 %patch6 -p1
195 %patch7 -p1
196 %patch8 -p2
197 %patch10 -p2
198 %patch11 -p2
199 %patch12 -p1
200
201 %build
202 cd mozilla
203 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
204 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
205 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
206
207 install -d libxul-sdk
208 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
209
210 cat << EOF > .mozconfig
211 mk_add_options MOZ_OBJDIR=%{objdir}
212
213 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
214 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
215
216 %if %{with crashreporter}
217 export MOZ_DEBUG_SYMBOLS=1
218 %endif
219
220 # Options for 'configure' (same as command-line options).
221 ac_add_options --prefix=%{_prefix}
222 ac_add_options --exec-prefix=%{_exec_prefix}
223 ac_add_options --bindir=%{_bindir}
224 ac_add_options --sbindir=%{_sbindir}
225 ac_add_options --sysconfdir=%{_sysconfdir}
226 ac_add_options --datadir=%{_datadir}
227 ac_add_options --includedir=%{_includedir}
228 ac_add_options --libdir=%{_libdir}
229 ac_add_options --libexecdir=%{_libexecdir}
230 ac_add_options --localstatedir=%{_localstatedir}
231 ac_add_options --sharedstatedir=%{_sharedstatedir}
232 ac_add_options --mandir=%{_mandir}
233 ac_add_options --infodir=%{_infodir}
234 %if %{?debug:1}0
235 ac_add_options --disable-optimize
236 ac_add_options --enable-debug
237 ac_add_options --enable-debug-modules
238 ac_add_options --enable-debugger-info-modules
239 ac_add_options --enable-crash-on-assert
240 %else
241 ac_add_options --disable-debug
242 ac_add_options --disable-debug-modules
243 ac_add_options --disable-logging
244 ac_add_options --enable-optimize="%{rpmcflags} -Os"
245 %endif
246 ac_add_options --disable-strip
247 ac_add_options --disable-strip-libs
248 %if %{with tests}
249 ac_add_options --enable-tests
250 %else
251 ac_add_options --disable-tests
252 %endif
253 ac_add_options --enable-gio
254 %if %{with gnomeui}
255 ac_add_options --enable-gnomeui
256 %else
257 ac_add_options --disable-gnomeui
258 %endif
259 ac_add_options --disable-gnomevfs
260 %if %{with ldap}
261 ac_add_options --enable-ldap
262 ac_add_options --with-system-ldap
263 %else
264 ac_add_options --disable-ldap
265 %endif
266 %if %{with crashreporter}
267 ac_add_options --enable-crashreporter
268 %else
269 ac_add_options --disable-crashreporter
270 %endif
271 ac_add_options --disable-xterm-updates
272 ac_add_options --enable-postscript
273 %if %{with lightning}
274 ac_add_options --enable-calendar
275 %else
276 ac_add_options --disable-calendar
277 %endif
278 ac_add_options --disable-installer
279 ac_add_options --disable-jsd
280 ac_add_options --disable-updater
281 ac_add_options --disable-xprint
282 ac_add_options --disable-permissions
283 ac_add_options --disable-pref-extensions
284 ac_add_options --enable-canvas
285 ac_add_options --enable-crypto
286 ac_add_options --enable-mathml
287 ac_add_options --enable-pango
288 ac_add_options --enable-reorder
289 ac_add_options --enable-startup-notification
290 ac_add_options --enable-svg
291 ac_add_options --enable-system-cairo
292 ac_add_options --enable-system-hunspell
293 ac_add_options --enable-system-sqlite
294 ac_add_options --enable-xft
295 ac_add_options --enable-application=mail
296 ac_add_options --enable-default-toolkit=cairo-gtk2
297 ac_add_options --enable-xinerama
298 ac_add_options --with-distribution-id=org.pld-linux
299 ac_add_options --with-branding=icedove/branding
300 %if %{with xulrunner}
301 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
302 ac_add_options --with-system-libxul
303 ac_add_options --enable-shared
304 ac_add_options --enable-libxul
305 %else
306 ac_add_options --disable-xul
307 %endif
308 ac_add_options --with-pthreads
309 ac_add_options --with-system-bz2
310 ac_add_options --with-system-jpeg
311 ac_add_options --with-system-nspr
312 ac_add_options --with-system-nss
313 ac_add_options --with-system-png
314 ac_add_options --with-system-zlib
315 ac_add_options --enable-single-profile
316 ac_add_options --disable-profilesharing
317 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
318 EOF
319
320 %{__make} -j1 -f client.mk build \
321         STRIP="/bin/true" \
322         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
323         CC="%{__cc}" \
324         CXX="%{__cxx}"
325
326 %if %{with crashreporter}
327 # create debuginfo for crash-stats.mozilla.com
328 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
329 %endif
330
331 %if %{with enigmail}
332 cd mailnews/extensions/enigmail
333 ./makemake -r -o %{objdir}
334 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
335         STRIP="/bin/true" \
336         CC="%{__cc}" \
337         CXX="%{__cxx}"
338 %endif
339
340 %install
341 rm -rf $RPM_BUILD_ROOT
342 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
343
344 cd %{objdir}
345 %{__make} -C mail/installer stage-package \
346         DESTDIR=$RPM_BUILD_ROOT \
347         MOZ_PKG_DIR=%{_libdir}/%{name} \
348         PKG_SKIP_STRIP=1
349
350 # Enable crash reporter for Firefox application
351 %if %{with crashreporter}
352 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
353
354 # Add debuginfo for crash-stats.mozilla.com
355 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
356 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
357 %endif
358
359 # copy manually lightning files, somewhy they are not installed by make
360 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
361         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
362         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
363
364 # move arch independant ones to datadir
365 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
366 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
367 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
368 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
369 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
370 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
371 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
372 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
373 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
374 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
375 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
376 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
377
378 # dir for arch independant extensions besides arch dependant extensions
379 # see mozilla/xpcom/build/nsXULAppAPI.h
380 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
381 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
382
383 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
384 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
385
386 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
387 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
388
389 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
390 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
391 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
392
393 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
394 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
395
396 # files created by regxpcom -register in post
397 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
398 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
399 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
400 #!/bin/sh
401 umask 022
402 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
403 # dangerous if you run this with sudo with keep_env += HOME
404 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
405 t=$(mktemp -d)
406 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
407 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
408 rm -rf $t
409 EOF
410 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
411
412 %if %{with enigmail}
413 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
414 install -d $ext_dir/{chrome,components,defaults/preferences}
415 cd mozilla/dist/bin
416 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
417 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
418 cp -rfLp components/enig* $ext_dir/components
419 cp -rfLp components/libenigmime.so $ext_dir/components
420 cp -rfLp components/libipc.so $ext_dir/components
421 cp -rfLp components/ipc.xpt $ext_dir/components
422 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
423 cd -
424 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
425 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
426 %endif
427
428 # remove unecessary stuff
429 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
430 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
431 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
432
433 # never package these. always remove
434 # nss
435 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
436 # nspr
437 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
438 # mozldap
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
440
441 %clean
442 rm -rf $RPM_BUILD_ROOT
443
444 %pretrans
445 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
446         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
447 fi
448 for d in chrome defaults icons isp modules res searchplugins; do
449         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
450                 install -d %{_datadir}/%{name}
451                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
452         fi
453 done
454 exit 0
455
456 %post
457 %{_libdir}/%{name}/register || :
458
459 %files
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_bindir}/icedove
462 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
463 %attr(755,root,root) %{_bindir}/thunderbird
464 %dir %{_libdir}/%{name}
465 %{_libdir}/%{name}/application.ini
466 %{_libdir}/%{name}/platform.ini
467 %{_libdir}/%{name}/blocklist.xml
468 %{_libdir}/%{name}/chrome.manifest
469 %{_libdir}/%{name}/greprefs.js
470 %dir %{_libdir}/%{name}/components
471 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
472 %{_libdir}/%{name}/components/*.js
473 %{_libdir}/%{name}/components/*.xpt
474 %{_libdir}/%{name}/components/components.manifest
475 %{_libdir}/%{name}/components/interfaces.manifest
476 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
477 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
478 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
479 %attr(755,root,root) %{_libdir}/%{name}/*.sh
480 %attr(755,root,root) %{_libdir}/%{name}/*-bin
481 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
482 %attr(755,root,root) %{_libdir}/%{name}/icedove
483 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
484 %attr(755,root,root) %{_libdir}/%{name}/register
485
486 # symlinks
487 %{_libdir}/%{name}/chrome
488 %{_libdir}/%{name}/defaults
489 %{_libdir}/%{name}/dictionaries
490 %{_libdir}/%{name}/hyphenation
491 %{_libdir}/%{name}/isp
492 %{_libdir}/%{name}/modules
493 %{_libdir}/%{name}/res
494 %{_libdir}/%{name}/searchplugins
495
496 %{_pixmapsdir}/icedove.png
497 %{_desktopdir}/icedove.desktop
498
499 %dir %{_datadir}/%{name}
500 %{_datadir}/%{name}/chrome
501 %{_datadir}/%{name}/defaults
502 %{_datadir}/%{name}/extensions
503 %{_datadir}/%{name}/isp
504 %{_datadir}/%{name}/modules
505 %{_datadir}/%{name}/res
506 %{_datadir}/%{name}/searchplugins
507
508 %if %{with crashreporter}
509 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
510 %{_libdir}/%{name}/crashreporter.ini
511 %{_libdir}/%{name}/Throbber-small.gif
512 %endif
513
514 %dir %{_libdir}/%{name}/extensions
515 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
516
517 # files created by regxpcom -register
518 %ghost %{_libdir}/%{name}/components/compreg.dat
519 %ghost %{_libdir}/%{name}/components/xpti.dat
520
521 %if %{with lightning}
522 %files addon-lightning
523 %defattr(644,root,root,755)
524 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
525 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
526 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
530 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
531 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
532 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
533 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
538 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
539 %endif
540
541 %if %{with enigmail}
542 %files addon-enigmail
543 %defattr(644,root,root,755)
544 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
545 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
546 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
547 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
548 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
549 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
550 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
551 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
552 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
553 %endif
This page took 1.198317 seconds and 4 git commands to generate.