]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- searchplugins to datadir
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
f4114a7f 11%bcond_without xulrunner # build with xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
6864d0a2 22%define enigmail_ver 1.3.5
af42cf6d
JB
23%define nspr_ver 4.8.8
24%define nss_ver 3.12.10
44be9ed4 25
d06a830c 26# convert firefox release number to platform version: 9.0.x -> 9.0.x
6864d0a2
AZ
27%define xulrunner_main 10.0
28%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#10.0})
4f34f106 29
7d981f69
ER
30%if %{without xulrunner}
31# The actual sqlite version (see RHBZ#480989):
32%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33%endif
34
44be9ed4 35Summary: Icedove - email client
36Summary(pl.UTF-8): Icedove - klient poczty
37Name: icedove
1a166995 38Version: 10.0.2
eca54e0f 39Release: 3
44be9ed4 40License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 41Group: X11/Applications/Networking
cadfb931 42Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
1a166995 43# Source0-md5: 624bef982d7ac610b1175737d9905150
44be9ed4 44Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
6864d0a2 45# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
44be9ed4 46Source2: %{name}-branding.tar.bz2
c105f759 47# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 48Source3: %{name}-rm_nonfree.sh
49Source4: %{name}.desktop
50Source5: %{name}.sh
44be9ed4 51Patch0: %{name}-branding.patch
faa5c89d
SP
52Patch1: %{name}-enigmail-shared.patch
53Patch2: %{name}-gcc.patch
54Patch3: %{name}-fonts.patch
55Patch4: %{name}-install.patch
5e9bb798 56Patch5: %{name}-hunspell.patch
faa5c89d 57Patch6: %{name}-prefs.patch
9a743685 58Patch7: system-mozldap.patch
a85e0ecb 59Patch8: %{name}-makefile.patch
6864d0a2 60#Patch9: %{name}-libpng.patch
ccc206fe 61Patch10: %{name}-extensiondir.patch
765a3a27 62Patch11: crashreporter.patch
268e7766 63Patch12: no-subshell.patch
5745d706 64URL: http://www.pld-linux.org/Packages/Icedove
6458b220 65BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 66BuildRequires: alsa-lib-devel
44be9ed4 67BuildRequires: automake
51a3b6db 68BuildRequires: bzip2-devel
e820c55e
JB
69BuildRequires: cairo-devel >= 1.10
70BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 71BuildRequires: freetype-devel >= 1:2.1.8
6458b220 72BuildRequires: glib2-devel >= 2.0
e820c55e 73BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 74BuildRequires: hunspell-devel
44be9ed4 75BuildRequires: libIDL-devel >= 0.8.0
6458b220 76%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 77%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 78%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 79BuildRequires: libiw-devel
44be9ed4 80BuildRequires: libjpeg-devel >= 6b
51a3b6db 81BuildRequires: libnotify-devel >= 0.4
e820c55e 82BuildRequires: libpng-devel >= 1.4.1
44be9ed4 83BuildRequires: libstdc++-devel
f4114a7f
ER
84BuildRequires: nspr-devel >= 1:%{nspr_ver}
85BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 86BuildRequires: pango-devel >= 1:1.1.0
e820c55e 87BuildRequires: perl-base >= 1:5.6
1c62cadb 88BuildRequires: pkgconfig
e820c55e 89BuildRequires: python >= 1:2.5
44be9ed4 90BuildRequires: sed >= 4.0
9d1bfad8 91BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 92BuildRequires: startup-notification-devel >= 0.8
44be9ed4 93BuildRequires: xorg-lib-libXext-devel
44be9ed4 94BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 95BuildRequires: xorg-lib-libXt-devel
5745d706 96BuildRequires: yasm
1c62cadb 97BuildRequires: zip
7d981f69 98%if %{with xulrunner}
4f34f106 99BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 100%else
44be9ed4 101Requires: myspell-common
f4114a7f
ER
102Requires: nspr >= 1:%{nspr_ver}
103Requires: nss >= 1:%{nss_ver}
4b6bc367 104Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 105%endif
4f34f106
ER
106Requires(post): mktemp >= 1.5-18
107%if %{with xulrunner}
108%requires_eq_to xulrunner xulrunner-devel
109%endif
44be9ed4 110Obsoletes: mozilla-thunderbird
111Obsoletes: mozilla-thunderbird-dictionary-en-US
112BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
9e366f18
AM
114%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
115
44be9ed4 116# iceweasel/icedove/iceape provide their own versions
c072808a 117%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 118%define _noautoprovfiles %{_libdir}/%{name}/components
119# we don't want these to satisfy xulrunner-devel
c072808a 120%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 121# and as we don't provide them, don't require either
c072808a 122%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 123
9e7875fc
ER
124%define topdir %{_builddir}/%{name}-%{version}
125%define objdir %{topdir}/obj-%{_target_cpu}
126
44be9ed4 127%description
6b327de6 128Icedove is an open-source, fast and portable email client.
44be9ed4 129
130%description -l pl.UTF-8
6b327de6
JB
131Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132poczty.
44be9ed4 133
6578c165 134%package addon-lightning
135Summary: An integrated calendar for Icedove
136Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
137License: MPL 1.1 or GPL v2+ or LGPL v2.1+
138Group: Applications/Networking
139Requires: %{name} = %{version}-%{release}
140
141%description addon-lightning
142Lightning is an calendar extension to Icedove email client.
143
144%description addon-lightning -l pl.UTF-8
145Lightning to rozszerzenie do klienta poczty Icedove dodające
146funkcjonalność kalendarza.
147
44be9ed4 148%package addon-enigmail
149Summary: Extension for the authentication and encryption features provided by GnuPG
150Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151License: MPL/LGPL
152Group: Applications/Networking
153URL: http://enigmail.mozdev.org/
cd056caa 154Requires: %{name} = %{version}-%{release}
d076d93e 155Requires: gnupg
75991bbb 156Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 157
158%description addon-enigmail
c5e06599 159Enigmail is an extension to the Icedove mail client which allows users
160to access the authentication and encryption features provided by
161GnuPG.
44be9ed4 162
163Main Features:
164- Encrypt/sign mail when sending, decrypt/authenticate received mail
165- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166- Per-Account based encryption and signing defaults
167- Per-Recipient rules for automated key selection, and
168 enabling/disabling encryption and signing
169- OpenPGP key management interface
170
171%description addon-enigmail -l pl.UTF-8
c5e06599 172Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
173użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174przez GnuPG.
44be9ed4 175
176Główne możliwości:
177- szyfrowanie/podpisywanie poczty przy wysyłaniu,
178 odszyfrowywanie/uwierzytelnianie poczty odebranej
179- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182 podpisywania dla każdego adresata
183- interfejs do zarządzania kluczami OpenPGP
184
185%prep
983562b1 186%setup -qc
f4114a7f 187mv comm-release mozilla
983562b1 188%setup -q -T -D -a2
189cd mozilla
1c70899a 190%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 191/bin/sh %{SOURCE3}
983562b1 192%patch0 -p1
faa5c89d
SP
193%{?with_enigmail:%patch1 -p1}
194%patch2 -p1
4ccc2157 195%patch3 -p1
faa5c89d 196%patch4 -p1
983562b1 197%patch6 -p1
9a743685 198%patch7 -p1
f4114a7f 199%patch8 -p2
1a166995 200#%%patch9 -p1
ccc206fe 201%patch10 -p2
765a3a27 202%patch11 -p2
268e7766 203%patch12 -p1
44be9ed4 204
205%build
983562b1 206cd mozilla
cadfb931
SP
207cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
208cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 209cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 210
9a743685
ER
211install -d libxul-sdk
212ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 213
fbac75ca 214cat << EOF > .mozconfig
9e7875fc 215mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 216
5745d706 217export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
218export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
765a3a27
ER
219
220%if %{with crashreporter}
221export MOZ_DEBUG_SYMBOLS=1
222%endif
223
59c5a0e8 224# Options for 'configure' (same as command-line options).
44be9ed4 225ac_add_options --prefix=%{_prefix}
226ac_add_options --exec-prefix=%{_exec_prefix}
227ac_add_options --bindir=%{_bindir}
228ac_add_options --sbindir=%{_sbindir}
229ac_add_options --sysconfdir=%{_sysconfdir}
230ac_add_options --datadir=%{_datadir}
231ac_add_options --includedir=%{_includedir}
232ac_add_options --libdir=%{_libdir}
233ac_add_options --libexecdir=%{_libexecdir}
234ac_add_options --localstatedir=%{_localstatedir}
235ac_add_options --sharedstatedir=%{_sharedstatedir}
236ac_add_options --mandir=%{_mandir}
237ac_add_options --infodir=%{_infodir}
238%if %{?debug:1}0
59c5a0e8 239ac_add_options --disable-optimize
44be9ed4 240ac_add_options --enable-debug
241ac_add_options --enable-debug-modules
59c5a0e8
SP
242ac_add_options --enable-debugger-info-modules
243ac_add_options --enable-crash-on-assert
44be9ed4 244%else
245ac_add_options --disable-debug
246ac_add_options --disable-debug-modules
59c5a0e8
SP
247ac_add_options --disable-logging
248ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 249%endif
88149483
ER
250ac_add_options --disable-strip
251ac_add_options --disable-strip-libs
44be9ed4 252%if %{with tests}
253ac_add_options --enable-tests
254%else
255ac_add_options --disable-tests
256%endif
6458b220 257ac_add_options --enable-gio
44be9ed4 258%if %{with gnomeui}
259ac_add_options --enable-gnomeui
260%else
261ac_add_options --disable-gnomeui
262%endif
44be9ed4 263ac_add_options --disable-gnomevfs
44be9ed4 264%if %{with ldap}
265ac_add_options --enable-ldap
9a743685 266ac_add_options --with-system-ldap
44be9ed4 267%else
268ac_add_options --disable-ldap
269%endif
765a3a27
ER
270%if %{with crashreporter}
271ac_add_options --enable-crashreporter
272%else
59c5a0e8 273ac_add_options --disable-crashreporter
765a3a27 274%endif
59c5a0e8 275ac_add_options --disable-xterm-updates
59c5a0e8 276ac_add_options --enable-postscript
d076d93e 277%if %{with lightning}
cb0e4412 278ac_add_options --enable-calendar
d076d93e
SP
279%else
280ac_add_options --disable-calendar
281%endif
44be9ed4 282ac_add_options --disable-installer
283ac_add_options --disable-jsd
88149483 284ac_add_options --disable-updater
44be9ed4 285ac_add_options --disable-xprint
cadfb931
SP
286ac_add_options --disable-permissions
287ac_add_options --disable-pref-extensions
44be9ed4 288ac_add_options --enable-canvas
289ac_add_options --enable-crypto
44be9ed4 290ac_add_options --enable-mathml
44be9ed4 291ac_add_options --enable-pango
292ac_add_options --enable-reorder
88149483
ER
293ac_add_options --enable-startup-notification
294ac_add_options --enable-svg
44be9ed4 295ac_add_options --enable-system-cairo
5e9bb798 296ac_add_options --enable-system-hunspell
7d981f69 297ac_add_options --enable-system-sqlite
44be9ed4 298ac_add_options --enable-xft
cadfb931
SP
299ac_add_options --enable-application=mail
300ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 301ac_add_options --enable-xinerama
88149483
ER
302ac_add_options --with-distribution-id=org.pld-linux
303ac_add_options --with-branding=icedove/branding
304%if %{with xulrunner}
f4114a7f
ER
305#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
306ac_add_options --with-system-libxul
fbac75ca 307ac_add_options --enable-shared
f4114a7f 308ac_add_options --enable-libxul
fbac75ca 309%else
f4114a7f 310ac_add_options --disable-xul
88149483
ER
311%endif
312ac_add_options --with-pthreads
313ac_add_options --with-system-bz2
44be9ed4 314ac_add_options --with-system-jpeg
315ac_add_options --with-system-nspr
316ac_add_options --with-system-nss
317ac_add_options --with-system-png
318ac_add_options --with-system-zlib
44be9ed4 319ac_add_options --enable-single-profile
320ac_add_options --disable-profilesharing
44be9ed4 321ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
322EOF
323
90e998ba 324%{__make} -j1 -f client.mk build \
d076d93e 325 STRIP="/bin/true" \
765a3a27 326 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 327 CC="%{__cc}" \
44be9ed4 328 CXX="%{__cxx}"
329
765a3a27
ER
330%if %{with crashreporter}
331# create debuginfo for crash-stats.mozilla.com
332%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
333%endif
334
44be9ed4 335%if %{with enigmail}
59c5a0e8 336cd mailnews/extensions/enigmail
9e7875fc
ER
337./makemake -r -o %{objdir}
338%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
339 STRIP="/bin/true" \
340 CC="%{__cc}" \
341 CXX="%{__cxx}"
44be9ed4 342%endif
343
344%install
345rm -rf $RPM_BUILD_ROOT
765a3a27 346install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 347
9e7875fc 348cd %{objdir}
ecf04393 349%{__make} -C mail/installer stage-package \
44be9ed4 350 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 351 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 352 PKG_SKIP_STRIP=1
353
765a3a27
ER
354# Enable crash reporter for Firefox application
355%if %{with crashreporter}
356%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
357
358# Add debuginfo for crash-stats.mozilla.com
51a3b6db 359install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
360cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
361%endif
362
ecf04393
ER
363# copy manually lightning files, somewhy they are not installed by make
364cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
365 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
366 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
367
44be9ed4 368# move arch independant ones to datadir
369mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
370mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 371mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 372mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 373mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
eca54e0f 374mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 375ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
376ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 377ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 378ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 379ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
eca54e0f 380ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
44be9ed4 381
c6ec3c1c
ER
382# dir for arch independant extensions besides arch dependant extensions
383# see mozilla/xpcom/build/nsXULAppAPI.h
384# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
385install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
386
63d8f5c3 387%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 388ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
389
e6bc19b3
ER
390%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
391ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
392
44be9ed4 393%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
394ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
395ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
396
52f5507d
ER
397cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
398cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 399
e8f4ba81 400# files created by regxpcom -register in post
52fc61e6
ER
401touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
402touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
403cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
404#!/bin/sh
405umask 022
406# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
407# dangerous if you run this with sudo with keep_env += HOME
408# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
409t=$(mktemp -d)
d50a2a28 410%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
411TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
412rm -rf $t
413EOF
414chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 415
44be9ed4 416%if %{with enigmail}
283702b9
ER
417ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
418install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 419cd mozilla/dist/bin
0516fc42 420#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
421#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
422cp -rfLp components/enig* $ext_dir/components
423cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 424cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
425cp -rfLp components/ipc.xpt $ext_dir/components
426cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
427cd -
52f5507d
ER
428cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
429cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 430%endif
431
9a743685 432# remove unecessary stuff
9e402408 433#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
0516fc42 434#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
435#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 436
9cdc8923
ER
437# never package these. always remove
438# nss
439%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
440# nspr
441%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 442# mozldap
9cdc8923 443%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 444
44be9ed4 445%clean
446rm -rf $RPM_BUILD_ROOT
447
448%pretrans
449if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
450 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
451fi
eca54e0f 452for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 453 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
454 install -d %{_datadir}/%{name}
455 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
456 fi
457done
458exit 0
459
e8f4ba81
ER
460%post
461%{_libdir}/%{name}/register || :
462
44be9ed4 463%files
464%defattr(644,root,root,755)
465%attr(755,root,root) %{_bindir}/icedove
466%attr(755,root,root) %{_bindir}/mozilla-thunderbird
467%attr(755,root,root) %{_bindir}/thunderbird
468%dir %{_libdir}/%{name}
765a3a27
ER
469%{_libdir}/%{name}/application.ini
470%{_libdir}/%{name}/platform.ini
6b327de6
JB
471%{_libdir}/%{name}/blocklist.xml
472%{_libdir}/%{name}/chrome.manifest
473%{_libdir}/%{name}/greprefs.js
44be9ed4 474%dir %{_libdir}/%{name}/components
475%attr(755,root,root) %{_libdir}/%{name}/components/*.so
476%{_libdir}/%{name}/components/*.js
477%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
478%{_libdir}/%{name}/components/components.manifest
479%{_libdir}/%{name}/components/interfaces.manifest
0516fc42 480%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 481%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 482%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 483%attr(755,root,root) %{_libdir}/%{name}/*.sh
484%attr(755,root,root) %{_libdir}/%{name}/*-bin
485%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 486%attr(755,root,root) %{_libdir}/%{name}/icedove
cf62736e 487%attr(755,root,root) %{_libdir}/%{name}/plugin-container
e8f4ba81 488%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 489
490# symlinks
491%{_libdir}/%{name}/chrome
492%{_libdir}/%{name}/defaults
493%{_libdir}/%{name}/dictionaries
e6bc19b3 494%{_libdir}/%{name}/hyphenation
44be9ed4 495%{_libdir}/%{name}/isp
9e097178 496%{_libdir}/%{name}/modules
44be9ed4 497%{_libdir}/%{name}/res
eca54e0f 498%{_libdir}/%{name}/searchplugins
44be9ed4 499
293928f3 500%{_pixmapsdir}/*.png
44be9ed4 501%{_desktopdir}/*.desktop
502
503%dir %{_datadir}/%{name}
504%{_datadir}/%{name}/chrome
505%{_datadir}/%{name}/defaults
eca54e0f 506%{_datadir}/%{name}/extensions
44be9ed4 507%{_datadir}/%{name}/isp
9e097178 508%{_datadir}/%{name}/modules
44be9ed4 509%{_datadir}/%{name}/res
eca54e0f 510%{_datadir}/%{name}/searchplugins
44be9ed4 511
765a3a27
ER
512%if %{with crashreporter}
513%attr(755,root,root) %{_libdir}/%{name}/crashreporter
514%{_libdir}/%{name}/crashreporter.ini
515%{_libdir}/%{name}/Throbber-small.gif
516%endif
517
44be9ed4 518%dir %{_libdir}/%{name}/extensions
519%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 520
52fc61e6
ER
521# files created by regxpcom -register
522%ghost %{_libdir}/%{name}/components/compreg.dat
523%ghost %{_libdir}/%{name}/components/xpti.dat
524
6578c165 525%if %{with lightning}
526%files addon-lightning
527%defattr(644,root,root,755)
f3b6d696 528%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 529%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
530%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 532%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
533%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
534%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
535%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
540%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 542%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
543%endif
44be9ed4 544
545%if %{with enigmail}
546%files addon-enigmail
547%defattr(644,root,root,755)
f6a43e2f
ER
548%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
549%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
550%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
551%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
552%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
553%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
554%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
555%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
556%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 557%endif
This page took 0.160065 seconds and 4 git commands to generate.