]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- searchplugins to datadir
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_without  xulrunner       # build with xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.3.5
23 %define         nspr_ver        4.8.8
24 %define         nss_ver         3.12.10
25
26 # convert firefox release number to platform version: 9.0.x -> 9.0.x
27 %define         xulrunner_main  10.0
28 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#10.0})
29
30 %if %{without xulrunner}
31 # The actual sqlite version (see RHBZ#480989):
32 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33 %endif
34
35 Summary:        Icedove - email client
36 Summary(pl.UTF-8):      Icedove - klient poczty
37 Name:           icedove
38 Version:        10.0.2
39 Release:        3
40 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
41 Group:          X11/Applications/Networking
42 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
43 # Source0-md5:  624bef982d7ac610b1175737d9905150
44 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
45 # Source1-md5:  1b008b0d106e238c11e4bead08126bc0
46 Source2:        %{name}-branding.tar.bz2
47 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
48 Source3:        %{name}-rm_nonfree.sh
49 Source4:        %{name}.desktop
50 Source5:        %{name}.sh
51 Patch0:         %{name}-branding.patch
52 Patch1:         %{name}-enigmail-shared.patch
53 Patch2:         %{name}-gcc.patch
54 Patch3:         %{name}-fonts.patch
55 Patch4:         %{name}-install.patch
56 Patch5:         %{name}-hunspell.patch
57 Patch6:         %{name}-prefs.patch
58 Patch7:         system-mozldap.patch
59 Patch8:         %{name}-makefile.patch
60 #Patch9:                %{name}-libpng.patch
61 Patch10:        %{name}-extensiondir.patch
62 Patch11:        crashreporter.patch
63 Patch12:        no-subshell.patch
64 URL:            http://www.pld-linux.org/Packages/Icedove
65 BuildRequires:  GConf2-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  automake
68 BuildRequires:  bzip2-devel
69 BuildRequires:  cairo-devel >= 1.10
70 BuildRequires:  dbus-glib-devel >= 0.60
71 BuildRequires:  freetype-devel >= 1:2.1.8
72 BuildRequires:  glib2-devel >= 2.0
73 BuildRequires:  gtk+2-devel >= 2:2.10.0
74 BuildRequires:  hunspell-devel
75 BuildRequires:  libIDL-devel >= 0.8.0
76 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
77 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
78 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
79 BuildRequires:  libiw-devel
80 BuildRequires:  libjpeg-devel >= 6b
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.1.0
87 BuildRequires:  perl-base >= 1:5.6
88 BuildRequires:  pkgconfig
89 BuildRequires:  python >= 1:2.5
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3.7.4
92 BuildRequires:  startup-notification-devel >= 0.8
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 BuildRequires:  yasm
97 BuildRequires:  zip
98 %if %{with xulrunner}
99 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
100 %else
101 Requires:       myspell-common
102 Requires:       nspr >= 1:%{nspr_ver}
103 Requires:       nss >= 1:%{nss_ver}
104 Requires:       sqlite3 >= %{sqlite_build_version}
105 %endif
106 Requires(post): mktemp >= 1.5-18
107 %if %{with xulrunner}
108 %requires_eq_to xulrunner xulrunner-devel
109 %endif
110 Obsoletes:      mozilla-thunderbird
111 Obsoletes:      mozilla-thunderbird-dictionary-en-US
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
115
116 # iceweasel/icedove/iceape provide their own versions
117 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
118 %define         _noautoprovfiles        %{_libdir}/%{name}/components
119 # we don't want these to satisfy xulrunner-devel
120 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
121 # and as we don't provide them, don't require either
122 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
123
124 %define         topdir          %{_builddir}/%{name}-%{version}
125 %define         objdir          %{topdir}/obj-%{_target_cpu}
126
127 %description
128 Icedove is an open-source, fast and portable email client.
129
130 %description -l pl.UTF-8
131 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132 poczty.
133
134 %package addon-lightning
135 Summary:        An integrated calendar for Icedove
136 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
137 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
138 Group:          Applications/Networking
139 Requires:       %{name} = %{version}-%{release}
140
141 %description addon-lightning
142 Lightning is an calendar extension to Icedove email client.
143
144 %description addon-lightning -l pl.UTF-8
145 Lightning to rozszerzenie do klienta poczty Icedove dodające
146 funkcjonalność kalendarza.
147
148 %package addon-enigmail
149 Summary:        Extension for the authentication and encryption features provided by GnuPG
150 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151 License:        MPL/LGPL
152 Group:          Applications/Networking
153 URL:            http://enigmail.mozdev.org/
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       gnupg
156 Obsoletes:      mozilla-thunderbird-addon-enigmail
157
158 %description addon-enigmail
159 Enigmail is an extension to the Icedove mail client which allows users
160 to access the authentication and encryption features provided by
161 GnuPG.
162
163 Main Features:
164 - Encrypt/sign mail when sending, decrypt/authenticate received mail
165 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166 - Per-Account based encryption and signing defaults
167 - Per-Recipient rules for automated key selection, and
168   enabling/disabling encryption and signing
169 - OpenPGP key management interface
170
171 %description addon-enigmail -l pl.UTF-8
172 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
173 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174 przez GnuPG.
175
176 Główne możliwości:
177 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
178   odszyfrowywanie/uwierzytelnianie poczty odebranej
179 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182   podpisywania dla każdego adresata
183 - interfejs do zarządzania kluczami OpenPGP
184
185 %prep
186 %setup -qc
187 mv comm-release mozilla
188 %setup -q -T -D -a2
189 cd mozilla
190 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
191 /bin/sh %{SOURCE3}
192 %patch0 -p1
193 %{?with_enigmail:%patch1 -p1}
194 %patch2 -p1
195 %patch3 -p1
196 %patch4 -p1
197 %patch6 -p1
198 %patch7 -p1
199 %patch8 -p2
200 #%%patch9 -p1
201 %patch10 -p2
202 %patch11 -p2
203 %patch12 -p1
204
205 %build
206 cd mozilla
207 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
208 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
209 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
210
211 install -d libxul-sdk
212 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
213
214 cat << EOF > .mozconfig
215 mk_add_options MOZ_OBJDIR=%{objdir}
216
217 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
218 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
219
220 %if %{with crashreporter}
221 export MOZ_DEBUG_SYMBOLS=1
222 %endif
223
224 # Options for 'configure' (same as command-line options).
225 ac_add_options --prefix=%{_prefix}
226 ac_add_options --exec-prefix=%{_exec_prefix}
227 ac_add_options --bindir=%{_bindir}
228 ac_add_options --sbindir=%{_sbindir}
229 ac_add_options --sysconfdir=%{_sysconfdir}
230 ac_add_options --datadir=%{_datadir}
231 ac_add_options --includedir=%{_includedir}
232 ac_add_options --libdir=%{_libdir}
233 ac_add_options --libexecdir=%{_libexecdir}
234 ac_add_options --localstatedir=%{_localstatedir}
235 ac_add_options --sharedstatedir=%{_sharedstatedir}
236 ac_add_options --mandir=%{_mandir}
237 ac_add_options --infodir=%{_infodir}
238 %if %{?debug:1}0
239 ac_add_options --disable-optimize
240 ac_add_options --enable-debug
241 ac_add_options --enable-debug-modules
242 ac_add_options --enable-debugger-info-modules
243 ac_add_options --enable-crash-on-assert
244 %else
245 ac_add_options --disable-debug
246 ac_add_options --disable-debug-modules
247 ac_add_options --disable-logging
248 ac_add_options --enable-optimize="%{rpmcflags} -Os"
249 %endif
250 ac_add_options --disable-strip
251 ac_add_options --disable-strip-libs
252 %if %{with tests}
253 ac_add_options --enable-tests
254 %else
255 ac_add_options --disable-tests
256 %endif
257 ac_add_options --enable-gio
258 %if %{with gnomeui}
259 ac_add_options --enable-gnomeui
260 %else
261 ac_add_options --disable-gnomeui
262 %endif
263 ac_add_options --disable-gnomevfs
264 %if %{with ldap}
265 ac_add_options --enable-ldap
266 ac_add_options --with-system-ldap
267 %else
268 ac_add_options --disable-ldap
269 %endif
270 %if %{with crashreporter}
271 ac_add_options --enable-crashreporter
272 %else
273 ac_add_options --disable-crashreporter
274 %endif
275 ac_add_options --disable-xterm-updates
276 ac_add_options --enable-postscript
277 %if %{with lightning}
278 ac_add_options --enable-calendar
279 %else
280 ac_add_options --disable-calendar
281 %endif
282 ac_add_options --disable-installer
283 ac_add_options --disable-jsd
284 ac_add_options --disable-updater
285 ac_add_options --disable-xprint
286 ac_add_options --disable-permissions
287 ac_add_options --disable-pref-extensions
288 ac_add_options --enable-canvas
289 ac_add_options --enable-crypto
290 ac_add_options --enable-mathml
291 ac_add_options --enable-pango
292 ac_add_options --enable-reorder
293 ac_add_options --enable-startup-notification
294 ac_add_options --enable-svg
295 ac_add_options --enable-system-cairo
296 ac_add_options --enable-system-hunspell
297 ac_add_options --enable-system-sqlite
298 ac_add_options --enable-xft
299 ac_add_options --enable-application=mail
300 ac_add_options --enable-default-toolkit=cairo-gtk2
301 ac_add_options --enable-xinerama
302 ac_add_options --with-distribution-id=org.pld-linux
303 ac_add_options --with-branding=icedove/branding
304 %if %{with xulrunner}
305 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
306 ac_add_options --with-system-libxul
307 ac_add_options --enable-shared
308 ac_add_options --enable-libxul
309 %else
310 ac_add_options --disable-xul
311 %endif
312 ac_add_options --with-pthreads
313 ac_add_options --with-system-bz2
314 ac_add_options --with-system-jpeg
315 ac_add_options --with-system-nspr
316 ac_add_options --with-system-nss
317 ac_add_options --with-system-png
318 ac_add_options --with-system-zlib
319 ac_add_options --enable-single-profile
320 ac_add_options --disable-profilesharing
321 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
322 EOF
323
324 %{__make} -j1 -f client.mk build \
325         STRIP="/bin/true" \
326         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
327         CC="%{__cc}" \
328         CXX="%{__cxx}"
329
330 %if %{with crashreporter}
331 # create debuginfo for crash-stats.mozilla.com
332 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
333 %endif
334
335 %if %{with enigmail}
336 cd mailnews/extensions/enigmail
337 ./makemake -r -o %{objdir}
338 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
339         STRIP="/bin/true" \
340         CC="%{__cc}" \
341         CXX="%{__cxx}"
342 %endif
343
344 %install
345 rm -rf $RPM_BUILD_ROOT
346 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
347
348 cd %{objdir}
349 %{__make} -C mail/installer stage-package \
350         DESTDIR=$RPM_BUILD_ROOT \
351         MOZ_PKG_DIR=%{_libdir}/%{name} \
352         PKG_SKIP_STRIP=1
353
354 # Enable crash reporter for Firefox application
355 %if %{with crashreporter}
356 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
357
358 # Add debuginfo for crash-stats.mozilla.com
359 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
360 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
361 %endif
362
363 # copy manually lightning files, somewhy they are not installed by make
364 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
365         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
366         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
367
368 # move arch independant ones to datadir
369 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
370 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
371 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
374 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
375 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
376 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
377 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
378 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
379 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
380 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
381
382 # dir for arch independant extensions besides arch dependant extensions
383 # see mozilla/xpcom/build/nsXULAppAPI.h
384 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
385 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
386
387 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
389
390 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
391 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
392
393 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
394 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
395 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
396
397 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
398 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
399
400 # files created by regxpcom -register in post
401 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
402 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
403 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
404 #!/bin/sh
405 umask 022
406 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
407 # dangerous if you run this with sudo with keep_env += HOME
408 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
409 t=$(mktemp -d)
410 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
411 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
412 rm -rf $t
413 EOF
414 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
415
416 %if %{with enigmail}
417 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
418 install -d $ext_dir/{chrome,components,defaults/preferences}
419 cd mozilla/dist/bin
420 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
421 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
422 cp -rfLp components/enig* $ext_dir/components
423 cp -rfLp components/libenigmime.so $ext_dir/components
424 cp -rfLp components/libipc.so $ext_dir/components
425 cp -rfLp components/ipc.xpt $ext_dir/components
426 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
427 cd -
428 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
429 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
430 %endif
431
432 # remove unecessary stuff
433 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
434 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
435 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
436
437 # never package these. always remove
438 # nss
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
440 # nspr
441 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
442 # mozldap
443 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
444
445 %clean
446 rm -rf $RPM_BUILD_ROOT
447
448 %pretrans
449 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
450         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
451 fi
452 for d in chrome defaults icons isp modules res searchplugins; do
453         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
454                 install -d %{_datadir}/%{name}
455                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
456         fi
457 done
458 exit 0
459
460 %post
461 %{_libdir}/%{name}/register || :
462
463 %files
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_bindir}/icedove
466 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
467 %attr(755,root,root) %{_bindir}/thunderbird
468 %dir %{_libdir}/%{name}
469 %{_libdir}/%{name}/application.ini
470 %{_libdir}/%{name}/platform.ini
471 %{_libdir}/%{name}/blocklist.xml
472 %{_libdir}/%{name}/chrome.manifest
473 %{_libdir}/%{name}/greprefs.js
474 %dir %{_libdir}/%{name}/components
475 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
476 %{_libdir}/%{name}/components/*.js
477 %{_libdir}/%{name}/components/*.xpt
478 %{_libdir}/%{name}/components/components.manifest
479 %{_libdir}/%{name}/components/interfaces.manifest
480 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
481 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
482 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
483 %attr(755,root,root) %{_libdir}/%{name}/*.sh
484 %attr(755,root,root) %{_libdir}/%{name}/*-bin
485 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
486 %attr(755,root,root) %{_libdir}/%{name}/icedove
487 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
488 %attr(755,root,root) %{_libdir}/%{name}/register
489
490 # symlinks
491 %{_libdir}/%{name}/chrome
492 %{_libdir}/%{name}/defaults
493 %{_libdir}/%{name}/dictionaries
494 %{_libdir}/%{name}/hyphenation
495 %{_libdir}/%{name}/isp
496 %{_libdir}/%{name}/modules
497 %{_libdir}/%{name}/res
498 %{_libdir}/%{name}/searchplugins
499
500 %{_pixmapsdir}/*.png
501 %{_desktopdir}/*.desktop
502
503 %dir %{_datadir}/%{name}
504 %{_datadir}/%{name}/chrome
505 %{_datadir}/%{name}/defaults
506 %{_datadir}/%{name}/extensions
507 %{_datadir}/%{name}/isp
508 %{_datadir}/%{name}/modules
509 %{_datadir}/%{name}/res
510 %{_datadir}/%{name}/searchplugins
511
512 %if %{with crashreporter}
513 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
514 %{_libdir}/%{name}/crashreporter.ini
515 %{_libdir}/%{name}/Throbber-small.gif
516 %endif
517
518 %dir %{_libdir}/%{name}/extensions
519 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
520
521 # files created by regxpcom -register
522 %ghost %{_libdir}/%{name}/components/compreg.dat
523 %ghost %{_libdir}/%{name}/components/xpti.dat
524
525 %if %{with lightning}
526 %files addon-lightning
527 %defattr(644,root,root,755)
528 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
531 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
532 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
533 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
534 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
535 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
540 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
541 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
542 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
543 %endif
544
545 %if %{with enigmail}
546 %files addon-enigmail
547 %defattr(644,root,root,755)
548 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
549 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
550 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
551 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
552 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
553 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
554 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
555 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
556 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
557 %endif
This page took 0.070361 seconds and 4 git commands to generate.