]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- system-xulrunner patch seems obsolete, but only xulrunner 17.x is supported
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
a367af64 22%define enigmail_ver 1.5.1
9c1b9ad4
JR
23%define nspr_ver 4.9.3
24%define nss_ver 3.14.1
44be9ed4 25
aaaf7356 26%define xulrunner_ver 2:17.0
4f34f106 27
7d981f69
ER
28%if %{without xulrunner}
29# The actual sqlite version (see RHBZ#480989):
30%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31%endif
32
44be9ed4 33Summary: Icedove - email client
34Summary(pl.UTF-8): Icedove - klient poczty
35Name: icedove
a367af64
JB
36Version: 17.0.3
37Release: 1
44be9ed4 38License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 39Group: X11/Applications/Networking
cadfb931 40Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
a367af64 41# Source0-md5: 180f7768f6419182ea78eeb80da7f588
44be9ed4 42Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
a367af64 43# Source1-md5: 3e71f84ed2c11471282412ebe4f5eb2d
44be9ed4 44Source2: %{name}-branding.tar.bz2
c105f759 45# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 46Source3: %{name}-rm_nonfree.sh
47Source4: %{name}.desktop
48Source5: %{name}.sh
44be9ed4 49Patch0: %{name}-branding.patch
faa5c89d 50Patch1: %{name}-enigmail-shared.patch
faa5c89d
SP
51Patch3: %{name}-fonts.patch
52Patch4: %{name}-install.patch
5e9bb798 53Patch5: %{name}-hunspell.patch
faa5c89d 54Patch6: %{name}-prefs.patch
9a743685 55Patch7: system-mozldap.patch
a85e0ecb 56Patch8: %{name}-makefile.patch
37973fb0 57Patch9: system-cairo.patch
ccc206fe 58Patch10: %{name}-extensiondir.patch
765a3a27 59Patch11: crashreporter.patch
268e7766 60Patch12: no-subshell.patch
03be87a5
JR
61# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
62Patch13: system-virtualenv.patch
13ed8387 63Patch14: gyp-slashism.patch
5745d706 64URL: http://www.pld-linux.org/Packages/Icedove
6458b220 65BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 66BuildRequires: alsa-lib-devel
44be9ed4 67BuildRequires: automake
51a3b6db 68BuildRequires: bzip2-devel
e820c55e
JB
69BuildRequires: cairo-devel >= 1.10
70BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 71BuildRequires: freetype-devel >= 1:2.1.8
6458b220 72BuildRequires: glib2-devel >= 2.0
e820c55e 73BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 74BuildRequires: hunspell-devel
44be9ed4 75BuildRequires: libIDL-devel >= 0.8.0
6458b220 76%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 77%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 78%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 79BuildRequires: libiw-devel
e82da7a1 80# requires libjpeg-turbo implementing at least libjpeg 6b API
44be9ed4 81BuildRequires: libjpeg-devel >= 6b
e82da7a1 82BuildRequires: libjpeg-turbo-devel
51a3b6db 83BuildRequires: libnotify-devel >= 0.4
e820c55e 84BuildRequires: libpng-devel >= 1.4.1
44be9ed4 85BuildRequires: libstdc++-devel
f4114a7f
ER
86BuildRequires: nspr-devel >= 1:%{nspr_ver}
87BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 88BuildRequires: pango-devel >= 1:1.14.0
e820c55e 89BuildRequires: perl-base >= 1:5.6
1c62cadb 90BuildRequires: pkgconfig
e820c55e 91BuildRequires: python >= 1:2.5
44be9ed4 92BuildRequires: sed >= 4.0
9d1bfad8 93BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 94BuildRequires: startup-notification-devel >= 0.8
44be9ed4 95BuildRequires: xorg-lib-libXext-devel
44be9ed4 96BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 97BuildRequires: xorg-lib-libXt-devel
5745d706 98BuildRequires: yasm
1c62cadb 99BuildRequires: zip
7d981f69 100%if %{with xulrunner}
e8326f77 101BuildRequires: xulrunner-devel >= %{xulrunner_ver}
fb0a1775 102BuildRequires: xulrunner-devel < 2:18
7d981f69 103%else
44be9ed4 104Requires: myspell-common
f4114a7f
ER
105Requires: nspr >= 1:%{nspr_ver}
106Requires: nss >= 1:%{nss_ver}
4b6bc367 107Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 108%endif
4f34f106
ER
109Requires(post): mktemp >= 1.5-18
110%if %{with xulrunner}
111%requires_eq_to xulrunner xulrunner-devel
112%endif
e82da7a1 113Requires: libjpeg-turbo
44be9ed4 114Obsoletes: mozilla-thunderbird
115Obsoletes: mozilla-thunderbird-dictionary-en-US
d606e9b3 116Conflicts: icedove-lang-resources < %{version}
44be9ed4 117BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
9e366f18
AM
119%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
120
44be9ed4 121# iceweasel/icedove/iceape provide their own versions
44be9ed4 122%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
123%if %{without xulrunner}
124# we don't want these to satisfy packages depending on xulrunner
125%define _noautoprov libmozalloc.so libxpcom.so libxul.so
44be9ed4 126# and as we don't provide them, don't require either
fb7d4f06
JB
127%define _noautoreq libmozalloc.so libxpcom.so libxul.so
128%endif
44be9ed4 129
9e7875fc
ER
130%define topdir %{_builddir}/%{name}-%{version}
131%define objdir %{topdir}/obj-%{_target_cpu}
132
44be9ed4 133%description
6b327de6 134Icedove is an open-source, fast and portable email client.
44be9ed4 135
136%description -l pl.UTF-8
6b327de6
JB
137Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
138poczty.
44be9ed4 139
6578c165 140%package addon-lightning
141Summary: An integrated calendar for Icedove
142Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
143License: MPL 1.1 or GPL v2+ or LGPL v2.1+
144Group: Applications/Networking
145Requires: %{name} = %{version}-%{release}
146
147%description addon-lightning
148Lightning is an calendar extension to Icedove email client.
149
150%description addon-lightning -l pl.UTF-8
151Lightning to rozszerzenie do klienta poczty Icedove dodające
152funkcjonalność kalendarza.
153
44be9ed4 154%package addon-enigmail
155Summary: Extension for the authentication and encryption features provided by GnuPG
156Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
157License: MPL/LGPL
158Group: Applications/Networking
159URL: http://enigmail.mozdev.org/
cd056caa 160Requires: %{name} = %{version}-%{release}
d076d93e 161Requires: gnupg
75991bbb 162Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 163
164%description addon-enigmail
c5e06599 165Enigmail is an extension to the Icedove mail client which allows users
166to access the authentication and encryption features provided by
167GnuPG.
44be9ed4 168
169Main Features:
170- Encrypt/sign mail when sending, decrypt/authenticate received mail
171- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
172- Per-Account based encryption and signing defaults
173- Per-Recipient rules for automated key selection, and
174 enabling/disabling encryption and signing
175- OpenPGP key management interface
176
177%description addon-enigmail -l pl.UTF-8
c5e06599 178Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
179użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
180przez GnuPG.
44be9ed4 181
182Główne możliwości:
183- szyfrowanie/podpisywanie poczty przy wysyłaniu,
184 odszyfrowywanie/uwierzytelnianie poczty odebranej
185- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
186- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
187- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
188 podpisywania dla każdego adresata
189- interfejs do zarządzania kluczami OpenPGP
190
191%prep
983562b1 192%setup -qc
a367af64 193mv comm-esr17 mozilla
983562b1 194%setup -q -T -D -a2
195cd mozilla
1c70899a 196%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 197/bin/sh %{SOURCE3}
983562b1 198%patch0 -p1
faa5c89d 199%{?with_enigmail:%patch1 -p1}
4ccc2157 200%patch3 -p1
faa5c89d 201%patch4 -p1
983562b1 202%patch6 -p1
9a743685 203%patch7 -p1
f4114a7f 204%patch8 -p2
3815090b 205%patch9 -p1
ccc206fe 206%patch10 -p2
765a3a27 207%patch11 -p2
268e7766 208%patch12 -p1
03be87a5 209%patch13 -p1
13ed8387 210%patch14 -p1
44be9ed4 211
212%build
983562b1 213cd mozilla
cadfb931
SP
214cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
215cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 216cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 217
fbac75ca 218cat << EOF > .mozconfig
9e7875fc 219mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 220
fac7e24d 221export CFLAGS="%{rpmcflags}"
73d54cb2 222export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
223
224%if %{with crashreporter}
225export MOZ_DEBUG_SYMBOLS=1
226%endif
227
59c5a0e8 228# Options for 'configure' (same as command-line options).
44be9ed4 229ac_add_options --prefix=%{_prefix}
230ac_add_options --exec-prefix=%{_exec_prefix}
231ac_add_options --bindir=%{_bindir}
232ac_add_options --sbindir=%{_sbindir}
233ac_add_options --sysconfdir=%{_sysconfdir}
234ac_add_options --datadir=%{_datadir}
235ac_add_options --includedir=%{_includedir}
236ac_add_options --libdir=%{_libdir}
237ac_add_options --libexecdir=%{_libexecdir}
238ac_add_options --localstatedir=%{_localstatedir}
239ac_add_options --sharedstatedir=%{_sharedstatedir}
240ac_add_options --mandir=%{_mandir}
241ac_add_options --infodir=%{_infodir}
242%if %{?debug:1}0
59c5a0e8 243ac_add_options --disable-optimize
44be9ed4 244ac_add_options --enable-debug
245ac_add_options --enable-debug-modules
59c5a0e8
SP
246ac_add_options --enable-debugger-info-modules
247ac_add_options --enable-crash-on-assert
44be9ed4 248%else
249ac_add_options --disable-debug
250ac_add_options --disable-debug-modules
59c5a0e8
SP
251ac_add_options --disable-logging
252ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 253%endif
88149483
ER
254ac_add_options --disable-strip
255ac_add_options --disable-strip-libs
44be9ed4 256%if %{with tests}
257ac_add_options --enable-tests
258%else
259ac_add_options --disable-tests
260%endif
6458b220 261ac_add_options --enable-gio
44be9ed4 262%if %{with gnomeui}
263ac_add_options --enable-gnomeui
264%else
265ac_add_options --disable-gnomeui
266%endif
44be9ed4 267ac_add_options --disable-gnomevfs
44be9ed4 268%if %{with ldap}
269ac_add_options --enable-ldap
9a743685 270ac_add_options --with-system-ldap
44be9ed4 271%else
272ac_add_options --disable-ldap
273%endif
765a3a27
ER
274%if %{with crashreporter}
275ac_add_options --enable-crashreporter
276%else
59c5a0e8 277ac_add_options --disable-crashreporter
765a3a27 278%endif
59c5a0e8 279ac_add_options --disable-xterm-updates
59c5a0e8 280ac_add_options --enable-postscript
d076d93e 281%if %{with lightning}
cb0e4412 282ac_add_options --enable-calendar
d076d93e
SP
283%else
284ac_add_options --disable-calendar
285%endif
44be9ed4 286ac_add_options --disable-installer
88149483 287ac_add_options --disable-updater
44be9ed4 288ac_add_options --disable-xprint
cadfb931
SP
289ac_add_options --disable-permissions
290ac_add_options --disable-pref-extensions
44be9ed4 291ac_add_options --enable-canvas
292ac_add_options --enable-crypto
44be9ed4 293ac_add_options --enable-mathml
44be9ed4 294ac_add_options --enable-pango
295ac_add_options --enable-reorder
88149483
ER
296ac_add_options --enable-startup-notification
297ac_add_options --enable-svg
44be9ed4 298ac_add_options --enable-system-cairo
5e9bb798 299ac_add_options --enable-system-hunspell
7d981f69 300ac_add_options --enable-system-sqlite
44be9ed4 301ac_add_options --enable-xft
cadfb931
SP
302ac_add_options --enable-application=mail
303ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 304ac_add_options --enable-xinerama
88149483
ER
305ac_add_options --with-distribution-id=org.pld-linux
306ac_add_options --with-branding=icedove/branding
307%if %{with xulrunner}
fac7e24d
JB
308ac_add_options --enable-shared-js
309ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 310ac_add_options --with-system-libxul
88149483
ER
311%endif
312ac_add_options --with-pthreads
313ac_add_options --with-system-bz2
44be9ed4 314ac_add_options --with-system-jpeg
315ac_add_options --with-system-nspr
316ac_add_options --with-system-nss
317ac_add_options --with-system-png
318ac_add_options --with-system-zlib
44be9ed4 319ac_add_options --enable-single-profile
320ac_add_options --disable-profilesharing
44be9ed4 321ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
322EOF
323
90e998ba 324%{__make} -j1 -f client.mk build \
d076d93e 325 STRIP="/bin/true" \
765a3a27 326 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
de09c00d 327 XLIBS="-lX11 -lXt" \
d076d93e 328 CC="%{__cc}" \
44be9ed4 329 CXX="%{__cxx}"
330
765a3a27
ER
331%if %{with crashreporter}
332# create debuginfo for crash-stats.mozilla.com
333%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
334%endif
335
44be9ed4 336%if %{with enigmail}
59c5a0e8 337cd mailnews/extensions/enigmail
9e7875fc
ER
338./makemake -r -o %{objdir}
339%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
340 STRIP="/bin/true" \
341 CC="%{__cc}" \
342 CXX="%{__cxx}"
916d4050
JR
343
344%{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
345 STRIP="/bin/true" \
346 CC="%{__cc}" \
347 CXX="%{__cxx}"
44be9ed4 348%endif
349
350%install
351rm -rf $RPM_BUILD_ROOT
765a3a27 352install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 353
9e7875fc 354cd %{objdir}
ecf04393 355%{__make} -C mail/installer stage-package \
44be9ed4 356 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 357 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 358 PKG_SKIP_STRIP=1
359
9b40a2c3
JB
360%if %{with xulrunner}
361# needed to find mozilla runtime
362ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
363%endif
364
365# Enable crash reporter for Thunderbird application
765a3a27
ER
366%if %{with crashreporter}
367%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
368
369# Add debuginfo for crash-stats.mozilla.com
51a3b6db 370install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
371cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
372%endif
373
ecf04393
ER
374# copy manually lightning files, somewhy they are not installed by make
375cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
376 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
377 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
378
44be9ed4 379# move arch independant ones to datadir
380mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
381mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 382mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 383mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
eca54e0f 384mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 385ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
386ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 387ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 388ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
eca54e0f 389ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
73d54cb2
JB
390%if %{without xulrunner}
391mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
392ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
393%endif
44be9ed4 394
c6ec3c1c
ER
395# dir for arch independant extensions besides arch dependant extensions
396# see mozilla/xpcom/build/nsXULAppAPI.h
397# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
398install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
399
73d54cb2 400%if %{without xulrunner}
63d8f5c3 401%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 402ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
e6bc19b3
ER
403%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
404ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
73d54cb2 405%endif
e6bc19b3 406
0889474f
JR
407%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
408 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
409 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
410
44be9ed4 411%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
412ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
413ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
414
52f5507d
ER
415cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
416cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 417
e8f4ba81 418# files created by regxpcom -register in post
52fc61e6
ER
419touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
420touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
421cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
422#!/bin/sh
423umask 022
424# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
425# dangerous if you run this with sudo with keep_env += HOME
426# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
427t=$(mktemp -d)
d50a2a28 428%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
429TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
430rm -rf $t
431EOF
432chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 433
44be9ed4 434%if %{with enigmail}
283702b9 435ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
916d4050 436install -d $ext_dir/{chrome,components,defaults/preferences,modules}
52fc61e6 437cd mozilla/dist/bin
916d4050 438cp -rfLp chrome/enigmail.jar $ext_dir/chrome
52fc61e6
ER
439cp -rfLp components/enig* $ext_dir/components
440cp -rfLp components/libenigmime.so $ext_dir/components
52fc61e6 441cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
de09c00d 442cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
916d4050 443cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
52fc61e6 444cd -
52f5507d
ER
445cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
446cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 447%endif
448
9cdc8923
ER
449# never package these. always remove
450# nss
451%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
452# nspr
453%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 454# mozldap
9cdc8923 455%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
3815090b
ER
456# testpilot quiz
457%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
283702b9 458
44be9ed4 459%clean
460rm -rf $RPM_BUILD_ROOT
461
462%pretrans
463if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
464 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
465fi
eca54e0f 466for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 467 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
468 install -d %{_datadir}/%{name}
469 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
470 fi
471done
472exit 0
473
e8f4ba81
ER
474%post
475%{_libdir}/%{name}/register || :
476
44be9ed4 477%files
478%defattr(644,root,root,755)
479%attr(755,root,root) %{_bindir}/icedove
480%attr(755,root,root) %{_bindir}/mozilla-thunderbird
481%attr(755,root,root) %{_bindir}/thunderbird
482%dir %{_libdir}/%{name}
765a3a27 483%{_libdir}/%{name}/application.ini
6b327de6
JB
484%{_libdir}/%{name}/blocklist.xml
485%{_libdir}/%{name}/chrome.manifest
44be9ed4 486%dir %{_libdir}/%{name}/components
44be9ed4 487%{_libdir}/%{name}/components/*.js
488%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
489%{_libdir}/%{name}/components/components.manifest
490%{_libdir}/%{name}/components/interfaces.manifest
73d54cb2
JB
491%attr(755,root,root) %{_libdir}/%{name}/*.sh
492%attr(755,root,root) %{_libdir}/%{name}/*-bin
493%attr(755,root,root) %{_libdir}/%{name}/icedove
494%attr(755,root,root) %{_libdir}/%{name}/register
495%if %{without xulrunner}
a367af64 496%{_libdir}/%{name}/dependentlibs.list
73d54cb2
JB
497%{_libdir}/%{name}/platform.ini
498%{_libdir}/%{name}/greprefs.js
499%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 500%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 501%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 502%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 503%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 504%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 505%endif
44be9ed4 506
507# symlinks
508%{_libdir}/%{name}/chrome
509%{_libdir}/%{name}/defaults
44be9ed4 510%{_libdir}/%{name}/isp
9e097178 511%{_libdir}/%{name}/modules
eca54e0f 512%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
513%if %{with xulrunner}
514%{_libdir}/%{name}/xulrunner
515%else
73d54cb2
JB
516%{_libdir}/%{name}/dictionaries
517%{_libdir}/%{name}/hyphenation
518%{_libdir}/%{name}/res
519%endif
44be9ed4 520
224cf96a
JB
521%{_pixmapsdir}/icedove.png
522%{_desktopdir}/icedove.desktop
44be9ed4 523
524%dir %{_datadir}/%{name}
525%{_datadir}/%{name}/chrome
526%{_datadir}/%{name}/defaults
eca54e0f 527%{_datadir}/%{name}/extensions
44be9ed4 528%{_datadir}/%{name}/isp
9e097178 529%{_datadir}/%{name}/modules
916d4050
JR
530%if %{with enigmail}
531%exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
532%exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
533%exclude %{_datadir}/%{name}/modules/keyManagement.jsm
534%exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
916d4050
JR
535%exclude %{_datadir}/%{name}/modules/subprocess.jsm
536%exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
537%exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
538%endif
eca54e0f 539%{_datadir}/%{name}/searchplugins
73d54cb2
JB
540%if %{without xulrunner}
541%{_datadir}/%{name}/res
542%endif
44be9ed4 543
765a3a27
ER
544%if %{with crashreporter}
545%attr(755,root,root) %{_libdir}/%{name}/crashreporter
546%{_libdir}/%{name}/crashreporter.ini
547%{_libdir}/%{name}/Throbber-small.gif
548%endif
549
44be9ed4 550%dir %{_libdir}/%{name}/extensions
551%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 552
52fc61e6
ER
553# files created by regxpcom -register
554%ghost %{_libdir}/%{name}/components/compreg.dat
555%ghost %{_libdir}/%{name}/components/xpti.dat
556
6578c165 557%if %{with lightning}
558%files addon-lightning
559%defattr(644,root,root,755)
f3b6d696 560%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 561%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
562%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
563%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 564%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
565%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
566%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
567%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 568%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
569%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
570%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
571%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
572%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
573%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 574%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
575%endif
44be9ed4 576
577%if %{with enigmail}
578%files addon-enigmail
579%defattr(644,root,root,755)
f6a43e2f
ER
580%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
581%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
582%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
583%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
584%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
585%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
586%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
587%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
588%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
916d4050
JR
589%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
590%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
591%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
44be9ed4 592%endif
This page took 0.160955 seconds and 4 git commands to generate.