]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- rel 1
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
19aa9cc1 22%define enigmail_ver 1.4.6
64b4570d
JB
23%define nspr_ver 4.9
24%define nss_ver 3.13.3
44be9ed4 25
aaaf7356 26%define xulrunner_ver 2:17.0
4f34f106 27
7d981f69
ER
28%if %{without xulrunner}
29# The actual sqlite version (see RHBZ#480989):
30%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31%endif
32
44be9ed4 33Summary: Icedove - email client
34Summary(pl.UTF-8): Icedove - klient poczty
35Name: icedove
19aa9cc1 36Version: 17.0
aaaf7356 37Release: 1
44be9ed4 38License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 39Group: X11/Applications/Networking
cadfb931 40Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
19aa9cc1 41# Source0-md5: f3690660044337273efb52f79cb15b0e
44be9ed4 42Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
19aa9cc1 43# Source1-md5: 3d42cff27e0f8da24bdabf8363d8261f
44be9ed4 44Source2: %{name}-branding.tar.bz2
c105f759 45# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 46Source3: %{name}-rm_nonfree.sh
47Source4: %{name}.desktop
48Source5: %{name}.sh
44be9ed4 49Patch0: %{name}-branding.patch
faa5c89d 50Patch1: %{name}-enigmail-shared.patch
fac7e24d 51Patch2: %{name}-system-xulrunner.patch
faa5c89d
SP
52Patch3: %{name}-fonts.patch
53Patch4: %{name}-install.patch
5e9bb798 54Patch5: %{name}-hunspell.patch
faa5c89d 55Patch6: %{name}-prefs.patch
9a743685 56Patch7: system-mozldap.patch
a85e0ecb 57Patch8: %{name}-makefile.patch
37973fb0 58Patch9: system-cairo.patch
ccc206fe 59Patch10: %{name}-extensiondir.patch
765a3a27 60Patch11: crashreporter.patch
268e7766 61Patch12: no-subshell.patch
03be87a5
JR
62# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
63Patch13: system-virtualenv.patch
5745d706 64URL: http://www.pld-linux.org/Packages/Icedove
6458b220 65BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 66BuildRequires: alsa-lib-devel
44be9ed4 67BuildRequires: automake
51a3b6db 68BuildRequires: bzip2-devel
e820c55e
JB
69BuildRequires: cairo-devel >= 1.10
70BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 71BuildRequires: freetype-devel >= 1:2.1.8
6458b220 72BuildRequires: glib2-devel >= 2.0
e820c55e 73BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 74BuildRequires: hunspell-devel
44be9ed4 75BuildRequires: libIDL-devel >= 0.8.0
6458b220 76%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 77%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 78%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 79BuildRequires: libiw-devel
44be9ed4 80BuildRequires: libjpeg-devel >= 6b
51a3b6db 81BuildRequires: libnotify-devel >= 0.4
e820c55e 82BuildRequires: libpng-devel >= 1.4.1
44be9ed4 83BuildRequires: libstdc++-devel
f4114a7f
ER
84BuildRequires: nspr-devel >= 1:%{nspr_ver}
85BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 86BuildRequires: pango-devel >= 1:1.14.0
e820c55e 87BuildRequires: perl-base >= 1:5.6
1c62cadb 88BuildRequires: pkgconfig
e820c55e 89BuildRequires: python >= 1:2.5
44be9ed4 90BuildRequires: sed >= 4.0
9d1bfad8 91BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 92BuildRequires: startup-notification-devel >= 0.8
44be9ed4 93BuildRequires: xorg-lib-libXext-devel
44be9ed4 94BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 95BuildRequires: xorg-lib-libXt-devel
5745d706 96BuildRequires: yasm
1c62cadb 97BuildRequires: zip
7d981f69 98%if %{with xulrunner}
e8326f77 99BuildRequires: xulrunner-devel >= %{xulrunner_ver}
7d981f69 100%else
44be9ed4 101Requires: myspell-common
f4114a7f
ER
102Requires: nspr >= 1:%{nspr_ver}
103Requires: nss >= 1:%{nss_ver}
4b6bc367 104Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 105%endif
4f34f106
ER
106Requires(post): mktemp >= 1.5-18
107%if %{with xulrunner}
108%requires_eq_to xulrunner xulrunner-devel
109%endif
44be9ed4 110Obsoletes: mozilla-thunderbird
111Obsoletes: mozilla-thunderbird-dictionary-en-US
d606e9b3 112Conflicts: icedove-lang-resources < %{version}
44be9ed4 113BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
9e366f18
AM
115%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
116
44be9ed4 117# iceweasel/icedove/iceape provide their own versions
44be9ed4 118%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
119%if %{without xulrunner}
120# we don't want these to satisfy packages depending on xulrunner
121%define _noautoprov libmozalloc.so libxpcom.so libxul.so
44be9ed4 122# and as we don't provide them, don't require either
fb7d4f06
JB
123%define _noautoreq libmozalloc.so libxpcom.so libxul.so
124%endif
44be9ed4 125
9e7875fc
ER
126%define topdir %{_builddir}/%{name}-%{version}
127%define objdir %{topdir}/obj-%{_target_cpu}
128
44be9ed4 129%description
6b327de6 130Icedove is an open-source, fast and portable email client.
44be9ed4 131
132%description -l pl.UTF-8
6b327de6
JB
133Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
134poczty.
44be9ed4 135
6578c165 136%package addon-lightning
137Summary: An integrated calendar for Icedove
138Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
139License: MPL 1.1 or GPL v2+ or LGPL v2.1+
140Group: Applications/Networking
141Requires: %{name} = %{version}-%{release}
142
143%description addon-lightning
144Lightning is an calendar extension to Icedove email client.
145
146%description addon-lightning -l pl.UTF-8
147Lightning to rozszerzenie do klienta poczty Icedove dodające
148funkcjonalność kalendarza.
149
44be9ed4 150%package addon-enigmail
151Summary: Extension for the authentication and encryption features provided by GnuPG
152Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
153License: MPL/LGPL
154Group: Applications/Networking
155URL: http://enigmail.mozdev.org/
cd056caa 156Requires: %{name} = %{version}-%{release}
d076d93e 157Requires: gnupg
75991bbb 158Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 159
160%description addon-enigmail
c5e06599 161Enigmail is an extension to the Icedove mail client which allows users
162to access the authentication and encryption features provided by
163GnuPG.
44be9ed4 164
165Main Features:
166- Encrypt/sign mail when sending, decrypt/authenticate received mail
167- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
168- Per-Account based encryption and signing defaults
169- Per-Recipient rules for automated key selection, and
170 enabling/disabling encryption and signing
171- OpenPGP key management interface
172
173%description addon-enigmail -l pl.UTF-8
c5e06599 174Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
175użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
176przez GnuPG.
44be9ed4 177
178Główne możliwości:
179- szyfrowanie/podpisywanie poczty przy wysyłaniu,
180 odszyfrowywanie/uwierzytelnianie poczty odebranej
181- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
182- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
183- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
184 podpisywania dla każdego adresata
185- interfejs do zarządzania kluczami OpenPGP
186
187%prep
983562b1 188%setup -qc
f4114a7f 189mv comm-release mozilla
983562b1 190%setup -q -T -D -a2
191cd mozilla
1c70899a 192%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 193/bin/sh %{SOURCE3}
983562b1 194%patch0 -p1
faa5c89d 195%{?with_enigmail:%patch1 -p1}
73d54cb2 196%{?with_xulrunner:%patch2 -p1}
4ccc2157 197%patch3 -p1
faa5c89d 198%patch4 -p1
983562b1 199%patch6 -p1
9a743685 200%patch7 -p1
f4114a7f 201%patch8 -p2
3815090b 202%patch9 -p1
ccc206fe 203%patch10 -p2
765a3a27 204%patch11 -p2
268e7766 205%patch12 -p1
03be87a5 206%patch13 -p1
44be9ed4 207
208%build
983562b1 209cd mozilla
cadfb931
SP
210cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 212cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 213
fbac75ca 214cat << EOF > .mozconfig
9e7875fc 215mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 216
fac7e24d 217export CFLAGS="%{rpmcflags}"
73d54cb2 218export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
219
220%if %{with crashreporter}
221export MOZ_DEBUG_SYMBOLS=1
222%endif
223
59c5a0e8 224# Options for 'configure' (same as command-line options).
44be9ed4 225ac_add_options --prefix=%{_prefix}
226ac_add_options --exec-prefix=%{_exec_prefix}
227ac_add_options --bindir=%{_bindir}
228ac_add_options --sbindir=%{_sbindir}
229ac_add_options --sysconfdir=%{_sysconfdir}
230ac_add_options --datadir=%{_datadir}
231ac_add_options --includedir=%{_includedir}
232ac_add_options --libdir=%{_libdir}
233ac_add_options --libexecdir=%{_libexecdir}
234ac_add_options --localstatedir=%{_localstatedir}
235ac_add_options --sharedstatedir=%{_sharedstatedir}
236ac_add_options --mandir=%{_mandir}
237ac_add_options --infodir=%{_infodir}
238%if %{?debug:1}0
59c5a0e8 239ac_add_options --disable-optimize
44be9ed4 240ac_add_options --enable-debug
241ac_add_options --enable-debug-modules
59c5a0e8
SP
242ac_add_options --enable-debugger-info-modules
243ac_add_options --enable-crash-on-assert
44be9ed4 244%else
245ac_add_options --disable-debug
246ac_add_options --disable-debug-modules
59c5a0e8
SP
247ac_add_options --disable-logging
248ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 249%endif
88149483
ER
250ac_add_options --disable-strip
251ac_add_options --disable-strip-libs
44be9ed4 252%if %{with tests}
253ac_add_options --enable-tests
254%else
255ac_add_options --disable-tests
256%endif
6458b220 257ac_add_options --enable-gio
44be9ed4 258%if %{with gnomeui}
259ac_add_options --enable-gnomeui
260%else
261ac_add_options --disable-gnomeui
262%endif
44be9ed4 263ac_add_options --disable-gnomevfs
44be9ed4 264%if %{with ldap}
265ac_add_options --enable-ldap
9a743685 266ac_add_options --with-system-ldap
44be9ed4 267%else
268ac_add_options --disable-ldap
269%endif
765a3a27
ER
270%if %{with crashreporter}
271ac_add_options --enable-crashreporter
272%else
59c5a0e8 273ac_add_options --disable-crashreporter
765a3a27 274%endif
59c5a0e8 275ac_add_options --disable-xterm-updates
59c5a0e8 276ac_add_options --enable-postscript
d076d93e 277%if %{with lightning}
cb0e4412 278ac_add_options --enable-calendar
d076d93e
SP
279%else
280ac_add_options --disable-calendar
281%endif
44be9ed4 282ac_add_options --disable-installer
88149483 283ac_add_options --disable-updater
44be9ed4 284ac_add_options --disable-xprint
cadfb931
SP
285ac_add_options --disable-permissions
286ac_add_options --disable-pref-extensions
44be9ed4 287ac_add_options --enable-canvas
288ac_add_options --enable-crypto
44be9ed4 289ac_add_options --enable-mathml
44be9ed4 290ac_add_options --enable-pango
291ac_add_options --enable-reorder
88149483
ER
292ac_add_options --enable-startup-notification
293ac_add_options --enable-svg
44be9ed4 294ac_add_options --enable-system-cairo
5e9bb798 295ac_add_options --enable-system-hunspell
7d981f69 296ac_add_options --enable-system-sqlite
44be9ed4 297ac_add_options --enable-xft
cadfb931
SP
298ac_add_options --enable-application=mail
299ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 300ac_add_options --enable-xinerama
88149483
ER
301ac_add_options --with-distribution-id=org.pld-linux
302ac_add_options --with-branding=icedove/branding
303%if %{with xulrunner}
fac7e24d
JB
304ac_add_options --enable-shared-js
305ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 306ac_add_options --with-system-libxul
88149483
ER
307%endif
308ac_add_options --with-pthreads
309ac_add_options --with-system-bz2
44be9ed4 310ac_add_options --with-system-jpeg
311ac_add_options --with-system-nspr
312ac_add_options --with-system-nss
313ac_add_options --with-system-png
314ac_add_options --with-system-zlib
44be9ed4 315ac_add_options --enable-single-profile
316ac_add_options --disable-profilesharing
44be9ed4 317ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
318EOF
319
90e998ba 320%{__make} -j1 -f client.mk build \
d076d93e 321 STRIP="/bin/true" \
765a3a27 322 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 323 CC="%{__cc}" \
44be9ed4 324 CXX="%{__cxx}"
325
765a3a27
ER
326%if %{with crashreporter}
327# create debuginfo for crash-stats.mozilla.com
328%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
329%endif
330
44be9ed4 331%if %{with enigmail}
59c5a0e8 332cd mailnews/extensions/enigmail
9e7875fc
ER
333./makemake -r -o %{objdir}
334%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
335 STRIP="/bin/true" \
336 CC="%{__cc}" \
337 CXX="%{__cxx}"
916d4050
JR
338
339%{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
340 STRIP="/bin/true" \
341 CC="%{__cc}" \
342 CXX="%{__cxx}"
44be9ed4 343%endif
344
345%install
346rm -rf $RPM_BUILD_ROOT
765a3a27 347install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 348
9e7875fc 349cd %{objdir}
ecf04393 350%{__make} -C mail/installer stage-package \
44be9ed4 351 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 352 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 353 PKG_SKIP_STRIP=1
354
9b40a2c3
JB
355%if %{with xulrunner}
356# needed to find mozilla runtime
357ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
358%endif
359
360# Enable crash reporter for Thunderbird application
765a3a27
ER
361%if %{with crashreporter}
362%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
363
364# Add debuginfo for crash-stats.mozilla.com
51a3b6db 365install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
366cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
367%endif
368
ecf04393
ER
369# copy manually lightning files, somewhy they are not installed by make
370cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
371 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
372 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
373
44be9ed4 374# move arch independant ones to datadir
375mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
376mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 377mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 378mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
eca54e0f 379mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 380ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
381ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 382ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 383ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
eca54e0f 384ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
73d54cb2
JB
385%if %{without xulrunner}
386mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
387ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
388%endif
44be9ed4 389
c6ec3c1c
ER
390# dir for arch independant extensions besides arch dependant extensions
391# see mozilla/xpcom/build/nsXULAppAPI.h
392# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
393install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
394
73d54cb2 395%if %{without xulrunner}
63d8f5c3 396%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 397ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
e6bc19b3
ER
398%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
399ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
73d54cb2 400%endif
e6bc19b3 401
0889474f
JR
402%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
403 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
404 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
405
44be9ed4 406%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
407ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
408ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
409
52f5507d
ER
410cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
411cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 412
e8f4ba81 413# files created by regxpcom -register in post
52fc61e6
ER
414touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
415touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
416cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
417#!/bin/sh
418umask 022
419# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
420# dangerous if you run this with sudo with keep_env += HOME
421# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
422t=$(mktemp -d)
d50a2a28 423%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
424TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
425rm -rf $t
426EOF
427chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 428
44be9ed4 429%if %{with enigmail}
283702b9 430ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
916d4050 431install -d $ext_dir/{chrome,components,defaults/preferences,modules}
52fc61e6 432cd mozilla/dist/bin
916d4050 433cp -rfLp chrome/enigmail.jar $ext_dir/chrome
52fc61e6
ER
434cp -rfLp components/enig* $ext_dir/components
435cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 436cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
437cp -rfLp components/ipc.xpt $ext_dir/components
438cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
916d4050
JR
439cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,pipeTransport,subprocess}.jsm $ext_dir/modules
440cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
52fc61e6 441cd -
52f5507d
ER
442cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
443cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 444%endif
445
9cdc8923
ER
446# never package these. always remove
447# nss
448%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
449# nspr
450%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 451# mozldap
9cdc8923 452%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
3815090b
ER
453# testpilot quiz
454%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
283702b9 455
44be9ed4 456%clean
457rm -rf $RPM_BUILD_ROOT
458
459%pretrans
460if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
461 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
462fi
eca54e0f 463for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 464 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
465 install -d %{_datadir}/%{name}
466 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
467 fi
468done
469exit 0
470
e8f4ba81
ER
471%post
472%{_libdir}/%{name}/register || :
473
44be9ed4 474%files
475%defattr(644,root,root,755)
476%attr(755,root,root) %{_bindir}/icedove
477%attr(755,root,root) %{_bindir}/mozilla-thunderbird
478%attr(755,root,root) %{_bindir}/thunderbird
479%dir %{_libdir}/%{name}
765a3a27 480%{_libdir}/%{name}/application.ini
6b327de6
JB
481%{_libdir}/%{name}/blocklist.xml
482%{_libdir}/%{name}/chrome.manifest
44be9ed4 483%dir %{_libdir}/%{name}/components
44be9ed4 484%{_libdir}/%{name}/components/*.js
485%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
486%{_libdir}/%{name}/components/components.manifest
487%{_libdir}/%{name}/components/interfaces.manifest
73d54cb2
JB
488%attr(755,root,root) %{_libdir}/%{name}/*.sh
489%attr(755,root,root) %{_libdir}/%{name}/*-bin
490%attr(755,root,root) %{_libdir}/%{name}/icedove
491%attr(755,root,root) %{_libdir}/%{name}/register
492%if %{without xulrunner}
493%{_libdir}/%{name}/platform.ini
494%{_libdir}/%{name}/greprefs.js
495%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 496%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 497%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 498%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 499%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 500%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 501%endif
44be9ed4 502
503# symlinks
504%{_libdir}/%{name}/chrome
505%{_libdir}/%{name}/defaults
44be9ed4 506%{_libdir}/%{name}/isp
9e097178 507%{_libdir}/%{name}/modules
eca54e0f 508%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
509%if %{with xulrunner}
510%{_libdir}/%{name}/xulrunner
511%else
73d54cb2
JB
512%{_libdir}/%{name}/dictionaries
513%{_libdir}/%{name}/hyphenation
514%{_libdir}/%{name}/res
515%endif
44be9ed4 516
224cf96a
JB
517%{_pixmapsdir}/icedove.png
518%{_desktopdir}/icedove.desktop
44be9ed4 519
520%dir %{_datadir}/%{name}
521%{_datadir}/%{name}/chrome
522%{_datadir}/%{name}/defaults
eca54e0f 523%{_datadir}/%{name}/extensions
44be9ed4 524%{_datadir}/%{name}/isp
9e097178 525%{_datadir}/%{name}/modules
916d4050
JR
526%if %{with enigmail}
527%exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
528%exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
529%exclude %{_datadir}/%{name}/modules/keyManagement.jsm
530%exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
531%exclude %{_datadir}/%{name}/modules/pipeTransport.jsm
532%exclude %{_datadir}/%{name}/modules/subprocess.jsm
533%exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
534%exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
535%endif
eca54e0f 536%{_datadir}/%{name}/searchplugins
73d54cb2
JB
537%if %{without xulrunner}
538%{_datadir}/%{name}/res
539%endif
44be9ed4 540
765a3a27
ER
541%if %{with crashreporter}
542%attr(755,root,root) %{_libdir}/%{name}/crashreporter
543%{_libdir}/%{name}/crashreporter.ini
544%{_libdir}/%{name}/Throbber-small.gif
545%endif
546
44be9ed4 547%dir %{_libdir}/%{name}/extensions
548%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 549
52fc61e6
ER
550# files created by regxpcom -register
551%ghost %{_libdir}/%{name}/components/compreg.dat
552%ghost %{_libdir}/%{name}/components/xpti.dat
553
6578c165 554%if %{with lightning}
555%files addon-lightning
556%defattr(644,root,root,755)
f3b6d696 557%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 558%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
559%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
560%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 561%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
562%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
563%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
564%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 565%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
566%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
567%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
568%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
569%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
570%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 571%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
572%endif
44be9ed4 573
574%if %{with enigmail}
575%files addon-enigmail
576%defattr(644,root,root,755)
f6a43e2f
ER
577%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
578%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
579%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
580%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
581%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
582%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
583%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
584%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
585%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
916d4050
JR
586%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
587%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
588%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
44be9ed4 589%endif
This page took 0.156788 seconds and 4 git commands to generate.