]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- up to 12.0.1
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
c0baf171 22%define enigmail_ver 1.4.1
64b4570d
JB
23%define nspr_ver 4.9
24%define nss_ver 3.13.3
44be9ed4 25
3815090b
ER
26# convert thunderbird release number to platform version: 12.0.x -> 12.0.x
27%define xulrunner_main 12.0
64b4570d 28%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#11.0})
4f34f106 29
7d981f69
ER
30%if %{without xulrunner}
31# The actual sqlite version (see RHBZ#480989):
32%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33%endif
34
44be9ed4 35Summary: Icedove - email client
36Summary(pl.UTF-8): Icedove - klient poczty
37Name: icedove
c0baf171 38Version: 12.0.1
3815090b 39Release: 1
44be9ed4 40License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 41Group: X11/Applications/Networking
cadfb931 42Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
c0baf171 43# Source0-md5: 64cacde4cb2b1e8736f1c3a0ea6a02db
44be9ed4 44Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
c0baf171 45# Source1-md5: 0eba75fbcf8f0bb32d538df102fbb8e9
44be9ed4 46Source2: %{name}-branding.tar.bz2
c105f759 47# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 48Source3: %{name}-rm_nonfree.sh
49Source4: %{name}.desktop
50Source5: %{name}.sh
44be9ed4 51Patch0: %{name}-branding.patch
faa5c89d 52Patch1: %{name}-enigmail-shared.patch
fac7e24d 53Patch2: %{name}-system-xulrunner.patch
faa5c89d
SP
54Patch3: %{name}-fonts.patch
55Patch4: %{name}-install.patch
5e9bb798 56Patch5: %{name}-hunspell.patch
faa5c89d 57Patch6: %{name}-prefs.patch
9a743685 58Patch7: system-mozldap.patch
a85e0ecb 59Patch8: %{name}-makefile.patch
3815090b
ER
60# this is only workaround, check if it is fixed with newer firefox
61Patch9: bug-722975-workaround.patch
ccc206fe 62Patch10: %{name}-extensiondir.patch
765a3a27 63Patch11: crashreporter.patch
268e7766 64Patch12: no-subshell.patch
5745d706 65URL: http://www.pld-linux.org/Packages/Icedove
6458b220 66BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 67BuildRequires: alsa-lib-devel
44be9ed4 68BuildRequires: automake
51a3b6db 69BuildRequires: bzip2-devel
e820c55e
JB
70BuildRequires: cairo-devel >= 1.10
71BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 72BuildRequires: freetype-devel >= 1:2.1.8
6458b220 73BuildRequires: glib2-devel >= 2.0
e820c55e 74BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 75BuildRequires: hunspell-devel
44be9ed4 76BuildRequires: libIDL-devel >= 0.8.0
6458b220 77%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 78%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 79%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 80BuildRequires: libiw-devel
44be9ed4 81BuildRequires: libjpeg-devel >= 6b
51a3b6db 82BuildRequires: libnotify-devel >= 0.4
e820c55e 83BuildRequires: libpng-devel >= 1.4.1
44be9ed4 84BuildRequires: libstdc++-devel
f4114a7f
ER
85BuildRequires: nspr-devel >= 1:%{nspr_ver}
86BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 87BuildRequires: pango-devel >= 1:1.14.0
e820c55e 88BuildRequires: perl-base >= 1:5.6
1c62cadb 89BuildRequires: pkgconfig
e820c55e 90BuildRequires: python >= 1:2.5
44be9ed4 91BuildRequires: sed >= 4.0
9d1bfad8 92BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 93BuildRequires: startup-notification-devel >= 0.8
44be9ed4 94BuildRequires: xorg-lib-libXext-devel
44be9ed4 95BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 96BuildRequires: xorg-lib-libXt-devel
5745d706 97BuildRequires: yasm
1c62cadb 98BuildRequires: zip
7d981f69 99%if %{with xulrunner}
4f34f106 100BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 101%else
44be9ed4 102Requires: myspell-common
f4114a7f
ER
103Requires: nspr >= 1:%{nspr_ver}
104Requires: nss >= 1:%{nss_ver}
4b6bc367 105Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 106%endif
4f34f106
ER
107Requires(post): mktemp >= 1.5-18
108%if %{with xulrunner}
109%requires_eq_to xulrunner xulrunner-devel
110%endif
44be9ed4 111Obsoletes: mozilla-thunderbird
112Obsoletes: mozilla-thunderbird-dictionary-en-US
113BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
9e366f18
AM
115%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
116
44be9ed4 117# iceweasel/icedove/iceape provide their own versions
44be9ed4 118%define _noautoprovfiles %{_libdir}/%{name}/components
119# we don't want these to satisfy xulrunner-devel
224cf96a 120%define _noautoprov libmozjs.so libxpcom.so libxul.so
44be9ed4 121# and as we don't provide them, don't require either
224cf96a 122%define _noautoreq libmozjs.so libxpcom.so libxul.so
44be9ed4 123
9e7875fc
ER
124%define topdir %{_builddir}/%{name}-%{version}
125%define objdir %{topdir}/obj-%{_target_cpu}
126
44be9ed4 127%description
6b327de6 128Icedove is an open-source, fast and portable email client.
44be9ed4 129
130%description -l pl.UTF-8
6b327de6
JB
131Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132poczty.
44be9ed4 133
6578c165 134%package addon-lightning
135Summary: An integrated calendar for Icedove
136Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
137License: MPL 1.1 or GPL v2+ or LGPL v2.1+
138Group: Applications/Networking
139Requires: %{name} = %{version}-%{release}
140
141%description addon-lightning
142Lightning is an calendar extension to Icedove email client.
143
144%description addon-lightning -l pl.UTF-8
145Lightning to rozszerzenie do klienta poczty Icedove dodające
146funkcjonalność kalendarza.
147
44be9ed4 148%package addon-enigmail
149Summary: Extension for the authentication and encryption features provided by GnuPG
150Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151License: MPL/LGPL
152Group: Applications/Networking
153URL: http://enigmail.mozdev.org/
cd056caa 154Requires: %{name} = %{version}-%{release}
d076d93e 155Requires: gnupg
75991bbb 156Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 157
158%description addon-enigmail
c5e06599 159Enigmail is an extension to the Icedove mail client which allows users
160to access the authentication and encryption features provided by
161GnuPG.
44be9ed4 162
163Main Features:
164- Encrypt/sign mail when sending, decrypt/authenticate received mail
165- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166- Per-Account based encryption and signing defaults
167- Per-Recipient rules for automated key selection, and
168 enabling/disabling encryption and signing
169- OpenPGP key management interface
170
171%description addon-enigmail -l pl.UTF-8
c5e06599 172Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
173użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174przez GnuPG.
44be9ed4 175
176Główne możliwości:
177- szyfrowanie/podpisywanie poczty przy wysyłaniu,
178 odszyfrowywanie/uwierzytelnianie poczty odebranej
179- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182 podpisywania dla każdego adresata
183- interfejs do zarządzania kluczami OpenPGP
184
185%prep
983562b1 186%setup -qc
f4114a7f 187mv comm-release mozilla
983562b1 188%setup -q -T -D -a2
189cd mozilla
1c70899a 190%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 191/bin/sh %{SOURCE3}
983562b1 192%patch0 -p1
faa5c89d 193%{?with_enigmail:%patch1 -p1}
73d54cb2 194%{?with_xulrunner:%patch2 -p1}
4ccc2157 195%patch3 -p1
faa5c89d 196%patch4 -p1
983562b1 197%patch6 -p1
9a743685 198%patch7 -p1
f4114a7f 199%patch8 -p2
3815090b
ER
200cd mozilla
201%patch9 -p1
202cd -
ccc206fe 203%patch10 -p2
765a3a27 204%patch11 -p2
268e7766 205%patch12 -p1
44be9ed4 206
207%build
983562b1 208cd mozilla
cadfb931
SP
209cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
210cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 211cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 212
fbac75ca 213cat << EOF > .mozconfig
9e7875fc 214mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 215
fac7e24d 216export CFLAGS="%{rpmcflags}"
73d54cb2 217export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
218
219%if %{with crashreporter}
220export MOZ_DEBUG_SYMBOLS=1
221%endif
222
59c5a0e8 223# Options for 'configure' (same as command-line options).
44be9ed4 224ac_add_options --prefix=%{_prefix}
225ac_add_options --exec-prefix=%{_exec_prefix}
226ac_add_options --bindir=%{_bindir}
227ac_add_options --sbindir=%{_sbindir}
228ac_add_options --sysconfdir=%{_sysconfdir}
229ac_add_options --datadir=%{_datadir}
230ac_add_options --includedir=%{_includedir}
231ac_add_options --libdir=%{_libdir}
232ac_add_options --libexecdir=%{_libexecdir}
233ac_add_options --localstatedir=%{_localstatedir}
234ac_add_options --sharedstatedir=%{_sharedstatedir}
235ac_add_options --mandir=%{_mandir}
236ac_add_options --infodir=%{_infodir}
237%if %{?debug:1}0
59c5a0e8 238ac_add_options --disable-optimize
44be9ed4 239ac_add_options --enable-debug
240ac_add_options --enable-debug-modules
59c5a0e8
SP
241ac_add_options --enable-debugger-info-modules
242ac_add_options --enable-crash-on-assert
44be9ed4 243%else
244ac_add_options --disable-debug
245ac_add_options --disable-debug-modules
59c5a0e8
SP
246ac_add_options --disable-logging
247ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 248%endif
88149483
ER
249ac_add_options --disable-strip
250ac_add_options --disable-strip-libs
44be9ed4 251%if %{with tests}
252ac_add_options --enable-tests
253%else
254ac_add_options --disable-tests
255%endif
6458b220 256ac_add_options --enable-gio
44be9ed4 257%if %{with gnomeui}
258ac_add_options --enable-gnomeui
259%else
260ac_add_options --disable-gnomeui
261%endif
44be9ed4 262ac_add_options --disable-gnomevfs
44be9ed4 263%if %{with ldap}
264ac_add_options --enable-ldap
9a743685 265ac_add_options --with-system-ldap
44be9ed4 266%else
267ac_add_options --disable-ldap
268%endif
765a3a27
ER
269%if %{with crashreporter}
270ac_add_options --enable-crashreporter
271%else
59c5a0e8 272ac_add_options --disable-crashreporter
765a3a27 273%endif
59c5a0e8 274ac_add_options --disable-xterm-updates
59c5a0e8 275ac_add_options --enable-postscript
d076d93e 276%if %{with lightning}
cb0e4412 277ac_add_options --enable-calendar
d076d93e
SP
278%else
279ac_add_options --disable-calendar
280%endif
44be9ed4 281ac_add_options --disable-installer
88149483 282ac_add_options --disable-updater
44be9ed4 283ac_add_options --disable-xprint
cadfb931
SP
284ac_add_options --disable-permissions
285ac_add_options --disable-pref-extensions
44be9ed4 286ac_add_options --enable-canvas
287ac_add_options --enable-crypto
44be9ed4 288ac_add_options --enable-mathml
44be9ed4 289ac_add_options --enable-pango
290ac_add_options --enable-reorder
88149483
ER
291ac_add_options --enable-startup-notification
292ac_add_options --enable-svg
44be9ed4 293ac_add_options --enable-system-cairo
5e9bb798 294ac_add_options --enable-system-hunspell
7d981f69 295ac_add_options --enable-system-sqlite
44be9ed4 296ac_add_options --enable-xft
cadfb931
SP
297ac_add_options --enable-application=mail
298ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 299ac_add_options --enable-xinerama
88149483
ER
300ac_add_options --with-distribution-id=org.pld-linux
301ac_add_options --with-branding=icedove/branding
302%if %{with xulrunner}
fac7e24d
JB
303ac_add_options --enable-shared-js
304ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 305ac_add_options --with-system-libxul
88149483
ER
306%endif
307ac_add_options --with-pthreads
308ac_add_options --with-system-bz2
44be9ed4 309ac_add_options --with-system-jpeg
310ac_add_options --with-system-nspr
311ac_add_options --with-system-nss
312ac_add_options --with-system-png
313ac_add_options --with-system-zlib
44be9ed4 314ac_add_options --enable-single-profile
315ac_add_options --disable-profilesharing
44be9ed4 316ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
317EOF
318
90e998ba 319%{__make} -j1 -f client.mk build \
d076d93e 320 STRIP="/bin/true" \
765a3a27 321 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 322 CC="%{__cc}" \
44be9ed4 323 CXX="%{__cxx}"
324
765a3a27
ER
325%if %{with crashreporter}
326# create debuginfo for crash-stats.mozilla.com
327%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
328%endif
329
44be9ed4 330%if %{with enigmail}
59c5a0e8 331cd mailnews/extensions/enigmail
9e7875fc
ER
332./makemake -r -o %{objdir}
333%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
334 STRIP="/bin/true" \
335 CC="%{__cc}" \
336 CXX="%{__cxx}"
44be9ed4 337%endif
338
339%install
340rm -rf $RPM_BUILD_ROOT
765a3a27 341install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 342
9e7875fc 343cd %{objdir}
ecf04393 344%{__make} -C mail/installer stage-package \
44be9ed4 345 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 346 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 347 PKG_SKIP_STRIP=1
348
9b40a2c3
JB
349%if %{with xulrunner}
350# needed to find mozilla runtime
351ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
352%endif
353
354# Enable crash reporter for Thunderbird application
765a3a27
ER
355%if %{with crashreporter}
356%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
357
358# Add debuginfo for crash-stats.mozilla.com
51a3b6db 359install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
360cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
361%endif
362
ecf04393
ER
363# copy manually lightning files, somewhy they are not installed by make
364cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
365 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
366 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
367
44be9ed4 368# move arch independant ones to datadir
369mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
370mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 371mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 372mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
eca54e0f 373mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 374ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
375ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 376ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 377ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
eca54e0f 378ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
73d54cb2
JB
379%if %{without xulrunner}
380mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
381ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
382%endif
44be9ed4 383
c6ec3c1c
ER
384# dir for arch independant extensions besides arch dependant extensions
385# see mozilla/xpcom/build/nsXULAppAPI.h
386# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
387install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
388
73d54cb2 389%if %{without xulrunner}
63d8f5c3 390%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 391ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
e6bc19b3
ER
392%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
393ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
73d54cb2 394%endif
e6bc19b3 395
44be9ed4 396%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
397ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
398ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
399
52f5507d
ER
400cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
401cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 402
e8f4ba81 403# files created by regxpcom -register in post
52fc61e6
ER
404touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
405touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
406cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
407#!/bin/sh
408umask 022
409# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
410# dangerous if you run this with sudo with keep_env += HOME
411# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
412t=$(mktemp -d)
d50a2a28 413%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
414TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
415rm -rf $t
416EOF
417chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 418
44be9ed4 419%if %{with enigmail}
283702b9
ER
420ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
421install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 422cd mozilla/dist/bin
0516fc42 423#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
424#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
425cp -rfLp components/enig* $ext_dir/components
426cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 427cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
428cp -rfLp components/ipc.xpt $ext_dir/components
429cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
430cd -
52f5507d
ER
431cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
432cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 433%endif
434
9cdc8923
ER
435# never package these. always remove
436# nss
437%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
438# nspr
439%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 440# mozldap
9cdc8923 441%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
3815090b
ER
442# testpilot quiz
443%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
283702b9 444
44be9ed4 445%clean
446rm -rf $RPM_BUILD_ROOT
447
448%pretrans
449if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
450 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
451fi
eca54e0f 452for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 453 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
454 install -d %{_datadir}/%{name}
455 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
456 fi
457done
458exit 0
459
e8f4ba81
ER
460%post
461%{_libdir}/%{name}/register || :
462
44be9ed4 463%files
464%defattr(644,root,root,755)
465%attr(755,root,root) %{_bindir}/icedove
466%attr(755,root,root) %{_bindir}/mozilla-thunderbird
467%attr(755,root,root) %{_bindir}/thunderbird
468%dir %{_libdir}/%{name}
765a3a27 469%{_libdir}/%{name}/application.ini
6b327de6
JB
470%{_libdir}/%{name}/blocklist.xml
471%{_libdir}/%{name}/chrome.manifest
44be9ed4 472%dir %{_libdir}/%{name}/components
44be9ed4 473%{_libdir}/%{name}/components/*.js
474%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
475%{_libdir}/%{name}/components/components.manifest
476%{_libdir}/%{name}/components/interfaces.manifest
73d54cb2
JB
477%attr(755,root,root) %{_libdir}/%{name}/*.sh
478%attr(755,root,root) %{_libdir}/%{name}/*-bin
479%attr(755,root,root) %{_libdir}/%{name}/icedove
480%attr(755,root,root) %{_libdir}/%{name}/register
481%if %{without xulrunner}
482%{_libdir}/%{name}/platform.ini
483%{_libdir}/%{name}/greprefs.js
484%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 485%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 486%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 487%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 488%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 489%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 490%endif
44be9ed4 491
492# symlinks
493%{_libdir}/%{name}/chrome
494%{_libdir}/%{name}/defaults
44be9ed4 495%{_libdir}/%{name}/isp
9e097178 496%{_libdir}/%{name}/modules
eca54e0f 497%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
498%if %{with xulrunner}
499%{_libdir}/%{name}/xulrunner
500%else
73d54cb2
JB
501%{_libdir}/%{name}/dictionaries
502%{_libdir}/%{name}/hyphenation
503%{_libdir}/%{name}/res
504%endif
44be9ed4 505
224cf96a
JB
506%{_pixmapsdir}/icedove.png
507%{_desktopdir}/icedove.desktop
44be9ed4 508
509%dir %{_datadir}/%{name}
510%{_datadir}/%{name}/chrome
511%{_datadir}/%{name}/defaults
eca54e0f 512%{_datadir}/%{name}/extensions
44be9ed4 513%{_datadir}/%{name}/isp
9e097178 514%{_datadir}/%{name}/modules
eca54e0f 515%{_datadir}/%{name}/searchplugins
73d54cb2
JB
516%if %{without xulrunner}
517%{_datadir}/%{name}/res
518%endif
44be9ed4 519
765a3a27
ER
520%if %{with crashreporter}
521%attr(755,root,root) %{_libdir}/%{name}/crashreporter
522%{_libdir}/%{name}/crashreporter.ini
523%{_libdir}/%{name}/Throbber-small.gif
524%endif
525
44be9ed4 526%dir %{_libdir}/%{name}/extensions
527%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 528
52fc61e6
ER
529# files created by regxpcom -register
530%ghost %{_libdir}/%{name}/components/compreg.dat
531%ghost %{_libdir}/%{name}/components/xpti.dat
532
6578c165 533%if %{with lightning}
534%files addon-lightning
535%defattr(644,root,root,755)
f3b6d696 536%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 540%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
542%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
543%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 544%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
545%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
546%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
547%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
548%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
549%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 550%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
551%endif
44be9ed4 552
553%if %{with enigmail}
554%files addon-enigmail
555%defattr(644,root,root,755)
f6a43e2f
ER
556%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
557%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
558%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
559%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
560%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
561%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
562%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
563%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
564%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 565%endif
This page took 0.149238 seconds and 4 git commands to generate.