]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- libdir/icedove is no longer a script running run-mozilla.sh, so do it directly...
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
37973fb0 22%define enigmail_ver 1.4.2
64b4570d
JB
23%define nspr_ver 4.9
24%define nss_ver 3.13.3
44be9ed4 25
37973fb0 26%define xulrunner_ver 2:13.0
4f34f106 27
7d981f69
ER
28%if %{without xulrunner}
29# The actual sqlite version (see RHBZ#480989):
30%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31%endif
32
44be9ed4 33Summary: Icedove - email client
34Summary(pl.UTF-8): Icedove - klient poczty
35Name: icedove
37973fb0 36Version: 13.0
3815090b 37Release: 1
44be9ed4 38License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 39Group: X11/Applications/Networking
cadfb931 40Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
37973fb0 41# Source0-md5: 0134c67c30e8598f2a64ea004d5bc4bc
44be9ed4 42Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
37973fb0 43# Source1-md5: ed608e1cd4cd20b96f7f5afdbf081141
44be9ed4 44Source2: %{name}-branding.tar.bz2
c105f759 45# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 46Source3: %{name}-rm_nonfree.sh
47Source4: %{name}.desktop
48Source5: %{name}.sh
44be9ed4 49Patch0: %{name}-branding.patch
faa5c89d 50Patch1: %{name}-enigmail-shared.patch
fac7e24d 51Patch2: %{name}-system-xulrunner.patch
faa5c89d
SP
52Patch3: %{name}-fonts.patch
53Patch4: %{name}-install.patch
5e9bb798 54Patch5: %{name}-hunspell.patch
faa5c89d 55Patch6: %{name}-prefs.patch
9a743685 56Patch7: system-mozldap.patch
a85e0ecb 57Patch8: %{name}-makefile.patch
37973fb0 58Patch9: system-cairo.patch
ccc206fe 59Patch10: %{name}-extensiondir.patch
765a3a27 60Patch11: crashreporter.patch
268e7766 61Patch12: no-subshell.patch
5745d706 62URL: http://www.pld-linux.org/Packages/Icedove
6458b220 63BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 64BuildRequires: alsa-lib-devel
44be9ed4 65BuildRequires: automake
51a3b6db 66BuildRequires: bzip2-devel
e820c55e
JB
67BuildRequires: cairo-devel >= 1.10
68BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 69BuildRequires: freetype-devel >= 1:2.1.8
6458b220 70BuildRequires: glib2-devel >= 2.0
e820c55e 71BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 72BuildRequires: hunspell-devel
44be9ed4 73BuildRequires: libIDL-devel >= 0.8.0
6458b220 74%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 75%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 76%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 77BuildRequires: libiw-devel
44be9ed4 78BuildRequires: libjpeg-devel >= 6b
51a3b6db 79BuildRequires: libnotify-devel >= 0.4
e820c55e 80BuildRequires: libpng-devel >= 1.4.1
44be9ed4 81BuildRequires: libstdc++-devel
f4114a7f
ER
82BuildRequires: nspr-devel >= 1:%{nspr_ver}
83BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 84BuildRequires: pango-devel >= 1:1.14.0
e820c55e 85BuildRequires: perl-base >= 1:5.6
1c62cadb 86BuildRequires: pkgconfig
e820c55e 87BuildRequires: python >= 1:2.5
44be9ed4 88BuildRequires: sed >= 4.0
9d1bfad8 89BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 90BuildRequires: startup-notification-devel >= 0.8
44be9ed4 91BuildRequires: xorg-lib-libXext-devel
44be9ed4 92BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 93BuildRequires: xorg-lib-libXt-devel
5745d706 94BuildRequires: yasm
1c62cadb 95BuildRequires: zip
7d981f69 96%if %{with xulrunner}
e8326f77 97BuildRequires: xulrunner-devel >= %{xulrunner_ver}
7d981f69 98%else
44be9ed4 99Requires: myspell-common
f4114a7f
ER
100Requires: nspr >= 1:%{nspr_ver}
101Requires: nss >= 1:%{nss_ver}
4b6bc367 102Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 103%endif
4f34f106
ER
104Requires(post): mktemp >= 1.5-18
105%if %{with xulrunner}
106%requires_eq_to xulrunner xulrunner-devel
107%endif
44be9ed4 108Obsoletes: mozilla-thunderbird
109Obsoletes: mozilla-thunderbird-dictionary-en-US
110BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
9e366f18
AM
112%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
113
44be9ed4 114# iceweasel/icedove/iceape provide their own versions
44be9ed4 115%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
116%if %{without xulrunner}
117# we don't want these to satisfy packages depending on xulrunner
118%define _noautoprov libmozalloc.so libxpcom.so libxul.so
44be9ed4 119# and as we don't provide them, don't require either
fb7d4f06
JB
120%define _noautoreq libmozalloc.so libxpcom.so libxul.so
121%endif
44be9ed4 122
9e7875fc
ER
123%define topdir %{_builddir}/%{name}-%{version}
124%define objdir %{topdir}/obj-%{_target_cpu}
125
44be9ed4 126%description
6b327de6 127Icedove is an open-source, fast and portable email client.
44be9ed4 128
129%description -l pl.UTF-8
6b327de6
JB
130Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
131poczty.
44be9ed4 132
6578c165 133%package addon-lightning
134Summary: An integrated calendar for Icedove
135Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
136License: MPL 1.1 or GPL v2+ or LGPL v2.1+
137Group: Applications/Networking
138Requires: %{name} = %{version}-%{release}
139
140%description addon-lightning
141Lightning is an calendar extension to Icedove email client.
142
143%description addon-lightning -l pl.UTF-8
144Lightning to rozszerzenie do klienta poczty Icedove dodające
145funkcjonalność kalendarza.
146
44be9ed4 147%package addon-enigmail
148Summary: Extension for the authentication and encryption features provided by GnuPG
149Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
150License: MPL/LGPL
151Group: Applications/Networking
152URL: http://enigmail.mozdev.org/
cd056caa 153Requires: %{name} = %{version}-%{release}
d076d93e 154Requires: gnupg
75991bbb 155Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 156
157%description addon-enigmail
c5e06599 158Enigmail is an extension to the Icedove mail client which allows users
159to access the authentication and encryption features provided by
160GnuPG.
44be9ed4 161
162Main Features:
163- Encrypt/sign mail when sending, decrypt/authenticate received mail
164- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
165- Per-Account based encryption and signing defaults
166- Per-Recipient rules for automated key selection, and
167 enabling/disabling encryption and signing
168- OpenPGP key management interface
169
170%description addon-enigmail -l pl.UTF-8
c5e06599 171Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
172użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
173przez GnuPG.
44be9ed4 174
175Główne możliwości:
176- szyfrowanie/podpisywanie poczty przy wysyłaniu,
177 odszyfrowywanie/uwierzytelnianie poczty odebranej
178- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
179- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
180- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
181 podpisywania dla każdego adresata
182- interfejs do zarządzania kluczami OpenPGP
183
184%prep
983562b1 185%setup -qc
f4114a7f 186mv comm-release mozilla
983562b1 187%setup -q -T -D -a2
188cd mozilla
1c70899a 189%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 190/bin/sh %{SOURCE3}
983562b1 191%patch0 -p1
faa5c89d 192%{?with_enigmail:%patch1 -p1}
73d54cb2 193%{?with_xulrunner:%patch2 -p1}
4ccc2157 194%patch3 -p1
faa5c89d 195%patch4 -p1
983562b1 196%patch6 -p1
9a743685 197%patch7 -p1
f4114a7f 198%patch8 -p2
3815090b 199%patch9 -p1
ccc206fe 200%patch10 -p2
765a3a27 201%patch11 -p2
268e7766 202%patch12 -p1
44be9ed4 203
204%build
983562b1 205cd mozilla
cadfb931
SP
206cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
207cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 208cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 209
fbac75ca 210cat << EOF > .mozconfig
9e7875fc 211mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 212
fac7e24d 213export CFLAGS="%{rpmcflags}"
73d54cb2 214export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
215
216%if %{with crashreporter}
217export MOZ_DEBUG_SYMBOLS=1
218%endif
219
59c5a0e8 220# Options for 'configure' (same as command-line options).
44be9ed4 221ac_add_options --prefix=%{_prefix}
222ac_add_options --exec-prefix=%{_exec_prefix}
223ac_add_options --bindir=%{_bindir}
224ac_add_options --sbindir=%{_sbindir}
225ac_add_options --sysconfdir=%{_sysconfdir}
226ac_add_options --datadir=%{_datadir}
227ac_add_options --includedir=%{_includedir}
228ac_add_options --libdir=%{_libdir}
229ac_add_options --libexecdir=%{_libexecdir}
230ac_add_options --localstatedir=%{_localstatedir}
231ac_add_options --sharedstatedir=%{_sharedstatedir}
232ac_add_options --mandir=%{_mandir}
233ac_add_options --infodir=%{_infodir}
234%if %{?debug:1}0
59c5a0e8 235ac_add_options --disable-optimize
44be9ed4 236ac_add_options --enable-debug
237ac_add_options --enable-debug-modules
59c5a0e8
SP
238ac_add_options --enable-debugger-info-modules
239ac_add_options --enable-crash-on-assert
44be9ed4 240%else
241ac_add_options --disable-debug
242ac_add_options --disable-debug-modules
59c5a0e8
SP
243ac_add_options --disable-logging
244ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 245%endif
88149483
ER
246ac_add_options --disable-strip
247ac_add_options --disable-strip-libs
44be9ed4 248%if %{with tests}
249ac_add_options --enable-tests
250%else
251ac_add_options --disable-tests
252%endif
6458b220 253ac_add_options --enable-gio
44be9ed4 254%if %{with gnomeui}
255ac_add_options --enable-gnomeui
256%else
257ac_add_options --disable-gnomeui
258%endif
44be9ed4 259ac_add_options --disable-gnomevfs
44be9ed4 260%if %{with ldap}
261ac_add_options --enable-ldap
9a743685 262ac_add_options --with-system-ldap
44be9ed4 263%else
264ac_add_options --disable-ldap
265%endif
765a3a27
ER
266%if %{with crashreporter}
267ac_add_options --enable-crashreporter
268%else
59c5a0e8 269ac_add_options --disable-crashreporter
765a3a27 270%endif
59c5a0e8 271ac_add_options --disable-xterm-updates
59c5a0e8 272ac_add_options --enable-postscript
d076d93e 273%if %{with lightning}
cb0e4412 274ac_add_options --enable-calendar
d076d93e
SP
275%else
276ac_add_options --disable-calendar
277%endif
44be9ed4 278ac_add_options --disable-installer
88149483 279ac_add_options --disable-updater
44be9ed4 280ac_add_options --disable-xprint
cadfb931
SP
281ac_add_options --disable-permissions
282ac_add_options --disable-pref-extensions
44be9ed4 283ac_add_options --enable-canvas
284ac_add_options --enable-crypto
44be9ed4 285ac_add_options --enable-mathml
44be9ed4 286ac_add_options --enable-pango
287ac_add_options --enable-reorder
88149483
ER
288ac_add_options --enable-startup-notification
289ac_add_options --enable-svg
44be9ed4 290ac_add_options --enable-system-cairo
5e9bb798 291ac_add_options --enable-system-hunspell
7d981f69 292ac_add_options --enable-system-sqlite
44be9ed4 293ac_add_options --enable-xft
cadfb931
SP
294ac_add_options --enable-application=mail
295ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 296ac_add_options --enable-xinerama
88149483
ER
297ac_add_options --with-distribution-id=org.pld-linux
298ac_add_options --with-branding=icedove/branding
299%if %{with xulrunner}
fac7e24d
JB
300ac_add_options --enable-shared-js
301ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 302ac_add_options --with-system-libxul
88149483
ER
303%endif
304ac_add_options --with-pthreads
305ac_add_options --with-system-bz2
44be9ed4 306ac_add_options --with-system-jpeg
307ac_add_options --with-system-nspr
308ac_add_options --with-system-nss
309ac_add_options --with-system-png
310ac_add_options --with-system-zlib
44be9ed4 311ac_add_options --enable-single-profile
312ac_add_options --disable-profilesharing
44be9ed4 313ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
314EOF
315
90e998ba 316%{__make} -j1 -f client.mk build \
d076d93e 317 STRIP="/bin/true" \
765a3a27 318 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 319 CC="%{__cc}" \
44be9ed4 320 CXX="%{__cxx}"
321
765a3a27
ER
322%if %{with crashreporter}
323# create debuginfo for crash-stats.mozilla.com
324%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
325%endif
326
44be9ed4 327%if %{with enigmail}
59c5a0e8 328cd mailnews/extensions/enigmail
9e7875fc
ER
329./makemake -r -o %{objdir}
330%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
331 STRIP="/bin/true" \
332 CC="%{__cc}" \
333 CXX="%{__cxx}"
44be9ed4 334%endif
335
336%install
337rm -rf $RPM_BUILD_ROOT
765a3a27 338install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 339
9e7875fc 340cd %{objdir}
ecf04393 341%{__make} -C mail/installer stage-package \
44be9ed4 342 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 343 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 344 PKG_SKIP_STRIP=1
345
9b40a2c3
JB
346%if %{with xulrunner}
347# needed to find mozilla runtime
348ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
349%endif
350
351# Enable crash reporter for Thunderbird application
765a3a27
ER
352%if %{with crashreporter}
353%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
354
355# Add debuginfo for crash-stats.mozilla.com
51a3b6db 356install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
357cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
358%endif
359
ecf04393
ER
360# copy manually lightning files, somewhy they are not installed by make
361cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
362 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
363 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
364
44be9ed4 365# move arch independant ones to datadir
366mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
367mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 368mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 369mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
eca54e0f 370mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 371ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
372ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 373ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 374ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
eca54e0f 375ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
73d54cb2
JB
376%if %{without xulrunner}
377mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
378ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
379%endif
44be9ed4 380
c6ec3c1c
ER
381# dir for arch independant extensions besides arch dependant extensions
382# see mozilla/xpcom/build/nsXULAppAPI.h
383# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
73d54cb2 386%if %{without xulrunner}
63d8f5c3 387%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 388ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
e6bc19b3
ER
389%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
390ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
73d54cb2 391%endif
e6bc19b3 392
44be9ed4 393%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
394ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
395ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
396
52f5507d
ER
397cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
398cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 399
e8f4ba81 400# files created by regxpcom -register in post
52fc61e6
ER
401touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
402touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
403cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
404#!/bin/sh
405umask 022
406# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
407# dangerous if you run this with sudo with keep_env += HOME
408# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
409t=$(mktemp -d)
d50a2a28 410%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
411TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
412rm -rf $t
413EOF
414chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 415
44be9ed4 416%if %{with enigmail}
283702b9
ER
417ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
418install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 419cd mozilla/dist/bin
0516fc42 420#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
421#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
422cp -rfLp components/enig* $ext_dir/components
423cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 424cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
425cp -rfLp components/ipc.xpt $ext_dir/components
426cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
427cd -
52f5507d
ER
428cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
429cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 430%endif
431
9cdc8923
ER
432# never package these. always remove
433# nss
434%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
435# nspr
436%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 437# mozldap
9cdc8923 438%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
3815090b
ER
439# testpilot quiz
440%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
283702b9 441
44be9ed4 442%clean
443rm -rf $RPM_BUILD_ROOT
444
445%pretrans
446if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
447 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
448fi
eca54e0f 449for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 450 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
451 install -d %{_datadir}/%{name}
452 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
453 fi
454done
455exit 0
456
e8f4ba81
ER
457%post
458%{_libdir}/%{name}/register || :
459
44be9ed4 460%files
461%defattr(644,root,root,755)
462%attr(755,root,root) %{_bindir}/icedove
463%attr(755,root,root) %{_bindir}/mozilla-thunderbird
464%attr(755,root,root) %{_bindir}/thunderbird
465%dir %{_libdir}/%{name}
765a3a27 466%{_libdir}/%{name}/application.ini
6b327de6
JB
467%{_libdir}/%{name}/blocklist.xml
468%{_libdir}/%{name}/chrome.manifest
44be9ed4 469%dir %{_libdir}/%{name}/components
44be9ed4 470%{_libdir}/%{name}/components/*.js
471%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
472%{_libdir}/%{name}/components/components.manifest
473%{_libdir}/%{name}/components/interfaces.manifest
73d54cb2
JB
474%attr(755,root,root) %{_libdir}/%{name}/*.sh
475%attr(755,root,root) %{_libdir}/%{name}/*-bin
476%attr(755,root,root) %{_libdir}/%{name}/icedove
477%attr(755,root,root) %{_libdir}/%{name}/register
478%if %{without xulrunner}
479%{_libdir}/%{name}/platform.ini
480%{_libdir}/%{name}/greprefs.js
481%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 482%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 483%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 484%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 485%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 486%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 487%endif
44be9ed4 488
489# symlinks
490%{_libdir}/%{name}/chrome
491%{_libdir}/%{name}/defaults
44be9ed4 492%{_libdir}/%{name}/isp
9e097178 493%{_libdir}/%{name}/modules
eca54e0f 494%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
495%if %{with xulrunner}
496%{_libdir}/%{name}/xulrunner
497%else
73d54cb2
JB
498%{_libdir}/%{name}/dictionaries
499%{_libdir}/%{name}/hyphenation
500%{_libdir}/%{name}/res
501%endif
44be9ed4 502
224cf96a
JB
503%{_pixmapsdir}/icedove.png
504%{_desktopdir}/icedove.desktop
44be9ed4 505
506%dir %{_datadir}/%{name}
507%{_datadir}/%{name}/chrome
508%{_datadir}/%{name}/defaults
eca54e0f 509%{_datadir}/%{name}/extensions
44be9ed4 510%{_datadir}/%{name}/isp
9e097178 511%{_datadir}/%{name}/modules
eca54e0f 512%{_datadir}/%{name}/searchplugins
73d54cb2
JB
513%if %{without xulrunner}
514%{_datadir}/%{name}/res
515%endif
44be9ed4 516
765a3a27
ER
517%if %{with crashreporter}
518%attr(755,root,root) %{_libdir}/%{name}/crashreporter
519%{_libdir}/%{name}/crashreporter.ini
520%{_libdir}/%{name}/Throbber-small.gif
521%endif
522
44be9ed4 523%dir %{_libdir}/%{name}/extensions
524%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 525
52fc61e6
ER
526# files created by regxpcom -register
527%ghost %{_libdir}/%{name}/components/compreg.dat
528%ghost %{_libdir}/%{name}/components/xpti.dat
529
6578c165 530%if %{with lightning}
531%files addon-lightning
532%defattr(644,root,root,755)
f3b6d696 533%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 534%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
539%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
540%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
542%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
543%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
544%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
545%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
546%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 547%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
548%endif
44be9ed4 549
550%if %{with enigmail}
551%files addon-enigmail
552%defattr(644,root,root,755)
f6a43e2f
ER
553%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
555%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
556%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
557%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
558%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
559%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
560%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
561%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 562%endif
This page took 0.157414 seconds and 4 git commands to generate.