]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- Requires(post,postun): gtk-update-icon-cache
[packages/opera.git] / opera.spec
CommitLineData
a79ddb02
AM
1# BRANCHES:
2# - HEAD - stable version
3# - DEVEL - development version
083d2812
AM
4# - WEEKLY - weekly development version
5#
6# NOTE: to avoid creating unreadable/unmaintainable spec:
7# - don't put static version here, create STATIC branch for that for example
8# - don't create useless bconds that for example limit SourceX: to current arch only
9#
edbbe593 10
35920030 11%define ver 11.01
083d2812 12%define shver %(echo %{ver} | tr -d .)
35920030 13%define buildid 1190
5422068c 14
40d43d2d 15Summary: World fastest web browser
048a8afa 16Summary(hu.UTF-8): A világ leggyorsabb webböngészője
0580138e 17Summary(pl.UTF-8): Najszybsza przeglądarka WWW na świecie
40d43d2d 18Name: opera
37147bb6 19Version: %{ver}
ea04865f 20Release: 2
94132831 21Epoch: 2
ae712f51 22License: Distributable
40d43d2d 23Group: X11/Applications/Networking
f486f8e4 24Source10: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.xz
35920030 25# Source10-md5: 9614f1c8b1e7e71aeb398122db30bfed
f486f8e4 26Source11: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.xz
35920030 27# Source11-md5: 802e1725acddc713dffb3441815156b9
083d2812 28Source0: %{name}.desktop
35677f25 29Patch0: %{name}-wrapper.patch
25718300
AM
30Patch1: %{name}-desktop.patch
31Patch2: %{name}-pluginpath.patch
8cb331c2 32URL: http://www.opera.com/
55fc796b 33BuildRequires: rpm >= 4.4.9-56
f6dbdb8e 34BuildRequires: rpmbuild(macros) >= 1.356
6eebcb83 35BuildRequires: sed >= 4.0
f486f8e4 36BuildRequires: xz
ea04865f
AF
37Requires(post,postun): gtk-update-icon-cache
38Requires(post,postun): hicolor-icon-theme
f6dbdb8e 39Requires: browser-plugins >= 2.0
c33af227 40Requires: desktop-file-utils
2f4fa75a 41Requires: freetype >= 2
3b8cc5d5 42Provides: wwwbrowser
37147bb6 43Obsoletes: opera-i18n
083d2812 44ExclusiveArch: %{ix86} %{x8664} ppc
8cb331c2 45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1e3271ab 46
0539d577
AM
47%define _enable_debug_packages 0
48
fa79b8f2 49%define _plugindir %{_libdir}/opera/plugins
7e80713c 50%define _operadocdir %{_docdir}/%{name}-%{ver}
083d2812
AM
51# alternative arch for plugin32
52%define alt_arch i386
8cb331c2 53
54%description
55Opera is world fastest web browser. It supports most of nowaday
55fc796b
ER
56extensions of HTML. And it is quite stable. This version is linked
57with shared version of Qt.
8cb331c2 58
048a8afa
ZU
59%description -l hu.UTF-8
60Opera a világ leggyorsabb webböngészője. A manapság elterjedt
61HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
62Ez a verzió a Qt megosztott verziójához linkelődik.
63
14283174
JR
64%description -l pl.UTF-8
65Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
66dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
083d2812 67wersja jest skonsolidowana dynamicznie z Qt.
37147bb6
AM
68
69%package plugin32
70Summary: Opera 32-bit plugins support
048a8afa 71Summary(hu.UTF-8): Opera 32-bites plugin támogatás
37147bb6
AM
72Summary(pl.UTF-8): Obsługa 32-bitowych wtyczek Opery
73Group: X11/Applications/Networking
74Requires: %{name} = %{epoch}:%{version}-%{release}
083d2812 75Requires: browser-plugins >= 2.0
37147bb6
AM
76
77%description plugin32
78Opera 32-bit plugins support.
79
048a8afa
ZU
80%description plugin32 -l hu.UTF-8
81Opera 32-bites plugin támogatás.
82
37147bb6
AM
83%description plugin32 -l pl.UTF-8
84Obsługa 32-bitowych wtyczek Opery.
58d714bb 85
8cb331c2 86%prep
643785f9 87%ifarch %{ix86}
07d1040c 88%setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
e789f1d0 89%endif
07d1040c 90
083d2812 91%ifarch %{x8664}
07d1040c 92%setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
3009d733 93%endif
07d1040c 94
25718300
AM
95sed -i -e '
96 s,@@{PREFIX},%{_prefix},g
97 s,@@{SUFFIX},,
98 s,@@{_SUFFIX},,
99' share/{applications/*.desktop,mime/packages/*.xml}
100
101sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
102
35677f25 103%patch0 -p1
25718300
AM
104%patch1 -p1
105
106# remove lib32/lib64 paths so patch2 can apply (i386 build contained lib64 as well, oh well)
107%{__sed} -i -e '/lib32\|lib64/d;$d' share/opera/defaults/pluginpath.ini
108%patch2 -p1
109
110mv lib/opera/plugins/README README.plugins
111mv share/opera/defaults/license.txt .
112mv share/doc/opera/* .
113
114# nobody wants scalable huge icons
115rm -rf share/icons/hicolor/scalable
116
117# opera packaging tools we don't need runtime
118mv share/opera/package .
8cb331c2 119
120%install
121rm -rf $RPM_BUILD_ROOT
07d1040c 122install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
8cb331c2 123
f6dbdb8e
ER
124%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
125# opera does not use for .xpt files
126*.xpt
6ab3a1e1
ER
127
128# use mplayerplug-in-opera instead
129mplayerplug-in*
f6dbdb8e
ER
130EOF
131
07d1040c
AM
132install -p opera* $RPM_BUILD_ROOT%{_bindir}
133cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
134cp -a share/* $RPM_BUILD_ROOT%{_datadir}
25718300 135#cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
6239047a 136
07d1040c 137sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
72b0ae2b 138
0539d577
AM
139cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/operaprefs_default.ini
140[ISP]
141Id="DISTRO"
142EOF
143
201511be
AM
144%if "%{pld_release}" == "ti"
145sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
146%else
147%if "%{pld_release}" == "ac"
148sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
149%else
150sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
151%endif
152%endif
201511be 153
8cb331c2 154%clean
155rm -rf $RPM_BUILD_ROOT
156
f6dbdb8e 157%post
25718300
AM
158%update_mime_database
159%update_icon_cache hicolor
160%update_desktop_database_post
f6dbdb8e
ER
161%update_browser_plugins
162
163%postun
25718300
AM
164%update_mime_database
165%update_icon_cache hicolor
166%update_desktop_database_postun
f6dbdb8e
ER
167if [ "$1" = 0 ]; then
168 %update_browser_plugins
169fi
170
083d2812
AM
171%post plugin32
172%update_browser_plugins
173
174%postun plugin32
175if [ "$1" = 0 ]; then
176 %update_browser_plugins
177fi
178
8cb331c2 179%files
180%defattr(644,root,root,755)
c2ef0548 181%doc LICENSE
07d1040c 182#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
f6dbdb8e
ER
183
184# browser plugins v2
07d1040c
AM
185%{_browserpluginsconfdir}/browsers.d/%{name}.*
186%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
0539d577 187%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
07d1040c
AM
188%attr(755,root,root) %{_bindir}/opera
189%attr(755,root,root) %{_bindir}/opera-widget-manager
1e3271ab 190%dir %{_libdir}/opera
37147bb6 191%ifarch %{x8664}
07d1040c 192%exclude %{_libdir}/opera/*-ia32-*
37147bb6 193%endif
07d1040c
AM
194%attr(755,root,root) %{_libdir}/opera/*.so
195%attr(755,root,root) %{_libdir}/opera/opera*
1e3271ab 196%dir %{_plugindir}
07d1040c
AM
197%dir %{_libdir}/opera/gstreamer
198%dir %{_libdir}/opera/gstreamer/plugins
199%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
200%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
a5b49fac
KK
201%dir %{_datadir}/opera
202%{_datadir}/opera/*.*
628633e1
AM
203%{_datadir}/opera/defaults
204%{_datadir}/opera/extra
a5b49fac
KK
205%{_datadir}/opera/skin
206%{_datadir}/opera/styles
628633e1 207%{_datadir}/opera/ui
07d1040c 208%{_datadir}/opera/unite
f8b4ca83 209%dir %{_datadir}/opera/locale
210%{_datadir}/opera/locale/en
37147bb6
AM
211%lang(be) %{_datadir}/opera/locale/be
212%lang(bg) %{_datadir}/opera/locale/bg
213%lang(cs) %{_datadir}/opera/locale/cs
214%lang(da) %{_datadir}/opera/locale/da
215%lang(de) %{_datadir}/opera/locale/de
216%lang(el) %{_datadir}/opera/locale/el
217%lang(en_GB) %{_datadir}/opera/locale/en-GB
07d1040c 218%lang(es_ES) %{_datadir}/opera/locale/es-ES
37147bb6 219%lang(es_LA) %{_datadir}/opera/locale/es-LA
bd7f9e14 220%lang(et) %{_datadir}/opera/locale/et
37147bb6
AM
221%lang(fi) %{_datadir}/opera/locale/fi
222%lang(fr) %{_datadir}/opera/locale/fr
223%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
224%lang(fy) %{_datadir}/opera/locale/fy
225%lang(hi) %{_datadir}/opera/locale/hi
226%lang(hr) %{_datadir}/opera/locale/hr
227%lang(hu) %{_datadir}/opera/locale/hu
ff88e30e 228%lang(id) %{_datadir}/opera/locale/id
37147bb6
AM
229%lang(it) %{_datadir}/opera/locale/it
230%lang(ja) %{_datadir}/opera/locale/ja
231%lang(ka) %{_datadir}/opera/locale/ka
232%lang(ko) %{_datadir}/opera/locale/ko
233%lang(lt) %{_datadir}/opera/locale/lt
234%lang(mk) %{_datadir}/opera/locale/mk
235%lang(nb) %{_datadir}/opera/locale/nb
236%lang(nl) %{_datadir}/opera/locale/nl
237%lang(nn) %{_datadir}/opera/locale/nn
238%lang(pl) %{_datadir}/opera/locale/pl
239%lang(pt) %{_datadir}/opera/locale/pt
240%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
628633e1 241%lang(ro) %{_datadir}/opera/locale/ro
37147bb6 242%lang(ru) %{_datadir}/opera/locale/ru
628633e1
AM
243%lang(sk) %{_datadir}/opera/locale/sk
244%lang(sr) %{_datadir}/opera/locale/sr
37147bb6 245%lang(sv) %{_datadir}/opera/locale/sv
bd7f9e14
AM
246%lang(ta) %{_datadir}/opera/locale/ta
247%lang(te) %{_datadir}/opera/locale/te
37147bb6 248%lang(tr) %{_datadir}/opera/locale/tr
ff88e30e 249%lang(uk) %{_datadir}/opera/locale/uk
66f1ccb5 250%lang(vi) %{_datadir}/opera/locale/vi
37147bb6 251%lang(zh_CN) %{_datadir}/opera/locale/zh-cn
628633e1 252%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
37147bb6 253%lang(zh_TW) %{_datadir}/opera/locale/zh-tw
f8c10437 254%{_datadir}/mime/packages/opera-extension.xml
07d1040c
AM
255%{_datadir}/mime/packages/opera-widget.xml
256%{_datadir}/mime/packages/opera-unite-application.xml
7b1a5f81 257%{_desktopdir}/*.desktop
1e3271ab 258%{_mandir}/man1/opera.1*
07d1040c
AM
259%{_mandir}/man1/opera-widget-manager.1*
260%{_iconsdir}/hicolor/*/*/*.png
671735f8
AM
261
262%ifarch %{x8664}
263%files plugin32
264%defattr(644,root,root,755)
07d1040c 265%attr(755,root,root) %{_libdir}/opera/*-ia32-*
671735f8 266%endif
This page took 0.145632 seconds and 4 git commands to generate.