]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- release 3
[packages/opera.git] / opera.spec
CommitLineData
a79ddb02
AM
1# BRANCHES:
2# - HEAD - stable version
3# - DEVEL - development version
4# - WEEKLY - weekly development version
6239047a 5#
37147bb6
AM
6# NOTE, to avoid creating unreadable/unmaintainable spec:
7# - don't put static version here, create STATIC branch for that for example
8# - don't create useless bconds that for example limit SourceX: to current arch only
9#
10#
11%define ver 9.50
12%define shver %(echo %{ver} | tr -d .)
13%define buildid 2042
14#
40d43d2d 15Summary: World fastest web browser
0580138e 16Summary(pl.UTF-8): Najszybsza przeglądarka WWW na świecie
40d43d2d 17Name: opera
37147bb6 18Version: %{ver}
c54f07a2 19Release: 3
94132831 20Epoch: 2
ae712f51 21License: Distributable
40d43d2d 22Group: X11/Applications/Networking
37147bb6
AM
23Source10: ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/i386/shared/%{name}-%{version}.gcc4-shared-qt3.i386.tar.bz2
24# Source10-md5: 34392767b4e1e233c682600d563d659f
25Source11: ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/x86_64/%{name}-%{version}.gcc4-shared-qt3.x86_64.tar.bz2
26# Source11-md5: 091ed5b0f8a7541c7555744defca7a6c
27Source12: ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/ppc/shared/%{name}-%{version}.gcc4-shared-qt3.ppc.tar.bz2
28# Source12-md5: c1b01ac1051c52a433514c3545bacac0
5949283a 29
2dbc1636 30Source4: %{name}.desktop
35677f25 31Patch0: %{name}-wrapper.patch
8cb331c2 32URL: http://www.opera.com/
f6dbdb8e 33BuildRequires: rpmbuild(macros) >= 1.356
6eebcb83 34BuildRequires: sed >= 4.0
f6dbdb8e 35Requires: browser-plugins >= 2.0
2f4fa75a 36Requires: freetype >= 2
3b8cc5d5 37Provides: wwwbrowser
37147bb6
AM
38Obsoletes: opera-i18n
39ExclusiveArch: %{ix86} %{x8664} ppc
8cb331c2 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1e3271ab 41
fa79b8f2 42%define _plugindir %{_libdir}/opera/plugins
7e80713c 43%define _operadocdir %{_docdir}/%{name}-%{ver}
8cb331c2 44
45%description
46Opera is world fastest web browser. It supports most of nowaday
37147bb6
AM
47extensions of HTML. And it is quite stable. This version is
48%{?with_shared:shared}%{!?with_shared:statically} linked with Qt.
8cb331c2 49
14283174
JR
50%description -l pl.UTF-8
51Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
52dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
37147bb6
AM
53wersja jest skonsolidowana
54%{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
55
56%package plugin32
57Summary: Opera 32-bit plugins support
58Summary(pl.UTF-8): Obsługa 32-bitowych wtyczek Opery
59Group: X11/Applications/Networking
60Requires: %{name} = %{epoch}:%{version}-%{release}
61
62%description plugin32
63Opera 32-bit plugins support.
64
65%description plugin32 -l pl.UTF-8
66Obsługa 32-bitowych wtyczek Opery.
58d714bb 67
8cb331c2 68%prep
643785f9 69%ifarch %{ix86}
37147bb6 70%setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.i386
2d8d939d 71%endif
37147bb6
AM
72%ifarch %{x8664}
73%setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.x86_64
643785f9 74%endif
195ff7d0 75%ifarch ppc
37147bb6 76%setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.ppc
b966c84f 77%endif
35677f25 78%patch0 -p1
8cb331c2 79
80%install
81rm -rf $RPM_BUILD_ROOT
54d2851e 82install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
8cb331c2 83
f6dbdb8e
ER
84%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
85# opera does not use for .xpt files
86*.xpt
6ab3a1e1
ER
87
88# use mplayerplug-in-opera instead
89mplayerplug-in*
929e48ab
ER
90
91# opera uses libjava.so to run java
92libjavaplugin_oji.so
f6dbdb8e
ER
93EOF
94
51e47e74 95sh install.sh \
7e80713c
KK
96 DESTDIR=$RPM_BUILD_ROOT \
97 --prefix=%{_prefix} \
2d8d939d
ER
98 --exec_prefix=%{_libdir}/%{name}/bin \
99 --plugindir=%{_libdir}/%{name}/plugins \
7e80713c 100 --docdir=%{_operadocdir}
6239047a 101
51e47e74 102# install in kde etc.
7b1a5f81 103install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
a8029af7 104
37147bb6
AM
105install etc/* $RPM_BUILD_ROOT%{_sysconfdir}
106install usr/share/pixmaps/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
72b0ae2b 107
8cb331c2 108%clean
109rm -rf $RPM_BUILD_ROOT
110
f6dbdb8e
ER
111%post
112%update_browser_plugins
113
114%postun
115if [ "$1" = 0 ]; then
116 %update_browser_plugins
117fi
118
8cb331c2 119%files
120%defattr(644,root,root,755)
c2ef0548 121%doc LICENSE
54d2851e 122%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
f6dbdb8e
ER
123
124# browser plugins v2
125%{_browserpluginsconfdir}/browsers.d/%{name}.*
126%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
127
1cfa2d1b 128%attr(755,root,root) %{_bindir}/*
1e3271ab 129%dir %{_libdir}/opera
98c525bc
AM
130%dir %{_libdir}/opera/bin
131%attr(755,root,root) %{_libdir}/opera/bin/*
37147bb6
AM
132%ifarch %{x8664}
133%exclude %{_libdir}/opera/bin/*-ia32-*
134%endif
1e3271ab 135%dir %{_plugindir}
a5b49fac
KK
136%dir %{_datadir}/opera
137%{_datadir}/opera/*.*
a5b49fac
KK
138%{_datadir}/opera/ini
139%{_datadir}/opera/java
140%{_datadir}/opera/skin
141%{_datadir}/opera/styles
f8b4ca83 142%dir %{_datadir}/opera/locale
143%{_datadir}/opera/locale/en
a6bb5241 144%{_datadir}/opera/locale/english.lng
37147bb6
AM
145%lang(be) %{_datadir}/opera/locale/be
146%lang(bg) %{_datadir}/opera/locale/bg
147%lang(cs) %{_datadir}/opera/locale/cs
148%lang(da) %{_datadir}/opera/locale/da
149%lang(de) %{_datadir}/opera/locale/de
150%lang(el) %{_datadir}/opera/locale/el
151%lang(en_GB) %{_datadir}/opera/locale/en-GB
152%lang(es_ES) %{_datadir}/opera/locale/es-ES
153%lang(es_LA) %{_datadir}/opera/locale/es-LA
154%lang(fi) %{_datadir}/opera/locale/fi
155%lang(fr) %{_datadir}/opera/locale/fr
156%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
157%lang(fy) %{_datadir}/opera/locale/fy
158%lang(hi) %{_datadir}/opera/locale/hi
159%lang(hr) %{_datadir}/opera/locale/hr
160%lang(hu) %{_datadir}/opera/locale/hu
161%lang(it) %{_datadir}/opera/locale/it
162%lang(ja) %{_datadir}/opera/locale/ja
163%lang(ka) %{_datadir}/opera/locale/ka
164%lang(ko) %{_datadir}/opera/locale/ko
165%lang(lt) %{_datadir}/opera/locale/lt
166%lang(mk) %{_datadir}/opera/locale/mk
167%lang(nb) %{_datadir}/opera/locale/nb
168%lang(nl) %{_datadir}/opera/locale/nl
169%lang(nn) %{_datadir}/opera/locale/nn
170%lang(pl) %{_datadir}/opera/locale/pl
171%lang(pt) %{_datadir}/opera/locale/pt
172%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
173%lang(ru) %{_datadir}/opera/locale/ru
174%lang(sv) %{_datadir}/opera/locale/sv
175%lang(tr) %{_datadir}/opera/locale/tr
176%lang(zh_CN) %{_datadir}/opera/locale/zh-cn
177%lang(zh_TW) %{_datadir}/opera/locale/zh-tw
7b1a5f81 178%{_desktopdir}/*.desktop
1e3271ab 179%{_mandir}/man1/opera.1*
7e80713c 180%{_pixmapsdir}/opera.xpm
671735f8
AM
181
182%ifarch %{x8664}
183%files plugin32
184%defattr(644,root,root,755)
185%attr(755,root,root) %{_libdir}/opera/bin/*-ia32-*
186%endif
This page took 0.191935 seconds and 4 git commands to generate.