]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- up to build 557
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
7f13a385 8%bcond_with weekly # weekly snapshot version
09f2d772 9
1b3f992f 10%ifarch sparc64 sparc
08bc83d7 11%undefine with_shared
1b3f992f 12%endif
13
7f13a385 14%if %{with weekly}
37e8381c 15%define ver 9.20
7f13a385
KK
16%define sver %{ver}
17%define fix %{nil}
37e8381c
AM
18%define dirrel 20070202
19%define magicstr 557
7f13a385
KK
20%define with_snap 1
21%else
e56cf118 22%if %{with snap}
b28972ca 23%define ver 9.0
7ad274ec 24%define sver %{ver}
6fe34fc1 25%define fix %{nil}
3a879908
AM
26%define dirrel 20060206
27%define reltype Preview-2
b28972ca 28%define magicstr %{nil}
e56cf118 29%else
9ce6f870
AM
30%define ver 9.10
31%define sver 9.10
94132831 32%define fix %{nil}
9ce6f870 33%define dirrel 20061214
6f7271b8 34%define reltype final
9ce6f870 35%define magicstr 521
e56cf118 36%endif
7f13a385 37%endif
e56cf118 38
6fe34fc1 39%define shver %(echo %{ver} | tr -d .)%{fix}
9b787f15 40%define x86_shared_rel %{dirrel}.5
655debcb 41%define x86_static_rel %{dirrel}.1
42%define sparc_shared_rel %{dirrel}.2
43%define sparc_static_rel %{dirrel}.1
a8b8cbf5 44%define ppc_shared_rel %{dirrel}.3
655debcb 45%define ppc_static_rel %{dirrel}.1
09f2d772 46%if %{with shared}
655debcb 47%define type shared
0d0211ae 48# We should be able to build src.rpm also on not supported archs
655debcb 49%define rel %{x86_shared_rel}
7edc0e0c 50%ifarch sparc64 sparc
a034ff51 51#%%define rel %{sparc_shared_rel}
52%define rel %{sparc_static_rel}
7edc0e0c
AM
53%endif
54%ifarch ppc
655debcb 55%define rel %{ppc_shared_rel}
7edc0e0c 56%endif
09f2d772 57%else
655debcb 58%define type static
655debcb 59%define rel %{x86_static_rel}
7edc0e0c 60%ifarch sparc sparc64
655debcb 61%define rel %{sparc_static_rel}
7edc0e0c
AM
62%endif
63%ifarch ppc
655debcb 64%define rel %{ppc_static_rel}
09f2d772 65%endif
7edc0e0c 66%endif
2dbc1636 67
b6dbc9f6
AM
68# define to 0 and then redefine to avoid
69# not defined macros
cbb8dbd3 70%define need_ix86_shared_snap 0
71%define need_sparc_shared_snap 0
72%define need_ppc_shared_snap 0
73%define need_ix86_static_snap 0
74%define need_sparc_static_snap 0
75%define need_ppc_static_snap 0
b6dbc9f6 76
cbb8dbd3 77%define need_ix86_shared 0
78%define need_sparc_shared 0
79%define need_ppc_shared 0
80%define need_ix86_static 0
81%define need_sparc_static 0
82%define need_ppc_static 0
b6dbc9f6 83
40d43d2d 84%if %{with incall}
85# with incall? [if]
86%if %{with snap}
87# with snap? [if]
88%if %{with shared}
89# with shared? [if]
90%define need_ix86_shared_snap 1
b28972ca 91%define need_sparc_shared_snap 0
40d43d2d 92%define need_ppc_shared_snap 1
042a9712 93%else
40d43d2d 94# with shared: [else]
95%define need_ix86_static_snap 1
7f13a385 96%define need_sparc_static_snap 1
40d43d2d 97%define need_ppc_static_snap 1
042a9712 98%endif
40d43d2d 99# with shared; [endif]
100%else
101# with snap: [else]
102%if %{with shared}
103# with shared? [if]
104%define need_ix86_shared 1
a034ff51 105#%%define need_sparc_shared 1
106%define need_sparc_static 1
40d43d2d 107%define need_ppc_shared 1
108%else
109# with shared: [else]
110%define need_ix86_static 1
cbb8dbd3 111%define need_sparc_static 1
40d43d2d 112%define need_ppc_static 1
2dbc1636 113%endif
40d43d2d 114# with shared; [endif]
ec0c336f 115%endif
40d43d2d 116# with snap; [endif]
117%else
118# with incall: [else]
119%ifarch %{ix86}
120# is ix86? [if]
121%if %{with snap}
122# with snap? [if]
123%if %{with shared}
124# with shared? [if]
125%define need_ix86_shared_snap 1
042a9712 126%else
40d43d2d 127# with shared: [else]
128%define need_ix86_static_snap 1
042a9712 129%endif
40d43d2d 130# with shared; [endif]
131%else
132# with snap: [else]
133%if %{with shared}
134# with shared? [if]
135%define need_ix86_shared 1
136%else
137# with shared: [else]
138%define need_ix86_static 1
2dbc1636 139%endif
40d43d2d 140# with shared; [endif]
ec0c336f 141%endif
40d43d2d 142# with snap; [endif]
143%endif
144# is ix86; [endif]
145%ifarch sparc sparc64
146# is sparc? [if]
147%if %{with snap}
148# with snap? [if]
149%if %{with shared}
150# with shared? [if]
151%define need_sparc_shared_snap 1
042a9712 152%else
40d43d2d 153# with shared: [else]
154%define need_sparc_static_snap 1
2dbc1636 155%endif
40d43d2d 156# with shared; [endif]
2dbc1636 157%else
40d43d2d 158# with snap: [else]
159%if %{with shared}
160# with shared? [if]
a034ff51 161#%%define need_sparc_shared 1
162%define need_sparc_static 1
042a9712 163%else
40d43d2d 164# with shared: [else]
165%define need_sparc_static 1
042a9712 166%endif
40d43d2d 167# with shared; [endif]
2dbc1636 168%endif
40d43d2d 169# with snap; [endif]
ec0c336f 170%endif
40d43d2d 171# is sparc; [endif]
172%ifarch ppc
173# is ppc? [if]
174%if %{with snap}
175# with snap? [if]
176%if %{with shared}
177# with shared? [if]
178%define need_ppc_shared_snap 1
042a9712 179%else
40d43d2d 180# with shared: [else]
181%define need_ppc_static_snap 1
042a9712 182%endif
40d43d2d 183# with shared; [endif]
184%else
185# with snap: [else]
186%if %{with shared}
187# with shared? [if]
188%define need_ppc_shared 1
189%else
190# with shared: [else]
191%define need_ppc_static 1
2dbc1636 192%endif
40d43d2d 193# with shared; [endif
ec0c336f 194%endif
40d43d2d 195# with snap; [endif
2dbc1636 196%endif
40d43d2d 197# is ppc; [endif]
2dbc1636 198%endif
40d43d2d 199# with incall; [endif]
200
054eb516
AM
201%if %{with weekly}
202%define need_ppc_shared_snap 0
203%define need_ppc_static_snap 0
204%define need_sparc_shared_snap 0
205%define need_sparc_static_snap 0
206%endif
207
f6dbdb8e 208%define _rel 4
40d43d2d 209Summary: World fastest web browser
210