]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- beta3
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
09f2d772 8
e56cf118 9%if %{with snap}
eca4b8ed 10%define ver 7.60
7ad274ec 11%define sver %{ver}
6fe34fc1 12%define fix %{nil}
0d67d240
AM
13%define dirrel 20041203
14%define reltype Preview-4
e56cf118 15%else
7ad274ec
AM
16%define ver 8.00
17%define sver 8.0
e4c6f6fd
AM
18%define fix b3
19%define dirrel 20050316
7ad274ec 20%define reltype beta
e56cf118
AM
21%endif
22
6fe34fc1
AM
23%define shver %(echo %{ver} | tr -d .)%{fix}
24%define x86_shared_rel %{dirrel}.4
655debcb 25%define x86_static_rel %{dirrel}.1
26%define sparc_shared_rel %{dirrel}.2
27%define sparc_static_rel %{dirrel}.1
a8b8cbf5 28%define ppc_shared_rel %{dirrel}.3
655debcb 29%define ppc_static_rel %{dirrel}.1
09f2d772 30%if %{with shared}
655debcb 31%define type shared
0d0211ae 32# We should be able to build src.rpm also on not supported archs
655debcb 33%define rel %{x86_shared_rel}
7edc0e0c 34%ifarch sparc64 sparc
655debcb 35%define rel %{sparc_shared_rel}
7edc0e0c
AM
36%endif
37%ifarch ppc
655debcb 38%define rel %{ppc_shared_rel}
7edc0e0c 39%endif
09f2d772 40%else
655debcb 41%define type static
655debcb 42%define rel %{x86_static_rel}
7edc0e0c 43%ifarch sparc sparc64
655debcb 44%define rel %{sparc_static_rel}
7edc0e0c
AM
45%endif
46%ifarch ppc
655debcb 47%define rel %{ppc_static_rel}
09f2d772 48%endif
7edc0e0c 49%endif
2dbc1636 50
b6dbc9f6
AM
51# define to 0 and then redefine to avoid
52# not defined macros
cbb8dbd3 53%define need_ix86_shared_snap 0
54%define need_sparc_shared_snap 0
55%define need_ppc_shared_snap 0
56%define need_ix86_static_snap 0
57%define need_sparc_static_snap 0
58%define need_ppc_static_snap 0
b6dbc9f6 59
cbb8dbd3 60%define need_ix86_shared 0
61%define need_sparc_shared 0
62%define need_ppc_shared 0
63%define need_ix86_static 0
64%define need_sparc_static 0
65%define need_ppc_static 0
b6dbc9f6 66
40d43d2d 67%if %{with incall}
68# with incall? [if]
69%if %{with snap}
70# with snap? [if]
71%if %{with shared}
72# with shared? [if]
73%define need_ix86_shared_snap 1
cbb8dbd3 74%define need_sparc_shared_snap 1
40d43d2d 75%define need_ppc_shared_snap 1
042a9712 76%else
40d43d2d 77# with shared: [else]
78%define need_ix86_static_snap 1
cbb8dbd3 79%define need_sparc_static_snap 1
40d43d2d 80%define need_ppc_static_snap 1
042a9712 81%endif
40d43d2d 82# with shared; [endif]
83%else
84# with snap: [else]
85%if %{with shared}
86# with shared? [if]
87%define need_ix86_shared 1
cbb8dbd3 88%define need_sparc_shared 1
40d43d2d 89%define need_ppc_shared 1
90%else
91# with shared: [else]
92%define need_ix86_static 1
cbb8dbd3 93%define need_sparc_static 1
40d43d2d 94%define need_ppc_static 1
2dbc1636 95%endif
40d43d2d 96# with shared; [endif]
ec0c336f 97%endif
40d43d2d 98# with snap; [endif]
99%else
100# with incall: [else]
101%ifarch %{ix86}
102# is ix86? [if]
103%if %{with snap}
104# with snap? [if]
105%if %{with shared}
106# with shared? [if]
107%define need_ix86_shared_snap 1
042a9712 108%else
40d43d2d 109# with shared: [else]
110%define need_ix86_static_snap 1
042a9712 111%endif
40d43d2d 112# with shared; [endif]
113%else
114# with snap: [else]
115%if %{with shared}
116# with shared? [if]
117%define need_ix86_shared 1
118%else
119# with shared: [else]
120%define need_ix86_static 1
2dbc1636 121%endif
40d43d2d 122# with shared; [endif]
ec0c336f 123%endif
40d43d2d 124# with snap; [endif]
125%endif
126# is ix86; [endif]
127%ifarch sparc sparc64
128# is sparc? [if]
129%if %{with snap}
130# with snap? [if]
131%if %{with shared}
132# with shared? [if]
133%define need_sparc_shared_snap 1
042a9712 134%else
40d43d2d 135# with shared: [else]
136%define need_sparc_static_snap 1
2dbc1636 137%endif
40d43d2d 138# with shared; [endif]
2dbc1636 139%else
40d43d2d 140# with snap: [else]
141%if %{with shared}
142# with shared? [if]
143%define need_sparc_shared 1
042a9712 144%else
40d43d2d 145# with shared: [else]
146%define need_sparc_static 1
042a9712 147%endif
40d43d2d 148# with shared; [endif]
2dbc1636 149%endif
40d43d2d 150# with snap; [endif]
ec0c336f 151%endif
40d43d2d 152# is sparc; [endif]
153%ifarch ppc
154# is ppc? [if]
155%if %{with snap}
156# with snap? [if]
157%if %{with shared}
158# with shared? [if]
159%define need_ppc_shared_snap 1
042a9712 160%else
40d43d2d 161# with shared: [else]
162%define need_ppc_static_snap 1
042a9712 163%endif
40d43d2d 164# with shared; [endif]
165%else
166# with snap: [else]
167%if %{with shared}
168# with shared? [if]
169%define need_ppc_shared 1
170%else
171# with shared: [else]
172%define need_ppc_static 1
2dbc1636 173%endif
40d43d2d 174# with shared; [endif
ec0c336f 175%endif
40d43d2d 176# with snap; [endif
2dbc1636 177%endif
40d43d2d 178# is ppc; [endif]
2dbc1636 179%endif
40d43d2d 180# with incall; [endif]
181
182Summary: World fastest web browser
183