]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- weekly needs different numbers dear charles, otherwise no md5 can be updated
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
7f13a385 8%bcond_with weekly # weekly snapshot version
09f2d772 9
1b3f992f 10%ifarch sparc64 sparc
08bc83d7 11%undefine with_shared
1b3f992f 12%endif
13
7f13a385
KK
14%if %{with weekly}
15%define ver 9.0
16%define sver %{ver}
17%define fix %{nil}
d6e41d46
AM
18%define dirrel 20060224
19%define magicstr 1670
7f13a385
KK
20%define with_snap 1
21%else
e56cf118 22%if %{with snap}
b28972ca 23%define ver 9.0
7ad274ec 24%define sver %{ver}
6fe34fc1 25%define fix %{nil}
3a879908
AM
26%define dirrel 20060206
27%define reltype Preview-2
b28972ca 28%define magicstr %{nil}
e56cf118 29%else
f082e35c
AM
30%define ver 8.52
31%define sver 8.52
94132831 32%define fix %{nil}
f082e35c 33%define dirrel 20060201
94132831 34%define reltype final
e56cf118 35%endif
7f13a385 36%endif
e56cf118 37
6fe34fc1 38%define shver %(echo %{ver} | tr -d .)%{fix}
9b787f15 39%define x86_shared_rel %{dirrel}.5
655debcb 40%define x86_static_rel %{dirrel}.1
41%define sparc_shared_rel %{dirrel}.2
42%define sparc_static_rel %{dirrel}.1
a8b8cbf5 43%define ppc_shared_rel %{dirrel}.3
655debcb 44%define ppc_static_rel %{dirrel}.1
09f2d772 45%if %{with shared}
655debcb 46%define type shared
0d0211ae 47# We should be able to build src.rpm also on not supported archs
655debcb 48%define rel %{x86_shared_rel}
7edc0e0c 49%ifarch sparc64 sparc
a034ff51 50#%%define rel %{sparc_shared_rel}
51%define rel %{sparc_static_rel}
7edc0e0c
AM
52%endif
53%ifarch ppc
655debcb 54%define rel %{ppc_shared_rel}
7edc0e0c 55%endif
09f2d772 56%else
655debcb 57%define type static
655debcb 58%define rel %{x86_static_rel}
7edc0e0c 59%ifarch sparc sparc64
655debcb 60%define rel %{sparc_static_rel}
7edc0e0c
AM
61%endif
62%ifarch ppc
655debcb 63%define rel %{ppc_static_rel}
09f2d772 64%endif
7edc0e0c 65%endif
2dbc1636 66
b6dbc9f6
AM
67# define to 0 and then redefine to avoid
68# not defined macros
cbb8dbd3 69%define need_ix86_shared_snap 0
70%define need_sparc_shared_snap 0
71%define need_ppc_shared_snap 0
72%define need_ix86_static_snap 0
73%define need_sparc_static_snap 0
74%define need_ppc_static_snap 0
b6dbc9f6 75
cbb8dbd3 76%define need_ix86_shared 0
77%define need_sparc_shared 0
78%define need_ppc_shared 0
79%define need_ix86_static 0
80%define need_sparc_static 0
81%define need_ppc_static 0
b6dbc9f6 82
40d43d2d 83%if %{with incall}
84# with incall? [if]
85%if %{with snap}
86# with snap? [if]
87%if %{with shared}
88# with shared? [if]
89%define need_ix86_shared_snap 1
b28972ca 90%define need_sparc_shared_snap 0
40d43d2d 91%define need_ppc_shared_snap 1
042a9712 92%else
40d43d2d 93# with shared: [else]
94%define need_ix86_static_snap 1
7f13a385 95%define need_sparc_static_snap 1
40d43d2d 96%define need_ppc_static_snap 1
042a9712 97%endif
40d43d2d 98# with shared; [endif]
99%else
100# with snap: [else]
101%if %{with shared}
102# with shared? [if]
103%define need_ix86_shared 1
a034ff51 104#%%define need_sparc_shared 1
105%define need_sparc_static 1
40d43d2d 106%define need_ppc_shared 1
107%else
108# with shared: [else]
109%define need_ix86_static 1
cbb8dbd3 110%define need_sparc_static 1
40d43d2d 111%define need_ppc_static 1
2dbc1636 112%endif
40d43d2d 113# with shared; [endif]
ec0c336f 114%endif
40d43d2d 115# with snap; [endif]
116%else
117# with incall: [else]
118%ifarch %{ix86}
119# is ix86? [if]
120%if %{with snap}
121# with snap? [if]
122%if %{with shared}
123# with shared? [if]
124%define need_ix86_shared_snap 1
042a9712 125%else
40d43d2d 126# with shared: [else]
127%define need_ix86_static_snap 1
042a9712 128%endif
40d43d2d 129# with shared; [endif]
130%else
131# with snap: [else]
132%if %{with shared}
133# with shared? [if]
134%define need_ix86_shared 1
135%else
136# with shared: [else]
137%define need_ix86_static 1
2dbc1636 138%endif
40d43d2d 139# with shared; [endif]
ec0c336f 140%endif
40d43d2d 141# with snap; [endif]
142%endif
143# is ix86; [endif]
144%ifarch sparc sparc64
145# is sparc? [if]
146%if %{with snap}
147# with snap? [if]
148%if %{with shared}
149# with shared? [if]
150%define need_sparc_shared_snap 1
042a9712 151%else
40d43d2d 152# with shared: [else]
153%define need_sparc_static_snap 1
2dbc1636 154%endif
40d43d2d 155# with shared; [endif]
2dbc1636 156%else
40d43d2d 157# with snap: [else]
158%if %{with shared}
159# with shared? [if]
a034ff51 160#%%define need_sparc_shared 1
161%define need_sparc_static 1
042a9712 162%else
40d43d2d 163# with shared: [else]
164%define need_sparc_static 1
042a9712 165%endif
40d43d2d 166# with shared; [endif]
2dbc1636 167%endif
40d43d2d 168# with snap; [endif]
ec0c336f 169%endif
40d43d2d 170# is sparc; [endif]
171%ifarch ppc
172# is ppc? [if]
173%if %{with snap}
174# with snap? [if]
175%if %{with shared}
176# with shared? [if]
177%define need_ppc_shared_snap 1
042a9712 178%else
40d43d2d 179# with shared: [else]
180%define need_ppc_static_snap 1
042a9712 181%endif
40d43d2d 182# with shared; [endif]
183%else
184# with snap: [else]
185%if %{with shared}
186# with shared? [if]
187%define need_ppc_shared 1
188%else
189# with shared: [else]
190%define need_ppc_static 1
2dbc1636 191%endif
40d43d2d 192# with shared; [endif
ec0c336f 193%endif
40d43d2d 194# with snap; [endif
2dbc1636 195%endif
40d43d2d 196# is ppc; [endif]
2dbc1636 197%endif
40d43d2d 198# with incall; [endif]
199
200Summary: World fastest web browser
201