]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- updated to 8.51 final
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
09f2d772 8
1b3f992f 9%ifarch sparc64 sparc
08bc83d7 10%undefine with_shared
1b3f992f 11%endif
12
e56cf118 13%if %{with snap}
b28972ca 14%define ver 9.0
7ad274ec 15%define sver %{ver}
6fe34fc1 16%define fix %{nil}
b28972ca
AM
17%define dirrel 20051020
18%define reltype Preview-1
19%define magicstr %{nil}
e56cf118 20%else
a0dc0cac
KK
21%define ver 8.51
22%define sver 8.51
94132831 23%define fix %{nil}
a0dc0cac 24%define dirrel 20051114
94132831 25%define reltype final
e56cf118
AM
26%endif
27
6fe34fc1 28%define shver %(echo %{ver} | tr -d .)%{fix}
9b787f15 29%define x86_shared_rel %{dirrel}.5
655debcb 30%define x86_static_rel %{dirrel}.1
31%define sparc_shared_rel %{dirrel}.2
32%define sparc_static_rel %{dirrel}.1
a8b8cbf5 33%define ppc_shared_rel %{dirrel}.3
655debcb 34%define ppc_static_rel %{dirrel}.1
09f2d772 35%if %{with shared}
655debcb 36%define type shared
0d0211ae 37# We should be able to build src.rpm also on not supported archs
655debcb 38%define rel %{x86_shared_rel}
7edc0e0c 39%ifarch sparc64 sparc
a034ff51 40#%%define rel %{sparc_shared_rel}
41%define rel %{sparc_static_rel}
7edc0e0c
AM
42%endif
43%ifarch ppc
655debcb 44%define rel %{ppc_shared_rel}
7edc0e0c 45%endif
09f2d772 46%else
655debcb 47%define type static
655debcb 48%define rel %{x86_static_rel}
7edc0e0c 49%ifarch sparc sparc64
655debcb 50%define rel %{sparc_static_rel}
7edc0e0c
AM
51%endif
52%ifarch ppc
655debcb 53%define rel %{ppc_static_rel}
09f2d772 54%endif
7edc0e0c 55%endif
2dbc1636 56
b6dbc9f6
AM
57# define to 0 and then redefine to avoid
58# not defined macros
cbb8dbd3 59%define need_ix86_shared_snap 0
60%define need_sparc_shared_snap 0
61%define need_ppc_shared_snap 0
62%define need_ix86_static_snap 0
63%define need_sparc_static_snap 0
64%define need_ppc_static_snap 0
b6dbc9f6 65
cbb8dbd3 66%define need_ix86_shared 0
67%define need_sparc_shared 0
68%define need_ppc_shared 0
69%define need_ix86_static 0
70%define need_sparc_static 0
71%define need_ppc_static 0
b6dbc9f6 72
40d43d2d 73%if %{with incall}
74# with incall? [if]
75%if %{with snap}
76# with snap? [if]
77%if %{with shared}
78# with shared? [if]
79%define need_ix86_shared_snap 1
b28972ca 80%define need_sparc_shared_snap 0
40d43d2d 81%define need_ppc_shared_snap 1
042a9712 82%else
40d43d2d 83# with shared: [else]
84%define need_ix86_static_snap 1
b28972ca 85%define need_sparc_static_snap 0
40d43d2d 86%define need_ppc_static_snap 1
042a9712 87%endif
40d43d2d 88# with shared; [endif]
89%else
90# with snap: [else]
91%if %{with shared}
92# with shared? [if]
93%define need_ix86_shared 1
a034ff51 94#%%define need_sparc_shared 1
95%define need_sparc_static 1
40d43d2d 96%define need_ppc_shared 1
97%else
98# with shared: [else]
99%define need_ix86_static 1
cbb8dbd3 100%define need_sparc_static 1
40d43d2d 101%define need_ppc_static 1
2dbc1636 102%endif
40d43d2d 103# with shared; [endif]
ec0c336f 104%endif
40d43d2d 105# with snap; [endif]
106%else
107# with incall: [else]
108%ifarch %{ix86}
109# is ix86? [if]
110%if %{with snap}
111# with snap? [if]
112%if %{with shared}
113# with shared? [if]
114%define need_ix86_shared_snap 1
042a9712 115%else
40d43d2d 116# with shared: [else]
117%define need_ix86_static_snap 1
042a9712 118%endif
40d43d2d 119# with shared; [endif]
120%else
121# with snap: [else]
122%if %{with shared}
123# with shared? [if]
124%define need_ix86_shared 1
125%else
126# with shared: [else]
127%define need_ix86_static 1
2dbc1636 128%endif
40d43d2d 129# with shared; [endif]
ec0c336f 130%endif
40d43d2d 131# with snap; [endif]
132%endif
133# is ix86; [endif]
134%ifarch sparc sparc64
135# is sparc? [if]
136%if %{with snap}
137# with snap? [if]
138%if %{with shared}
139# with shared? [if]
140%define need_sparc_shared_snap 1
042a9712 141%else
40d43d2d 142# with shared: [else]
143%define need_sparc_static_snap 1
2dbc1636 144%endif
40d43d2d 145# with shared; [endif]
2dbc1636 146%else
40d43d2d 147# with snap: [else]
148%if %{with shared}
149# with shared? [if]
a034ff51 150#%%define need_sparc_shared 1
151%define need_sparc_static 1
042a9712 152%else
40d43d2d 153# with shared: [else]
154%define need_sparc_static 1
042a9712 155%endif
40d43d2d 156# with shared; [endif]
2dbc1636 157%endif
40d43d2d 158# with snap; [endif]
ec0c336f 159%endif
40d43d2d 160# is sparc; [endif]
161%ifarch ppc
162# is ppc? [if]
163%if %{with snap}
164# with snap? [if]
165%if %{with shared}
166# with shared? [if]
167%define need_ppc_shared_snap 1
042a9712 168%else
40d43d2d 169# with shared: [else]
170%define need_ppc_static_snap 1
042a9712 171%endif
40d43d2d 172# with shared; [endif]
173%else
174# with snap: [else]
175%if %{with shared}
176# with shared? [if]
177%define need_ppc_shared 1
178%else
179# with shared: [else]
180%define need_ppc_static 1
2dbc1636 181%endif
40d43d2d 182# with shared; [endif
ec0c336f 183%endif
40d43d2d 184# with snap; [endif
2dbc1636 185%endif
40d43d2d 186# is ppc; [endif]
2dbc1636 187%endif
40d43d2d 188# with incall; [endif]
189
190Summary: World fastest web browser
191