]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- up to 10.60 final
[packages/opera.git] / opera.spec
CommitLineData
a79ddb02
AM
1# BRANCHES:
2# - HEAD - stable version
3# - DEVEL - development version
083d2812
AM
4# - WEEKLY - weekly development version
5#
6# NOTE: to avoid creating unreadable/unmaintainable spec:
7# - don't put static version here, create STATIC branch for that for example
8# - don't create useless bconds that for example limit SourceX: to current arch only
9#
edbbe593 10
07d1040c 11%define ver 10.60
083d2812 12%define shver %(echo %{ver} | tr -d .)
07d1040c 13%define buildid 6386
5422068c 14
40d43d2d 15Summary: World fastest web browser
048a8afa 16Summary(hu.UTF-8): A világ leggyorsabb webböngészője
0580138e 17Summary(pl.UTF-8): Najszybsza przeglądarka WWW na świecie
40d43d2d 18Name: opera
37147bb6 19Version: %{ver}
4da9c75d 20Release: 1
94132831 21Epoch: 2
ae712f51 22License: Distributable
40d43d2d 23Group: X11/Applications/Networking
07d1040c
AM
24Source10: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.bz2
25# Source10-md5: e86d604b2f9397a618e8ecf357748f55
26Source11: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.bz2
27# Source11-md5: 6415f21430bade3193d0d6c174e3bfb1
28Source12: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.ppc.linux.tar.bz2
29# Source12-md5: 4cd09b64a0d1c3826b3e7038326c14dc
083d2812 30Source0: %{name}.desktop
35677f25 31Patch0: %{name}-wrapper.patch
07d1040c 32Patch1: %{name}-agent.patch
8cb331c2 33URL: http://www.opera.com/
55fc796b 34BuildRequires: rpm >= 4.4.9-56
f6dbdb8e 35BuildRequires: rpmbuild(macros) >= 1.356
6eebcb83 36BuildRequires: sed >= 4.0
f6dbdb8e 37Requires: browser-plugins >= 2.0
2f4fa75a 38Requires: freetype >= 2
3b8cc5d5 39Provides: wwwbrowser
37147bb6 40Obsoletes: opera-i18n
083d2812 41ExclusiveArch: %{ix86} %{x8664} ppc
8cb331c2 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1e3271ab 43
fa79b8f2 44%define _plugindir %{_libdir}/opera/plugins
7e80713c 45%define _operadocdir %{_docdir}/%{name}-%{ver}
083d2812
AM
46# alternative arch for plugin32
47%define alt_arch i386
8cb331c2 48
49%description
50Opera is world fastest web browser. It supports most of nowaday
55fc796b
ER
51extensions of HTML. And it is quite stable. This version is linked
52with shared version of Qt.
8cb331c2 53
048a8afa
ZU
54%description -l hu.UTF-8
55Opera a világ leggyorsabb webböngészője. A manapság elterjedt
56HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
57Ez a verzió a Qt megosztott verziójához linkelődik.
58
14283174
JR
59%description -l pl.UTF-8
60Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
61dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
083d2812 62wersja jest skonsolidowana dynamicznie z Qt.
37147bb6
AM
63
64%package plugin32
65Summary: Opera 32-bit plugins support
048a8afa 66Summary(hu.UTF-8): Opera 32-bites plugin támogatás
37147bb6
AM
67Summary(pl.UTF-8): Obsługa 32-bitowych wtyczek Opery
68Group: X11/Applications/Networking
69Requires: %{name} = %{epoch}:%{version}-%{release}
083d2812 70Requires: browser-plugins >= 2.0
37147bb6
AM
71
72%description plugin32
73Opera 32-bit plugins support.
74
048a8afa
ZU
75%description plugin32 -l hu.UTF-8
76Opera 32-bites plugin támogatás.
77
37147bb6
AM
78%description plugin32 -l pl.UTF-8
79Obsługa 32-bitowych wtyczek Opery.
58d714bb 80
8cb331c2 81%prep
643785f9 82%ifarch %{ix86}
07d1040c 83%setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
e789f1d0 84%endif
07d1040c 85
083d2812 86%ifarch %{x8664}
07d1040c 87%setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
3009d733 88%endif
07d1040c 89
195ff7d0 90%ifarch ppc
07d1040c 91%setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.ppc.linux
b966c84f 92%endif
07d1040c 93
35677f25 94%patch0 -p1
07d1040c 95#%patch1 -p1
8cb331c2 96
97%install
98rm -rf $RPM_BUILD_ROOT
07d1040c 99install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
8cb331c2 100
f6dbdb8e
ER
101%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
102# opera does not use for .xpt files
103*.xpt
6ab3a1e1
ER
104
105# use mplayerplug-in-opera instead
106mplayerplug-in*
f6dbdb8e
ER
107EOF
108
083d2812
AM
109%ifarch %{x8664}
110install -d $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/plugins
111%browser_plugins_add_browser %{name} -a %{alt_arch} -p %{_prefix}/lib/%{name}/plugins -b <<'EOF'
112# opera does not use for .xpt files
113*.xpt
114
115# use mplayerplug-in-opera instead
116mplayerplug-in*
083d2812
AM
117EOF
118%endif
119
07d1040c
AM
120install -p opera* $RPM_BUILD_ROOT%{_bindir}
121cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
122cp -a share/* $RPM_BUILD_ROOT%{_datadir}
123#cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
6239047a 124
07d1040c 125sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
72b0ae2b 126
07d1040c 127%if 0
201511be
AM
128%if "%{pld_release}" == "ti"
129sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
130%else
131%if "%{pld_release}" == "ac"
132sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
133%else
134sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
135%endif
136%endif
07d1040c 137%endif
201511be 138
8cb331c2 139%clean
140rm -rf $RPM_BUILD_ROOT
141
f6dbdb8e
ER
142%post
143%update_browser_plugins
144
145%postun
146if [ "$1" = 0 ]; then
147 %update_browser_plugins
148fi
149
083d2812
AM
150%post plugin32
151%update_browser_plugins
152
153%postun plugin32
154if [ "$1" = 0 ]; then
155 %update_browser_plugins
156fi
157
8cb331c2 158%files
159%defattr(644,root,root,755)
c2ef0548 160%doc LICENSE
07d1040c 161#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
f6dbdb8e
ER
162
163# browser plugins v2
07d1040c
AM
164%{_browserpluginsconfdir}/browsers.d/%{name}.*
165%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
f6dbdb8e 166
07d1040c
AM
167%attr(755,root,root) %{_bindir}/opera
168%attr(755,root,root) %{_bindir}/opera-widget-manager
1e3271ab 169%dir %{_libdir}/opera
37147bb6 170%ifarch %{x8664}
07d1040c 171%exclude %{_libdir}/opera/*-ia32-*
37147bb6 172%endif
07d1040c
AM
173%attr(755,root,root) %{_libdir}/opera/*.so
174%attr(755,root,root) %{_libdir}/opera/opera*
1e3271ab 175%dir %{_plugindir}
07d1040c
AM
176%dir %{_libdir}/opera/gstreamer
177%dir %{_libdir}/opera/gstreamer/plugins
178%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
179%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
a5b49fac
KK
180%dir %{_datadir}/opera
181%{_datadir}/opera/*.*
628633e1
AM
182%{_datadir}/opera/defaults
183%{_datadir}/opera/extra
a5b49fac 184%{_datadir}/opera/skin
07d1040c 185#%{_datadir}/opera/scripts
a5b49fac 186%{_datadir}/opera/styles
628633e1 187%{_datadir}/opera/ui
07d1040c 188%{_datadir}/opera/unite
f8b4ca83 189%dir %{_datadir}/opera/locale
190%{_datadir}/opera/locale/en
37147bb6
AM
191%lang(be) %{_datadir}/opera/locale/be
192%lang(bg) %{_datadir}/opera/locale/bg
193%lang(cs) %{_datadir}/opera/locale/cs
194%lang(da) %{_datadir}/opera/locale/da
195%lang(de) %{_datadir}/opera/locale/de
196%lang(el) %{_datadir}/opera/locale/el
197%lang(en_GB) %{_datadir}/opera/locale/en-GB
07d1040c 198%lang(es_ES) %{_datadir}/opera/locale/es-ES
37147bb6 199%lang(es_LA) %{_datadir}/opera/locale/es-LA
bd7f9e14 200%lang(et) %{_datadir}/opera/locale/et
37147bb6
AM
201%lang(fi) %{_datadir}/opera/locale/fi
202%lang(fr) %{_datadir}/opera/locale/fr
203%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
204%lang(fy) %{_datadir}/opera/locale/fy
205%lang(hi) %{_datadir}/opera/locale/hi
206%lang(hr) %{_datadir}/opera/locale/hr
207%lang(hu) %{_datadir}/opera/locale/hu
ff88e30e 208%lang(id) %{_datadir}/opera/locale/id
37147bb6
AM
209%lang(it) %{_datadir}/opera/locale/it
210%lang(ja) %{_datadir}/opera/locale/ja
211%lang(ka) %{_datadir}/opera/locale/ka
212%lang(ko) %{_datadir}/opera/locale/ko
213%lang(lt) %{_datadir}/opera/locale/lt
214%lang(mk) %{_datadir}/opera/locale/mk
215%lang(nb) %{_datadir}/opera/locale/nb
216%lang(nl) %{_datadir}/opera/locale/nl
217%lang(nn) %{_datadir}/opera/locale/nn
218%lang(pl) %{_datadir}/opera/locale/pl
219%lang(pt) %{_datadir}/opera/locale/pt
220%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
628633e1 221%lang(ro) %{_datadir}/opera/locale/ro
37147bb6 222%lang(ru) %{_datadir}/opera/locale/ru
628633e1
AM
223%lang(sk) %{_datadir}/opera/locale/sk
224%lang(sr) %{_datadir}/opera/locale/sr
37147bb6 225%lang(sv) %{_datadir}/opera/locale/sv
bd7f9e14
AM
226%lang(ta) %{_datadir}/opera/locale/ta
227%lang(te) %{_datadir}/opera/locale/te
37147bb6 228%lang(tr) %{_datadir}/opera/locale/tr
ff88e30e 229%lang(uk) %{_datadir}/opera/locale/uk
66f1ccb5 230%lang(vi) %{_datadir}/opera/locale/vi
37147bb6 231%lang(zh_CN) %{_datadir}/opera/locale/zh-cn
628633e1 232%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
37147bb6 233%lang(zh_TW) %{_datadir}/opera/locale/zh-tw
07d1040c
AM
234%{_datadir}/mime/packages/opera-widget.xml
235%{_datadir}/mime/packages/opera-unite-application.xml
7b1a5f81 236%{_desktopdir}/*.desktop
1e3271ab 237%{_mandir}/man1/opera.1*
07d1040c
AM
238%{_mandir}/man1/opera-widget-manager.1*
239%{_iconsdir}/hicolor/*/*/*.png
240%{_iconsdir}/hicolor/*/*/*.svg
671735f8
AM
241
242%ifarch %{x8664}
243%files plugin32
244%defattr(644,root,root,755)
07d1040c 245%attr(755,root,root) %{_libdir}/opera/*-ia32-*
671735f8 246%endif
This page took 0.355921 seconds and 4 git commands to generate.