]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- up to 10.60 final
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version
5 #
6 # NOTE: to avoid creating unreadable/unmaintainable spec:
7 # - don't put static version here, create STATIC branch for that for example
8 # - don't create useless bconds that for example limit SourceX: to current arch only
9 #
10
11 %define         ver     10.60
12 %define         shver   %(echo %{ver} | tr -d .)
13 %define         buildid 6386
14
15 Summary:        World fastest web browser
16 Summary(hu.UTF-8):      A világ leggyorsabb webböngészője
17 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
18 Name:           opera
19 Version:        %{ver}
20 Release:        1
21 Epoch:          2
22 License:        Distributable
23 Group:          X11/Applications/Networking
24 Source10:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.bz2
25 # Source10-md5: e86d604b2f9397a618e8ecf357748f55
26 Source11:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.bz2
27 # Source11-md5: 6415f21430bade3193d0d6c174e3bfb1
28 Source12:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.ppc.linux.tar.bz2
29 # Source12-md5: 4cd09b64a0d1c3826b3e7038326c14dc
30 Source0:        %{name}.desktop
31 Patch0:         %{name}-wrapper.patch
32 Patch1:         %{name}-agent.patch
33 URL:            http://www.opera.com/
34 BuildRequires:  rpm >= 4.4.9-56
35 BuildRequires:  rpmbuild(macros) >= 1.356
36 BuildRequires:  sed >= 4.0
37 Requires:       browser-plugins >= 2.0
38 Requires:       freetype >= 2
39 Provides:       wwwbrowser
40 Obsoletes:      opera-i18n
41 ExclusiveArch:  %{ix86} %{x8664} ppc
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _plugindir      %{_libdir}/opera/plugins
45 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
46 # alternative arch for plugin32
47 %define         alt_arch        i386
48
49 %description
50 Opera is world fastest web browser. It supports most of nowaday
51 extensions of HTML. And it is quite stable. This version is linked
52 with shared version of Qt.
53
54 %description -l hu.UTF-8
55 Opera a világ leggyorsabb webböngészője. A manapság elterjedt
56 HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
57 Ez a verzió a Qt megosztott verziójához linkelődik.
58
59 %description -l pl.UTF-8
60 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
61 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
62 wersja jest skonsolidowana dynamicznie z Qt.
63
64 %package plugin32
65 Summary:        Opera 32-bit plugins support
66 Summary(hu.UTF-8):      Opera 32-bites plugin támogatás
67 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
68 Group:          X11/Applications/Networking
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70 Requires:       browser-plugins >= 2.0
71
72 %description plugin32
73 Opera 32-bit plugins support.
74
75 %description plugin32 -l hu.UTF-8
76 Opera 32-bites plugin támogatás.
77
78 %description plugin32 -l pl.UTF-8
79 Obsługa 32-bitowych wtyczek Opery.
80
81 %prep
82 %ifarch %{ix86}
83 %setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
84 %endif
85
86 %ifarch %{x8664}
87 %setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
88 %endif
89
90 %ifarch ppc
91 %setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.ppc.linux
92 %endif
93
94 %patch0 -p1
95 #%patch1 -p1
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
100
101 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
102 # opera does not use for .xpt files
103 *.xpt
104
105 # use mplayerplug-in-opera instead
106 mplayerplug-in*
107 EOF
108
109 %ifarch %{x8664}
110 install -d $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/plugins
111 %browser_plugins_add_browser %{name} -a %{alt_arch} -p %{_prefix}/lib/%{name}/plugins -b <<'EOF'
112 # opera does not use for .xpt files
113 *.xpt
114
115 # use mplayerplug-in-opera instead
116 mplayerplug-in*
117 EOF
118 %endif
119
120 install -p opera* $RPM_BUILD_ROOT%{_bindir}
121 cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
122 cp -a share/* $RPM_BUILD_ROOT%{_datadir}
123 #cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
124
125 sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
126
127 %if 0
128 %if "%{pld_release}" == "ti"
129 sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
130 %else
131 %if "%{pld_release}" == "ac"
132 sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
133 %else
134 sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
135 %endif
136 %endif
137 %endif
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 %update_browser_plugins
144
145 %postun
146 if [ "$1" = 0 ]; then
147         %update_browser_plugins
148 fi
149
150 %post plugin32
151 %update_browser_plugins
152
153 %postun plugin32
154 if [ "$1" = 0 ]; then
155         %update_browser_plugins
156 fi
157
158 %files
159 %defattr(644,root,root,755)
160 %doc LICENSE
161 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
162
163 # browser plugins v2
164 %{_browserpluginsconfdir}/browsers.d/%{name}.*
165 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
166
167 %attr(755,root,root) %{_bindir}/opera
168 %attr(755,root,root) %{_bindir}/opera-widget-manager
169 %dir %{_libdir}/opera
170 %ifarch %{x8664}
171 %exclude %{_libdir}/opera/*-ia32-*
172 %endif
173 %attr(755,root,root) %{_libdir}/opera/*.so
174 %attr(755,root,root) %{_libdir}/opera/opera*
175 %dir %{_plugindir}
176 %dir %{_libdir}/opera/gstreamer
177 %dir %{_libdir}/opera/gstreamer/plugins
178 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
179 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
180 %dir %{_datadir}/opera
181 %{_datadir}/opera/*.*
182 %{_datadir}/opera/defaults
183 %{_datadir}/opera/extra
184 %{_datadir}/opera/skin
185 #%{_datadir}/opera/scripts
186 %{_datadir}/opera/styles
187 %{_datadir}/opera/ui
188 %{_datadir}/opera/unite
189 %dir %{_datadir}/opera/locale
190 %{_datadir}/opera/locale/en
191 %lang(be) %{_datadir}/opera/locale/be
192 %lang(bg) %{_datadir}/opera/locale/bg
193 %lang(cs) %{_datadir}/opera/locale/cs
194 %lang(da) %{_datadir}/opera/locale/da
195 %lang(de) %{_datadir}/opera/locale/de
196 %lang(el) %{_datadir}/opera/locale/el
197 %lang(en_GB) %{_datadir}/opera/locale/en-GB
198 %lang(es_ES) %{_datadir}/opera/locale/es-ES
199 %lang(es_LA) %{_datadir}/opera/locale/es-LA
200 %lang(et) %{_datadir}/opera/locale/et
201 %lang(fi) %{_datadir}/opera/locale/fi
202 %lang(fr) %{_datadir}/opera/locale/fr
203 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
204 %lang(fy) %{_datadir}/opera/locale/fy
205 %lang(hi) %{_datadir}/opera/locale/hi
206 %lang(hr) %{_datadir}/opera/locale/hr
207 %lang(hu) %{_datadir}/opera/locale/hu
208 %lang(id) %{_datadir}/opera/locale/id
209 %lang(it) %{_datadir}/opera/locale/it
210 %lang(ja) %{_datadir}/opera/locale/ja
211 %lang(ka) %{_datadir}/opera/locale/ka
212 %lang(ko) %{_datadir}/opera/locale/ko
213 %lang(lt) %{_datadir}/opera/locale/lt
214 %lang(mk) %{_datadir}/opera/locale/mk
215 %lang(nb) %{_datadir}/opera/locale/nb
216 %lang(nl) %{_datadir}/opera/locale/nl
217 %lang(nn) %{_datadir}/opera/locale/nn
218 %lang(pl) %{_datadir}/opera/locale/pl
219 %lang(pt) %{_datadir}/opera/locale/pt
220 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
221 %lang(ro) %{_datadir}/opera/locale/ro
222 %lang(ru) %{_datadir}/opera/locale/ru
223 %lang(sk) %{_datadir}/opera/locale/sk
224 %lang(sr) %{_datadir}/opera/locale/sr
225 %lang(sv) %{_datadir}/opera/locale/sv
226 %lang(ta) %{_datadir}/opera/locale/ta
227 %lang(te) %{_datadir}/opera/locale/te
228 %lang(tr) %{_datadir}/opera/locale/tr
229 %lang(uk) %{_datadir}/opera/locale/uk
230 %lang(vi) %{_datadir}/opera/locale/vi
231 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
232 %lang(zh_HK) %{_datadir}/opera/locale/zh-hk
233 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
234 %{_datadir}/mime/packages/opera-widget.xml
235 %{_datadir}/mime/packages/opera-unite-application.xml
236 %{_desktopdir}/*.desktop
237 %{_mandir}/man1/opera.1*
238 %{_mandir}/man1/opera-widget-manager.1*
239 %{_iconsdir}/hicolor/*/*/*.png
240 %{_iconsdir}/hicolor/*/*/*.svg
241
242 %ifarch %{x8664}
243 %files plugin32
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libdir}/opera/*-ia32-*
246 %endif
This page took 0.044306 seconds and 4 git commands to generate.