]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- ini is back; debuginfo package disabled as it makes no sense here
[packages/opera.git] / opera.spec
CommitLineData
a79ddb02
AM
1# BRANCHES:
2# - HEAD - stable version
3# - DEVEL - development version
083d2812
AM
4# - WEEKLY - weekly development version
5#
6# NOTE: to avoid creating unreadable/unmaintainable spec:
7# - don't put static version here, create STATIC branch for that for example
8# - don't create useless bconds that for example limit SourceX: to current arch only
9#
edbbe593 10
07d1040c 11%define ver 10.60
083d2812 12%define shver %(echo %{ver} | tr -d .)
07d1040c 13%define buildid 6386
5422068c 14
40d43d2d 15Summary: World fastest web browser
048a8afa 16Summary(hu.UTF-8): A világ leggyorsabb webböngészője
0580138e 17Summary(pl.UTF-8): Najszybsza przeglądarka WWW na świecie
40d43d2d 18Name: opera
37147bb6 19Version: %{ver}
4da9c75d 20Release: 1
94132831 21Epoch: 2
ae712f51 22License: Distributable
40d43d2d 23Group: X11/Applications/Networking
07d1040c
AM
24Source10: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.bz2
25# Source10-md5: e86d604b2f9397a618e8ecf357748f55
26Source11: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.bz2
27# Source11-md5: 6415f21430bade3193d0d6c174e3bfb1
28Source12: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.ppc.linux.tar.bz2
29# Source12-md5: 4cd09b64a0d1c3826b3e7038326c14dc
083d2812 30Source0: %{name}.desktop
35677f25 31Patch0: %{name}-wrapper.patch
8cb331c2 32URL: http://www.opera.com/
55fc796b 33BuildRequires: rpm >= 4.4.9-56
f6dbdb8e 34BuildRequires: rpmbuild(macros) >= 1.356
6eebcb83 35BuildRequires: sed >= 4.0
f6dbdb8e 36Requires: browser-plugins >= 2.0
2f4fa75a 37Requires: freetype >= 2
3b8cc5d5 38Provides: wwwbrowser
37147bb6 39Obsoletes: opera-i18n
083d2812 40ExclusiveArch: %{ix86} %{x8664} ppc
8cb331c2 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1e3271ab 42
0539d577
AM
43%define _enable_debug_packages 0
44
fa79b8f2 45%define _plugindir %{_libdir}/opera/plugins
7e80713c 46%define _operadocdir %{_docdir}/%{name}-%{ver}
083d2812
AM
47# alternative arch for plugin32
48%define alt_arch i386
8cb331c2 49
50%description
51Opera is world fastest web browser. It supports most of nowaday
55fc796b
ER
52extensions of HTML. And it is quite stable. This version is linked
53with shared version of Qt.
8cb331c2 54
048a8afa
ZU
55%description -l hu.UTF-8
56Opera a világ leggyorsabb webböngészője. A manapság elterjedt
57HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
58Ez a verzió a Qt megosztott verziójához linkelődik.
59
14283174
JR
60%description -l pl.UTF-8
61Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
62dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
083d2812 63wersja jest skonsolidowana dynamicznie z Qt.
37147bb6
AM
64
65%package plugin32
66Summary: Opera 32-bit plugins support
048a8afa 67Summary(hu.UTF-8): Opera 32-bites plugin támogatás
37147bb6
AM
68Summary(pl.UTF-8): Obsługa 32-bitowych wtyczek Opery
69Group: X11/Applications/Networking
70Requires: %{name} = %{epoch}:%{version}-%{release}
083d2812 71Requires: browser-plugins >= 2.0
37147bb6
AM
72
73%description plugin32
74Opera 32-bit plugins support.
75
048a8afa
ZU
76%description plugin32 -l hu.UTF-8
77Opera 32-bites plugin támogatás.
78
37147bb6
AM
79%description plugin32 -l pl.UTF-8
80Obsługa 32-bitowych wtyczek Opery.
58d714bb 81
8cb331c2 82%prep
643785f9 83%ifarch %{ix86}
07d1040c 84%setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
e789f1d0 85%endif
07d1040c 86
083d2812 87%ifarch %{x8664}
07d1040c 88%setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
3009d733 89%endif
07d1040c 90
195ff7d0 91%ifarch ppc
07d1040c 92%setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.ppc.linux
b966c84f 93%endif
07d1040c 94
35677f25 95%patch0 -p1
8cb331c2 96
97%install
98rm -rf $RPM_BUILD_ROOT
07d1040c 99install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
8cb331c2 100
f6dbdb8e
ER
101%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
102# opera does not use for .xpt files
103*.xpt
6ab3a1e1
ER
104
105# use mplayerplug-in-opera instead
106mplayerplug-in*
f6dbdb8e
ER
107EOF
108
083d2812
AM
109%ifarch %{x8664}
110install -d $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/plugins
111%browser_plugins_add_browser %{name} -a %{alt_arch} -p %{_prefix}/lib/%{name}/plugins -b <<'EOF'
112# opera does not use for .xpt files
113*.xpt
114
115# use mplayerplug-in-opera instead
116mplayerplug-in*
083d2812
AM
117EOF
118%endif
119
07d1040c
AM
120install -p opera* $RPM_BUILD_ROOT%{_bindir}
121cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
122cp -a share/* $RPM_BUILD_ROOT%{_datadir}
6239047a 123
07d1040c 124sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
72b0ae2b 125
0539d577
AM
126cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/operaprefs_default.ini
127[ISP]
128Id="DISTRO"
129EOF
130
201511be
AM
131%if "%{pld_release}" == "ti"
132sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
133%else
134%if "%{pld_release}" == "ac"
135sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
136%else
137sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
138%endif
139%endif
201511be 140
8cb331c2 141%clean
142rm -rf $RPM_BUILD_ROOT
143
f6dbdb8e
ER
144%post
145%update_browser_plugins
146
147%postun
148if [ "$1" = 0 ]; then
149 %update_browser_plugins
150fi
151
083d2812
AM
152%post plugin32
153%update_browser_plugins
154
155%postun plugin32
156if [ "$1" = 0 ]; then
157 %update_browser_plugins
158fi
159
8cb331c2 160%files
161%defattr(644,root,root,755)
c2ef0548 162%doc LICENSE
07d1040c 163#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
f6dbdb8e
ER
164
165# browser plugins v2
07d1040c
AM
166%{_browserpluginsconfdir}/browsers.d/%{name}.*
167%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
0539d577 168%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
07d1040c
AM
169%attr(755,root,root) %{_bindir}/opera
170%attr(755,root,root) %{_bindir}/opera-widget-manager
1e3271ab 171%dir %{_libdir}/opera
37147bb6 172%ifarch %{x8664}
07d1040c 173%exclude %{_libdir}/opera/*-ia32-*
37147bb6 174%endif
07d1040c
AM
175%attr(755,root,root) %{_libdir}/opera/*.so
176%attr(755,root,root) %{_libdir}/opera/opera*
1e3271ab 177%dir %{_plugindir}
07d1040c
AM
178%dir %{_libdir}/opera/gstreamer
179%dir %{_libdir}/opera/gstreamer/plugins
180%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
181%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
a5b49fac
KK
182%dir %{_datadir}/opera
183%{_datadir}/opera/*.*
628633e1
AM
184%{_datadir}/opera/defaults
185%{_datadir}/opera/extra
a5b49fac
KK
186%{_datadir}/opera/skin
187%{_datadir}/opera/styles
628633e1 188%{_datadir}/opera/ui
07d1040c 189%{_datadir}/opera/unite
f8b4ca83 190%dir %{_datadir}/opera/locale
191%{_datadir}/opera/locale/en
37147bb6
AM
192%lang(be) %{_datadir}/opera/locale/be
193%lang(bg) %{_datadir}/opera/locale/bg
194%lang(cs) %{_datadir}/opera/locale/cs
195%lang(da) %{_datadir}/opera/locale/da
196%lang(de) %{_datadir}/opera/locale/de
197%lang(el) %{_datadir}/opera/locale/el
198%lang(en_GB) %{_datadir}/opera/locale/en-GB
07d1040c 199%lang(es_ES) %{_datadir}/opera/locale/es-ES
37147bb6 200%lang(es_LA) %{_datadir}/opera/locale/es-LA
bd7f9e14 201%lang(et) %{_datadir}/opera/locale/et
37147bb6
AM
202%lang(fi) %{_datadir}/opera/locale/fi
203%lang(fr) %{_datadir}/opera/locale/fr
204%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
205%lang(fy) %{_datadir}/opera/locale/fy
206%lang(hi) %{_datadir}/opera/locale/hi
207%lang(hr) %{_datadir}/opera/locale/hr
208%lang(hu) %{_datadir}/opera/locale/hu
ff88e30e 209%lang(id) %{_datadir}/opera/locale/id
37147bb6
AM
210%lang(it) %{_datadir}/opera/locale/it
211%lang(ja) %{_datadir}/opera/locale/ja
212%lang(ka) %{_datadir}/opera/locale/ka
213%lang(ko) %{_datadir}/opera/locale/ko
214%lang(lt) %{_datadir}/opera/locale/lt
215%lang(mk) %{_datadir}/opera/locale/mk
216%lang(nb) %{_datadir}/opera/locale/nb
217%lang(nl) %{_datadir}/opera/locale/nl
218%lang(nn) %{_datadir}/opera/locale/nn
219%lang(pl) %{_datadir}/opera/locale/pl
220%lang(pt) %{_datadir}/opera/locale/pt
221%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
628633e1 222%lang(ro) %{_datadir}/opera/locale/ro
37147bb6 223%lang(ru) %{_datadir}/opera/locale/ru
628633e1
AM
224%lang(sk) %{_datadir}/opera/locale/sk
225%lang(sr) %{_datadir}/opera/locale/sr
37147bb6 226%lang(sv) %{_datadir}/opera/locale/sv
bd7f9e14
AM
227%lang(ta) %{_datadir}/opera/locale/ta
228%lang(te) %{_datadir}/opera/locale/te
37147bb6 229%lang(tr) %{_datadir}/opera/locale/tr
ff88e30e 230%lang(uk) %{_datadir}/opera/locale/uk
66f1ccb5 231%lang(vi) %{_datadir}/opera/locale/vi
37147bb6 232%lang(zh_CN) %{_datadir}/opera/locale/zh-cn
628633e1 233%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
37147bb6 234%lang(zh_TW) %{_datadir}/opera/locale/zh-tw
07d1040c
AM
235%{_datadir}/mime/packages/opera-widget.xml
236%{_datadir}/mime/packages/opera-unite-application.xml
7b1a5f81 237%{_desktopdir}/*.desktop
1e3271ab 238%{_mandir}/man1/opera.1*
07d1040c
AM
239%{_mandir}/man1/opera-widget-manager.1*
240%{_iconsdir}/hicolor/*/*/*.png
241%{_iconsdir}/hicolor/*/*/*.svg
671735f8
AM
242
243%ifarch %{x8664}
244%files plugin32
245%defattr(644,root,root,755)
07d1040c 246%attr(755,root,root) %{_libdir}/opera/*-ia32-*
671735f8 247%endif
This page took 0.183925 seconds and 4 git commands to generate.