]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- ini is back; debuginfo package disabled as it makes no sense here
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version
5 #
6 # NOTE: to avoid creating unreadable/unmaintainable spec:
7 # - don't put static version here, create STATIC branch for that for example
8 # - don't create useless bconds that for example limit SourceX: to current arch only
9 #
10
11 %define         ver     10.60
12 %define         shver   %(echo %{ver} | tr -d .)
13 %define         buildid 6386
14
15 Summary:        World fastest web browser
16 Summary(hu.UTF-8):      A világ leggyorsabb webböngészője
17 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
18 Name:           opera
19 Version:        %{ver}
20 Release:        1
21 Epoch:          2
22 License:        Distributable
23 Group:          X11/Applications/Networking
24 Source10:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.bz2
25 # Source10-md5: e86d604b2f9397a618e8ecf357748f55
26 Source11:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.bz2
27 # Source11-md5: 6415f21430bade3193d0d6c174e3bfb1
28 Source12:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.ppc.linux.tar.bz2
29 # Source12-md5: 4cd09b64a0d1c3826b3e7038326c14dc
30 Source0:        %{name}.desktop
31 Patch0:         %{name}-wrapper.patch
32 URL:            http://www.opera.com/
33 BuildRequires:  rpm >= 4.4.9-56
34 BuildRequires:  rpmbuild(macros) >= 1.356
35 BuildRequires:  sed >= 4.0
36 Requires:       browser-plugins >= 2.0
37 Requires:       freetype >= 2
38 Provides:       wwwbrowser
39 Obsoletes:      opera-i18n
40 ExclusiveArch:  %{ix86} %{x8664} ppc
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _enable_debug_packages  0
44
45 %define         _plugindir      %{_libdir}/opera/plugins
46 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
47 # alternative arch for plugin32
48 %define         alt_arch        i386
49
50 %description
51 Opera is world fastest web browser. It supports most of nowaday
52 extensions of HTML. And it is quite stable. This version is linked
53 with shared version of Qt.
54
55 %description -l hu.UTF-8
56 Opera a világ leggyorsabb webböngészője. A manapság elterjedt
57 HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
58 Ez a verzió a Qt megosztott verziójához linkelődik.
59
60 %description -l pl.UTF-8
61 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
62 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
63 wersja jest skonsolidowana dynamicznie z Qt.
64
65 %package plugin32
66 Summary:        Opera 32-bit plugins support
67 Summary(hu.UTF-8):      Opera 32-bites plugin támogatás
68 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
69 Group:          X11/Applications/Networking
70 Requires:       %{name} = %{epoch}:%{version}-%{release}
71 Requires:       browser-plugins >= 2.0
72
73 %description plugin32
74 Opera 32-bit plugins support.
75
76 %description plugin32 -l hu.UTF-8
77 Opera 32-bites plugin támogatás.
78
79 %description plugin32 -l pl.UTF-8
80 Obsługa 32-bitowych wtyczek Opery.
81
82 %prep
83 %ifarch %{ix86}
84 %setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
85 %endif
86
87 %ifarch %{x8664}
88 %setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
89 %endif
90
91 %ifarch ppc
92 %setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.ppc.linux
93 %endif
94
95 %patch0 -p1
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
100
101 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
102 # opera does not use for .xpt files
103 *.xpt
104
105 # use mplayerplug-in-opera instead
106 mplayerplug-in*
107 EOF
108
109 %ifarch %{x8664}
110 install -d $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/plugins
111 %browser_plugins_add_browser %{name} -a %{alt_arch} -p %{_prefix}/lib/%{name}/plugins -b <<'EOF'
112 # opera does not use for .xpt files
113 *.xpt
114
115 # use mplayerplug-in-opera instead
116 mplayerplug-in*
117 EOF
118 %endif
119
120 install -p opera* $RPM_BUILD_ROOT%{_bindir}
121 cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
122 cp -a share/* $RPM_BUILD_ROOT%{_datadir}
123
124 sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
125
126 cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/operaprefs_default.ini
127 [ISP]
128 Id="DISTRO"
129 EOF
130
131 %if "%{pld_release}" == "ti"
132 sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
133 %else
134 %if "%{pld_release}" == "ac"
135 sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
136 %else
137 sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
138 %endif
139 %endif
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 %update_browser_plugins
146
147 %postun
148 if [ "$1" = 0 ]; then
149         %update_browser_plugins
150 fi
151
152 %post plugin32
153 %update_browser_plugins
154
155 %postun plugin32
156 if [ "$1" = 0 ]; then
157         %update_browser_plugins
158 fi
159
160 %files
161 %defattr(644,root,root,755)
162 %doc LICENSE
163 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
164
165 # browser plugins v2
166 %{_browserpluginsconfdir}/browsers.d/%{name}.*
167 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
168 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
169 %attr(755,root,root) %{_bindir}/opera
170 %attr(755,root,root) %{_bindir}/opera-widget-manager
171 %dir %{_libdir}/opera
172 %ifarch %{x8664}
173 %exclude %{_libdir}/opera/*-ia32-*
174 %endif
175 %attr(755,root,root) %{_libdir}/opera/*.so
176 %attr(755,root,root) %{_libdir}/opera/opera*
177 %dir %{_plugindir}
178 %dir %{_libdir}/opera/gstreamer
179 %dir %{_libdir}/opera/gstreamer/plugins
180 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
181 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
182 %dir %{_datadir}/opera
183 %{_datadir}/opera/*.*
184 %{_datadir}/opera/defaults
185 %{_datadir}/opera/extra
186 %{_datadir}/opera/skin
187 %{_datadir}/opera/styles
188 %{_datadir}/opera/ui
189 %{_datadir}/opera/unite
190 %dir %{_datadir}/opera/locale
191 %{_datadir}/opera/locale/en
192 %lang(be) %{_datadir}/opera/locale/be
193 %lang(bg) %{_datadir}/opera/locale/bg
194 %lang(cs) %{_datadir}/opera/locale/cs
195 %lang(da) %{_datadir}/opera/locale/da
196 %lang(de) %{_datadir}/opera/locale/de
197 %lang(el) %{_datadir}/opera/locale/el
198 %lang(en_GB) %{_datadir}/opera/locale/en-GB
199 %lang(es_ES) %{_datadir}/opera/locale/es-ES
200 %lang(es_LA) %{_datadir}/opera/locale/es-LA
201 %lang(et) %{_datadir}/opera/locale/et
202 %lang(fi) %{_datadir}/opera/locale/fi
203 %lang(fr) %{_datadir}/opera/locale/fr
204 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
205 %lang(fy) %{_datadir}/opera/locale/fy
206 %lang(hi) %{_datadir}/opera/locale/hi
207 %lang(hr) %{_datadir}/opera/locale/hr
208 %lang(hu) %{_datadir}/opera/locale/hu
209 %lang(id) %{_datadir}/opera/locale/id
210 %lang(it) %{_datadir}/opera/locale/it
211 %lang(ja) %{_datadir}/opera/locale/ja
212 %lang(ka) %{_datadir}/opera/locale/ka
213 %lang(ko) %{_datadir}/opera/locale/ko
214 %lang(lt) %{_datadir}/opera/locale/lt
215 %lang(mk) %{_datadir}/opera/locale/mk
216 %lang(nb) %{_datadir}/opera/locale/nb
217 %lang(nl) %{_datadir}/opera/locale/nl
218 %lang(nn) %{_datadir}/opera/locale/nn
219 %lang(pl) %{_datadir}/opera/locale/pl
220 %lang(pt) %{_datadir}/opera/locale/pt
221 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
222 %lang(ro) %{_datadir}/opera/locale/ro
223 %lang(ru) %{_datadir}/opera/locale/ru
224 %lang(sk) %{_datadir}/opera/locale/sk
225 %lang(sr) %{_datadir}/opera/locale/sr
226 %lang(sv) %{_datadir}/opera/locale/sv
227 %lang(ta) %{_datadir}/opera/locale/ta
228 %lang(te) %{_datadir}/opera/locale/te
229 %lang(tr) %{_datadir}/opera/locale/tr
230 %lang(uk) %{_datadir}/opera/locale/uk
231 %lang(vi) %{_datadir}/opera/locale/vi
232 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
233 %lang(zh_HK) %{_datadir}/opera/locale/zh-hk
234 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
235 %{_datadir}/mime/packages/opera-widget.xml
236 %{_datadir}/mime/packages/opera-unite-application.xml
237 %{_desktopdir}/*.desktop
238 %{_mandir}/man1/opera.1*
239 %{_mandir}/man1/opera-widget-manager.1*
240 %{_iconsdir}/hicolor/*/*/*.png
241 %{_iconsdir}/hicolor/*/*/*.svg
242
243 %ifarch %{x8664}
244 %files plugin32
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/opera/*-ia32-*
247 %endif
This page took 0.082095 seconds and 4 git commands to generate.