]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- up to 11.01
[packages/opera.git] / opera.spec
CommitLineData
a79ddb02
AM
1# BRANCHES:
2# - HEAD - stable version
3# - DEVEL - development version
083d2812
AM
4# - WEEKLY - weekly development version
5#
6# NOTE: to avoid creating unreadable/unmaintainable spec:
7# - don't put static version here, create STATIC branch for that for example
8# - don't create useless bconds that for example limit SourceX: to current arch only
9#
edbbe593 10
35920030 11%define ver 11.01
083d2812 12%define shver %(echo %{ver} | tr -d .)
35920030 13%define buildid 1190
5422068c 14
40d43d2d 15Summary: World fastest web browser
048a8afa 16Summary(hu.UTF-8): A világ leggyorsabb webböngészője
0580138e 17Summary(pl.UTF-8): Najszybsza przeglądarka WWW na świecie
40d43d2d 18Name: opera
37147bb6 19Version: %{ver}
b7f14704 20Release: 1
94132831 21Epoch: 2
ae712f51 22License: Distributable
40d43d2d 23Group: X11/Applications/Networking
f486f8e4 24Source10: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.xz
35920030 25# Source10-md5: 9614f1c8b1e7e71aeb398122db30bfed
f486f8e4 26Source11: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.xz
35920030 27# Source11-md5: 802e1725acddc713dffb3441815156b9
083d2812 28Source0: %{name}.desktop
35677f25 29Patch0: %{name}-wrapper.patch
25718300
AM
30Patch1: %{name}-desktop.patch
31Patch2: %{name}-pluginpath.patch
8cb331c2 32URL: http://www.opera.com/
55fc796b 33BuildRequires: rpm >= 4.4.9-56
f6dbdb8e 34BuildRequires: rpmbuild(macros) >= 1.356
6eebcb83 35BuildRequires: sed >= 4.0
f486f8e4 36BuildRequires: xz
f6dbdb8e 37Requires: browser-plugins >= 2.0
c33af227 38Requires: desktop-file-utils
2f4fa75a 39Requires: freetype >= 2
3b8cc5d5 40Provides: wwwbrowser
37147bb6 41Obsoletes: opera-i18n
083d2812 42ExclusiveArch: %{ix86} %{x8664} ppc
8cb331c2 43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1e3271ab 44
0539d577
AM
45%define _enable_debug_packages 0
46
fa79b8f2 47%define _plugindir %{_libdir}/opera/plugins
7e80713c 48%define _operadocdir %{_docdir}/%{name}-%{ver}
083d2812
AM
49# alternative arch for plugin32
50%define alt_arch i386
8cb331c2 51
52%description
53Opera is world fastest web browser. It supports most of nowaday
55fc796b
ER
54extensions of HTML. And it is quite stable. This version is linked
55with shared version of Qt.
8cb331c2 56
048a8afa
ZU
57%description -l hu.UTF-8
58Opera a világ leggyorsabb webböngészője. A manapság elterjedt
59HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
60Ez a verzió a Qt megosztott verziójához linkelődik.
61
14283174
JR
62%description -l pl.UTF-8
63Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
64dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
083d2812 65wersja jest skonsolidowana dynamicznie z Qt.
37147bb6
AM
66
67%package plugin32
68Summary: Opera 32-bit plugins support
048a8afa 69Summary(hu.UTF-8): Opera 32-bites plugin támogatás
37147bb6
AM
70Summary(pl.UTF-8): Obsługa 32-bitowych wtyczek Opery
71Group: X11/Applications/Networking
72Requires: %{name} = %{epoch}:%{version}-%{release}
083d2812 73Requires: browser-plugins >= 2.0
37147bb6
AM
74
75%description plugin32
76Opera 32-bit plugins support.
77
048a8afa
ZU
78%description plugin32 -l hu.UTF-8
79Opera 32-bites plugin támogatás.
80
37147bb6
AM
81%description plugin32 -l pl.UTF-8
82Obsługa 32-bitowych wtyczek Opery.
58d714bb 83
8cb331c2 84%prep
643785f9 85%ifarch %{ix86}
07d1040c 86%setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
e789f1d0 87%endif
07d1040c 88
083d2812 89%ifarch %{x8664}
07d1040c 90%setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
3009d733 91%endif
07d1040c 92
25718300
AM
93sed -i -e '
94 s,@@{PREFIX},%{_prefix},g
95 s,@@{SUFFIX},,
96 s,@@{_SUFFIX},,
97' share/{applications/*.desktop,mime/packages/*.xml}
98
99sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
100
35677f25 101%patch0 -p1
25718300
AM
102%patch1 -p1
103
104# remove lib32/lib64 paths so patch2 can apply (i386 build contained lib64 as well, oh well)
105%{__sed} -i -e '/lib32\|lib64/d;$d' share/opera/defaults/pluginpath.ini
106%patch2 -p1
107
108mv lib/opera/plugins/README README.plugins
109mv share/opera/defaults/license.txt .
110mv share/doc/opera/* .
111
112# nobody wants scalable huge icons
113rm -rf share/icons/hicolor/scalable
114
115# opera packaging tools we don't need runtime
116mv share/opera/package .
8cb331c2 117
118%install
119rm -rf $RPM_BUILD_ROOT
07d1040c 120install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
8cb331c2 121
f6dbdb8e
ER
122%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
123# opera does not use for .xpt files
124*.xpt
6ab3a1e1
ER
125
126# use mplayerplug-in-opera instead
127mplayerplug-in*
f6dbdb8e
ER
128EOF
129
07d1040c
AM
130install -p opera* $RPM_BUILD_ROOT%{_bindir}
131cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
132cp -a share/* $RPM_BUILD_ROOT%{_datadir}
25718300 133#cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
6239047a 134
07d1040c 135sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
72b0ae2b 136
0539d577
AM
137cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/operaprefs_default.ini
138[ISP]
139Id="DISTRO"
140EOF
141
201511be
AM
142%if "%{pld_release}" == "ti"
143sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
144%else
145%if "%{pld_release}" == "ac"
146sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
147%else
148sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
149%endif
150%endif
201511be 151
8cb331c2 152%clean
153rm -rf $RPM_BUILD_ROOT
154
f6dbdb8e 155%post
25718300
AM
156%update_mime_database
157%update_icon_cache hicolor
158%update_desktop_database_post
f6dbdb8e
ER
159%update_browser_plugins
160
161%postun
25718300
AM
162%update_mime_database
163%update_icon_cache hicolor
164%update_desktop_database_postun
f6dbdb8e
ER
165if [ "$1" = 0 ]; then
166 %update_browser_plugins
167fi
168
083d2812
AM
169%post plugin32
170%update_browser_plugins
171
172%postun plugin32
173if [ "$1" = 0 ]; then
174 %update_browser_plugins
175fi
176
8cb331c2 177%files
178%defattr(644,root,root,755)
c2ef0548 179%doc LICENSE
07d1040c 180#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
f6dbdb8e
ER
181
182# browser plugins v2
07d1040c
AM
183%{_browserpluginsconfdir}/browsers.d/%{name}.*
184%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
0539d577 185%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
07d1040c
AM
186%attr(755,root,root) %{_bindir}/opera
187%attr(755,root,root) %{_bindir}/opera-widget-manager
1e3271ab 188%dir %{_libdir}/opera
37147bb6 189%ifarch %{x8664}
07d1040c 190%exclude %{_libdir}/opera/*-ia32-*
37147bb6 191%endif
07d1040c
AM
192%attr(755,root,root) %{_libdir}/opera/*.so
193%attr(755,root,root) %{_libdir}/opera/opera*
1e3271ab 194%dir %{_plugindir}
07d1040c
AM
195%dir %{_libdir}/opera/gstreamer
196%dir %{_libdir}/opera/gstreamer/plugins
197%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
198%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
a5b49fac
KK
199%dir %{_datadir}/opera
200%{_datadir}/opera/*.*
628633e1
AM
201%{_datadir}/opera/defaults
202%{_datadir}/opera/extra
a5b49fac
KK
203%{_datadir}/opera/skin
204%{_datadir}/opera/styles
628633e1 205%{_datadir}/opera/ui
07d1040c 206%{_datadir}/opera/unite
f8b4ca83 207%dir %{_datadir}/opera/locale
208%{_datadir}/opera/locale/en
37147bb6
AM
209%lang(be) %{_datadir}/opera/locale/be
210%lang(bg) %{_datadir}/opera/locale/bg
211%lang(cs) %{_datadir}/opera/locale/cs
212%lang(da) %{_datadir}/opera/locale/da
213%lang(de) %{_datadir}/opera/locale/de
214%lang(el) %{_datadir}/opera/locale/el
215%lang(en_GB) %{_datadir}/opera/locale/en-GB
07d1040c 216%lang(es_ES) %{_datadir}/opera/locale/es-ES
37147bb6 217%lang(es_LA) %{_datadir}/opera/locale/es-LA
bd7f9e14 218%lang(et) %{_datadir}/opera/locale/et
37147bb6
AM
219%lang(fi) %{_datadir}/opera/locale/fi
220%lang(fr) %{_datadir}/opera/locale/fr
221%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
222%lang(fy) %{_datadir}/opera/locale/fy
223%lang(hi) %{_datadir}/opera/locale/hi
224%lang(hr) %{_datadir}/opera/locale/hr
225%lang(hu) %{_datadir}/opera/locale/hu
ff88e30e 226%lang(id) %{_datadir}/opera/locale/id
37147bb6
AM
227%lang(it) %{_datadir}/opera/locale/it
228%lang(ja) %{_datadir}/opera/locale/ja
229%lang(ka) %{_datadir}/opera/locale/ka
230%lang(ko) %{_datadir}/opera/locale/ko
231%lang(lt) %{_datadir}/opera/locale/lt
232%lang(mk) %{_datadir}/opera/locale/mk
233%lang(nb) %{_datadir}/opera/locale/nb
234%lang(nl) %{_datadir}/opera/locale/nl
235%lang(nn) %{_datadir}/opera/locale/nn
236%lang(pl) %{_datadir}/opera/locale/pl
237%lang(pt) %{_datadir}/opera/locale/pt
238%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
628633e1 239%lang(ro) %{_datadir}/opera/locale/ro
37147bb6 240%lang(ru) %{_datadir}/opera/locale/ru
628633e1
AM
241%lang(sk) %{_datadir}/opera/locale/sk
242%lang(sr) %{_datadir}/opera/locale/sr
37147bb6 243%lang(sv) %{_datadir}/opera/locale/sv
bd7f9e14
AM
244%lang(ta) %{_datadir}/opera/locale/ta
245%lang(te) %{_datadir}/opera/locale/te
37147bb6 246%lang(tr) %{_datadir}/opera/locale/tr
ff88e30e 247%lang(uk) %{_datadir}/opera/locale/uk
66f1ccb5 248%lang(vi) %{_datadir}/opera/locale/vi
37147bb6 249%lang(zh_CN) %{_datadir}/opera/locale/zh-cn
628633e1 250%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
37147bb6 251%lang(zh_TW) %{_datadir}/opera/locale/zh-tw
f8c10437 252%{_datadir}/mime/packages/opera-extension.xml
07d1040c
AM
253%{_datadir}/mime/packages/opera-widget.xml
254%{_datadir}/mime/packages/opera-unite-application.xml
7b1a5f81 255%{_desktopdir}/*.desktop
1e3271ab 256%{_mandir}/man1/opera.1*
07d1040c
AM
257%{_mandir}/man1/opera-widget-manager.1*
258%{_iconsdir}/hicolor/*/*/*.png
671735f8
AM
259
260%ifarch %{x8664}
261%files plugin32
262%defattr(644,root,root,755)
07d1040c 263%attr(755,root,root) %{_libdir}/opera/*-ia32-*
671735f8 264%endif
This page took 0.110775 seconds and 4 git commands to generate.