]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- release 2
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
2c687024 4#
5# Conditional build:
c6f8dd12 6%bcond_without static_sqlite # with static sqlite3
3834eb29 7%bcond_with static_projectm # with static projectM
0b056df0 8
3834eb29 9%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 10Summary: A music player and library organiser
df3c0ac1 11Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 12Name: clementine
e0ba0da9 13Version: 1.0.1
a5e288c7 14Release: 2
bf1e6952
ER
15License: GPL v3 and GPL v2+
16Group: Applications/Multimedia
f823a794 17URL: http://www.clementine-player.org/
bf272879 18Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
e0ba0da9 19# Source0-md5: 54dc47eb2de5960cd1654e1249a59bc6
f823a794 20Patch0: desktop-install.patch
10ecf727 21Patch1: unbundle-po.patch
64d9867e
ER
22BuildRequires: QtCore-devel >= %{qtver}
23BuildRequires: QtDBus-devel >= %{qtver}
24BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 25BuildRequires: QtIOCompressor-devel
64d9867e
ER
26BuildRequires: QtNetwork-devel >= %{qtver}
27BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 28BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
29BuildRequires: QtSql-devel >= %{qtver}
30%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
31BuildRequires: QtXml-devel >= %{qtver}
bf1e6952 32BuildRequires: boost-devel
7279ad3f 33BuildRequires: cmake >= 2.6
f823a794 34#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 35BuildRequires: gettext-devel
f823a794 36%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 37BuildRequires: glib2-devel
849a0dcb 38BuildRequires: gstreamer-devel >= 0.10
bf1e6952 39BuildRequires: gtest-devel
8f83a8c0
ER
40BuildRequires: libgpod-devel >= 0.7.92
41BuildRequires: libimobiledevice-devel
2eedc3b1 42BuildRequires: libindicate-qt-devel
e0ba0da9 43BuildRequires: liblastfm-devel >= 0.3.3
8f83a8c0 44BuildRequires: libmtp-devel
8f83a8c0 45BuildRequires: libplist-devel
f823a794 46%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 47BuildRequires: libqxt-devel
8f83a8c0 48BuildRequires: libxml2-devel
75ec0859 49BuildRequires: pkgconfig
2eedc3b1 50BuildRequires: pkgconfig
e0ba0da9
JP
51BuildRequires: protobuf-devel
52BuildRequires: qjson-devel
64d9867e 53BuildRequires: qt4-build >= %{qtver}
b6199a83 54BuildRequires: qt4-linguist
55BuildRequires: qt4-qmake
7aaa97de 56BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 57BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 58BuildRequires: sed >= 4.0
742e4e0a 59%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 60BuildRequires: taglib-devel >= 1.6
8f83a8c0 61BuildRequires: usbmuxd-devel
726826ed 62Requires(post,postun): desktop-file-utils
23941661
AF
63Requires(post,postun): gtk-update-icon-cache
64Requires(post,postun): hicolor-icon-theme
acb98f48 65Requires: QtSingleApplication >= 2.6-4
64d9867e 66%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
4282eb18 67Requires: gstreamer-audio-effects-base
f2d911f2
ER
68# while we do not link (yet), we use datafiles
69Requires: libprojectM
bf1e6952
ER
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
f2d911f2
ER
72# see libprojectM.spec for explanation
73%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
74
bf1e6952
ER
75%description
76Clementine is a modern music player and library organiser. It is
77largely a port of Amarok 1.4, with some features rewritten to take
78advantage of Qt4.
79
df3c0ac1
ZU
80%description -l hu.UTF-8
81Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
82az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
83a Qt4 előnyeit.
84
bf1e6952 85%prep
bf272879 86%setup -q -n %{name}-%{version}
f2d911f2 87%patch0 -p1
10ecf727 88%patch1 -p1
bf1e6952
ER
89
90# We already don't use these but just to make sure
f2d911f2 91rm -rf 3rdparty/gmock
742e4e0a 92%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
93rm -rf 3rdparty/qtsingleapplication
94rm -rf 3rdparty/qxt
95rm -rf 3rdparty/qtiocompressor
aca708d9 96%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 97
7279ad3f 98# Don't build tests. They require gmock
f2d911f2 99sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
100# remove -Wall
101sed -i -e 's/-Wall//' src/CMakeLists.txt
bf1e6952
ER
102
103%build
104install -d build
7aaa97de 105install -d build/src/translations
bf1e6952 106cd build
88ca6f4b 107%cmake \
f2d911f2 108 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 109 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
6bcbdfe8 110 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
111 -DUSE_SYSTEM_QXT=ON \
112 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 113 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 114 ..
bf1e6952
ER
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119%{__make} -C build install \
120 DESTDIR=$RPM_BUILD_ROOT
121
f823a794
ER
122rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
123
10ecf727
ER
124%find_lang %{name} --with-qm
125
23f69c7b
BZ
126install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
127cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
128cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
129
bf1e6952
ER
130%clean
131rm -rf $RPM_BUILD_ROOT
132
726826ed
ER
133%post
134%update_desktop_database_post
2eedc3b1 135%update_icon_cache hicolor
726826ed
ER
136
137%postun
138%update_desktop_database_postun
2eedc3b1 139%update_icon_cache hicolor
726826ed 140
10ecf727 141%files -f %{name}.lang
bf1e6952 142%defattr(644,root,root,755)
e0ba0da9 143%doc Changelog
bf1e6952
ER
144%attr(755,root,root) %{_bindir}/clementine
145%{_desktopdir}/clementine.desktop
7279ad3f 146%{_pixmapsdir}/clementine.png
23f69c7b
BZ
147%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
148%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.069043 seconds and 4 git commands to generate.