]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
Version: 1.1.1
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
2c687024 4#
5# Conditional build:
c6f8dd12 6%bcond_without static_sqlite # with static sqlite3
3834eb29 7%bcond_with static_projectm # with static projectM
0b056df0 8
3834eb29 9%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 10Summary: A music player and library organiser
df3c0ac1 11Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 12Name: clementine
dbbdd85a
JK
13Version: 1.1.1
14Release: 1
bf1e6952
ER
15License: GPL v3 and GPL v2+
16Group: Applications/Multimedia
f823a794 17URL: http://www.clementine-player.org/
bf272879 18Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
dbbdd85a 19# Source0-md5: 28e4afb822388bd337a761db8f86febf
f823a794 20Patch0: desktop-install.patch
10ecf727 21Patch1: unbundle-po.patch
64d9867e
ER
22BuildRequires: QtCore-devel >= %{qtver}
23BuildRequires: QtDBus-devel >= %{qtver}
24BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 25BuildRequires: QtIOCompressor-devel
64d9867e
ER
26BuildRequires: QtNetwork-devel >= %{qtver}
27BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 28BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
29BuildRequires: QtSql-devel >= %{qtver}
30%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
31BuildRequires: QtXml-devel >= %{qtver}
bf1e6952 32BuildRequires: boost-devel
7279ad3f 33BuildRequires: cmake >= 2.6
f823a794 34#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 35BuildRequires: gettext-devel
f823a794 36%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 37BuildRequires: glib2-devel
dbbdd85a
JK
38BuildRequires: gstreamer0.10-devel
39BuildRequires: gstreamer0.10-plugins-base-devel
bf1e6952 40BuildRequires: gtest-devel
8f83a8c0
ER
41BuildRequires: libgpod-devel >= 0.7.92
42BuildRequires: libimobiledevice-devel
2eedc3b1 43BuildRequires: libindicate-qt-devel
e0ba0da9 44BuildRequires: liblastfm-devel >= 0.3.3
8f83a8c0 45BuildRequires: libmtp-devel
8f83a8c0 46BuildRequires: libplist-devel
f823a794 47%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 48BuildRequires: libqxt-devel
8f83a8c0 49BuildRequires: libxml2-devel
75ec0859 50BuildRequires: pkgconfig
2eedc3b1 51BuildRequires: pkgconfig
e0ba0da9
JP
52BuildRequires: protobuf-devel
53BuildRequires: qjson-devel
64d9867e 54BuildRequires: qt4-build >= %{qtver}
b6199a83 55BuildRequires: qt4-linguist
56BuildRequires: qt4-qmake
7aaa97de 57BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 58BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 59BuildRequires: sed >= 4.0
742e4e0a 60%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 61BuildRequires: taglib-devel >= 1.6
8f83a8c0 62BuildRequires: usbmuxd-devel
726826ed 63Requires(post,postun): desktop-file-utils
23941661
AF
64Requires(post,postun): gtk-update-icon-cache
65Requires(post,postun): hicolor-icon-theme
acb98f48 66Requires: QtSingleApplication >= 2.6-4
64d9867e 67%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
dbbdd85a 68Requires: gstreamer0.10-audio-effects-base
f2d911f2
ER
69# while we do not link (yet), we use datafiles
70Requires: libprojectM
bf1e6952
ER
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
f2d911f2
ER
73# see libprojectM.spec for explanation
74%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
75
bf1e6952
ER
76%description
77Clementine is a modern music player and library organiser. It is
78largely a port of Amarok 1.4, with some features rewritten to take
79advantage of Qt4.
80
df3c0ac1
ZU
81%description -l hu.UTF-8
82Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
83az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
84a Qt4 előnyeit.
85
bf1e6952 86%prep
bf272879 87%setup -q -n %{name}-%{version}
f2d911f2 88%patch0 -p1
10ecf727 89%patch1 -p1
bf1e6952
ER
90
91# We already don't use these but just to make sure
f2d911f2 92rm -rf 3rdparty/gmock
742e4e0a 93%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
94rm -rf 3rdparty/qtsingleapplication
95rm -rf 3rdparty/qxt
96rm -rf 3rdparty/qtiocompressor
aca708d9 97%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 98
7279ad3f 99# Don't build tests. They require gmock
f2d911f2 100sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
101# remove -Wall
102sed -i -e 's/-Wall//' src/CMakeLists.txt
bf1e6952
ER
103
104%build
105install -d build
7aaa97de 106install -d build/src/translations
bf1e6952 107cd build
88ca6f4b 108%cmake \
f2d911f2 109 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 110 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
6bcbdfe8 111 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
112 -DUSE_SYSTEM_QXT=ON \
113 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 114 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 115 ..
bf1e6952
ER
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120%{__make} -C build install \
121 DESTDIR=$RPM_BUILD_ROOT
122
f823a794
ER
123rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
124
dbbdd85a
JK
125# not in our glibc?
126rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
127
10ecf727
ER
128%find_lang %{name} --with-qm
129
23f69c7b
BZ
130install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
131cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
132cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
133
bf1e6952
ER
134%clean
135rm -rf $RPM_BUILD_ROOT
136
726826ed
ER
137%post
138%update_desktop_database_post
2eedc3b1 139%update_icon_cache hicolor
726826ed
ER
140
141%postun
142%update_desktop_database_postun
2eedc3b1 143%update_icon_cache hicolor
726826ed 144
10ecf727 145%files -f %{name}.lang
bf1e6952 146%defattr(644,root,root,755)
e0ba0da9 147%doc Changelog
bf1e6952 148%attr(755,root,root) %{_bindir}/clementine
dbbdd85a 149%attr(755,root,root) %{_bindir}/clementine-tagreader
bf1e6952 150%{_desktopdir}/clementine.desktop
7279ad3f 151%{_pixmapsdir}/clementine.png
23f69c7b
BZ
152%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
153%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.099152 seconds and 4 git commands to generate.