]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
ruby-json any version should do
[packages/chef.git] / chef.spec
CommitLineData
4613dfe7 1# NOTE:
10b8ffc4
ER
2# - check releases here: https://downloads.chef.io/chef-client/debian/
3# the versions tagged in github are somewhat newer, perhaps dev-releases
4613dfe7 4
8354a17e
ER
5# Conditional build:
6%bcond_with tests # build without tests
7
e307965b
ER
8Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
9Name: chef
4e5a0fdf 10Version: 14.1.21
a18fec1c 11Release: 0.3
e307965b 12License: Apache v2.0
aabebe0b 13Group: Networking/Admin
10b8ffc4 14Source0: https://github.com/chef/chef/archive/v%{version}/%{name}-%{version}.tar.gz
4e5a0fdf 15# Source0-md5: b67966a9b9e6c0a5947a604239267415
02d95ccd 16Source2: %{name}.tmpfiles
5c13348f
ER
17Source3: https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
18# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
7abbc83b 19Patch0: platform-pld.patch
bc8e6547 20Patch1: FHS.patch
0e535bd2 21Patch2: poldek.patch
7fbe09ae 22Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
33efc2f8 23# Patch3-md5: 8ff0fdfde6dc90018698775bf8f13062
fce4f0b8 24Patch4: optional-plist.patch
64a8eb69 25Patch5: gemdeps.patch
4613dfe7 26URL: https://wiki.opscode.com/display/chef/
303651f6 27BuildRequires: rpm-rubyprov
5c13348f 28BuildRequires: rpmbuild(macros) >= 1.673
68cfa14e
ER
29BuildRequires: sed >= 4.0
30%if %{with tests}
31BuildRequires: ruby-rack
32BuildRequires: ruby-rake
5165006a
ER
33BuildRequires: ruby-rspec-core < 2.15
34BuildRequires: ruby-rspec-core >= 2.14.0
35BuildRequires: ruby-rspec-expectations < 2.15
36BuildRequires: ruby-rspec-expectations >= 2.14.0
37BuildRequires: ruby-rspec-mocks < 2.15
38BuildRequires: ruby-rspec-mocks >= 2.14.0
39BuildRequires: ruby-rspec_junit_formatter
68cfa14e 40%endif
97e7edae 41Requires: lsb-release
31feaf16 42Requires: poldek >= 0.30
f0820095 43Requires: ruby >= 1:1.9.3.429-4
16f49c06 44Requires: ruby-chef-config = %{version}-%{release}
bf7e149a 45Requires: ruby-erubis >= 2.7.0-3
a18fec1c 46Requires: ruby-json
e8757686
ER
47Requires: ruby-mime-types < 2
48Requires: ruby-mime-types >= 1.16
bf7e149a 49Requires: ruby-mixlib-authentication >= 1.3.0-2
e8757686
ER
50Requires: ruby-mixlib-config < 3
51Requires: ruby-mixlib-config >= 2.0
b337cd8c 52Requires: ruby-mixlib-log >= 1.6.0-2
b6745d8f 53Requires: ruby-ohai < 9
2a1bbc08 54Requires: ruby-rest-client >= 1.0.4
bce16be1 55Requires: ruby-rubygems
7798c5f4 56Suggests: chef-zero >= 2.1.4
fce4f0b8 57Suggests: ruby-plist >= 3.1.0
e307965b
ER
58BuildArch: noarch
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
820f7abc
ER
61# do not generate python dependency, yum support is optional
62%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
63
e307965b
ER
64%description
65A systems integration framework, built to bring the benefits of
66configuration management to your entire infrastructure.
67
16f49c06
ER
68%package -n ruby-chef-config
69Summary: Chef's default configuration and config loading
70Group: Development/Languages
16f49c06
ER
71
72%description -n ruby-chef-config
73Chef's default configuration and config loading.
74
5c13348f
ER
75%package -n bash-completion-knife
76Summary: bash-completion for knife
77Summary(pl.UTF-8): bashowe uzupełnianie nazw dla knifea
78Group: Applications/Shells
79Requires: %{name} >= 0.10
80Requires: bash-completion >= 2.0
81
82%description -n bash-completion-knife
83This package provides bash-completion for knife.
84
85%description -n bash-completion-knife -l pl.UTF-8
86Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
87
be8cf7bb
ER
88%package -n knife
89Summary: knife - Chef Server API client utility
aabebe0b 90Group: Networking/Admin
be8cf7bb
ER
91Requires: %{name} = %{version}-%{release}
92
93%description -n knife
94Knife is a command-line utility used to manage data on a Chef server
95through the HTTP(S) API. Knife is organized into groups of subcommands
96centered around the various object types in Chef. Each category of
97subcommand is documented in its own manual page.
98
e307965b 99%prep
10b8ffc4 100%setup -q
c8ed2d9c 101#%patch0 -p1 # UPDATE
bc8e6547 102%patch1 -p1
31feaf16 103%patch2 -p1
7fbe09ae 104%patch3 -p1
fce4f0b8 105%patch4 -p1
64a8eb69 106%patch5 -p1
e307965b 107
68cfa14e
ER
108%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
109
10b8ffc4
ER
110%ifos linux
111# those do not match s.executables from .gemspec
112rm bin/chef-service-manager
113rm bin/chef-windows-service
114%endif
115
4530c37b
ER
116# don't package this, a maintainer's rake task
117rm chef-config/lib/chef-config/package_task.rb
118
5165006a
ER
119# cleanup backups after patching
120find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
121
10b8ffc4 122grep --exclude-dir=spec --exclude-dir=distro --exclude=CHANGELOG.md -r /var/chef . && exit 1
5165006a 123
8354a17e 124%build
1dc7ecda
ER
125# make gemspec self-contained
126%__gem_helper spec-dump %{name}.gemspec
127
8354a17e
ER
128%if %{with tests}
129rspec spec
130%endif
131
1dc7ecda
ER
132cd chef-config
133# make gemspec self-contained
134%__gem_helper spec-dump %{name}-config.gemspec
135
e307965b
ER
136%install
137rm -rf $RPM_BUILD_ROOT
4e5a0fdf 138install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_bindir},%{systemdtmpfilesdir}} \
f972dda7 139 $RPM_BUILD_ROOT%{ruby_vendorlibdir}/chef/reporting \
1dc7ecda 140 $RPM_BUILD_ROOT%{ruby_specdir} \
66e54417 141 $RPM_BUILD_ROOT/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,reports,backup}}
66164e90 142
16f49c06 143# chef
68cfa14e 144cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 145cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
1dc7ecda 146cp -p chef-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
e307965b 147
16f49c06
ER
148# chef-config
149cp -a chef-config/lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
1dc7ecda 150cp -p chef-config/chef-config-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
16f49c06 151
02d95ccd 152cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 153
5c13348f
ER
154install -d $RPM_BUILD_ROOT%{bash_compdir}
155cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
156
bce16be1
ER
157%clean
158rm -rf $RPM_BUILD_ROOT
159
e307965b
ER
160%files
161%defattr(644,root,root,755)
2a1bbc08 162%doc README.md CONTRIBUTING.md
303651f6 163%dir %{_sysconfdir}/%{name}
2a1bbc08 164%attr(755,root,root) %{_bindir}/chef-apply
e307965b 165%attr(755,root,root) %{_bindir}/chef-client
4e5a0fdf 166%attr(755,root,root) %{_bindir}/chef-resource-inspector
2a1bbc08 167%attr(755,root,root) %{_bindir}/chef-shell
e307965b 168%attr(755,root,root) %{_bindir}/chef-solo
be8cf7bb
ER
169%{ruby_vendorlibdir}/chef.rb
170%{ruby_vendorlibdir}/chef
1dc7ecda 171%{ruby_specdir}/chef-%{version}.gemspec
be8cf7bb
ER
172%exclude %{ruby_vendorlibdir}/chef/knife
173%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
174%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
175%exclude %{ruby_vendorlibdir}/chef/knife.rb
176%{systemdtmpfilesdir}/chef.conf
177
178%dir /var/lib/%{name}
179%dir /var/lib/%{name}/roles
180%dir /var/lib/%{name}/data_bags
181%dir /var/lib/%{name}/environments
66e54417 182%dir /var/lib/%{name}/reports
7e5aff6c 183%dir %attr(750,root,root) /var/lib/%{name}/backup
be8cf7bb
ER
184
185%dir /var/cache/%{name}
186%dir /var/run/%{name}
187
16f49c06
ER
188%files -n ruby-chef-config
189%defattr(644,root,root,755)
190%{ruby_vendorlibdir}/chef-config.rb
191%{ruby_vendorlibdir}/chef-config
1dc7ecda 192%{ruby_specdir}/chef-config-%{version}.gemspec
16f49c06 193
be8cf7bb
ER
194%files -n knife
195%defattr(644,root,root,755)
196%attr(755,root,root) %{_bindir}/knife
197%{ruby_vendorlibdir}/chef/knife.rb
198%{ruby_vendorlibdir}/chef/knife
199%{ruby_vendorlibdir}/chef/application/knife.rb
200%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
303651f6 201
5c13348f
ER
202%files -n bash-completion-knife
203%defattr(644,root,root,755)
204%{bash_compdir}/knife
This page took 0.196497 seconds and 4 git commands to generate.