]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
add platform pld support, packages installed with yum
[packages/chef.git] / chef.spec
CommitLineData
bce16be1
ER
1# TODO
2# - try not to use /var/chef
e307965b
ER
3Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
4Name: chef
2a1bbc08 5Version: 11.4.0
7abbc83b 6Release: 0.7
e307965b
ER
7License: Apache v2.0
8Group: Development/Languages
e307965b 9Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
2a1bbc08 10# Source0-md5: 1ebabd6fdeae44a99d5cb199c38adc15
7abbc83b 11Patch0: platform-pld.patch
2a1bbc08 12URL: http://wiki.opscode.com/display/chef
303651f6
ER
13BuildRequires: rpm-rubyprov
14BuildRequires: rpmbuild(macros) >= 1.656
97e7edae 15Requires: lsb-release
e307965b 16Requires: ruby >= 1:1.8.7
bce16be1 17Requires: ruby-erubis
2a1bbc08
ER
18Requires: ruby-highline >= 1.6.9
19Requires: ruby-json <= 1.7.7
20Requires: ruby-json >= 1.4.4
21Requires: ruby-mixlib-authentication >= 1.3.0
22Requires: ruby-mixlib-cli >= 1.3.0
bce16be1
ER
23Requires: ruby-mixlib-config >= 1.1.2
24Requires: ruby-mixlib-log >= 1.3.0
2a1bbc08
ER
25Requires: ruby-mixlib-shellout
26Requires: ruby-net-ssh >= 2.6
27Requires: ruby-net-ssh-multi >= 1.1.0
28Requires: ruby-ohai >= 0.6.0
29Requires: ruby-rest-client < 1.7.0
30Requires: ruby-rest-client >= 1.0.4
bce16be1 31Requires: ruby-rubygems
2a1bbc08 32Requires: ruby-yajl >= 1.1
7abbc83b 33Requires: yum
e307965b
ER
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38A systems integration framework, built to bring the benefits of
39configuration management to your entire infrastructure.
40
41%prep
303651f6 42%setup -q
7abbc83b 43%patch0 -p1
e307965b
ER
44
45%install
46rm -rf $RPM_BUILD_ROOT
47install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
e307965b
ER
48cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
49cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
50
303651f6
ER
51install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var}/%{name}
52
bce16be1
ER
53%clean
54rm -rf $RPM_BUILD_ROOT
55
e307965b
ER
56%files
57%defattr(644,root,root,755)
2a1bbc08 58%doc README.md CONTRIBUTING.md
303651f6 59%dir %{_sysconfdir}/%{name}
2a1bbc08 60%attr(755,root,root) %{_bindir}/chef-apply
e307965b 61%attr(755,root,root) %{_bindir}/chef-client
2a1bbc08 62%attr(755,root,root) %{_bindir}/chef-shell
e307965b
ER
63%attr(755,root,root) %{_bindir}/chef-solo
64%attr(755,root,root) %{_bindir}/knife
65%attr(755,root,root) %{_bindir}/shef
66%{ruby_rubylibdir}/chef.rb
67%{ruby_rubylibdir}/chef
303651f6
ER
68
69# FIXME: FHS
70%dir /var/%{name}
This page took 0.133814 seconds and 4 git commands to generate.