]> git.pld-linux.org Git - packages/chef.git/commitdiff
add platform pld support, packages installed with yum
authorElan Ruusamäe <glen@delfi.ee>
Sun, 14 Apr 2013 18:39:56 +0000 (21:39 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 14 Apr 2013 18:39:56 +0000 (21:39 +0300)
chef.spec
platform-pld.patch [new file with mode: 0644]

index acc737e293aae7b8d7b722be52c2562f6387d707..419b46ed4026b60e24adcc2626498aab42f7ee6d 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -3,11 +3,12 @@
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
 Version:       11.4.0
-Release:       0.5
+Release:       0.7
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
 # Source0-md5: 1ebabd6fdeae44a99d5cb199c38adc15
+Patch0:                platform-pld.patch
 URL:           http://wiki.opscode.com/display/chef
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.656
@@ -29,6 +30,7 @@ Requires:     ruby-rest-client < 1.7.0
 Requires:      ruby-rest-client >= 1.0.4
 Requires:      ruby-rubygems
 Requires:      ruby-yajl >= 1.1
+Requires:      yum
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -38,6 +40,7 @@ configuration management to your entire infrastructure.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
diff --git a/platform-pld.patch b/platform-pld.patch
new file mode 100644 (file)
index 0000000..c60bf64
--- /dev/null
@@ -0,0 +1,17 @@
+--- chef-11.4.0/lib/chef/platform.rb~  2013-04-14 16:43:01.000000000 +0300
++++ chef-11.4.0/lib/chef/platform.rb   2013-04-14 21:34:43.907576130 +0300
+@@ -147,6 +147,14 @@
+               :mdadm => Chef::Provider::Mdadm
+             }
+           },
++          :pld => {
++            :default => {
++              :service => Chef::Provider::Service::Redhat,
++              :cron => Chef::Provider::Cron,
++              :package => Chef::Provider::Package::Yum,
++              :mdadm => Chef::Provider::Mdadm
++            }
++          },
+           :suse     => {
+             :default => {
+               :service => Chef::Provider::Service::Redhat,
This page took 0.097345 seconds and 4 git commands to generate.