]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
add sample chef.rb config
[packages/chef.git] / chef.spec
CommitLineData
8354a17e
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
e307965b
ER
5Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6Name: chef
68cfa14e 7Version: 11.4.4
55a45456 8Release: 1
e307965b
ER
9License: Apache v2.0
10Group: Development/Languages
e307965b 11Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
68cfa14e 12# Source0-md5: dc50aa6a4a7d4785a4c82fcaab3f9436
5cb2f1b0 13Source1: %{name}.rb
7abbc83b 14Patch0: platform-pld.patch
bc8e6547 15Patch1: FHS.patch
2a1bbc08 16URL: http://wiki.opscode.com/display/chef
303651f6
ER
17BuildRequires: rpm-rubyprov
18BuildRequires: rpmbuild(macros) >= 1.656
68cfa14e
ER
19BuildRequires: sed >= 4.0
20%if %{with tests}
8354a17e
ER
21BuildRequires: ruby-abstract
22BuildRequires: ruby-mixlib-authentication >= 1.3.0
55a45456 23BuildRequires: ruby-net-ssh-multi >= 1.1.0
68cfa14e
ER
24BuildRequires: ruby-rack
25BuildRequires: ruby-rake
8354a17e 26#BuildRequires: ruby-rdoc
55a45456 27BuildRequires: ruby-rest-client >= 1.0.4
68cfa14e
ER
28BuildRequires: ruby-rspec-core >= 2.12.0
29BuildRequires: ruby-rspec-expectations >= 2.12.0
30BuildRequires: ruby-rspec-mocks >= 2.12.0
8354a17e
ER
31#BuildRequires: ruby-rspec_junit_formatter
32#BuildRequires: ruby-sdoc
68cfa14e 33%endif
97e7edae 34Requires: lsb-release
bce16be1 35Requires: ruby-erubis
2a1bbc08 36Requires: ruby-highline >= 1.6.9
2a1bbc08
ER
37Requires: ruby-json >= 1.4.4
38Requires: ruby-mixlib-authentication >= 1.3.0
39Requires: ruby-mixlib-cli >= 1.3.0
bce16be1
ER
40Requires: ruby-mixlib-config >= 1.1.2
41Requires: ruby-mixlib-log >= 1.3.0
2a1bbc08
ER
42Requires: ruby-mixlib-shellout
43Requires: ruby-net-ssh >= 2.6
44Requires: ruby-net-ssh-multi >= 1.1.0
45Requires: ruby-ohai >= 0.6.0
2a1bbc08 46Requires: ruby-rest-client >= 1.0.4
bce16be1 47Requires: ruby-rubygems
2a1bbc08 48Requires: ruby-yajl >= 1.1
68cfa14e 49Requires: yum >= 3.4.3-7
e307965b
ER
50BuildArch: noarch
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54A systems integration framework, built to bring the benefits of
55configuration management to your entire infrastructure.
56
57%prep
303651f6 58%setup -q
7abbc83b 59%patch0 -p1
bc8e6547 60%patch1 -p1
e307965b 61
68cfa14e
ER
62%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
63
8354a17e
ER
64%build
65%if %{with tests}
66rspec spec
67%endif
68
e307965b
ER
69%install
70rm -rf $RPM_BUILD_ROOT
bc8e6547
ER
71install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}} \
72 $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
68cfa14e 73cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 74cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
e307965b 75
5cb2f1b0 76cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
303651f6 77
bce16be1
ER
78%clean
79rm -rf $RPM_BUILD_ROOT
80
e307965b
ER
81%files
82%defattr(644,root,root,755)
2a1bbc08 83%doc README.md CONTRIBUTING.md
303651f6 84%dir %{_sysconfdir}/%{name}
5cb2f1b0 85%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 86%attr(755,root,root) %{_bindir}/chef-apply
e307965b 87%attr(755,root,root) %{_bindir}/chef-client
2a1bbc08 88%attr(755,root,root) %{_bindir}/chef-shell
e307965b
ER
89%attr(755,root,root) %{_bindir}/chef-solo
90%attr(755,root,root) %{_bindir}/knife
91%attr(755,root,root) %{_bindir}/shef
68cfa14e
ER
92%{ruby_vendorlibdir}/chef.rb
93%{ruby_vendorlibdir}/chef
303651f6 94
bc8e6547
ER
95%dir /var/lib/%{name}
96%dir /var/cache/%{name}
This page took 0.084025 seconds and 4 git commands to generate.