]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
up to 11.4.4, update deps
[packages/chef.git] / chef.spec
CommitLineData
bce16be1
ER
1# TODO
2# - try not to use /var/chef
e307965b
ER
3Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
4Name: chef
68cfa14e
ER
5Version: 11.4.4
6Release: 0.11
e307965b
ER
7License: Apache v2.0
8Group: Development/Languages
e307965b 9Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
68cfa14e 10# Source0-md5: dc50aa6a4a7d4785a4c82fcaab3f9436
7abbc83b 11Patch0: platform-pld.patch
2a1bbc08 12URL: http://wiki.opscode.com/display/chef
303651f6
ER
13BuildRequires: rpm-rubyprov
14BuildRequires: rpmbuild(macros) >= 1.656
68cfa14e
ER
15BuildRequires: sed >= 4.0
16%if %{with tests}
17BuildRequires: ruby-rack
18BuildRequires: ruby-rake
19BuildRequires: ruby-rdoc
20BuildRequires: ruby-rspec-core >= 2.12.0
21BuildRequires: ruby-rspec-expectations >= 2.12.0
22BuildRequires: ruby-rspec-mocks >= 2.12.0
23BuildRequires: ruby-rspec_junit_formatter
24BuildRequires: ruby-sdoc
25%endif
97e7edae 26Requires: lsb-release
bce16be1 27Requires: ruby-erubis
2a1bbc08 28Requires: ruby-highline >= 1.6.9
2a1bbc08
ER
29Requires: ruby-json >= 1.4.4
30Requires: ruby-mixlib-authentication >= 1.3.0
31Requires: ruby-mixlib-cli >= 1.3.0
bce16be1
ER
32Requires: ruby-mixlib-config >= 1.1.2
33Requires: ruby-mixlib-log >= 1.3.0
2a1bbc08
ER
34Requires: ruby-mixlib-shellout
35Requires: ruby-net-ssh >= 2.6
36Requires: ruby-net-ssh-multi >= 1.1.0
37Requires: ruby-ohai >= 0.6.0
2a1bbc08 38Requires: ruby-rest-client >= 1.0.4
bce16be1 39Requires: ruby-rubygems
2a1bbc08 40Requires: ruby-yajl >= 1.1
68cfa14e 41Requires: yum >= 3.4.3-7
e307965b
ER
42BuildArch: noarch
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46A systems integration framework, built to bring the benefits of
47configuration management to your entire infrastructure.
48
49%prep
303651f6 50%setup -q
7abbc83b 51%patch0 -p1
e307965b 52
68cfa14e
ER
53%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
54
e307965b
ER
55%install
56rm -rf $RPM_BUILD_ROOT
68cfa14e
ER
57install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
58cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 59cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
e307965b 60
303651f6
ER
61install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var}/%{name}
62
bce16be1
ER
63%clean
64rm -rf $RPM_BUILD_ROOT
65
e307965b
ER
66%files
67%defattr(644,root,root,755)
2a1bbc08 68%doc README.md CONTRIBUTING.md
303651f6 69%dir %{_sysconfdir}/%{name}
2a1bbc08 70%attr(755,root,root) %{_bindir}/chef-apply
e307965b 71%attr(755,root,root) %{_bindir}/chef-client
2a1bbc08 72%attr(755,root,root) %{_bindir}/chef-shell
e307965b
ER
73%attr(755,root,root) %{_bindir}/chef-solo
74%attr(755,root,root) %{_bindir}/knife
75%attr(755,root,root) %{_bindir}/shef
68cfa14e
ER
76%{ruby_vendorlibdir}/chef.rb
77%{ruby_vendorlibdir}/chef
303651f6
ER
78
79# FIXME: FHS
80%dir /var/%{name}
This page took 0.067767 seconds and 4 git commands to generate.