]> git.pld-linux.org Git - packages/chef.git/commitdiff
up to 11.4.4, update deps
authorElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 22:30:11 +0000 (01:30 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 22:30:11 +0000 (01:30 +0300)
chef.spec

index 419b46ed4026b60e24adcc2626498aab42f7ee6d..e8a6017a37589560b0a6d890f003654b7c824f7c 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -2,21 +2,30 @@
 # - try not to use /var/chef
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
-Version:       11.4.0
-Release:       0.7
+Version:       11.4.4
+Release:       0.11
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
-# Source0-md5: 1ebabd6fdeae44a99d5cb199c38adc15
+# Source0-md5: dc50aa6a4a7d4785a4c82fcaab3f9436
 Patch0:                platform-pld.patch
 URL:           http://wiki.opscode.com/display/chef
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.656
+BuildRequires: sed >= 4.0
+%if %{with tests}
+BuildRequires: ruby-rack
+BuildRequires: ruby-rake
+BuildRequires: ruby-rdoc
+BuildRequires: ruby-rspec-core >= 2.12.0
+BuildRequires: ruby-rspec-expectations >= 2.12.0
+BuildRequires: ruby-rspec-mocks >= 2.12.0
+BuildRequires: ruby-rspec_junit_formatter
+BuildRequires: ruby-sdoc
+%endif
 Requires:      lsb-release
-Requires:      ruby >= 1:1.8.7
 Requires:      ruby-erubis
 Requires:      ruby-highline >= 1.6.9
-Requires:      ruby-json <= 1.7.7
 Requires:      ruby-json >= 1.4.4
 Requires:      ruby-mixlib-authentication >= 1.3.0
 Requires:      ruby-mixlib-cli >= 1.3.0
@@ -26,11 +35,10 @@ Requires:   ruby-mixlib-shellout
 Requires:      ruby-net-ssh >= 2.6
 Requires:      ruby-net-ssh-multi >= 1.1.0
 Requires:      ruby-ohai >= 0.6.0
-Requires:      ruby-rest-client < 1.7.0
 Requires:      ruby-rest-client >= 1.0.4
 Requires:      ruby-rubygems
 Requires:      ruby-yajl >= 1.1
-Requires:      yum
+Requires:      yum >= 3.4.3-7
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -42,11 +50,13 @@ configuration management to your entire infrastructure.
 %setup -q
 %patch0 -p1
 
+%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
+
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
+install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
+cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
-cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
 
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var}/%{name}
 
@@ -63,8 +73,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/chef-solo
 %attr(755,root,root) %{_bindir}/knife
 %attr(755,root,root) %{_bindir}/shef
-%{ruby_rubylibdir}/chef.rb
-%{ruby_rubylibdir}/chef
+%{ruby_vendorlibdir}/chef.rb
+%{ruby_vendorlibdir}/chef
 
 # FIXME: FHS
 %dir /var/%{name}
This page took 0.039168 seconds and 4 git commands to generate.