]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
R iproute2 for /sbin/ip and ohai to detect ips properly
[packages/chef.git] / chef.spec
CommitLineData
8354a17e
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
e307965b
ER
5Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6Name: chef
0769c463 7Version: 11.6.2
bb312a69 8Release: 6
e307965b
ER
9License: Apache v2.0
10Group: Development/Languages
e307965b 11Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
0769c463 12# Source0-md5: 8db9eb4b3c75be30e8125ea4eedd3f01
5cb2f1b0 13Source1: %{name}.rb
02d95ccd 14Source2: %{name}.tmpfiles
7abbc83b 15Patch0: platform-pld.patch
bc8e6547 16Patch1: FHS.patch
31feaf16 17Patch2: https://github.com/glensc/chef/compare/poldek.patch
3f49fa87 18# Patch2-md5: 5a0fc35de33910b41cba4e87dcb4bf9a
7fbe09ae 19Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
4852435c 20# Patch3-md5: 8ff0fdfde6dc90018698775bf8f13062
2a1bbc08 21URL: http://wiki.opscode.com/display/chef
303651f6
ER
22BuildRequires: rpm-rubyprov
23BuildRequires: rpmbuild(macros) >= 1.656
68cfa14e
ER
24BuildRequires: sed >= 4.0
25%if %{with tests}
8354a17e 26BuildRequires: ruby-abstract
f0820095
ER
27BuildRequires: ruby-chef-zero < 2
28BuildRequires: ruby-chef-zero >= 1.4
8354a17e 29BuildRequires: ruby-mixlib-authentication >= 1.3.0
55a45456 30BuildRequires: ruby-net-ssh-multi >= 1.1.0
f0820095
ER
31BuildRequires: ruby-puma < 2
32BuildRequires: ruby-puma >= 1.6
68cfa14e
ER
33BuildRequires: ruby-rack
34BuildRequires: ruby-rake
8354a17e 35#BuildRequires: ruby-rdoc
55a45456 36BuildRequires: ruby-rest-client >= 1.0.4
68cfa14e
ER
37BuildRequires: ruby-rspec-core >= 2.12.0
38BuildRequires: ruby-rspec-expectations >= 2.12.0
39BuildRequires: ruby-rspec-mocks >= 2.12.0
8354a17e
ER
40#BuildRequires: ruby-rspec_junit_formatter
41#BuildRequires: ruby-sdoc
68cfa14e 42%endif
3bda27fd 43Requires: diffutils
bb312a69 44Requires: iproute2
97e7edae 45Requires: lsb-release
31feaf16 46Requires: poldek >= 0.30
f0820095 47Requires: ruby >= 1:1.9.3.429-4
bce16be1 48Requires: ruby-erubis
2a1bbc08 49Requires: ruby-highline >= 1.6.9
2a1bbc08
ER
50Requires: ruby-json >= 1.4.4
51Requires: ruby-mixlib-authentication >= 1.3.0
52Requires: ruby-mixlib-cli >= 1.3.0
bce16be1
ER
53Requires: ruby-mixlib-config >= 1.1.2
54Requires: ruby-mixlib-log >= 1.3.0
2a1bbc08
ER
55Requires: ruby-mixlib-shellout
56Requires: ruby-net-ssh >= 2.6
57Requires: ruby-net-ssh-multi >= 1.1.0
58Requires: ruby-ohai >= 0.6.0
2a1bbc08 59Requires: ruby-rest-client >= 1.0.4
bce16be1 60Requires: ruby-rubygems
2a1bbc08 61Requires: ruby-yajl >= 1.1
e307965b
ER
62BuildArch: noarch
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
820f7abc
ER
65# do not generate python dependency, yum support is optional
66%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
67
e307965b
ER
68%description
69A systems integration framework, built to bring the benefits of
70configuration management to your entire infrastructure.
71
72%prep
303651f6 73%setup -q
7abbc83b 74%patch0 -p1
bc8e6547 75%patch1 -p1
31feaf16 76%patch2 -p1
7fbe09ae 77%patch3 -p1
e307965b 78
a58665ad
ER
79grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
80
68cfa14e
ER
81%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
82
8354a17e
ER
83%build
84%if %{with tests}
85rspec spec
86%endif
87
e307965b
ER
88%install
89rm -rf $RPM_BUILD_ROOT
02d95ccd 90install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
e3f1b868 91 $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}}
66164e90 92
68cfa14e 93cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 94cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 95cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
e307965b 96
5cb2f1b0 97cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
02d95ccd 98cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 99
bce16be1
ER
100%clean
101rm -rf $RPM_BUILD_ROOT
102
e307965b
ER
103%files
104%defattr(644,root,root,755)
2a1bbc08 105%doc README.md CONTRIBUTING.md
303651f6 106%dir %{_sysconfdir}/%{name}
5cb2f1b0 107%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 108%attr(755,root,root) %{_bindir}/chef-apply
e307965b 109%attr(755,root,root) %{_bindir}/chef-client
f0820095 110%attr(755,root,root) %{_bindir}/chef-service-manager
2a1bbc08 111%attr(755,root,root) %{_bindir}/chef-shell
e307965b
ER
112%attr(755,root,root) %{_bindir}/chef-solo
113%attr(755,root,root) %{_bindir}/knife
114%attr(755,root,root) %{_bindir}/shef
958b507e
ER
115%{_mandir}/man1/chef-shell.1*
116%{_mandir}/man1/knife-bootstrap.1*
117%{_mandir}/man1/knife-client.1*
118%{_mandir}/man1/knife-configure.1*
119%{_mandir}/man1/knife-cookbook-site.1*
120%{_mandir}/man1/knife-cookbook.1*
121%{_mandir}/man1/knife-data-bag.1*
122%{_mandir}/man1/knife-environment.1*
123%{_mandir}/man1/knife-exec.1*
124%{_mandir}/man1/knife-index.1*
125%{_mandir}/man1/knife-node.1*
126%{_mandir}/man1/knife-role.1*
127%{_mandir}/man1/knife-search.1*
128%{_mandir}/man1/knife-ssh.1*
129%{_mandir}/man1/knife-status.1*
130%{_mandir}/man1/knife-tag.1*
131%{_mandir}/man1/knife.1*
132%{_mandir}/man8/chef-client.8*
133%{_mandir}/man8/chef-expander.8*
134%{_mandir}/man8/chef-expanderctl.8*
135%{_mandir}/man8/chef-server-webui.8*
136%{_mandir}/man8/chef-server.8*
137%{_mandir}/man8/chef-solo.8*
138%{_mandir}/man8/chef-solr.8*
68cfa14e
ER
139%{ruby_vendorlibdir}/chef.rb
140%{ruby_vendorlibdir}/chef
02d95ccd 141%{systemdtmpfilesdir}/chef.conf
303651f6 142
bc8e6547 143%dir /var/lib/%{name}
66164e90
ER
144%dir /var/lib/%{name}/roles
145%dir /var/lib/%{name}/data_bags
146%dir /var/lib/%{name}/environments
e3f1b868 147%dir %attr(750,root,root) /var/lib/%{name}/backup
66164e90 148
bc8e6547 149%dir /var/cache/%{name}
02d95ccd 150%dir /var/run/%{name}
This page took 0.132503 seconds and 4 git commands to generate.