]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
do not require plist when not using the feature
[packages/chef.git] / chef.spec
CommitLineData
4613dfe7
ER
1# NOTE:
2# - check releases here: https://github.com/opscode/chef/releases
3
8354a17e
ER
4# Conditional build:
5%bcond_with tests # build without tests
6
e307965b
ER
7Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
8Name: chef
05d6135c
ER
9Version: 11.14.6
10Release: 1
e307965b 11License: Apache v2.0
aabebe0b 12Group: Networking/Admin
e307965b 13Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
05d6135c 14# Source0-md5: 0a7dbf9c3b7b9e285de034031faf008f
5cb2f1b0 15Source1: %{name}.rb
02d95ccd 16Source2: %{name}.tmpfiles
5c13348f
ER
17Source3: https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
18# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
7abbc83b 19Patch0: platform-pld.patch
bc8e6547 20Patch1: FHS.patch
0e535bd2 21Patch2: poldek.patch
7fbe09ae 22Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
33efc2f8 23# Patch3-md5: 8ff0fdfde6dc90018698775bf8f13062
fce4f0b8 24Patch4: optional-plist.patch
4613dfe7 25URL: https://wiki.opscode.com/display/chef/
303651f6 26BuildRequires: rpm-rubyprov
5c13348f 27BuildRequires: rpmbuild(macros) >= 1.673
68cfa14e
ER
28BuildRequires: sed >= 4.0
29%if %{with tests}
30BuildRequires: ruby-rack
31BuildRequires: ruby-rake
5165006a
ER
32BuildRequires: ruby-rspec-core < 2.15
33BuildRequires: ruby-rspec-core >= 2.14.0
34BuildRequires: ruby-rspec-expectations < 2.15
35BuildRequires: ruby-rspec-expectations >= 2.14.0
36BuildRequires: ruby-rspec-mocks < 2.15
37BuildRequires: ruby-rspec-mocks >= 2.14.0
38BuildRequires: ruby-rspec_junit_formatter
68cfa14e 39%endif
97e7edae 40Requires: lsb-release
31feaf16 41Requires: poldek >= 0.30
f0820095 42Requires: ruby >= 1:1.9.3.429-4
e8757686 43Requires: ruby-diff-lcs < 2
e8757686 44Requires: ruby-diff-lcs >= 1.2.4
5165006a 45Requires: ruby-erubis < 3
bf7e149a 46Requires: ruby-erubis >= 2.7.0-3
5165006a 47Requires: ruby-highline < 2
2a1bbc08 48Requires: ruby-highline >= 1.6.9
5165006a 49Requires: ruby-json <= 1.8.1
2a1bbc08 50Requires: ruby-json >= 1.4.4
e8757686
ER
51Requires: ruby-mime-types < 2
52Requires: ruby-mime-types >= 1.16
5165006a 53Requires: ruby-mixlib-authentication < 2
bf7e149a 54Requires: ruby-mixlib-authentication >= 1.3.0-2
5165006a
ER
55Requires: ruby-mixlib-cli < 2
56Requires: ruby-mixlib-cli >= 1.4
e8757686
ER
57Requires: ruby-mixlib-config < 3
58Requires: ruby-mixlib-config >= 2.0
5165006a 59Requires: ruby-mixlib-log < 2
b337cd8c 60Requires: ruby-mixlib-log >= 1.6.0-2
24ed2278 61Requires: ruby-mixlib-shellout >= 1.4
5165006a 62Requires: ruby-net-ssh < 3
2a1bbc08 63Requires: ruby-net-ssh >= 2.6
5165006a
ER
64Requires: ruby-net-ssh-multi < 2
65Requires: ruby-net-ssh-multi >= 1.1
24ed2278 66Requires: ruby-ohai < 8
e8757686 67Requires: ruby-ohai >= 6.0
5165006a 68Requires: ruby-rest-client < 1.7.0
2a1bbc08 69Requires: ruby-rest-client >= 1.0.4
bce16be1 70Requires: ruby-rubygems
5165006a 71Requires: ruby-yajl < 2
2a1bbc08 72Requires: ruby-yajl >= 1.1
24ed2278 73Suggests: chef-zero >= 2.0
fce4f0b8 74Suggests: ruby-plist >= 3.1.0
e307965b
ER
75BuildArch: noarch
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
820f7abc
ER
78# do not generate python dependency, yum support is optional
79%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
80
e307965b
ER
81%description
82A systems integration framework, built to bring the benefits of
83configuration management to your entire infrastructure.
84
5c13348f
ER
85%package -n bash-completion-knife
86Summary: bash-completion for knife
87Summary(pl.UTF-8): bashowe uzupełnianie nazw dla knifea
88Group: Applications/Shells
89Requires: %{name} >= 0.10
90Requires: bash-completion >= 2.0
91
92%description -n bash-completion-knife
93This package provides bash-completion for knife.
94
95%description -n bash-completion-knife -l pl.UTF-8
96Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
97
be8cf7bb
ER
98%package -n knife
99Summary: knife - Chef Server API client utility
aabebe0b 100Group: Networking/Admin
be8cf7bb
ER
101Requires: %{name} = %{version}-%{release}
102
103%description -n knife
104Knife is a command-line utility used to manage data on a Chef server
105through the HTTP(S) API. Knife is organized into groups of subcommands
106centered around the various object types in Chef. Each category of
107subcommand is documented in its own manual page.
108
e307965b 109%prep
303651f6 110%setup -q
5e5186a8 111gzip -d metadata
7abbc83b 112%patch0 -p1
bc8e6547 113%patch1 -p1
31feaf16 114%patch2 -p1
7fbe09ae 115%patch3 -p1
fce4f0b8 116%patch4 -p1
e307965b 117
68cfa14e
ER
118%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
119
5165006a
ER
120# cleanup backups after patching
121find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
122
123grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
124
8354a17e
ER
125%build
126%if %{with tests}
127rspec spec
128%endif
129
e307965b
ER
130%install
131rm -rf $RPM_BUILD_ROOT
f972dda7
ER
132install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
133 $RPM_BUILD_ROOT%{ruby_vendorlibdir}/chef/reporting \
134 $RPM_BUILD_ROOT/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}
66164e90 135
68cfa14e 136cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 137cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 138cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
23fa8236 139%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/README.md
e307965b 140
5cb2f1b0 141cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
02d95ccd 142cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 143
5c13348f
ER
144install -d $RPM_BUILD_ROOT%{bash_compdir}
145cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
146
bce16be1
ER
147%clean
148rm -rf $RPM_BUILD_ROOT
149
e307965b
ER
150%files
151%defattr(644,root,root,755)
2a1bbc08 152%doc README.md CONTRIBUTING.md
303651f6 153%dir %{_sysconfdir}/%{name}
5cb2f1b0 154%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 155%attr(755,root,root) %{_bindir}/chef-apply
e307965b 156%attr(755,root,root) %{_bindir}/chef-client
f0820095 157%attr(755,root,root) %{_bindir}/chef-service-manager
2a1bbc08 158%attr(755,root,root) %{_bindir}/chef-shell
e307965b 159%attr(755,root,root) %{_bindir}/chef-solo
e307965b 160%attr(755,root,root) %{_bindir}/shef
958b507e 161%{_mandir}/man1/chef-shell.1*
be8cf7bb
ER
162%{_mandir}/man8/chef-client.8*
163%{_mandir}/man8/chef-solo.8*
164%{ruby_vendorlibdir}/chef.rb
165%{ruby_vendorlibdir}/chef
166%exclude %{ruby_vendorlibdir}/chef/knife
167%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
168%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
169%exclude %{ruby_vendorlibdir}/chef/knife.rb
170%{systemdtmpfilesdir}/chef.conf
171
172%dir /var/lib/%{name}
173%dir /var/lib/%{name}/roles
174%dir /var/lib/%{name}/data_bags
175%dir /var/lib/%{name}/environments
7e5aff6c 176%dir %attr(750,root,root) /var/lib/%{name}/backup
be8cf7bb
ER
177
178%dir /var/cache/%{name}
179%dir /var/run/%{name}
180
181%files -n knife
182%defattr(644,root,root,755)
183%attr(755,root,root) %{_bindir}/knife
184%{ruby_vendorlibdir}/chef/knife.rb
185%{ruby_vendorlibdir}/chef/knife
186%{ruby_vendorlibdir}/chef/application/knife.rb
187%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
958b507e
ER
188%{_mandir}/man1/knife-bootstrap.1*
189%{_mandir}/man1/knife-client.1*
190%{_mandir}/man1/knife-configure.1*
191%{_mandir}/man1/knife-cookbook-site.1*
192%{_mandir}/man1/knife-cookbook.1*
193%{_mandir}/man1/knife-data-bag.1*
23fa8236
ER
194%{_mandir}/man1/knife-delete.1*
195%{_mandir}/man1/knife-deps.1*
196%{_mandir}/man1/knife-diff.1*
197%{_mandir}/man1/knife-download.1*
198%{_mandir}/man1/knife-edit.1*
958b507e
ER
199%{_mandir}/man1/knife-environment.1*
200%{_mandir}/man1/knife-exec.1*
23fa8236
ER
201%{_mandir}/man1/knife-index-rebuild.1*
202%{_mandir}/man1/knife-list.1*
958b507e 203%{_mandir}/man1/knife-node.1*
23fa8236
ER
204%{_mandir}/man1/knife-raw.1*
205%{_mandir}/man1/knife-recipe-list.1*
958b507e
ER
206%{_mandir}/man1/knife-role.1*
207%{_mandir}/man1/knife-search.1*
96f87093 208%{_mandir}/man1/knife-serve.1*
23fa8236 209%{_mandir}/man1/knife-show.1*
958b507e 210%{_mandir}/man1/knife-ssh.1*
96f87093
ER
211%{_mandir}/man1/knife-ssl-check.1*
212%{_mandir}/man1/knife-ssl-fetch.1*
958b507e
ER
213%{_mandir}/man1/knife-status.1*
214%{_mandir}/man1/knife-tag.1*
23fa8236
ER
215%{_mandir}/man1/knife-upload.1*
216%{_mandir}/man1/knife-user.1*
217%{_mandir}/man1/knife-xargs.1*
958b507e 218%{_mandir}/man1/knife.1*
303651f6 219
5c13348f
ER
220%files -n bash-completion-knife
221%defattr(644,root,root,755)
222%{bash_compdir}/knife
This page took 0.058358 seconds and 4 git commands to generate.