]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
up to 11.14.6, allow shellout 2.0
[packages/chef.git] / chef.spec
CommitLineData
4613dfe7
ER
1# NOTE:
2# - check releases here: https://github.com/opscode/chef/releases
3
8354a17e
ER
4# Conditional build:
5%bcond_with tests # build without tests
6
e307965b
ER
7Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
8Name: chef
05d6135c
ER
9Version: 11.14.6
10Release: 1
e307965b 11License: Apache v2.0
aabebe0b 12Group: Networking/Admin
e307965b 13Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
05d6135c 14# Source0-md5: 0a7dbf9c3b7b9e285de034031faf008f
5cb2f1b0 15Source1: %{name}.rb
02d95ccd 16Source2: %{name}.tmpfiles
5c13348f
ER
17Source3: https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
18# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
7abbc83b 19Patch0: platform-pld.patch
bc8e6547 20Patch1: FHS.patch
0e535bd2 21Patch2: poldek.patch
7fbe09ae 22Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
33efc2f8 23# Patch3-md5: 8ff0fdfde6dc90018698775bf8f13062
4613dfe7 24URL: https://wiki.opscode.com/display/chef/
303651f6 25BuildRequires: rpm-rubyprov
5c13348f 26BuildRequires: rpmbuild(macros) >= 1.673
68cfa14e
ER
27BuildRequires: sed >= 4.0
28%if %{with tests}
29BuildRequires: ruby-rack
30BuildRequires: ruby-rake
5165006a
ER
31BuildRequires: ruby-rspec-core < 2.15
32BuildRequires: ruby-rspec-core >= 2.14.0
33BuildRequires: ruby-rspec-expectations < 2.15
34BuildRequires: ruby-rspec-expectations >= 2.14.0
35BuildRequires: ruby-rspec-mocks < 2.15
36BuildRequires: ruby-rspec-mocks >= 2.14.0
37BuildRequires: ruby-rspec_junit_formatter
68cfa14e 38%endif
97e7edae 39Requires: lsb-release
31feaf16 40Requires: poldek >= 0.30
f0820095 41Requires: ruby >= 1:1.9.3.429-4
e8757686 42Requires: ruby-diff-lcs < 2
e8757686 43Requires: ruby-diff-lcs >= 1.2.4
5165006a 44Requires: ruby-erubis < 3
bf7e149a 45Requires: ruby-erubis >= 2.7.0-3
5165006a 46Requires: ruby-highline < 2
2a1bbc08 47Requires: ruby-highline >= 1.6.9
5165006a 48Requires: ruby-json <= 1.8.1
2a1bbc08 49Requires: ruby-json >= 1.4.4
e8757686
ER
50Requires: ruby-mime-types < 2
51Requires: ruby-mime-types >= 1.16
5165006a 52Requires: ruby-mixlib-authentication < 2
bf7e149a 53Requires: ruby-mixlib-authentication >= 1.3.0-2
5165006a
ER
54Requires: ruby-mixlib-cli < 2
55Requires: ruby-mixlib-cli >= 1.4
e8757686
ER
56Requires: ruby-mixlib-config < 3
57Requires: ruby-mixlib-config >= 2.0
5165006a 58Requires: ruby-mixlib-log < 2
b337cd8c 59Requires: ruby-mixlib-log >= 1.6.0-2
24ed2278 60Requires: ruby-mixlib-shellout >= 1.4
5165006a 61Requires: ruby-net-ssh < 3
2a1bbc08 62Requires: ruby-net-ssh >= 2.6
5165006a
ER
63Requires: ruby-net-ssh-multi < 2
64Requires: ruby-net-ssh-multi >= 1.1
24ed2278 65Requires: ruby-ohai < 8
e8757686 66Requires: ruby-ohai >= 6.0
5165006a 67Requires: ruby-rest-client < 1.7.0
2a1bbc08 68Requires: ruby-rest-client >= 1.0.4
bce16be1 69Requires: ruby-rubygems
5165006a 70Requires: ruby-yajl < 2
2a1bbc08 71Requires: ruby-yajl >= 1.1
24ed2278 72Suggests: chef-zero >= 2.0
e307965b
ER
73BuildArch: noarch
74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
820f7abc
ER
76# do not generate python dependency, yum support is optional
77%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
78
e307965b
ER
79%description
80A systems integration framework, built to bring the benefits of
81configuration management to your entire infrastructure.
82
5c13348f
ER
83%package -n bash-completion-knife
84Summary: bash-completion for knife
85Summary(pl.UTF-8): bashowe uzupełnianie nazw dla knifea
86Group: Applications/Shells
87Requires: %{name} >= 0.10
88Requires: bash-completion >= 2.0
89
90%description -n bash-completion-knife
91This package provides bash-completion for knife.
92
93%description -n bash-completion-knife -l pl.UTF-8
94Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
95
be8cf7bb
ER
96%package -n knife
97Summary: knife - Chef Server API client utility
aabebe0b 98Group: Networking/Admin
be8cf7bb
ER
99Requires: %{name} = %{version}-%{release}
100
101%description -n knife
102Knife is a command-line utility used to manage data on a Chef server
103through the HTTP(S) API. Knife is organized into groups of subcommands
104centered around the various object types in Chef. Each category of
105subcommand is documented in its own manual page.
106
e307965b 107%prep
303651f6 108%setup -q
5e5186a8 109gzip -d metadata
7abbc83b 110%patch0 -p1
bc8e6547 111%patch1 -p1
31feaf16 112%patch2 -p1
7fbe09ae 113%patch3 -p1
e307965b 114
68cfa14e
ER
115%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
116
5165006a
ER
117# cleanup backups after patching
118find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
119
120grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
121
8354a17e
ER
122%build
123%if %{with tests}
124rspec spec
125%endif
126
e307965b
ER
127%install
128rm -rf $RPM_BUILD_ROOT
f972dda7
ER
129install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
130 $RPM_BUILD_ROOT%{ruby_vendorlibdir}/chef/reporting \
131 $RPM_BUILD_ROOT/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}
66164e90 132
68cfa14e 133cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 134cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 135cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
23fa8236 136%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/README.md
e307965b 137
5cb2f1b0 138cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
02d95ccd 139cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 140
5c13348f
ER
141install -d $RPM_BUILD_ROOT%{bash_compdir}
142cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
143
bce16be1
ER
144%clean
145rm -rf $RPM_BUILD_ROOT
146
e307965b
ER
147%files
148%defattr(644,root,root,755)
2a1bbc08 149%doc README.md CONTRIBUTING.md
303651f6 150%dir %{_sysconfdir}/%{name}
5cb2f1b0 151%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 152%attr(755,root,root) %{_bindir}/chef-apply
e307965b 153%attr(755,root,root) %{_bindir}/chef-client
f0820095 154%attr(755,root,root) %{_bindir}/chef-service-manager
2a1bbc08 155%attr(755,root,root) %{_bindir}/chef-shell
e307965b 156%attr(755,root,root) %{_bindir}/chef-solo
e307965b 157%attr(755,root,root) %{_bindir}/shef
958b507e 158%{_mandir}/man1/chef-shell.1*
be8cf7bb
ER
159%{_mandir}/man8/chef-client.8*
160%{_mandir}/man8/chef-solo.8*
161%{ruby_vendorlibdir}/chef.rb
162%{ruby_vendorlibdir}/chef
163%exclude %{ruby_vendorlibdir}/chef/knife
164%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
165%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
166%exclude %{ruby_vendorlibdir}/chef/knife.rb
167%{systemdtmpfilesdir}/chef.conf
168
169%dir /var/lib/%{name}
170%dir /var/lib/%{name}/roles
171%dir /var/lib/%{name}/data_bags
172%dir /var/lib/%{name}/environments
7e5aff6c 173%dir %attr(750,root,root) /var/lib/%{name}/backup
be8cf7bb
ER
174
175%dir /var/cache/%{name}
176%dir /var/run/%{name}
177
178%files -n knife
179%defattr(644,root,root,755)
180%attr(755,root,root) %{_bindir}/knife
181%{ruby_vendorlibdir}/chef/knife.rb
182%{ruby_vendorlibdir}/chef/knife
183%{ruby_vendorlibdir}/chef/application/knife.rb
184%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
958b507e
ER
185%{_mandir}/man1/knife-bootstrap.1*
186%{_mandir}/man1/knife-client.1*
187%{_mandir}/man1/knife-configure.1*
188%{_mandir}/man1/knife-cookbook-site.1*
189%{_mandir}/man1/knife-cookbook.1*
190%{_mandir}/man1/knife-data-bag.1*
23fa8236
ER
191%{_mandir}/man1/knife-delete.1*
192%{_mandir}/man1/knife-deps.1*
193%{_mandir}/man1/knife-diff.1*
194%{_mandir}/man1/knife-download.1*
195%{_mandir}/man1/knife-edit.1*
958b507e
ER
196%{_mandir}/man1/knife-environment.1*
197%{_mandir}/man1/knife-exec.1*
23fa8236
ER
198%{_mandir}/man1/knife-index-rebuild.1*
199%{_mandir}/man1/knife-list.1*
958b507e 200%{_mandir}/man1/knife-node.1*
23fa8236
ER
201%{_mandir}/man1/knife-raw.1*
202%{_mandir}/man1/knife-recipe-list.1*
958b507e
ER
203%{_mandir}/man1/knife-role.1*
204%{_mandir}/man1/knife-search.1*
96f87093 205%{_mandir}/man1/knife-serve.1*
23fa8236 206%{_mandir}/man1/knife-show.1*
958b507e 207%{_mandir}/man1/knife-ssh.1*
96f87093
ER
208%{_mandir}/man1/knife-ssl-check.1*
209%{_mandir}/man1/knife-ssl-fetch.1*
958b507e
ER
210%{_mandir}/man1/knife-status.1*
211%{_mandir}/man1/knife-tag.1*
23fa8236
ER
212%{_mandir}/man1/knife-upload.1*
213%{_mandir}/man1/knife-user.1*
214%{_mandir}/man1/knife-xargs.1*
958b507e 215%{_mandir}/man1/knife.1*
303651f6 216
5c13348f
ER
217%files -n bash-completion-knife
218%defattr(644,root,root,755)
219%{bash_compdir}/knife
This page took 0.06023 seconds and 4 git commands to generate.