]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
updated files
[packages/chef.git] / chef.spec
CommitLineData
4613dfe7
ER
1# NOTE:
2# - check releases here: https://github.com/opscode/chef/releases
3
8354a17e
ER
4# Conditional build:
5%bcond_with tests # build without tests
6
e307965b
ER
7Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
8Name: chef
a6477451
ER
9Version: 12.10.24
10Release: 0.1
e307965b 11License: Apache v2.0
aabebe0b 12Group: Networking/Admin
e307965b 13Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
a6477451 14# Source0-md5: 43819ee38d7cb40ea5578b74d87af1c7
02d95ccd 15Source2: %{name}.tmpfiles
5c13348f
ER
16Source3: https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
17# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
7abbc83b 18Patch0: platform-pld.patch
bc8e6547 19Patch1: FHS.patch
0e535bd2 20Patch2: poldek.patch
7fbe09ae 21Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
33efc2f8 22# Patch3-md5: 8ff0fdfde6dc90018698775bf8f13062
fce4f0b8 23Patch4: optional-plist.patch
4613dfe7 24URL: https://wiki.opscode.com/display/chef/
303651f6 25BuildRequires: rpm-rubyprov
5c13348f 26BuildRequires: rpmbuild(macros) >= 1.673
68cfa14e
ER
27BuildRequires: sed >= 4.0
28%if %{with tests}
29BuildRequires: ruby-rack
30BuildRequires: ruby-rake
5165006a
ER
31BuildRequires: ruby-rspec-core < 2.15
32BuildRequires: ruby-rspec-core >= 2.14.0
33BuildRequires: ruby-rspec-expectations < 2.15
34BuildRequires: ruby-rspec-expectations >= 2.14.0
35BuildRequires: ruby-rspec-mocks < 2.15
36BuildRequires: ruby-rspec-mocks >= 2.14.0
37BuildRequires: ruby-rspec_junit_formatter
68cfa14e 38%endif
97e7edae 39Requires: lsb-release
31feaf16 40Requires: poldek >= 0.30
f0820095 41Requires: ruby >= 1:1.9.3.429-4
e8757686 42Requires: ruby-diff-lcs < 2
e8757686 43Requires: ruby-diff-lcs >= 1.2.4
5165006a 44Requires: ruby-erubis < 3
bf7e149a 45Requires: ruby-erubis >= 2.7.0-3
7798c5f4
ER
46Requires: ruby-ffi-yajl < 2
47Requires: ruby-ffi-yajl >= 1.0
5165006a 48Requires: ruby-highline < 2
2a1bbc08 49Requires: ruby-highline >= 1.6.9
5165006a 50Requires: ruby-json <= 1.8.1
2a1bbc08 51Requires: ruby-json >= 1.4.4
e8757686
ER
52Requires: ruby-mime-types < 2
53Requires: ruby-mime-types >= 1.16
5165006a 54Requires: ruby-mixlib-authentication < 2
bf7e149a 55Requires: ruby-mixlib-authentication >= 1.3.0-2
5165006a
ER
56Requires: ruby-mixlib-cli < 2
57Requires: ruby-mixlib-cli >= 1.4
e8757686
ER
58Requires: ruby-mixlib-config < 3
59Requires: ruby-mixlib-config >= 2.0
5165006a 60Requires: ruby-mixlib-log < 2
b337cd8c 61Requires: ruby-mixlib-log >= 1.6.0-2
24ed2278 62Requires: ruby-mixlib-shellout >= 1.4
5165006a 63Requires: ruby-net-ssh < 3
2a1bbc08 64Requires: ruby-net-ssh >= 2.6
5165006a
ER
65Requires: ruby-net-ssh-multi < 2
66Requires: ruby-net-ssh-multi >= 1.1
24ed2278 67Requires: ruby-ohai < 8
e8757686 68Requires: ruby-ohai >= 6.0
2a1bbc08 69Requires: ruby-rest-client >= 1.0.4
bce16be1 70Requires: ruby-rubygems
5165006a 71Requires: ruby-yajl < 2
2a1bbc08 72Requires: ruby-yajl >= 1.1
7798c5f4 73Suggests: chef-zero >= 2.1.4
fce4f0b8 74Suggests: ruby-plist >= 3.1.0
e307965b
ER
75BuildArch: noarch
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
820f7abc
ER
78# do not generate python dependency, yum support is optional
79%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
80
e307965b
ER
81%description
82A systems integration framework, built to bring the benefits of
83configuration management to your entire infrastructure.
84
5c13348f
ER
85%package -n bash-completion-knife
86Summary: bash-completion for knife
87Summary(pl.UTF-8): bashowe uzupełnianie nazw dla knifea
88Group: Applications/Shells
89Requires: %{name} >= 0.10
90Requires: bash-completion >= 2.0
91
92%description -n bash-completion-knife
93This package provides bash-completion for knife.
94
95%description -n bash-completion-knife -l pl.UTF-8
96Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
97
be8cf7bb
ER
98%package -n knife
99Summary: knife - Chef Server API client utility
aabebe0b 100Group: Networking/Admin
be8cf7bb
ER
101Requires: %{name} = %{version}-%{release}
102
103%description -n knife
104Knife is a command-line utility used to manage data on a Chef server
105through the HTTP(S) API. Knife is organized into groups of subcommands
106centered around the various object types in Chef. Each category of
107subcommand is documented in its own manual page.
108
e307965b 109%prep
303651f6 110%setup -q
5e5186a8 111gzip -d metadata
c8ed2d9c 112#%patch0 -p1 # UPDATE
bc8e6547 113%patch1 -p1
31feaf16 114%patch2 -p1
7fbe09ae 115%patch3 -p1
fce4f0b8 116%patch4 -p1
e307965b 117
68cfa14e
ER
118%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
119
5165006a
ER
120# cleanup backups after patching
121find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
122
123grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
124
8354a17e
ER
125%build
126%if %{with tests}
127rspec spec
128%endif
129
e307965b
ER
130%install
131rm -rf $RPM_BUILD_ROOT
f972dda7
ER
132install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
133 $RPM_BUILD_ROOT%{ruby_vendorlibdir}/chef/reporting \
134 $RPM_BUILD_ROOT/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}
66164e90 135
68cfa14e 136cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 137cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 138cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
23fa8236 139%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/README.md
e307965b 140
02d95ccd 141cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 142
5c13348f
ER
143install -d $RPM_BUILD_ROOT%{bash_compdir}
144cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
145
bce16be1
ER
146%clean
147rm -rf $RPM_BUILD_ROOT
148
e307965b
ER
149%files
150%defattr(644,root,root,755)
2a1bbc08 151%doc README.md CONTRIBUTING.md
303651f6 152%dir %{_sysconfdir}/%{name}
2a1bbc08 153%attr(755,root,root) %{_bindir}/chef-apply
e307965b 154%attr(755,root,root) %{_bindir}/chef-client
2a1bbc08 155%attr(755,root,root) %{_bindir}/chef-shell
e307965b 156%attr(755,root,root) %{_bindir}/chef-solo
958b507e 157%{_mandir}/man1/chef-shell.1*
8eb00d5a 158%{_mandir}/man8/chef-apply.8*
be8cf7bb
ER
159%{_mandir}/man8/chef-client.8*
160%{_mandir}/man8/chef-solo.8*
161%{ruby_vendorlibdir}/chef.rb
162%{ruby_vendorlibdir}/chef
163%exclude %{ruby_vendorlibdir}/chef/knife
164%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
165%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
166%exclude %{ruby_vendorlibdir}/chef/knife.rb
167%{systemdtmpfilesdir}/chef.conf
168
169%dir /var/lib/%{name}
170%dir /var/lib/%{name}/roles
171%dir /var/lib/%{name}/data_bags
172%dir /var/lib/%{name}/environments
7e5aff6c 173%dir %attr(750,root,root) /var/lib/%{name}/backup
be8cf7bb
ER
174
175%dir /var/cache/%{name}
176%dir /var/run/%{name}
177
178%files -n knife
179%defattr(644,root,root,755)
180%attr(755,root,root) %{_bindir}/knife
181%{ruby_vendorlibdir}/chef/knife.rb
182%{ruby_vendorlibdir}/chef/knife
183%{ruby_vendorlibdir}/chef/application/knife.rb
184%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
958b507e
ER
185%{_mandir}/man1/knife-bootstrap.1*
186%{_mandir}/man1/knife-client.1*
187%{_mandir}/man1/knife-configure.1*
188%{_mandir}/man1/knife-cookbook-site.1*
189%{_mandir}/man1/knife-cookbook.1*
190%{_mandir}/man1/knife-data-bag.1*
23fa8236
ER
191%{_mandir}/man1/knife-delete.1*
192%{_mandir}/man1/knife-deps.1*
193%{_mandir}/man1/knife-diff.1*
194%{_mandir}/man1/knife-download.1*
195%{_mandir}/man1/knife-edit.1*
958b507e
ER
196%{_mandir}/man1/knife-environment.1*
197%{_mandir}/man1/knife-exec.1*
23fa8236
ER
198%{_mandir}/man1/knife-index-rebuild.1*
199%{_mandir}/man1/knife-list.1*
958b507e 200%{_mandir}/man1/knife-node.1*
23fa8236
ER
201%{_mandir}/man1/knife-raw.1*
202%{_mandir}/man1/knife-recipe-list.1*
958b507e
ER
203%{_mandir}/man1/knife-role.1*
204%{_mandir}/man1/knife-search.1*
96f87093 205%{_mandir}/man1/knife-serve.1*
23fa8236 206%{_mandir}/man1/knife-show.1*
958b507e 207%{_mandir}/man1/knife-ssh.1*
96f87093
ER
208%{_mandir}/man1/knife-ssl-check.1*
209%{_mandir}/man1/knife-ssl-fetch.1*
958b507e
ER
210%{_mandir}/man1/knife-status.1*
211%{_mandir}/man1/knife-tag.1*
23fa8236
ER
212%{_mandir}/man1/knife-upload.1*
213%{_mandir}/man1/knife-user.1*
214%{_mandir}/man1/knife-xargs.1*
958b507e 215%{_mandir}/man1/knife.1*
303651f6 216
5c13348f
ER
217%files -n bash-completion-knife
218%defattr(644,root,root,755)
219%{bash_compdir}/knife
This page took 0.084036 seconds and 4 git commands to generate.