]> git.pld-linux.org Git - packages/elektra.git/blame - elektra.spec
- more files updates (important part); release 3
[packages/elektra.git] / elektra.spec
CommitLineData
088942e6 1# TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
de7f9f03
JB
2#
3# Conditonal build:
f33e068e 4%bcond_with full # "full" variant (libelektra-full with all plugins linked in)
c89b1889 5%bcond_without java # Java support: JNA binding and JNI plugin (needs Java 8)
088942e6
JB
6%bcond_without glib # GLib/GObject binding
7%bcond_without lua # Lua (5.2) support: binding and plugin
8%bcond_without python2 # Python 2 support: binding and plugin
9%bcond_without python3 # Python 3 support: binding and plugin
10%bcond_without qt # Qt GUI
e37e525c 11
b511c548 12Summary: A key/value pair database to store software configurations
3afb30a1 13Summary(pl.UTF-8): Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
08a1423c 14Name: elektra
27ae2dbf 15Version: 0.8.19
43be5fbd 16Release: 3
08a1423c 17License: BSD
b511c548 18Group: Applications/System
de7f9f03 19Source0: http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
27ae2dbf 20# Source0-md5: 6669e765c834e259fb7570f126b85d7e
088942e6
JB
21Patch1: %{name}-no-markdown.patch
22Patch2: %{name}-no-deb.patch
de7f9f03 23URL: http://www.libelektra.org/
088942e6
JB
24%if %{with qt}
25BuildRequires: Qt5Core-devel >= 5
26BuildRequires: Qt5Gui-devel >= 5
27BuildRequires: Qt5Qml-devel >= 5
28BuildRequires: Qt5Quick-devel >= 5
088942e6 29BuildRequires: Qt5Test-devel >= 5
e37e525c 30BuildRequires: Qt5Widgets-devel >= 5
088942e6
JB
31%endif
32BuildRequires: augeas-devel >= 1.0
33BuildRequires: boost-devel
34BuildRequires: cmake >= 2.8.8
f33e068e 35BuildRequires: dbus-devel
de7f9f03 36BuildRequires: doxygen
0c175270 37BuildRequires: gettext-tools
088942e6
JB
38%{?with_glib:BuildRequires: glib2-devel >= 1:2.36}
39%{?with_glib:BuildRequires: gobject-introspection-devel >= 1.38}
c89b1889 40# for binding
088942e6
JB
41%{?with_java:BuildRequires: java-jna}
42%{?with_java:BuildRequires: jdk >= 1.8}
c89b1889
JB
43# jawt for plugin
44%{?with_java:BuildRequires: jre-X11 >= 1.8}
088942e6
JB
45BuildRequires: libgcrypt-devel
46%{?with_qt:BuildRequires: libmarkdown-devel}
de7f9f03 47BuildRequires: libstdc++-devel
088942e6 48BuildRequires: libxml2-devel >= 2.0
b0fec8fa 49BuildRequires: libxslt-progs
088942e6 50%{?with_lua:BuildRequires: lua52-devel >= 5.2}
de7f9f03 51BuildRequires: pkgconfig
088942e6
JB
52%{?with_python2:BuildRequires: python-devel >= 1:2.7}
53%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
3b20dccf 54BuildRequires: ronn
088942e6
JB
55BuildRequires: rpm-pythonprov
56BuildRequires: rpmbuild(macros) >= 1.612
57BuildRequires: swig >= 2
58%if %{with python2} || %{with python3}
59BuildRequires: swig-python >= 2
60%endif
61BuildRequires: systemd-devel
62BuildRequires: tcl-devel
f33e068e 63BuildRequires: yajl-devel
de7f9f03 64Requires: %{name}-libs = %{version}-%{release}
731cdbee 65Requires: mktemp
08a1423c 66Obsoletes: registry
a1ae6c6c 67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69%description
b511c548 70The Elektra Project provides a framework to store generic
71configuration data in an hierarchical key-value pair database, instead
72of a human-readable only text file.
a1ae6c6c 73
74This way any software can read/save his configuration using a
75consistent API. Also, applications can be aware of other applications
76configurations, leveraging easy application integration.
77
9b93ecfb 78%description -l pl.UTF-8
ff4dd69b 79Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
80konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
81danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 82
9b93ecfb
JR
83W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
84pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
85konfiguracji innych aplikacji, ułatwiając ich integrację.
a1ae6c6c 86
088942e6
JB
87%package gui
88Summary: Qt based GUI for Elektra
89Summary(pl.UTF-8): Oparty na Qt graficzny interfejs do Elektry
90Group: X11/Applications
91Requires: %{name} = %{version}-%{release}
92
93%description gui
94Qt based GUI for Elektra.
95
96%description gui -l pl.UTF-8
97Oparty na Qt graficzny interfejs do Elektry.
98
c89b1889
JB
99%package plugin-jni
100Summary: Java JNI plugin for Elektra
101Summary(pl.UTF-8): Wtyczka Java JNI dla Elektry
102Group: Libraries
103Requires: %{name} = %{version}-%{release}
104# jawt
105Requires: jre-X11 >= 1.8
106
107%description plugin-jni
108Java JNI plugin for Elektra. It allows to use plugins written in Java.
109
110%description plugin-jni -l pl.UTF-8
111Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
112Javie.
113
114%package plugin-lua
115Summary: Lua plugin for Elektra
116Summary(pl.UTF-8): Wtyczka Lua dla Elektry
117Group: Libraries
118Requires: %{name} = %{version}-%{release}
119Requires: lua52-libs >= 5.2
120
121%description plugin-lua
122Lua plugin for Elektra. It allows to use plugins written in Lua.
123
124%description plugin-lua -l pl.UTF-8
125Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
126
127%package plugin-python2
128Summary: Python 2 plugin for Elektra
129Summary(pl.UTF-8): Wtyczka Python 2 dla Elektry
130Group: Libraries
131Requires: %{name} = %{version}-%{release}
132Requires: python-libs >= 1:2.7
133
134%description plugin-python2
135Python 2 plugin for Elektra. It allows to use plugins written in
136Python 2.
137
138%description plugin-python2 -l pl.UTF-8
139Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
140Pythonie 2.
141
142%package plugin-python3
143Summary: Python plugin for Elektra
144Summary(pl.UTF-8): Wtyczka Python dla Elektry
145Group: Libraries
146Requires: %{name} = %{version}-%{release}
147Requires: python3-libs >= 1:3.2
148
149%description plugin-python3
150Python 3 plugin for Elektra. It allows to use plugins written in
151Python 3.
152
153%description plugin-python3 -l pl.UTF-8
154Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
155Pythonie 3.
156
088942e6
JB
157%package -n bash-completion-elektra
158Summary: Bash completion for Elektra commands
159Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
160Group: Applications/Shells
161Requires: %{name} = %{version}-%{release}
162Requires: bash-completion
e37e525c
ER
163%if "%{_rpmversion}" >= "5"
164BuildArch: noarch
165%endif
088942e6
JB
166
167%description -n bash-completion-elektra
168Bash completion for Elektra kdb command.
169
170%description -n bash-completion-elektra -l pl.UTF-8
171Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
172
de7f9f03
JB
173%package libs
174Summary: Elektra Project libraries
175Summary(pl.UTF-8): Biblioteki projektu Elektra
176Group: Libraries
f33e068e 177Obsoletes: elektra-cpp < 0.8
de7f9f03 178Conflicts: elektra < 0.7
a1ae6c6c 179
de7f9f03 180%description libs
b511c548 181The Elektra Project provides a framework to store generic
182configuration data in an hierarchical key-value pair database, instead
183of a human-readable only text file.
a1ae6c6c 184
185This way any software can read/save his configuration using a
186consistent API. Also, applications can be aware of other applications
187configurations, leveraging easy application integration.
188
de7f9f03 189This package contains Elektra shared libraries.
a1ae6c6c 190
de7f9f03 191%description libs -l pl.UTF-8
ff4dd69b 192Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
193konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
194danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 195
9b93ecfb
JR
196W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
197pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
198konfiguracji innych aplikacji, ułatwiając ich integrację.
85fe0e6b 199
de7f9f03
JB
200Ten pakiet zawiera biblioteki współdzielone Elektry.
201
202%package devel
203Summary: Include files and API documentation for Elektra Project
204Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja API projektu Elektra
205Group: Development/Libraries
206Requires: %{name}-libs = %{version}-%{release}
207
208%description devel
209This package contains the include files and API manual pages to use
210the Elektra API in C.
211
212%description devel -l pl.UTF-8
9b93ecfb
JR
213Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
214systemowego opisującego sposób użycia API Elektry w C.
a1ae6c6c 215
b511c548 216%package static
de7f9f03
JB
217Summary: Static libraries for Elektra Project
218Summary(pl.UTF-8): Statyczne biblioteki projektu Elektra
85fe0e6b 219Group: Development/Libraries
de7f9f03 220Requires: %{name}-devel = %{version}-%{release}
a1ae6c6c 221
b511c548 222%description static
de7f9f03 223This package contains static libraries for Elektra Project.
a1ae6c6c 224
de7f9f03
JB
225%description static -l pl.UTF-8
226Ten pakiet zawiera statyczne biblioteki projektu Elektra.
a1ae6c6c 227
de7f9f03
JB
228%package cpp-devel
229Summary: Header files of C++ interface for Elektra library
230Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
231Group: Development/Libraries
f33e068e 232Requires: %{name}-devel = %{version}-%{release}
de7f9f03 233Requires: libstdc++-devel
f33e068e 234Obsoletes: elektra-cpp-static < 0.8
de7f9f03
JB
235
236%description cpp-devel
237Header files of C++ interface for Elektra library.
238
239%description cpp-devel -l pl.UTF-8
240Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
241
088942e6
JB
242%package glib
243Summary: GLib/GObject binding for Elektra
244Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry
245Group: Libraries
246Requires: %{name}-libs = %{version}-%{release}
247Requires: glib2 >= 1:2.36
248
249%description glib
250GLib/GObject binding for Elektra.
251
252%description glib -l pl.UTF-8
253Wiązanie GLib/GObject do Elektry.
254
255%package glib-devel
256Summary: GLib/GObject binding for Elektra - development files
257Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry - pliki programistyczne
258Group: Libraries
259Requires: %{name}-devel = %{version}-%{release}
260Requires: glib2-devel >= 1:2.36
261
262%description glib-devel
263GLib/GObject binding for Elektra - development files.
264
265%description glib-devel -l pl.UTF-8
266Wiązanie GLib/GObject do Elektry - pliki programistyczne.
267
c89b1889
JB
268%package -n java-elektra
269Summary: Java binding for Elektra
270Summary(pl.UTF-8): Wiązanie języka Java dla Elektry
271Group: Libraries
272Requires: %{name}-libs = %{version}-%{release}
273Requires: java-jna
274Requires: jre
275
276%description -n java-elektra
277Java binding for Elektra.
278
279%description -n java-elektra -l pl.UTF-8
280Wiązanie języka Java dla Elektry.
281
088942e6
JB
282%package -n lua-elektra
283Summary: Lua binding for Elektra
284Summary(pl.UTF-8): Wiązanie języka Lua dla Elektry
285Group: Libraries
286Requires: %{name}-libs = %{version}-%{release}
287Requires: lua52-libs >= 5.2
288
289%description -n lua-elektra
290Lua binding for Elektra.
291
292%description -n lua-elektra -l pl.UTF-8
293Wiązanie języka Lua dla Elektry.
294
295%package -n lua-elektra-glib
296Summary: Lua/GI binding for Elektra
297Summary(pl.UTF-8): Wiązanie Lua/GI dla Elektry
298Group: Libraries
299Requires: %{name}-glib = %{version}-%{release}
300Requires: lua52-libs >= 5.2
301#R: lua52-lgi ?
302
303%description -n lua-elektra-glib
304Lua/GI binding for Elektra.
305
306%description -n lua-elektra-glib -l pl.UTF-8
307Wiązanie Lua/GI dla Elektry.
308
309%package -n python-elektra
310Summary: Python 2 binding for Elektra
311Summary(pl.UTF-8): Wiązanie Pythona 2 dla Elektry
312Group: Libraries
313Requires: %{name}-libs = %{version}-%{release}
314Requires: python-libs >= 1:2.7
315
316%description -n python-elektra
317Python 2 binding for Elektra.
318
319%description -n python-elektra -l pl.UTF-8
320Wiązanie Pythona 2 dla Elektry.
321
322%package -n python3-elektra
323Summary: Python 3 binding for Elektra
324Summary(pl.UTF-8): Wiązanie Pythona 3 dla Elektry
325Group: Libraries
326Requires: %{name}-libs = %{version}-%{release}
327Requires: python3-libs >= 1:3.2
328
329%description -n python3-elektra
330Python 3 binding for Elektra.
331
332%description -n python3-elektra -l pl.UTF-8
333Wiązanie Pythona 3 dla Elektry.
334
335%package -n python3-elektra-glib
336Summary: Python 3 GI binding for Elektra
337Summary(pl.UTF-8): Wiązanie Pythona 3 GI dla Elektry
338Group: Libraries
339Requires: %{name}-glib = %{version}-%{release}
340Requires: python3-pygobject3 >= 3
341
342%description -n python3-elektra-glib
343Python 3 GI binding for Elektra.
344
345%description -n python3-elektra-glib -l pl.UTF-8
346Wiązanie Pythona 3 GI dla Elektry.
347
a1ae6c6c 348%prep
de7f9f03 349%setup -q
088942e6
JB
350%patch1 -p1
351%patch2 -p1
a1ae6c6c 352
353%build
f33e068e
JB
354install -d build
355cd build
356%cmake .. \
088942e6 357 -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
f33e068e 358 %{!?with_full:-DBUILD_FULL=OFF} \
088942e6 359 -DINSTALL_TESTING=FALSE \
f33e068e 360 -DPLUGINS=ALL \
088942e6 361 -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
3e0386dc
AM
362 -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}" \
363 -DBUILD_STATIC=ON
f33e068e 364
f870a14f 365%{__make} -j1
a1ae6c6c 366
367%install
368rm -rf $RPM_BUILD_ROOT
ff4dd69b 369
f33e068e
JB
370%{__make} -C build install \
371 DESTDIR=$RPM_BUILD_ROOT
de7f9f03 372
f33e068e
JB
373install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
374
3e0386dc
AM
375install -d $RPM_BUILD_ROOT/etc/bash_completion.d
376mv $RPM_BUILD_ROOT{%{bash_compdir}/kdb,/etc/bash_completion.d/kdb}
377
088942e6
JB
378%if %{with python2}
379%py_comp $RPM_BUILD_ROOT%{py_sitedir}
380%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
381%py_postclean
382%endif
383
384%if %{with python3}
385%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
386%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
387%endif
388
43be5fbd
JB
389# "static" variant (with libelektra-static and thus all plugins linked in);
390# we don't need it
391%{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
392
de7f9f03 393# prepare docs
f33e068e 394%{__rm} -rf installed-doc
de7f9f03 395install -d installed-doc
f33e068e 396%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
de7f9f03 397
43be5fbd 398%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,md_scripts_README,src_libs_getenv_README_md}.3elektra
de7f9f03 399
a1ae6c6c 400%clean
401rm -rf $RPM_BUILD_ROOT
402
de7f9f03
JB
403%post libs -p /sbin/ldconfig
404%postun libs -p /sbin/ldconfig
405
088942e6
JB
406%post glib -p /sbin/ldconfig
407%postun glib -p /sbin/ldconfig
408
a1ae6c6c 409%files
410%defattr(644,root,root,755)
3e0386dc 411%doc doc/{AUTHORS,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
f33e068e
JB
412# doc/standards installed-doc/scripts
413%attr(755,root,root) %{_bindir}/kdb
414%if %{with full}
415%attr(755,root,root) %{_bindir}/kdb-full
de7f9f03 416%endif
f33e068e 417%dir %{_libdir}/elektra
088942e6
JB
418# R: augeas-libs
419%attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
3e0386dc
AM
420%attr(755,root,root) %{_libdir}/elektra/libelektra-base64.so
421%attr(755,root,root) %{_libdir}/elektra/libelektra-blockresolver.so
422%attr(755,root,root) %{_libdir}/elektra/libelektra-boolean.so
423%attr(755,root,root) %{_libdir}/elektra/libelektra-c.so
424%attr(755,root,root) %{_libdir}/elektra/libelektra-cachefilter.so
f33e068e 425%attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
088942e6
JB
426%attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
427%attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
428%attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
429# R: libgcrypt
3e0386dc
AM
430%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_gcrypt.so
431%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_openssl.so
088942e6 432%attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
3e0386dc 433%attr(755,root,root) %{_libdir}/elektra/libelektra-curlget.so
f33e068e
JB
434# R: dbus
435%attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
3e0386dc 436%attr(755,root,root) %{_libdir}/elektra/libelektra-desktop.so
f33e068e 437%attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
3e0386dc 438%attr(755,root,root) %{_libdir}/elektra/libelektra-dpkg.so
f33e068e 439%attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
088942e6 440%attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
f33e068e 441%attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
3e0386dc 442%attr(755,root,root) %{_libdir}/elektra/libelektra-fcrypt.so
088942e6 443%attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
f33e068e 444%attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
3e0386dc 445%attr(755,root,root) %{_libdir}/elektra/libelektra-gitresolver.so
f33e068e
JB
446%attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
447%attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
448%attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
449%attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
450%attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
088942e6
JB
451# uses internal inih library
452%attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
3e0386dc 453%attr(755,root,root) %{_libdir}/elektra/libelektra-iterate.so
088942e6
JB
454# R: systemd-libs
455%attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
456%attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
457%attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
458%attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
459%attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
460%attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
088942e6 461%attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
3e0386dc 462%attr(755,root,root) %{_libdir}/elektra/libelektra-mozprefs.so
f33e068e 463%attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
088942e6
JB
464%attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
465# uses internal nickel library
f33e068e
JB
466%attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
467%attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
3e0386dc 468%attr(755,root,root) %{_libdir}/elektra/libelektra-passwd.so
f33e068e 469%attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
3e0386dc 470%attr(755,root,root) %{_libdir}/elektra/libelektra-profile.so
088942e6
JB
471%attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
472%attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
f33e068e 473%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
088942e6 474%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
3e0386dc
AM
475%attr(755,root,root) %{_libdir}/elektra/libelektra-required.so
476%attr(755,root,root) %{_libdir}/elektra/libelektra-semlock.so
477%attr(755,root,root) %{_libdir}/elektra/libelektra-shell.so
478%attr(755,root,root) %{_libdir}/elektra/libelektra-simplespeclang.so
f33e068e 479%attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
3e0386dc
AM
480%attr(755,root,root) %{_libdir}/elektra/libelektra-spec.so
481%attr(755,root,root) %{_libdir}/elektra/libelektra-storage.so
f33e068e 482%attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
088942e6 483%attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
f33e068e
JB
484%attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
485%attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
486%attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
487%attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
488%attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
489%attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
490%attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
491%attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
088942e6 492%attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
f33e068e
JB
493# R: libxml2
494%attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
495# R: yajl
496%attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
85892bd2
JB
497%dir %{_libdir}/elektra/tool_exec
498%attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
3e0386dc 499%attr(755,root,root) %{_libdir}/elektra/tool_exec/configure-firefox
85892bd2
JB
500%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
501%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
502%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
503%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
504%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
505%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
506%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
3e0386dc 507%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-open
85892bd2
JB
508%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
509%attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
3e0386dc
AM
510%dir %{_libdir}/elektra/tool_exec/ffconfig
511%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupConfig
512%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupHomepage
513%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupProxy
514%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/writeConfigFiles
515%attr(755,root,root) %{_libdir}/elektra/tool_exec/find-tools
516%attr(755,root,root) %{_libdir}/elektra/tool_exec/install-sh-completion
85892bd2
JB
517%attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
518%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
519%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
520%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
521%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
85892bd2
JB
522%attr(755,root,root) %{_libdir}/elektra/tool_exec/race
523%attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
3e0386dc 524%attr(755,root,root) %{_libdir}/elektra/tool_exec/upgrade-bootstrap
f33e068e 525%{_datadir}/sgml/elektra
3b20dccf
JB
526%{_mandir}/man1/kdb.1*
527%{_mandir}/man1/kdb-check.1*
528%{_mandir}/man1/kdb-convert.1*
529%{_mandir}/man1/kdb-cp.1*
43be5fbd 530%{_mandir}/man1/kdb-editor.1*
3b20dccf
JB
531%{_mandir}/man1/kdb-export.1*
532%{_mandir}/man1/kdb-file.1*
43be5fbd 533%{_mandir}/man1/kdb-find-tools.1*
3b20dccf
JB
534%{_mandir}/man1/kdb-fstab.1*
535%{_mandir}/man1/kdb-get.1*
536%{_mandir}/man1/kdb-getmeta.1*
43be5fbd 537%{_mandir}/man1/kdb-global-mount.1*
3b20dccf
JB
538%{_mandir}/man1/kdb-help.1*
539%{_mandir}/man1/kdb-import.1*
540%{_mandir}/man1/kdb-info.1*
541%{_mandir}/man1/kdb-introduction.1*
542%{_mandir}/man1/kdb-list.1*
543%{_mandir}/man1/kdb-list-tools.1*
544%{_mandir}/man1/kdb-ls.1*
545%{_mandir}/man1/kdb-lsmeta.1*
546%{_mandir}/man1/kdb-merge.1*
547%{_mandir}/man1/kdb-mount.1*
548%{_mandir}/man1/kdb-mv.1*
549%{_mandir}/man1/kdb-remount.1*
550%{_mandir}/man1/kdb-rm.1*
551%{_mandir}/man1/kdb-set.1*
552%{_mandir}/man1/kdb-setmeta.1*
553%{_mandir}/man1/kdb-sget.1*
554%{_mandir}/man1/kdb-shell.1*
43be5fbd 555%{_mandir}/man1/kdb-spec-mount.1*
3b20dccf
JB
556%{_mandir}/man1/kdb-test.1*
557%{_mandir}/man1/kdb-umount.1*
558%{_mandir}/man1/kdb-vset.1*
559%{_mandir}/man7/elektra-*.7*
de7f9f03 560
088942e6
JB
561%if 0
562%files gen ?
563%defattr(644,root,root,755)
85892bd2 564%attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
088942e6
JB
565%{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
566# FIXME: should be in elektra_gen subdir
567%{py_sitescriptdir}/support
568%{_datadir}/elektra/templates
569%endif
570
571%files gui
572%defattr(644,root,root,755)
3e0386dc 573%attr(755,root,root) %{_bindir}/elektra-qt-editor
85892bd2 574%attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
3e0386dc
AM
575%{_datadir}/appdata/org.libelektra.elektra-qt-editor.appdata.xml
576%{_desktopdir}/org.libelektra.elektra-qt-editor.desktop
577%{_iconsdir}/hicolor/scalable/apps/elektra-symbolic.svg
578%{_iconsdir}/hicolor/scalable/apps/elektra.svg
3b20dccf 579%{_mandir}/man1/kdb-qt-gui.1*
088942e6 580
c89b1889
JB
581%if %{with java}
582%files plugin-jni
583%defattr(644,root,root,755)
584# R: jre with jawt
585%attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
586%endif
587
588%if %{with lua}
589%files plugin-lua
590%defattr(644,root,root,755)
591# R: lua52-libs
592%attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
593%endif
594
595%if %{with python2}
596%files plugin-python2
597%defattr(644,root,root,755)
598# R: python-libs
599%attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
600%endif
601
602%if %{with python3}
603%files plugin-python3
604%defattr(644,root,root,755)
605# R: python3-libs
606%attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
607%endif
608
088942e6
JB
609%files -n bash-completion-elektra
610%defattr(644,root,root,755)
611/etc/bash_completion.d/kdb
612
de7f9f03
JB
613%files libs
614%defattr(644,root,root,755)
f33e068e
JB
615%attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
616%attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
3e0386dc
AM
617%attr(755,root,root) %{_libdir}/libelektra-core.so.*.*.*
618%attr(755,root,root) %ghost %{_libdir}/libelektra-core.so.4
619%attr(755,root,root) %{_libdir}/libelektra-ease.so.*.*.*
620%attr(755,root,root) %ghost %{_libdir}/libelektra-ease.so.4
621%attr(755,root,root) %{_libdir}/libelektra-kdb.so.*.*.*
622%attr(755,root,root) %ghost %{_libdir}/libelektra-kdb.so.4
623%attr(755,root,root) %{_libdir}/libelektra-meta.so.*.*.*
624%attr(755,root,root) %ghost %{_libdir}/libelektra-meta.so.4
625%attr(755,root,root) %{_libdir}/libelektra-plugin.so.*.*.*
626%attr(755,root,root) %ghost %{_libdir}/libelektra-plugin.so.4
627%attr(755,root,root) %{_libdir}/libelektra-proposal.so.*.*.*
628%attr(755,root,root) %ghost %{_libdir}/libelektra-proposal.so.4
629%attr(755,root,root) %{_libdir}/libelektratools.so.*.*.*
630%attr(755,root,root) %ghost %{_libdir}/libelektratools.so.2
f33e068e
JB
631%if %{with full}
632%attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
633%attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
634%endif
a1ae6c6c 635
636%files devel
637%defattr(644,root,root,755)
088942e6 638%doc doc/API.md installed-doc/elektra-api/html
de7f9f03 639%attr(755,root,root) %{_libdir}/libelektra.so
43be5fbd
JB
640%attr(755,root,root) %{_libdir}/libelektra-core.so
641%attr(755,root,root) %{_libdir}/libelektra-ease.so
642%attr(755,root,root) %{_libdir}/libelektra-kdb.so
643%attr(755,root,root) %{_libdir}/libelektra-meta.so
644%attr(755,root,root) %{_libdir}/libelektra-plugin.so
645%attr(755,root,root) %{_libdir}/libelektra-proposal.so
646%attr(755,root,root) %{_libdir}/libelektratools.so
f33e068e
JB
647%if %{with full}
648%attr(755,root,root) %{_libdir}/libelektra-full.so
649%endif
650%dir %{_includedir}/elektra
088942e6 651%{_includedir}/elektra/kdb*.h
de7f9f03 652%{_pkgconfigdir}/elektra.pc
088942e6
JB
653%{_datadir}/cmake/Modules/ElektraConfig*.cmake
654%{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
655%{_mandir}/man3/api.3elektra*
f33e068e
JB
656%{_mandir}/man3/deprecated.3elektra*
657%{_mandir}/man3/kdb*.3elektra*
658%{_mandir}/man3/key*.3elektra*
088942e6 659%{_mandir}/man3/meta.3elektra*
f33e068e 660%{_mandir}/man3/plugin.3elektra*
088942e6 661%{_mandir}/man3/proposal.3elektra*
a1ae6c6c 662
b511c548 663%files static
85fe0e6b 664%defattr(644,root,root,755)
f33e068e 665%{_libdir}/libelektra-static.a
37555a25 666%{_libdir}/libelektratools-static.a
de7f9f03
JB
667
668%files cpp-devel
669%defattr(644,root,root,755)
f33e068e 670%{_includedir}/elektra/*.hpp
088942e6
JB
671%{_includedir}/elektra/helper
672%{_includedir}/elektra/merging
37555a25 673# libelektratools API man pages
088942e6
JB
674%{_mandir}/man3/automergeconfiguration.hpp.3elektra*
675%{_mandir}/man3/automergestrategy.cpp.3elektra*
676%{_mandir}/man3/automergestrategy.hpp.3elektra*
677%{_mandir}/man3/comparison.cpp.3elektra*
678%{_mandir}/man3/comparison.hpp.3elektra*
37555a25
JB
679%{_mandir}/man3/backend.hpp.3elektra*
680%{_mandir}/man3/backends.hpp.3elektra*
088942e6
JB
681%{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
682%{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
683%{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
684%{_mandir}/man3/mergeconfiguration.hpp.3elektra*
685%{_mandir}/man3/mergeconflict.hpp.3elektra*
686%{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
687%{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
688%{_mandir}/man3/mergeresult.cpp.3elektra*
689%{_mandir}/man3/mergeresult.hpp.3elektra*
690%{_mandir}/man3/mergetask.hpp.3elektra*
691%{_mandir}/man3/mergetestutils.cpp.3elektra*
692%{_mandir}/man3/metamergestrategy.cpp.3elektra*
693%{_mandir}/man3/metamergestrategy.hpp.3elektra*
694%{_mandir}/man3/newkeystrategy.cpp.3elektra*
695%{_mandir}/man3/newkeystrategy.hpp.3elektra*
696%{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
697%{_mandir}/man3/onesidestrategy.cpp.3elektra*
698%{_mandir}/man3/onesidestrategy.hpp.3elektra*
699%{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
700%{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
37555a25
JB
701%{_mandir}/man3/modules.cpp.3elektra*
702%{_mandir}/man3/modules.hpp.3elektra*
703%{_mandir}/man3/plugin.cpp.3elektra*
704%{_mandir}/man3/plugin.hpp.3elektra*
705%{_mandir}/man3/plugins.cpp.3elektra*
706%{_mandir}/man3/plugins.hpp.3elektra*
707%{_mandir}/man3/src_backend.cpp.3elektra*
088942e6
JB
708%{_mandir}/man3/testtool_*.cpp.3elektra*
709%{_mandir}/man3/threewaymerge.cpp.3elektra*
710%{_mandir}/man3/threewaymerge.hpp.3elektra*
37555a25 711%{_mandir}/man3/toolexcept.hpp.3elektra*
088942e6
JB
712
713%if %{with glib}
714%files glib
715%defattr(644,root,root,755)
716%attr(755,root,root) %{_libdir}/libgelektra-4.0.so
717%{_libdir}/girepository-1.0/GElektra-4.0.typelib
718
719%files glib-devel
720%defattr(644,root,root,755)
721%{_datadir}/gir-1.0/GElektra-4.0.gir
722%{_includedir}/elektra/gelektra-*.h
723%{_pkgconfigdir}/gelektra-4.0.pc
724%endif
725
c89b1889
JB
726%if %{with java}
727%files -n java-elektra
728%defattr(644,root,root,755)
a0e8445f
JB
729%{_javadir}/libelektra-1.jar
730%{_javadir}/libelektra.jar
c89b1889
JB
731%endif
732
088942e6
JB
733%if %{with lua}
734%files -n lua-elektra
735%defattr(644,root,root,755)
736%attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
737
738%if %{with glib}
739%files -n lua-elektra-glib
740%defattr(644,root,root,755)
741%dir %{_datadir}/lua/5.2/lgi
742%dir %{_datadir}/lua/5.2/lgi/override
743%{_datadir}/lua/5.2/lgi/override/GElektra.lua
744%endif
745%endif
746
747%if %{with python2}
748%files -n python-elektra
749%defattr(644,root,root,755)
750%attr(755,root,root) %{py_sitedir}/_kdb.so
751%{py_sitedir}/kdb.py[co]
752%endif
753
754%if %{with python3}
755%files -n python3-elektra
756%defattr(644,root,root,755)
757%attr(755,root,root) %{py3_sitedir}/_kdb.so
758%{py3_sitedir}/kdb.py
759%{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
760
761%if %{with glib}
762%files -n python3-elektra-glib
763%defattr(644,root,root,755)
764%{py3_sitedir}/gi/overrides/GElektra.py
765%{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
766%endif
767%endif
This page took 0.242661 seconds and 4 git commands to generate.