]> git.pld-linux.org Git - packages/elektra.git/blame - elektra.spec
- python 3.6
[packages/elektra.git] / elektra.spec
CommitLineData
088942e6 1# TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
de7f9f03
JB
2#
3# Conditonal build:
f33e068e 4%bcond_with full # "full" variant (libelektra-full with all plugins linked in)
c89b1889 5%bcond_without java # Java support: JNA binding and JNI plugin (needs Java 8)
088942e6
JB
6%bcond_without glib # GLib/GObject binding
7%bcond_without lua # Lua (5.2) support: binding and plugin
8%bcond_without python2 # Python 2 support: binding and plugin
9%bcond_without python3 # Python 3 support: binding and plugin
10%bcond_without qt # Qt GUI
de7f9f03 11#
b511c548 12Summary: A key/value pair database to store software configurations
3afb30a1 13Summary(pl.UTF-8): Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
08a1423c 14Name: elektra
088942e6 15Version: 0.8.14
f44a8592 16Release: 2
08a1423c 17License: BSD
b511c548 18Group: Applications/System
de7f9f03 19Source0: http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
088942e6 20# Source0-md5: a87cd3845e590bf413959dfd555e3704
de7f9f03 21Patch0: %{name}-elektraenv.patch
088942e6
JB
22Patch1: %{name}-no-markdown.patch
23Patch2: %{name}-no-deb.patch
de7f9f03 24URL: http://www.libelektra.org/
088942e6
JB
25%if %{with qt}
26BuildRequires: Qt5Core-devel >= 5
27BuildRequires: Qt5Gui-devel >= 5
28BuildRequires: Qt5Qml-devel >= 5
29BuildRequires: Qt5Quick-devel >= 5
30BuildRequires: Qt5Widgets-devel >= 5
31BuildRequires: Qt5Test-devel >= 5
32%endif
33BuildRequires: augeas-devel >= 1.0
34BuildRequires: boost-devel
35BuildRequires: cmake >= 2.8.8
f33e068e 36BuildRequires: dbus-devel
de7f9f03 37BuildRequires: doxygen
0c175270 38BuildRequires: gettext-tools
088942e6
JB
39%{?with_glib:BuildRequires: glib2-devel >= 1:2.36}
40%{?with_glib:BuildRequires: gobject-introspection-devel >= 1.38}
c89b1889 41# for binding
088942e6
JB
42%{?with_java:BuildRequires: java-jna}
43%{?with_java:BuildRequires: jdk >= 1.8}
c89b1889
JB
44# jawt for plugin
45%{?with_java:BuildRequires: jre-X11 >= 1.8}
088942e6
JB
46BuildRequires: libgcrypt-devel
47%{?with_qt:BuildRequires: libmarkdown-devel}
de7f9f03 48BuildRequires: libstdc++-devel
088942e6 49BuildRequires: libxml2-devel >= 2.0
b0fec8fa 50BuildRequires: libxslt-progs
088942e6 51%{?with_lua:BuildRequires: lua52-devel >= 5.2}
de7f9f03 52BuildRequires: pkgconfig
088942e6
JB
53%{?with_python2:BuildRequires: python-devel >= 1:2.7}
54%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
3b20dccf 55BuildRequires: ronn
088942e6
JB
56BuildRequires: rpm-pythonprov
57BuildRequires: rpmbuild(macros) >= 1.612
58BuildRequires: swig >= 2
59%if %{with python2} || %{with python3}
60BuildRequires: swig-python >= 2
61%endif
62BuildRequires: systemd-devel
63BuildRequires: tcl-devel
f33e068e 64BuildRequires: yajl-devel
de7f9f03 65Requires: %{name}-libs = %{version}-%{release}
731cdbee 66Requires: mktemp
08a1423c 67Obsoletes: registry
a1ae6c6c 68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70%description
b511c548 71The Elektra Project provides a framework to store generic
72configuration data in an hierarchical key-value pair database, instead
73of a human-readable only text file.
a1ae6c6c 74
75This way any software can read/save his configuration using a
76consistent API. Also, applications can be aware of other applications
77configurations, leveraging easy application integration.
78
9b93ecfb 79%description -l pl.UTF-8
ff4dd69b 80Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
81konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
82danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 83
9b93ecfb
JR
84W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
85pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
86konfiguracji innych aplikacji, ułatwiając ich integrację.
a1ae6c6c 87
088942e6
JB
88%package gui
89Summary: Qt based GUI for Elektra
90Summary(pl.UTF-8): Oparty na Qt graficzny interfejs do Elektry
91Group: X11/Applications
92Requires: %{name} = %{version}-%{release}
93
94%description gui
95Qt based GUI for Elektra.
96
97%description gui -l pl.UTF-8
98Oparty na Qt graficzny interfejs do Elektry.
99
c89b1889
JB
100%package plugin-jni
101Summary: Java JNI plugin for Elektra
102Summary(pl.UTF-8): Wtyczka Java JNI dla Elektry
103Group: Libraries
104Requires: %{name} = %{version}-%{release}
105# jawt
106Requires: jre-X11 >= 1.8
107
108%description plugin-jni
109Java JNI plugin for Elektra. It allows to use plugins written in Java.
110
111%description plugin-jni -l pl.UTF-8
112Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
113Javie.
114
115%package plugin-lua
116Summary: Lua plugin for Elektra
117Summary(pl.UTF-8): Wtyczka Lua dla Elektry
118Group: Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: lua52-libs >= 5.2
121
122%description plugin-lua
123Lua plugin for Elektra. It allows to use plugins written in Lua.
124
125%description plugin-lua -l pl.UTF-8
126Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
127
128%package plugin-python2
129Summary: Python 2 plugin for Elektra
130Summary(pl.UTF-8): Wtyczka Python 2 dla Elektry
131Group: Libraries
132Requires: %{name} = %{version}-%{release}
133Requires: python-libs >= 1:2.7
134
135%description plugin-python2
136Python 2 plugin for Elektra. It allows to use plugins written in
137Python 2.
138
139%description plugin-python2 -l pl.UTF-8
140Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
141Pythonie 2.
142
143%package plugin-python3
144Summary: Python plugin for Elektra
145Summary(pl.UTF-8): Wtyczka Python dla Elektry
146Group: Libraries
147Requires: %{name} = %{version}-%{release}
148Requires: python3-libs >= 1:3.2
149
150%description plugin-python3
151Python 3 plugin for Elektra. It allows to use plugins written in
152Python 3.
153
154%description plugin-python3 -l pl.UTF-8
155Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
156Pythonie 3.
157
088942e6
JB
158%package -n bash-completion-elektra
159Summary: Bash completion for Elektra commands
160Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
161Group: Applications/Shells
162Requires: %{name} = %{version}-%{release}
163Requires: bash-completion
164
165%description -n bash-completion-elektra
166Bash completion for Elektra kdb command.
167
168%description -n bash-completion-elektra -l pl.UTF-8
169Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
170
de7f9f03
JB
171%package libs
172Summary: Elektra Project libraries
173Summary(pl.UTF-8): Biblioteki projektu Elektra
174Group: Libraries
f33e068e 175Obsoletes: elektra-cpp < 0.8
de7f9f03 176Conflicts: elektra < 0.7
a1ae6c6c 177
de7f9f03 178%description libs
b511c548 179The Elektra Project provides a framework to store generic
180configuration data in an hierarchical key-value pair database, instead
181of a human-readable only text file.
a1ae6c6c 182
183This way any software can read/save his configuration using a
184consistent API. Also, applications can be aware of other applications
185configurations, leveraging easy application integration.
186
de7f9f03 187This package contains Elektra shared libraries.
a1ae6c6c 188
de7f9f03 189%description libs -l pl.UTF-8
ff4dd69b 190Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
191konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
192danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 193
9b93ecfb
JR
194W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
195pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
196konfiguracji innych aplikacji, ułatwiając ich integrację.
85fe0e6b 197
de7f9f03
JB
198Ten pakiet zawiera biblioteki współdzielone Elektry.
199
200%package devel
201Summary: Include files and API documentation for Elektra Project
202Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja API projektu Elektra
203Group: Development/Libraries
204Requires: %{name}-libs = %{version}-%{release}
205
206%description devel
207This package contains the include files and API manual pages to use
208the Elektra API in C.
209
210%description devel -l pl.UTF-8
9b93ecfb
JR
211Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
212systemowego opisującego sposób użycia API Elektry w C.
a1ae6c6c 213
b511c548 214%package static
de7f9f03
JB
215Summary: Static libraries for Elektra Project
216Summary(pl.UTF-8): Statyczne biblioteki projektu Elektra
85fe0e6b 217Group: Development/Libraries
de7f9f03 218Requires: %{name}-devel = %{version}-%{release}
a1ae6c6c 219
b511c548 220%description static
de7f9f03 221This package contains static libraries for Elektra Project.
a1ae6c6c 222
de7f9f03
JB
223%description static -l pl.UTF-8
224Ten pakiet zawiera statyczne biblioteki projektu Elektra.
a1ae6c6c 225
de7f9f03
JB
226%package cpp-devel
227Summary: Header files of C++ interface for Elektra library
228Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
229Group: Development/Libraries
f33e068e 230Requires: %{name}-devel = %{version}-%{release}
de7f9f03 231Requires: libstdc++-devel
f33e068e 232Obsoletes: elektra-cpp-static < 0.8
de7f9f03
JB
233
234%description cpp-devel
235Header files of C++ interface for Elektra library.
236
237%description cpp-devel -l pl.UTF-8
238Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
239
088942e6
JB
240%package glib
241Summary: GLib/GObject binding for Elektra
242Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry
243Group: Libraries
244Requires: %{name}-libs = %{version}-%{release}
245Requires: glib2 >= 1:2.36
246
247%description glib
248GLib/GObject binding for Elektra.
249
250%description glib -l pl.UTF-8
251Wiązanie GLib/GObject do Elektry.
252
253%package glib-devel
254Summary: GLib/GObject binding for Elektra - development files
255Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry - pliki programistyczne
256Group: Libraries
257Requires: %{name}-devel = %{version}-%{release}
258Requires: glib2-devel >= 1:2.36
259
260%description glib-devel
261GLib/GObject binding for Elektra - development files.
262
263%description glib-devel -l pl.UTF-8
264Wiązanie GLib/GObject do Elektry - pliki programistyczne.
265
c89b1889
JB
266%package -n java-elektra
267Summary: Java binding for Elektra
268Summary(pl.UTF-8): Wiązanie języka Java dla Elektry
269Group: Libraries
270Requires: %{name}-libs = %{version}-%{release}
271Requires: java-jna
272Requires: jre
273
274%description -n java-elektra
275Java binding for Elektra.
276
277%description -n java-elektra -l pl.UTF-8
278Wiązanie języka Java dla Elektry.
279
088942e6
JB
280%package -n lua-elektra
281Summary: Lua binding for Elektra
282Summary(pl.UTF-8): Wiązanie języka Lua dla Elektry
283Group: Libraries
284Requires: %{name}-libs = %{version}-%{release}
285Requires: lua52-libs >= 5.2
286
287%description -n lua-elektra
288Lua binding for Elektra.
289
290%description -n lua-elektra -l pl.UTF-8
291Wiązanie języka Lua dla Elektry.
292
293%package -n lua-elektra-glib
294Summary: Lua/GI binding for Elektra
295Summary(pl.UTF-8): Wiązanie Lua/GI dla Elektry
296Group: Libraries
297Requires: %{name}-glib = %{version}-%{release}
298Requires: lua52-libs >= 5.2
299#R: lua52-lgi ?
300
301%description -n lua-elektra-glib
302Lua/GI binding for Elektra.
303
304%description -n lua-elektra-glib -l pl.UTF-8
305Wiązanie Lua/GI dla Elektry.
306
307%package -n python-elektra
308Summary: Python 2 binding for Elektra
309Summary(pl.UTF-8): Wiązanie Pythona 2 dla Elektry
310Group: Libraries
311Requires: %{name}-libs = %{version}-%{release}
312Requires: python-libs >= 1:2.7
313
314%description -n python-elektra
315Python 2 binding for Elektra.
316
317%description -n python-elektra -l pl.UTF-8
318Wiązanie Pythona 2 dla Elektry.
319
320%package -n python3-elektra
321Summary: Python 3 binding for Elektra
322Summary(pl.UTF-8): Wiązanie Pythona 3 dla Elektry
323Group: Libraries
324Requires: %{name}-libs = %{version}-%{release}
325Requires: python3-libs >= 1:3.2
326
327%description -n python3-elektra
328Python 3 binding for Elektra.
329
330%description -n python3-elektra -l pl.UTF-8
331Wiązanie Pythona 3 dla Elektry.
332
333%package -n python3-elektra-glib
334Summary: Python 3 GI binding for Elektra
335Summary(pl.UTF-8): Wiązanie Pythona 3 GI dla Elektry
336Group: Libraries
337Requires: %{name}-glib = %{version}-%{release}
338Requires: python3-pygobject3 >= 3
339
340%description -n python3-elektra-glib
341Python 3 GI binding for Elektra.
342
343%description -n python3-elektra-glib -l pl.UTF-8
344Wiązanie Pythona 3 GI dla Elektry.
345
a1ae6c6c 346%prep
de7f9f03 347%setup -q
b511c548 348%patch0 -p1
088942e6
JB
349%patch1 -p1
350%patch2 -p1
a1ae6c6c 351
352%build
f33e068e
JB
353install -d build
354cd build
355%cmake .. \
088942e6 356 -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
f33e068e 357 %{!?with_full:-DBUILD_FULL=OFF} \
088942e6 358 -DINSTALL_TESTING=FALSE \
f33e068e 359 -DPLUGINS=ALL \
088942e6
JB
360 -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
361 -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}"
f33e068e 362
f870a14f 363%{__make} -j1
a1ae6c6c 364
365%install
366rm -rf $RPM_BUILD_ROOT
eeac539a 367install -d $RPM_BUILD_ROOT/etc/sysconfig
ff4dd69b 368
f33e068e
JB
369%{__make} -C build install \
370 DESTDIR=$RPM_BUILD_ROOT
de7f9f03 371
088942e6 372%{__mv} $RPM_BUILD_ROOT/etc/profile.d/{kdb,kdb.sh}
f33e068e 373echo 'RUN="no"' > $RPM_BUILD_ROOT/etc/sysconfig/elektra
f33e068e
JB
374install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
375
088942e6
JB
376%if %{with python2}
377%py_comp $RPM_BUILD_ROOT%{py_sitedir}
378%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
379%py_postclean
380%endif
381
382%if %{with python3}
383%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
384%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
385%endif
386
387# "static" variant (with libelektra-static and thus all plugins linked in);
388# we don't need it
389%{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
390
391%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/elektra/test_data
a1ae6c6c 392
de7f9f03 393# prepare docs
f33e068e 394%{__rm} -rf installed-doc
de7f9f03 395install -d installed-doc
f33e068e 396%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
de7f9f03 397
088942e6 398%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,src_plugins_*_md}.3elektra
de7f9f03 399
a1ae6c6c 400%clean
401rm -rf $RPM_BUILD_ROOT
402
de7f9f03
JB
403%post libs -p /sbin/ldconfig
404%postun libs -p /sbin/ldconfig
405
088942e6
JB
406%post glib -p /sbin/ldconfig
407%postun glib -p /sbin/ldconfig
408
a1ae6c6c 409%files
410%defattr(644,root,root,755)
088942e6 411%doc doc/{AUTHORS,COPYING,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
f33e068e
JB
412# doc/standards installed-doc/scripts
413%attr(755,root,root) %{_bindir}/kdb
414%if %{with full}
415%attr(755,root,root) %{_bindir}/kdb-full
de7f9f03 416%endif
f33e068e 417%dir %{_libdir}/elektra
088942e6
JB
418# R: augeas-libs
419%attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
f33e068e 420%attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
088942e6
JB
421%attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
422%attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
423%attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
424# R: libgcrypt
425%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto.so
426%attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
f33e068e
JB
427# R: dbus
428%attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
429%attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
430%attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
088942e6 431%attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
f33e068e 432%attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
088942e6 433%attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
f33e068e
JB
434%attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
435%attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
436%attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
437%attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
438%attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
439%attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
088942e6
JB
440# uses internal inih library
441%attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
442# R: systemd-libs
443%attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
444%attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
445%attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
446%attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
447%attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
448%attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
088942e6 449%attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
f33e068e 450%attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
088942e6
JB
451%attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
452# uses internal nickel library
f33e068e
JB
453%attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
454%attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
455%attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
088942e6
JB
456%attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
457%attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
f33e068e 458%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
088942e6 459%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
f33e068e
JB
460%attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
461%attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
088942e6 462%attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
f33e068e
JB
463%attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
464%attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
465%attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
466%attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
467%attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
468%attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
469%attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
470%attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
088942e6 471%attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
f33e068e
JB
472# R: libxml2
473%attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
474# R: yajl
475%attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
85892bd2
JB
476%dir %{_libdir}/elektra/tool_exec
477%attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
478%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
479%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
480%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
481%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
482%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
483%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
484%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
485%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
486%attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
487%attr(755,root,root) %{_libdir}/elektra/tool_exec/getenv
488%attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
489%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
490%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
491%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
492%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
493%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-spec
494%attr(755,root,root) %{_libdir}/elektra/tool_exec/race
495%attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
088942e6 496%attr(755,root,root) /etc/profile.d/kdb.sh
de7f9f03 497%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/elektra
f33e068e 498%{_datadir}/sgml/elektra
3b20dccf
JB
499%{_mandir}/man1/kdb.1*
500%{_mandir}/man1/kdb-check.1*
501%{_mandir}/man1/kdb-convert.1*
502%{_mandir}/man1/kdb-cp.1*
503%{_mandir}/man1/kdb-elektrify-getenv.1*
504%{_mandir}/man1/kdb-export.1*
505%{_mandir}/man1/kdb-file.1*
506%{_mandir}/man1/kdb-fstab.1*
507%{_mandir}/man1/kdb-get.1*
508%{_mandir}/man1/kdb-getmeta.1*
509%{_mandir}/man1/kdb-help.1*
510%{_mandir}/man1/kdb-import.1*
511%{_mandir}/man1/kdb-info.1*
512%{_mandir}/man1/kdb-introduction.1*
513%{_mandir}/man1/kdb-list.1*
514%{_mandir}/man1/kdb-list-tools.1*
515%{_mandir}/man1/kdb-ls.1*
516%{_mandir}/man1/kdb-lsmeta.1*
517%{_mandir}/man1/kdb-merge.1*
518%{_mandir}/man1/kdb-mount.1*
519%{_mandir}/man1/kdb-mv.1*
520%{_mandir}/man1/kdb-remount.1*
521%{_mandir}/man1/kdb-rm.1*
522%{_mandir}/man1/kdb-set.1*
523%{_mandir}/man1/kdb-setmeta.1*
524%{_mandir}/man1/kdb-sget.1*
525%{_mandir}/man1/kdb-shell.1*
526%{_mandir}/man1/kdb-test.1*
527%{_mandir}/man1/kdb-umount.1*
528%{_mandir}/man1/kdb-vset.1*
529%{_mandir}/man7/elektra-*.7*
de7f9f03 530
088942e6
JB
531%if 0
532%files gen ?
533%defattr(644,root,root,755)
85892bd2 534%attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
088942e6
JB
535%{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
536# FIXME: should be in elektra_gen subdir
537%{py_sitescriptdir}/support
538%{_datadir}/elektra/templates
539%endif
540
541%files gui
542%defattr(644,root,root,755)
85892bd2 543%attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
3b20dccf 544%{_mandir}/man1/kdb-qt-gui.1*
088942e6 545
c89b1889
JB
546%if %{with java}
547%files plugin-jni
548%defattr(644,root,root,755)
549# R: jre with jawt
550%attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
551%endif
552
553%if %{with lua}
554%files plugin-lua
555%defattr(644,root,root,755)
556# R: lua52-libs
557%attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
558%endif
559
560%if %{with python2}
561%files plugin-python2
562%defattr(644,root,root,755)
563# R: python-libs
564%attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
565%endif
566
567%if %{with python3}
568%files plugin-python3
569%defattr(644,root,root,755)
570# R: python3-libs
571%attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
572%endif
573
088942e6
JB
574%files -n bash-completion-elektra
575%defattr(644,root,root,755)
576/etc/bash_completion.d/kdb
577
de7f9f03
JB
578%files libs
579%defattr(644,root,root,755)
f33e068e
JB
580%attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
581%attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
088942e6 582%attr(755,root,root) %{_libdir}/libelektragetenv.so
37555a25 583%attr(755,root,root) %{_libdir}/libelektratools.so
f33e068e
JB
584%if %{with full}
585%attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
586%attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
587%endif
a1ae6c6c 588
589%files devel
590%defattr(644,root,root,755)
088942e6 591%doc doc/API.md installed-doc/elektra-api/html
de7f9f03 592%attr(755,root,root) %{_libdir}/libelektra.so
f33e068e
JB
593%if %{with full}
594%attr(755,root,root) %{_libdir}/libelektra-full.so
595%endif
596%dir %{_includedir}/elektra
088942e6
JB
597%{_includedir}/elektra/crypto_internal.h
598%{_includedir}/elektra/kdb*.h
de7f9f03 599%{_pkgconfigdir}/elektra.pc
088942e6
JB
600%{_datadir}/cmake/Modules/ElektraConfig*.cmake
601%{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
602%{_mandir}/man3/api.3elektra*
f33e068e
JB
603%{_mandir}/man3/deprecated.3elektra*
604%{_mandir}/man3/kdb*.3elektra*
605%{_mandir}/man3/key*.3elektra*
088942e6 606%{_mandir}/man3/meta.3elektra*
f33e068e 607%{_mandir}/man3/plugin.3elektra*
088942e6
JB
608%{_mandir}/man3/proposal.3elektra*
609%{_mandir}/man3/proposal.c.3elektra*
a1ae6c6c 610
b511c548 611%files static
85fe0e6b 612%defattr(644,root,root,755)
f33e068e 613%{_libdir}/libelektra-static.a
37555a25 614%{_libdir}/libelektratools-static.a
de7f9f03
JB
615
616%files cpp-devel
617%defattr(644,root,root,755)
f33e068e 618%{_includedir}/elektra/*.hpp
088942e6
JB
619%{_includedir}/elektra/helper
620%{_includedir}/elektra/merging
37555a25 621# libelektratools API man pages
088942e6
JB
622%{_mandir}/man3/automergeconfiguration.hpp.3elektra*
623%{_mandir}/man3/automergestrategy.cpp.3elektra*
624%{_mandir}/man3/automergestrategy.hpp.3elektra*
625%{_mandir}/man3/comparison.cpp.3elektra*
626%{_mandir}/man3/comparison.hpp.3elektra*
37555a25
JB
627%{_mandir}/man3/backend.hpp.3elektra*
628%{_mandir}/man3/backends.hpp.3elektra*
088942e6
JB
629%{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
630%{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
631%{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
632%{_mandir}/man3/mergeconfiguration.hpp.3elektra*
633%{_mandir}/man3/mergeconflict.hpp.3elektra*
634%{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
635%{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
636%{_mandir}/man3/mergeresult.cpp.3elektra*
637%{_mandir}/man3/mergeresult.hpp.3elektra*
638%{_mandir}/man3/mergetask.hpp.3elektra*
639%{_mandir}/man3/mergetestutils.cpp.3elektra*
640%{_mandir}/man3/metamergestrategy.cpp.3elektra*
641%{_mandir}/man3/metamergestrategy.hpp.3elektra*
642%{_mandir}/man3/newkeystrategy.cpp.3elektra*
643%{_mandir}/man3/newkeystrategy.hpp.3elektra*
644%{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
645%{_mandir}/man3/onesidestrategy.cpp.3elektra*
646%{_mandir}/man3/onesidestrategy.hpp.3elektra*
647%{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
648%{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
37555a25
JB
649%{_mandir}/man3/modules.cpp.3elektra*
650%{_mandir}/man3/modules.hpp.3elektra*
651%{_mandir}/man3/plugin.cpp.3elektra*
652%{_mandir}/man3/plugin.hpp.3elektra*
653%{_mandir}/man3/plugins.cpp.3elektra*
654%{_mandir}/man3/plugins.hpp.3elektra*
655%{_mandir}/man3/src_backend.cpp.3elektra*
088942e6
JB
656%{_mandir}/man3/testtool_*.cpp.3elektra*
657%{_mandir}/man3/threewaymerge.cpp.3elektra*
658%{_mandir}/man3/threewaymerge.hpp.3elektra*
37555a25 659%{_mandir}/man3/toolexcept.hpp.3elektra*
088942e6
JB
660
661%if %{with glib}
662%files glib
663%defattr(644,root,root,755)
664%attr(755,root,root) %{_libdir}/libgelektra-4.0.so
665%{_libdir}/girepository-1.0/GElektra-4.0.typelib
666
667%files glib-devel
668%defattr(644,root,root,755)
669%{_datadir}/gir-1.0/GElektra-4.0.gir
670%{_includedir}/elektra/gelektra-*.h
671%{_pkgconfigdir}/gelektra-4.0.pc
672%endif
673
c89b1889
JB
674%if %{with java}
675%files -n java-elektra
676%defattr(644,root,root,755)
a0e8445f
JB
677%{_javadir}/libelektra-1.jar
678%{_javadir}/libelektra.jar
c89b1889
JB
679%endif
680
088942e6
JB
681%if %{with lua}
682%files -n lua-elektra
683%defattr(644,root,root,755)
684%attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
685
686%if %{with glib}
687%files -n lua-elektra-glib
688%defattr(644,root,root,755)
689%dir %{_datadir}/lua/5.2/lgi
690%dir %{_datadir}/lua/5.2/lgi/override
691%{_datadir}/lua/5.2/lgi/override/GElektra.lua
692%endif
693%endif
694
695%if %{with python2}
696%files -n python-elektra
697%defattr(644,root,root,755)
698%attr(755,root,root) %{py_sitedir}/_kdb.so
699%{py_sitedir}/kdb.py[co]
700%endif
701
702%if %{with python3}
703%files -n python3-elektra
704%defattr(644,root,root,755)
705%attr(755,root,root) %{py3_sitedir}/_kdb.so
706%{py3_sitedir}/kdb.py
707%{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
708
709%if %{with glib}
710%files -n python3-elektra-glib
711%defattr(644,root,root,755)
712%{py3_sitedir}/gi/overrides/GElektra.py
713%{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
714%endif
715%endif
This page took 0.153133 seconds and 4 git commands to generate.