]> git.pld-linux.org Git - packages/elektra.git/blame - elektra.spec
- updated to 0.8.14
[packages/elektra.git] / elektra.spec
CommitLineData
088942e6 1# TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
de7f9f03
JB
2#
3# Conditonal build:
f33e068e 4%bcond_with full # "full" variant (libelektra-full with all plugins linked in)
088942e6
JB
5%bcond_with java # Java support: JNA binding and JNI plugin (needs Java 8)
6%bcond_without glib # GLib/GObject binding
7%bcond_without lua # Lua (5.2) support: binding and plugin
8%bcond_without python2 # Python 2 support: binding and plugin
9%bcond_without python3 # Python 3 support: binding and plugin
10%bcond_without qt # Qt GUI
de7f9f03 11#
b511c548 12Summary: A key/value pair database to store software configurations
3afb30a1 13Summary(pl.UTF-8): Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
08a1423c 14Name: elektra
088942e6 15Version: 0.8.14
f33e068e 16Release: 1
08a1423c 17License: BSD
b511c548 18Group: Applications/System
de7f9f03 19Source0: http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
088942e6 20# Source0-md5: a87cd3845e590bf413959dfd555e3704
de7f9f03 21Patch0: %{name}-elektraenv.patch
088942e6
JB
22Patch1: %{name}-no-markdown.patch
23Patch2: %{name}-no-deb.patch
de7f9f03 24URL: http://www.libelektra.org/
088942e6
JB
25%if %{with qt}
26BuildRequires: Qt5Core-devel >= 5
27BuildRequires: Qt5Gui-devel >= 5
28BuildRequires: Qt5Qml-devel >= 5
29BuildRequires: Qt5Quick-devel >= 5
30BuildRequires: Qt5Widgets-devel >= 5
31BuildRequires: Qt5Test-devel >= 5
32%endif
33BuildRequires: augeas-devel >= 1.0
34BuildRequires: boost-devel
35BuildRequires: cmake >= 2.8.8
f33e068e 36BuildRequires: dbus-devel
de7f9f03 37BuildRequires: doxygen
0c175270 38BuildRequires: gettext-tools
088942e6
JB
39%{?with_glib:BuildRequires: glib2-devel >= 1:2.36}
40%{?with_glib:BuildRequires: gobject-introspection-devel >= 1.38}
41%{?with_java:BuildRequires: java-jna}
42%{?with_java:BuildRequires: jdk >= 1.8}
43BuildRequires: libgcrypt-devel
44%{?with_qt:BuildRequires: libmarkdown-devel}
de7f9f03 45BuildRequires: libstdc++-devel
088942e6 46BuildRequires: libxml2-devel >= 2.0
b0fec8fa 47BuildRequires: libxslt-progs
088942e6 48%{?with_lua:BuildRequires: lua52-devel >= 5.2}
de7f9f03 49BuildRequires: pkgconfig
088942e6
JB
50%{?with_python2:BuildRequires: python-devel >= 1:2.7}
51%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
52BuildRequires: rpm-pythonprov
53BuildRequires: rpmbuild(macros) >= 1.612
54BuildRequires: swig >= 2
55%if %{with python2} || %{with python3}
56BuildRequires: swig-python >= 2
57%endif
58BuildRequires: systemd-devel
59BuildRequires: tcl-devel
f33e068e 60BuildRequires: yajl-devel
de7f9f03 61Requires: %{name}-libs = %{version}-%{release}
731cdbee 62Requires: mktemp
08a1423c 63Obsoletes: registry
a1ae6c6c 64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66%description
b511c548 67The Elektra Project provides a framework to store generic
68configuration data in an hierarchical key-value pair database, instead
69of a human-readable only text file.
a1ae6c6c 70
71This way any software can read/save his configuration using a
72consistent API. Also, applications can be aware of other applications
73configurations, leveraging easy application integration.
74
9b93ecfb 75%description -l pl.UTF-8
ff4dd69b 76Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
77konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
78danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 79
9b93ecfb
JR
80W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
81pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
82konfiguracji innych aplikacji, ułatwiając ich integrację.
a1ae6c6c 83
088942e6
JB
84%package gui
85Summary: Qt based GUI for Elektra
86Summary(pl.UTF-8): Oparty na Qt graficzny interfejs do Elektry
87Group: X11/Applications
88Requires: %{name} = %{version}-%{release}
89
90%description gui
91Qt based GUI for Elektra.
92
93%description gui -l pl.UTF-8
94Oparty na Qt graficzny interfejs do Elektry.
95
96%package -n bash-completion-elektra
97Summary: Bash completion for Elektra commands
98Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
99Group: Applications/Shells
100Requires: %{name} = %{version}-%{release}
101Requires: bash-completion
102
103%description -n bash-completion-elektra
104Bash completion for Elektra kdb command.
105
106%description -n bash-completion-elektra -l pl.UTF-8
107Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
108
de7f9f03
JB
109%package libs
110Summary: Elektra Project libraries
111Summary(pl.UTF-8): Biblioteki projektu Elektra
112Group: Libraries
f33e068e 113Obsoletes: elektra-cpp < 0.8
de7f9f03 114Conflicts: elektra < 0.7
a1ae6c6c 115
de7f9f03 116%description libs
b511c548 117The Elektra Project provides a framework to store generic
118configuration data in an hierarchical key-value pair database, instead
119of a human-readable only text file.
a1ae6c6c 120
121This way any software can read/save his configuration using a
122consistent API. Also, applications can be aware of other applications
123configurations, leveraging easy application integration.
124
de7f9f03 125This package contains Elektra shared libraries.
a1ae6c6c 126
de7f9f03 127%description libs -l pl.UTF-8
ff4dd69b 128Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
129konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
130danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 131
9b93ecfb
JR
132W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
133pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
134konfiguracji innych aplikacji, ułatwiając ich integrację.
85fe0e6b 135
de7f9f03
JB
136Ten pakiet zawiera biblioteki współdzielone Elektry.
137
138%package devel
139Summary: Include files and API documentation for Elektra Project
140Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja API projektu Elektra
141Group: Development/Libraries
142Requires: %{name}-libs = %{version}-%{release}
143
144%description devel
145This package contains the include files and API manual pages to use
146the Elektra API in C.
147
148%description devel -l pl.UTF-8
9b93ecfb
JR
149Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
150systemowego opisującego sposób użycia API Elektry w C.
a1ae6c6c 151
b511c548 152%package static
de7f9f03
JB
153Summary: Static libraries for Elektra Project
154Summary(pl.UTF-8): Statyczne biblioteki projektu Elektra
85fe0e6b 155Group: Development/Libraries
de7f9f03 156Requires: %{name}-devel = %{version}-%{release}
a1ae6c6c 157
b511c548 158%description static
de7f9f03 159This package contains static libraries for Elektra Project.
a1ae6c6c 160
de7f9f03
JB
161%description static -l pl.UTF-8
162Ten pakiet zawiera statyczne biblioteki projektu Elektra.
a1ae6c6c 163
de7f9f03
JB
164%package cpp-devel
165Summary: Header files of C++ interface for Elektra library
166Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
167Group: Development/Libraries
f33e068e 168Requires: %{name}-devel = %{version}-%{release}
de7f9f03 169Requires: libstdc++-devel
f33e068e 170Obsoletes: elektra-cpp-static < 0.8
de7f9f03
JB
171
172%description cpp-devel
173Header files of C++ interface for Elektra library.
174
175%description cpp-devel -l pl.UTF-8
176Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
177
088942e6
JB
178%package glib
179Summary: GLib/GObject binding for Elektra
180Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry
181Group: Libraries
182Requires: %{name}-libs = %{version}-%{release}
183Requires: glib2 >= 1:2.36
184
185%description glib
186GLib/GObject binding for Elektra.
187
188%description glib -l pl.UTF-8
189Wiązanie GLib/GObject do Elektry.
190
191%package glib-devel
192Summary: GLib/GObject binding for Elektra - development files
193Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry - pliki programistyczne
194Group: Libraries
195Requires: %{name}-devel = %{version}-%{release}
196Requires: glib2-devel >= 1:2.36
197
198%description glib-devel
199GLib/GObject binding for Elektra - development files.
200
201%description glib-devel -l pl.UTF-8
202Wiązanie GLib/GObject do Elektry - pliki programistyczne.
203
204%package -n lua-elektra
205Summary: Lua binding for Elektra
206Summary(pl.UTF-8): Wiązanie języka Lua dla Elektry
207Group: Libraries
208Requires: %{name}-libs = %{version}-%{release}
209Requires: lua52-libs >= 5.2
210
211%description -n lua-elektra
212Lua binding for Elektra.
213
214%description -n lua-elektra -l pl.UTF-8
215Wiązanie języka Lua dla Elektry.
216
217%package -n lua-elektra-glib
218Summary: Lua/GI binding for Elektra
219Summary(pl.UTF-8): Wiązanie Lua/GI dla Elektry
220Group: Libraries
221Requires: %{name}-glib = %{version}-%{release}
222Requires: lua52-libs >= 5.2
223#R: lua52-lgi ?
224
225%description -n lua-elektra-glib
226Lua/GI binding for Elektra.
227
228%description -n lua-elektra-glib -l pl.UTF-8
229Wiązanie Lua/GI dla Elektry.
230
231%package -n python-elektra
232Summary: Python 2 binding for Elektra
233Summary(pl.UTF-8): Wiązanie Pythona 2 dla Elektry
234Group: Libraries
235Requires: %{name}-libs = %{version}-%{release}
236Requires: python-libs >= 1:2.7
237
238%description -n python-elektra
239Python 2 binding for Elektra.
240
241%description -n python-elektra -l pl.UTF-8
242Wiązanie Pythona 2 dla Elektry.
243
244%package -n python3-elektra
245Summary: Python 3 binding for Elektra
246Summary(pl.UTF-8): Wiązanie Pythona 3 dla Elektry
247Group: Libraries
248Requires: %{name}-libs = %{version}-%{release}
249Requires: python3-libs >= 1:3.2
250
251%description -n python3-elektra
252Python 3 binding for Elektra.
253
254%description -n python3-elektra -l pl.UTF-8
255Wiązanie Pythona 3 dla Elektry.
256
257%package -n python3-elektra-glib
258Summary: Python 3 GI binding for Elektra
259Summary(pl.UTF-8): Wiązanie Pythona 3 GI dla Elektry
260Group: Libraries
261Requires: %{name}-glib = %{version}-%{release}
262Requires: python3-pygobject3 >= 3
263
264%description -n python3-elektra-glib
265Python 3 GI binding for Elektra.
266
267%description -n python3-elektra-glib -l pl.UTF-8
268Wiązanie Pythona 3 GI dla Elektry.
269
a1ae6c6c 270%prep
de7f9f03 271%setup -q
b511c548 272%patch0 -p1
088942e6
JB
273%patch1 -p1
274%patch2 -p1
a1ae6c6c 275
276%build
f33e068e
JB
277install -d build
278cd build
279%cmake .. \
088942e6 280 -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
f33e068e 281 %{!?with_full:-DBUILD_FULL=OFF} \
088942e6 282 -DINSTALL_TESTING=FALSE \
f33e068e 283 -DPLUGINS=ALL \
088942e6
JB
284 -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
285 -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}"
f33e068e 286
f870a14f 287%{__make} -j1
a1ae6c6c 288
289%install
290rm -rf $RPM_BUILD_ROOT
eeac539a 291install -d $RPM_BUILD_ROOT/etc/sysconfig
ff4dd69b 292
f33e068e
JB
293%{__make} -C build install \
294 DESTDIR=$RPM_BUILD_ROOT
de7f9f03 295
088942e6 296%{__mv} $RPM_BUILD_ROOT/etc/profile.d/{kdb,kdb.sh}
f33e068e 297echo 'RUN="no"' > $RPM_BUILD_ROOT/etc/sysconfig/elektra
f33e068e
JB
298install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
299
088942e6
JB
300%if %{with python2}
301%py_comp $RPM_BUILD_ROOT%{py_sitedir}
302%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
303%py_postclean
304%endif
305
306%if %{with python3}
307%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
308%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
309%endif
310
311# "static" variant (with libelektra-static and thus all plugins linked in);
312# we don't need it
313%{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
314
315%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/elektra/test_data
a1ae6c6c 316
de7f9f03 317# prepare docs
f33e068e 318%{__rm} -rf installed-doc
de7f9f03 319install -d installed-doc
f33e068e 320%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
de7f9f03 321
088942e6 322%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,src_plugins_*_md}.3elektra
de7f9f03 323
a1ae6c6c 324%clean
325rm -rf $RPM_BUILD_ROOT
326
de7f9f03
JB
327%post libs -p /sbin/ldconfig
328%postun libs -p /sbin/ldconfig
329
088942e6
JB
330%post glib -p /sbin/ldconfig
331%postun glib -p /sbin/ldconfig
332
a1ae6c6c 333%files
334%defattr(644,root,root,755)
088942e6 335%doc doc/{AUTHORS,COPYING,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
f33e068e
JB
336# doc/standards installed-doc/scripts
337%attr(755,root,root) %{_bindir}/kdb
338%if %{with full}
339%attr(755,root,root) %{_bindir}/kdb-full
de7f9f03 340%endif
f33e068e 341%dir %{_libdir}/elektra
088942e6
JB
342# R: augeas-libs
343%attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
f33e068e 344%attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
088942e6
JB
345%attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
346%attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
347%attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
348# R: libgcrypt
349%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto.so
350%attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
f33e068e
JB
351# R: dbus
352%attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
353%attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
354%attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
088942e6 355%attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
f33e068e 356%attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
088942e6 357%attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
f33e068e
JB
358%attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
359%attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
360%attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
361%attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
362%attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
363%attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
088942e6
JB
364# uses internal inih library
365%attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
366# R: systemd-libs
367%attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
368%attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
369%attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
370%attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
371%attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
372%attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
373%if %{with lua}
374# R: lua52-libs
375%attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
376%endif
377%attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
f33e068e 378%attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
088942e6
JB
379%attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
380# uses internal nickel library
f33e068e
JB
381%attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
382%attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
383%attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
088942e6
JB
384%if %{with python2}
385# R: python-libs
386%attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
387%endif
388%if %{with python3}
389# R: python3-libs
390%attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
391%endif
392%attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
393%attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
f33e068e 394%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
088942e6 395%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
f33e068e
JB
396%attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
397%attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
088942e6 398%attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
f33e068e
JB
399%attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
400%attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
401%attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
402%attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
403%attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
404%attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
405%attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
406%attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
088942e6 407%attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
f33e068e
JB
408# R: libxml2
409%attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
410# R: yajl
411%attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
088942e6
JB
412%if "%{_libdir}" != "%{_prefix}/lib"
413%dir %{_prefix}/lib/elektra
414%endif
415%dir %{_prefix}/lib/elektra/tool_exec
416%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/benchmark-createtree
417%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-fstab
418%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-hosts
419%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-inittab
420%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-users
421%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektra-merge
422%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektra-mount
423%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektra-umount
424%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektrify-getenv
425%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/example-xorg
426%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/getenv
427%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/list-tools
428%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-augeas
429%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-info
430%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-kde
431%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-openicc
432%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-spec
433%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/race
434%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/umount-all
435
436%attr(755,root,root) /etc/profile.d/kdb.sh
de7f9f03 437%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/elektra
f33e068e 438%{_datadir}/sgml/elektra
de7f9f03 439
088942e6
JB
440%if 0
441%files gen ?
442%defattr(644,root,root,755)
443%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/gen
444%{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
445# FIXME: should be in elektra_gen subdir
446%{py_sitescriptdir}/support
447%{_datadir}/elektra/templates
448%endif
449
450%files gui
451%defattr(644,root,root,755)
452%attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/qt-gui
453
454%files -n bash-completion-elektra
455%defattr(644,root,root,755)
456/etc/bash_completion.d/kdb
457
de7f9f03
JB
458%files libs
459%defattr(644,root,root,755)
f33e068e
JB
460%attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
461%attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
088942e6 462%attr(755,root,root) %{_libdir}/libelektragetenv.so
37555a25 463%attr(755,root,root) %{_libdir}/libelektratools.so
f33e068e
JB
464%if %{with full}
465%attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
466%attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
467%endif
a1ae6c6c 468
469%files devel
470%defattr(644,root,root,755)
088942e6 471%doc doc/API.md installed-doc/elektra-api/html
de7f9f03 472%attr(755,root,root) %{_libdir}/libelektra.so
f33e068e
JB
473%if %{with full}
474%attr(755,root,root) %{_libdir}/libelektra-full.so
475%endif
476%dir %{_includedir}/elektra
088942e6
JB
477%{_includedir}/elektra/crypto_internal.h
478%{_includedir}/elektra/kdb*.h
de7f9f03 479%{_pkgconfigdir}/elektra.pc
088942e6
JB
480%{_datadir}/cmake/Modules/ElektraConfig*.cmake
481%{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
482%{_mandir}/man3/api.3elektra*
f33e068e
JB
483%{_mandir}/man3/deprecated.3elektra*
484%{_mandir}/man3/kdb*.3elektra*
485%{_mandir}/man3/key*.3elektra*
088942e6 486%{_mandir}/man3/meta.3elektra*
f33e068e 487%{_mandir}/man3/plugin.3elektra*
088942e6
JB
488%{_mandir}/man3/proposal.3elektra*
489%{_mandir}/man3/proposal.c.3elektra*
a1ae6c6c 490
b511c548 491%files static
85fe0e6b 492%defattr(644,root,root,755)
f33e068e 493%{_libdir}/libelektra-static.a
37555a25 494%{_libdir}/libelektratools-static.a
de7f9f03
JB
495
496%files cpp-devel
497%defattr(644,root,root,755)
f33e068e 498%{_includedir}/elektra/*.hpp
088942e6
JB
499%{_includedir}/elektra/helper
500%{_includedir}/elektra/merging
37555a25 501# libelektratools API man pages
088942e6
JB
502%{_mandir}/man3/automergeconfiguration.hpp.3elektra*
503%{_mandir}/man3/automergestrategy.cpp.3elektra*
504%{_mandir}/man3/automergestrategy.hpp.3elektra*
505%{_mandir}/man3/comparison.cpp.3elektra*
506%{_mandir}/man3/comparison.hpp.3elektra*
37555a25
JB
507%{_mandir}/man3/backend.hpp.3elektra*
508%{_mandir}/man3/backends.hpp.3elektra*
088942e6
JB
509%{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
510%{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
511%{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
512%{_mandir}/man3/mergeconfiguration.hpp.3elektra*
513%{_mandir}/man3/mergeconflict.hpp.3elektra*
514%{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
515%{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
516%{_mandir}/man3/mergeresult.cpp.3elektra*
517%{_mandir}/man3/mergeresult.hpp.3elektra*
518%{_mandir}/man3/mergetask.hpp.3elektra*
519%{_mandir}/man3/mergetestutils.cpp.3elektra*
520%{_mandir}/man3/metamergestrategy.cpp.3elektra*
521%{_mandir}/man3/metamergestrategy.hpp.3elektra*
522%{_mandir}/man3/newkeystrategy.cpp.3elektra*
523%{_mandir}/man3/newkeystrategy.hpp.3elektra*
524%{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
525%{_mandir}/man3/onesidestrategy.cpp.3elektra*
526%{_mandir}/man3/onesidestrategy.hpp.3elektra*
527%{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
528%{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
37555a25
JB
529%{_mandir}/man3/modules.cpp.3elektra*
530%{_mandir}/man3/modules.hpp.3elektra*
531%{_mandir}/man3/plugin.cpp.3elektra*
532%{_mandir}/man3/plugin.hpp.3elektra*
533%{_mandir}/man3/plugins.cpp.3elektra*
534%{_mandir}/man3/plugins.hpp.3elektra*
535%{_mandir}/man3/src_backend.cpp.3elektra*
088942e6
JB
536%{_mandir}/man3/testtool_*.cpp.3elektra*
537%{_mandir}/man3/threewaymerge.cpp.3elektra*
538%{_mandir}/man3/threewaymerge.hpp.3elektra*
37555a25 539%{_mandir}/man3/toolexcept.hpp.3elektra*
088942e6
JB
540
541%if %{with glib}
542%files glib
543%defattr(644,root,root,755)
544%attr(755,root,root) %{_libdir}/libgelektra-4.0.so
545%{_libdir}/girepository-1.0/GElektra-4.0.typelib
546
547%files glib-devel
548%defattr(644,root,root,755)
549%{_datadir}/gir-1.0/GElektra-4.0.gir
550%{_includedir}/elektra/gelektra-*.h
551%{_pkgconfigdir}/gelektra-4.0.pc
552%endif
553
554%if %{with lua}
555%files -n lua-elektra
556%defattr(644,root,root,755)
557%attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
558
559%if %{with glib}
560%files -n lua-elektra-glib
561%defattr(644,root,root,755)
562%dir %{_datadir}/lua/5.2/lgi
563%dir %{_datadir}/lua/5.2/lgi/override
564%{_datadir}/lua/5.2/lgi/override/GElektra.lua
565%endif
566%endif
567
568%if %{with python2}
569%files -n python-elektra
570%defattr(644,root,root,755)
571%attr(755,root,root) %{py_sitedir}/_kdb.so
572%{py_sitedir}/kdb.py[co]
573%endif
574
575%if %{with python3}
576%files -n python3-elektra
577%defattr(644,root,root,755)
578%attr(755,root,root) %{py3_sitedir}/_kdb.so
579%{py3_sitedir}/kdb.py
580%{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
581
582%if %{with glib}
583%files -n python3-elektra-glib
584%defattr(644,root,root,755)
585%{py3_sitedir}/gi/overrides/GElektra.py
586%{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
587%endif
588%endif
This page took 0.14176 seconds and 4 git commands to generate.