]> git.pld-linux.org Git - packages/elektra.git/blame - elektra.spec
noarch bash-completions package
[packages/elektra.git] / elektra.spec
CommitLineData
088942e6 1# TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
de7f9f03
JB
2#
3# Conditonal build:
f33e068e 4%bcond_with full # "full" variant (libelektra-full with all plugins linked in)
c89b1889 5%bcond_without java # Java support: JNA binding and JNI plugin (needs Java 8)
088942e6
JB
6%bcond_without glib # GLib/GObject binding
7%bcond_without lua # Lua (5.2) support: binding and plugin
8%bcond_without python2 # Python 2 support: binding and plugin
9%bcond_without python3 # Python 3 support: binding and plugin
10%bcond_without qt # Qt GUI
e37e525c 11
b511c548 12Summary: A key/value pair database to store software configurations
3afb30a1 13Summary(pl.UTF-8): Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
08a1423c 14Name: elektra
27ae2dbf 15Version: 0.8.19
e37e525c 16Release: 2
08a1423c 17License: BSD
b511c548 18Group: Applications/System
de7f9f03 19Source0: http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
27ae2dbf 20# Source0-md5: 6669e765c834e259fb7570f126b85d7e
088942e6
JB
21Patch1: %{name}-no-markdown.patch
22Patch2: %{name}-no-deb.patch
de7f9f03 23URL: http://www.libelektra.org/
088942e6
JB
24%if %{with qt}
25BuildRequires: Qt5Core-devel >= 5
26BuildRequires: Qt5Gui-devel >= 5
27BuildRequires: Qt5Qml-devel >= 5
28BuildRequires: Qt5Quick-devel >= 5
088942e6 29BuildRequires: Qt5Test-devel >= 5
e37e525c 30BuildRequires: Qt5Widgets-devel >= 5
088942e6
JB
31%endif
32BuildRequires: augeas-devel >= 1.0
33BuildRequires: boost-devel
34BuildRequires: cmake >= 2.8.8
f33e068e 35BuildRequires: dbus-devel
de7f9f03 36BuildRequires: doxygen
0c175270 37BuildRequires: gettext-tools
088942e6
JB
38%{?with_glib:BuildRequires: glib2-devel >= 1:2.36}
39%{?with_glib:BuildRequires: gobject-introspection-devel >= 1.38}
c89b1889 40# for binding
088942e6
JB
41%{?with_java:BuildRequires: java-jna}
42%{?with_java:BuildRequires: jdk >= 1.8}
c89b1889
JB
43# jawt for plugin
44%{?with_java:BuildRequires: jre-X11 >= 1.8}
088942e6
JB
45BuildRequires: libgcrypt-devel
46%{?with_qt:BuildRequires: libmarkdown-devel}
de7f9f03 47BuildRequires: libstdc++-devel
088942e6 48BuildRequires: libxml2-devel >= 2.0
b0fec8fa 49BuildRequires: libxslt-progs
088942e6 50%{?with_lua:BuildRequires: lua52-devel >= 5.2}
de7f9f03 51BuildRequires: pkgconfig
088942e6
JB
52%{?with_python2:BuildRequires: python-devel >= 1:2.7}
53%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
3b20dccf 54BuildRequires: ronn
088942e6
JB
55BuildRequires: rpm-pythonprov
56BuildRequires: rpmbuild(macros) >= 1.612
57BuildRequires: swig >= 2
58%if %{with python2} || %{with python3}
59BuildRequires: swig-python >= 2
60%endif
61BuildRequires: systemd-devel
62BuildRequires: tcl-devel
f33e068e 63BuildRequires: yajl-devel
de7f9f03 64Requires: %{name}-libs = %{version}-%{release}
731cdbee 65Requires: mktemp
08a1423c 66Obsoletes: registry
a1ae6c6c 67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69%description
b511c548 70The Elektra Project provides a framework to store generic
71configuration data in an hierarchical key-value pair database, instead
72of a human-readable only text file.
a1ae6c6c 73
74This way any software can read/save his configuration using a
75consistent API. Also, applications can be aware of other applications
76configurations, leveraging easy application integration.
77
9b93ecfb 78%description -l pl.UTF-8
ff4dd69b 79Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
80konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
81danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 82
9b93ecfb
JR
83W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
84pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
85konfiguracji innych aplikacji, ułatwiając ich integrację.
a1ae6c6c 86
088942e6
JB
87%package gui
88Summary: Qt based GUI for Elektra
89Summary(pl.UTF-8): Oparty na Qt graficzny interfejs do Elektry
90Group: X11/Applications
91Requires: %{name} = %{version}-%{release}
92
93%description gui
94Qt based GUI for Elektra.
95
96%description gui -l pl.UTF-8
97Oparty na Qt graficzny interfejs do Elektry.
98
c89b1889
JB
99%package plugin-jni
100Summary: Java JNI plugin for Elektra
101Summary(pl.UTF-8): Wtyczka Java JNI dla Elektry
102Group: Libraries
103Requires: %{name} = %{version}-%{release}
104# jawt
105Requires: jre-X11 >= 1.8
106
107%description plugin-jni
108Java JNI plugin for Elektra. It allows to use plugins written in Java.
109
110%description plugin-jni -l pl.UTF-8
111Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
112Javie.
113
114%package plugin-lua
115Summary: Lua plugin for Elektra
116Summary(pl.UTF-8): Wtyczka Lua dla Elektry
117Group: Libraries
118Requires: %{name} = %{version}-%{release}
119Requires: lua52-libs >= 5.2
120
121%description plugin-lua
122Lua plugin for Elektra. It allows to use plugins written in Lua.
123
124%description plugin-lua -l pl.UTF-8
125Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
126
127%package plugin-python2
128Summary: Python 2 plugin for Elektra
129Summary(pl.UTF-8): Wtyczka Python 2 dla Elektry
130Group: Libraries
131Requires: %{name} = %{version}-%{release}
132Requires: python-libs >= 1:2.7
133
134%description plugin-python2
135Python 2 plugin for Elektra. It allows to use plugins written in
136Python 2.
137
138%description plugin-python2 -l pl.UTF-8
139Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
140Pythonie 2.
141
142%package plugin-python3
143Summary: Python plugin for Elektra
144Summary(pl.UTF-8): Wtyczka Python dla Elektry
145Group: Libraries
146Requires: %{name} = %{version}-%{release}
147Requires: python3-libs >= 1:3.2
148
149%description plugin-python3
150Python 3 plugin for Elektra. It allows to use plugins written in
151Python 3.
152
153%description plugin-python3 -l pl.UTF-8
154Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
155Pythonie 3.
156
088942e6
JB
157%package -n bash-completion-elektra
158Summary: Bash completion for Elektra commands
159Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
160Group: Applications/Shells
161Requires: %{name} = %{version}-%{release}
162Requires: bash-completion
e37e525c
ER
163%if "%{_rpmversion}" >= "5"
164BuildArch: noarch
165%endif
088942e6
JB
166
167%description -n bash-completion-elektra
168Bash completion for Elektra kdb command.
169
170%description -n bash-completion-elektra -l pl.UTF-8
171Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
172
de7f9f03
JB
173%package libs
174Summary: Elektra Project libraries
175Summary(pl.UTF-8): Biblioteki projektu Elektra
176Group: Libraries
f33e068e 177Obsoletes: elektra-cpp < 0.8
de7f9f03 178Conflicts: elektra < 0.7
a1ae6c6c 179
de7f9f03 180%description libs
b511c548 181The Elektra Project provides a framework to store generic
182configuration data in an hierarchical key-value pair database, instead
183of a human-readable only text file.
a1ae6c6c 184
185This way any software can read/save his configuration using a
186consistent API. Also, applications can be aware of other applications
187configurations, leveraging easy application integration.
188
de7f9f03 189This package contains Elektra shared libraries.
a1ae6c6c 190
de7f9f03 191%description libs -l pl.UTF-8
ff4dd69b 192Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
193konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
194danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 195
9b93ecfb
JR
196W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
197pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
198konfiguracji innych aplikacji, ułatwiając ich integrację.
85fe0e6b 199
de7f9f03
JB
200Ten pakiet zawiera biblioteki współdzielone Elektry.
201
202%package devel
203Summary: Include files and API documentation for Elektra Project
204Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja API projektu Elektra
205Group: Development/Libraries
206Requires: %{name}-libs = %{version}-%{release}
207
208%description devel
209This package contains the include files and API manual pages to use
210the Elektra API in C.
211
212%description devel -l pl.UTF-8
9b93ecfb
JR
213Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
214systemowego opisującego sposób użycia API Elektry w C.
a1ae6c6c 215
b511c548 216%package static
de7f9f03
JB
217Summary: Static libraries for Elektra Project
218Summary(pl.UTF-8): Statyczne biblioteki projektu Elektra
85fe0e6b 219Group: Development/Libraries
de7f9f03 220Requires: %{name}-devel = %{version}-%{release}
a1ae6c6c 221
b511c548 222%description static
de7f9f03 223This package contains static libraries for Elektra Project.
a1ae6c6c 224
de7f9f03
JB
225%description static -l pl.UTF-8
226Ten pakiet zawiera statyczne biblioteki projektu Elektra.
a1ae6c6c 227
de7f9f03
JB
228%package cpp-devel
229Summary: Header files of C++ interface for Elektra library
230Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
231Group: Development/Libraries
f33e068e 232Requires: %{name}-devel = %{version}-%{release}
de7f9f03 233Requires: libstdc++-devel
f33e068e 234Obsoletes: elektra-cpp-static < 0.8
de7f9f03
JB
235
236%description cpp-devel
237Header files of C++ interface for Elektra library.
238
239%description cpp-devel -l pl.UTF-8
240Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
241
088942e6
JB
242%package glib
243Summary: GLib/GObject binding for Elektra
244Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry
245Group: Libraries
246Requires: %{name}-libs = %{version}-%{release}
247Requires: glib2 >= 1:2.36
248
249%description glib
250GLib/GObject binding for Elektra.
251
252%description glib -l pl.UTF-8
253Wiązanie GLib/GObject do Elektry.
254
255%package glib-devel
256Summary: GLib/GObject binding for Elektra - development files
257Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry - pliki programistyczne
258Group: Libraries
259Requires: %{name}-devel = %{version}-%{release}
260Requires: glib2-devel >= 1:2.36
261
262%description glib-devel
263GLib/GObject binding for Elektra - development files.
264
265%description glib-devel -l pl.UTF-8
266Wiązanie GLib/GObject do Elektry - pliki programistyczne.
267
c89b1889
JB
268%package -n java-elektra
269Summary: Java binding for Elektra
270Summary(pl.UTF-8): Wiązanie języka Java dla Elektry
271Group: Libraries
272Requires: %{name}-libs = %{version}-%{release}
273Requires: java-jna
274Requires: jre
275
276%description -n java-elektra
277Java binding for Elektra.
278
279%description -n java-elektra -l pl.UTF-8
280Wiązanie języka Java dla Elektry.
281
088942e6
JB
282%package -n lua-elektra
283Summary: Lua binding for Elektra
284Summary(pl.UTF-8): Wiązanie języka Lua dla Elektry
285Group: Libraries
286Requires: %{name}-libs = %{version}-%{release}
287Requires: lua52-libs >= 5.2
288
289%description -n lua-elektra
290Lua binding for Elektra.
291
292%description -n lua-elektra -l pl.UTF-8
293Wiązanie języka Lua dla Elektry.
294
295%package -n lua-elektra-glib
296Summary: Lua/GI binding for Elektra
297Summary(pl.UTF-8): Wiązanie Lua/GI dla Elektry
298Group: Libraries
299Requires: %{name}-glib = %{version}-%{release}
300Requires: lua52-libs >= 5.2
301#R: lua52-lgi ?
302
303%description -n lua-elektra-glib
304Lua/GI binding for Elektra.
305
306%description -n lua-elektra-glib -l pl.UTF-8
307Wiązanie Lua/GI dla Elektry.
308
309%package -n python-elektra
310Summary: Python 2 binding for Elektra
311Summary(pl.UTF-8): Wiązanie Pythona 2 dla Elektry
312Group: Libraries
313Requires: %{name}-libs = %{version}-%{release}
314Requires: python-libs >= 1:2.7
315
316%description -n python-elektra
317Python 2 binding for Elektra.
318
319%description -n python-elektra -l pl.UTF-8
320Wiązanie Pythona 2 dla Elektry.
321
322%package -n python3-elektra
323Summary: Python 3 binding for Elektra
324Summary(pl.UTF-8): Wiązanie Pythona 3 dla Elektry
325Group: Libraries
326Requires: %{name}-libs = %{version}-%{release}
327Requires: python3-libs >= 1:3.2
328
329%description -n python3-elektra
330Python 3 binding for Elektra.
331
332%description -n python3-elektra -l pl.UTF-8
333Wiązanie Pythona 3 dla Elektry.
334
335%package -n python3-elektra-glib
336Summary: Python 3 GI binding for Elektra
337Summary(pl.UTF-8): Wiązanie Pythona 3 GI dla Elektry
338Group: Libraries
339Requires: %{name}-glib = %{version}-%{release}
340Requires: python3-pygobject3 >= 3
341
342%description -n python3-elektra-glib
343Python 3 GI binding for Elektra.
344
345%description -n python3-elektra-glib -l pl.UTF-8
346Wiązanie Pythona 3 GI dla Elektry.
347
a1ae6c6c 348%prep
de7f9f03 349%setup -q
088942e6
JB
350%patch1 -p1
351%patch2 -p1
a1ae6c6c 352
353%build
f33e068e
JB
354install -d build
355cd build
356%cmake .. \
088942e6 357 -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
f33e068e 358 %{!?with_full:-DBUILD_FULL=OFF} \
088942e6 359 -DINSTALL_TESTING=FALSE \
f33e068e 360 -DPLUGINS=ALL \
088942e6 361 -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
3e0386dc
AM
362 -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}" \
363 -DBUILD_STATIC=ON
f33e068e 364
f870a14f 365%{__make} -j1
a1ae6c6c 366
367%install
368rm -rf $RPM_BUILD_ROOT
ff4dd69b 369
f33e068e
JB
370%{__make} -C build install \
371 DESTDIR=$RPM_BUILD_ROOT
de7f9f03 372
f33e068e
JB
373install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
374
3e0386dc
AM
375install -d $RPM_BUILD_ROOT/etc/bash_completion.d
376mv $RPM_BUILD_ROOT{%{bash_compdir}/kdb,/etc/bash_completion.d/kdb}
377
088942e6
JB
378%if %{with python2}
379%py_comp $RPM_BUILD_ROOT%{py_sitedir}
380%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
381%py_postclean
382%endif
383
384%if %{with python3}
385%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
386%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
387%endif
388
de7f9f03 389# prepare docs
f33e068e 390%{__rm} -rf installed-doc
de7f9f03 391install -d installed-doc
f33e068e 392%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
de7f9f03 393
27ae2dbf 394%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*}.3elektra
de7f9f03 395
a1ae6c6c 396%clean
397rm -rf $RPM_BUILD_ROOT
398
de7f9f03
JB
399%post libs -p /sbin/ldconfig
400%postun libs -p /sbin/ldconfig
401
088942e6
JB
402%post glib -p /sbin/ldconfig
403%postun glib -p /sbin/ldconfig
404
a1ae6c6c 405%files
406%defattr(644,root,root,755)
3e0386dc 407%doc doc/{AUTHORS,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
f33e068e
JB
408# doc/standards installed-doc/scripts
409%attr(755,root,root) %{_bindir}/kdb
410%if %{with full}
411%attr(755,root,root) %{_bindir}/kdb-full
de7f9f03 412%endif
f33e068e 413%dir %{_libdir}/elektra
088942e6
JB
414# R: augeas-libs
415%attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
3e0386dc
AM
416%attr(755,root,root) %{_libdir}/elektra/libelektra-base64.so
417%attr(755,root,root) %{_libdir}/elektra/libelektra-blockresolver.so
418%attr(755,root,root) %{_libdir}/elektra/libelektra-boolean.so
419%attr(755,root,root) %{_libdir}/elektra/libelektra-c.so
420%attr(755,root,root) %{_libdir}/elektra/libelektra-cachefilter.so
f33e068e 421%attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
088942e6
JB
422%attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
423%attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
424%attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
425# R: libgcrypt
3e0386dc
AM
426%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_gcrypt.so
427%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_openssl.so
088942e6 428%attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
3e0386dc 429%attr(755,root,root) %{_libdir}/elektra/libelektra-curlget.so
f33e068e
JB
430# R: dbus
431%attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
3e0386dc 432%attr(755,root,root) %{_libdir}/elektra/libelektra-desktop.so
f33e068e 433%attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
3e0386dc 434%attr(755,root,root) %{_libdir}/elektra/libelektra-dpkg.so
f33e068e 435%attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
088942e6 436%attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
f33e068e 437%attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
3e0386dc 438%attr(755,root,root) %{_libdir}/elektra/libelektra-fcrypt.so
088942e6 439%attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
f33e068e 440%attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
3e0386dc 441%attr(755,root,root) %{_libdir}/elektra/libelektra-gitresolver.so
f33e068e
JB
442%attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
443%attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
444%attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
445%attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
446%attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
088942e6
JB
447# uses internal inih library
448%attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
3e0386dc 449%attr(755,root,root) %{_libdir}/elektra/libelektra-iterate.so
088942e6
JB
450# R: systemd-libs
451%attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
452%attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
453%attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
454%attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
455%attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
456%attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
088942e6 457%attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
3e0386dc 458%attr(755,root,root) %{_libdir}/elektra/libelektra-mozprefs.so
f33e068e 459%attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
088942e6
JB
460%attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
461# uses internal nickel library
f33e068e
JB
462%attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
463%attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
3e0386dc 464%attr(755,root,root) %{_libdir}/elektra/libelektra-passwd.so
f33e068e 465%attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
3e0386dc 466%attr(755,root,root) %{_libdir}/elektra/libelektra-profile.so
088942e6
JB
467%attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
468%attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
f33e068e 469%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
088942e6 470%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
3e0386dc
AM
471%attr(755,root,root) %{_libdir}/elektra/libelektra-required.so
472%attr(755,root,root) %{_libdir}/elektra/libelektra-semlock.so
473%attr(755,root,root) %{_libdir}/elektra/libelektra-shell.so
474%attr(755,root,root) %{_libdir}/elektra/libelektra-simplespeclang.so
f33e068e 475%attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
3e0386dc
AM
476%attr(755,root,root) %{_libdir}/elektra/libelektra-spec.so
477%attr(755,root,root) %{_libdir}/elektra/libelektra-storage.so
f33e068e 478%attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
088942e6 479%attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
f33e068e
JB
480%attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
481%attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
482%attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
483%attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
484%attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
485%attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
486%attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
487%attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
088942e6 488%attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
f33e068e
JB
489# R: libxml2
490%attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
491# R: yajl
492%attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
85892bd2
JB
493%dir %{_libdir}/elektra/tool_exec
494%attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
3e0386dc 495%attr(755,root,root) %{_libdir}/elektra/tool_exec/configure-firefox
85892bd2
JB
496%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
497%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
498%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
499%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
500%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
501%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
502%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
3e0386dc 503%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-open
85892bd2
JB
504%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
505%attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
3e0386dc
AM
506%dir %{_libdir}/elektra/tool_exec/ffconfig
507%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupConfig
508%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupHomepage
509%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupProxy
510%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/writeConfigFiles
511%attr(755,root,root) %{_libdir}/elektra/tool_exec/find-tools
512%attr(755,root,root) %{_libdir}/elektra/tool_exec/install-sh-completion
85892bd2
JB
513%attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
514%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
515%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
516%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
517%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
85892bd2
JB
518%attr(755,root,root) %{_libdir}/elektra/tool_exec/race
519%attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
3e0386dc 520%attr(755,root,root) %{_libdir}/elektra/tool_exec/upgrade-bootstrap
f33e068e 521%{_datadir}/sgml/elektra
3b20dccf
JB
522%{_mandir}/man1/kdb.1*
523%{_mandir}/man1/kdb-check.1*
524%{_mandir}/man1/kdb-convert.1*
525%{_mandir}/man1/kdb-cp.1*
3b20dccf
JB
526%{_mandir}/man1/kdb-export.1*
527%{_mandir}/man1/kdb-file.1*
528%{_mandir}/man1/kdb-fstab.1*
529%{_mandir}/man1/kdb-get.1*
530%{_mandir}/man1/kdb-getmeta.1*
531%{_mandir}/man1/kdb-help.1*
532%{_mandir}/man1/kdb-import.1*
533%{_mandir}/man1/kdb-info.1*
534%{_mandir}/man1/kdb-introduction.1*
535%{_mandir}/man1/kdb-list.1*
536%{_mandir}/man1/kdb-list-tools.1*
537%{_mandir}/man1/kdb-ls.1*
538%{_mandir}/man1/kdb-lsmeta.1*
539%{_mandir}/man1/kdb-merge.1*
540%{_mandir}/man1/kdb-mount.1*
541%{_mandir}/man1/kdb-mv.1*
542%{_mandir}/man1/kdb-remount.1*
543%{_mandir}/man1/kdb-rm.1*
544%{_mandir}/man1/kdb-set.1*
545%{_mandir}/man1/kdb-setmeta.1*
546%{_mandir}/man1/kdb-sget.1*
547%{_mandir}/man1/kdb-shell.1*
548%{_mandir}/man1/kdb-test.1*
549%{_mandir}/man1/kdb-umount.1*
550%{_mandir}/man1/kdb-vset.1*
551%{_mandir}/man7/elektra-*.7*
de7f9f03 552
088942e6
JB
553%if 0
554%files gen ?
555%defattr(644,root,root,755)
85892bd2 556%attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
088942e6
JB
557%{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
558# FIXME: should be in elektra_gen subdir
559%{py_sitescriptdir}/support
560%{_datadir}/elektra/templates
561%endif
562
563%files gui
564%defattr(644,root,root,755)
3e0386dc 565%attr(755,root,root) %{_bindir}/elektra-qt-editor
85892bd2 566%attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
3e0386dc
AM
567%{_datadir}/appdata/org.libelektra.elektra-qt-editor.appdata.xml
568%{_desktopdir}/org.libelektra.elektra-qt-editor.desktop
569%{_iconsdir}/hicolor/scalable/apps/elektra-symbolic.svg
570%{_iconsdir}/hicolor/scalable/apps/elektra.svg
3b20dccf 571%{_mandir}/man1/kdb-qt-gui.1*
088942e6 572
c89b1889
JB
573%if %{with java}
574%files plugin-jni
575%defattr(644,root,root,755)
576# R: jre with jawt
577%attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
578%endif
579
580%if %{with lua}
581%files plugin-lua
582%defattr(644,root,root,755)
583# R: lua52-libs
584%attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
585%endif
586
587%if %{with python2}
588%files plugin-python2
589%defattr(644,root,root,755)
590# R: python-libs
591%attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
592%endif
593
594%if %{with python3}
595%files plugin-python3
596%defattr(644,root,root,755)
597# R: python3-libs
598%attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
599%endif
600
088942e6
JB
601%files -n bash-completion-elektra
602%defattr(644,root,root,755)
603/etc/bash_completion.d/kdb
604
de7f9f03
JB
605%files libs
606%defattr(644,root,root,755)
f33e068e
JB
607%attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
608%attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
3e0386dc
AM
609%attr(755,root,root) %{_libdir}/libelektra-core.so.*.*.*
610%attr(755,root,root) %ghost %{_libdir}/libelektra-core.so.4
611%attr(755,root,root) %{_libdir}/libelektra-ease.so.*.*.*
612%attr(755,root,root) %ghost %{_libdir}/libelektra-ease.so.4
613%attr(755,root,root) %{_libdir}/libelektra-kdb.so.*.*.*
614%attr(755,root,root) %ghost %{_libdir}/libelektra-kdb.so.4
615%attr(755,root,root) %{_libdir}/libelektra-meta.so.*.*.*
616%attr(755,root,root) %ghost %{_libdir}/libelektra-meta.so.4
617%attr(755,root,root) %{_libdir}/libelektra-plugin.so.*.*.*
618%attr(755,root,root) %ghost %{_libdir}/libelektra-plugin.so.4
619%attr(755,root,root) %{_libdir}/libelektra-proposal.so.*.*.*
620%attr(755,root,root) %ghost %{_libdir}/libelektra-proposal.so.4
621%attr(755,root,root) %{_libdir}/libelektratools.so.*.*.*
622%attr(755,root,root) %ghost %{_libdir}/libelektratools.so.2
f33e068e
JB
623%if %{with full}
624%attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
625%attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
626%endif
a1ae6c6c 627
628%files devel
629%defattr(644,root,root,755)
088942e6 630%doc doc/API.md installed-doc/elektra-api/html
de7f9f03 631%attr(755,root,root) %{_libdir}/libelektra.so
f33e068e
JB
632%if %{with full}
633%attr(755,root,root) %{_libdir}/libelektra-full.so
634%endif
635%dir %{_includedir}/elektra
088942e6 636%{_includedir}/elektra/kdb*.h
de7f9f03 637%{_pkgconfigdir}/elektra.pc
088942e6
JB
638%{_datadir}/cmake/Modules/ElektraConfig*.cmake
639%{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
640%{_mandir}/man3/api.3elektra*
f33e068e
JB
641%{_mandir}/man3/deprecated.3elektra*
642%{_mandir}/man3/kdb*.3elektra*
643%{_mandir}/man3/key*.3elektra*
088942e6 644%{_mandir}/man3/meta.3elektra*
f33e068e 645%{_mandir}/man3/plugin.3elektra*
088942e6 646%{_mandir}/man3/proposal.3elektra*
a1ae6c6c 647
b511c548 648%files static
85fe0e6b 649%defattr(644,root,root,755)
f33e068e 650%{_libdir}/libelektra-static.a
37555a25 651%{_libdir}/libelektratools-static.a
de7f9f03
JB
652
653%files cpp-devel
654%defattr(644,root,root,755)
f33e068e 655%{_includedir}/elektra/*.hpp
088942e6
JB
656%{_includedir}/elektra/helper
657%{_includedir}/elektra/merging
37555a25 658# libelektratools API man pages
088942e6
JB
659%{_mandir}/man3/automergeconfiguration.hpp.3elektra*
660%{_mandir}/man3/automergestrategy.cpp.3elektra*
661%{_mandir}/man3/automergestrategy.hpp.3elektra*
662%{_mandir}/man3/comparison.cpp.3elektra*
663%{_mandir}/man3/comparison.hpp.3elektra*
37555a25
JB
664%{_mandir}/man3/backend.hpp.3elektra*
665%{_mandir}/man3/backends.hpp.3elektra*
088942e6
JB
666%{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
667%{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
668%{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
669%{_mandir}/man3/mergeconfiguration.hpp.3elektra*
670%{_mandir}/man3/mergeconflict.hpp.3elektra*
671%{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
672%{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
673%{_mandir}/man3/mergeresult.cpp.3elektra*
674%{_mandir}/man3/mergeresult.hpp.3elektra*
675%{_mandir}/man3/mergetask.hpp.3elektra*
676%{_mandir}/man3/mergetestutils.cpp.3elektra*
677%{_mandir}/man3/metamergestrategy.cpp.3elektra*
678%{_mandir}/man3/metamergestrategy.hpp.3elektra*
679%{_mandir}/man3/newkeystrategy.cpp.3elektra*
680%{_mandir}/man3/newkeystrategy.hpp.3elektra*
681%{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
682%{_mandir}/man3/onesidestrategy.cpp.3elektra*
683%{_mandir}/man3/onesidestrategy.hpp.3elektra*
684%{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
685%{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
37555a25
JB
686%{_mandir}/man3/modules.cpp.3elektra*
687%{_mandir}/man3/modules.hpp.3elektra*
688%{_mandir}/man3/plugin.cpp.3elektra*
689%{_mandir}/man3/plugin.hpp.3elektra*
690%{_mandir}/man3/plugins.cpp.3elektra*
691%{_mandir}/man3/plugins.hpp.3elektra*
692%{_mandir}/man3/src_backend.cpp.3elektra*
088942e6
JB
693%{_mandir}/man3/testtool_*.cpp.3elektra*
694%{_mandir}/man3/threewaymerge.cpp.3elektra*
695%{_mandir}/man3/threewaymerge.hpp.3elektra*
37555a25 696%{_mandir}/man3/toolexcept.hpp.3elektra*
088942e6
JB
697
698%if %{with glib}
699%files glib
700%defattr(644,root,root,755)
701%attr(755,root,root) %{_libdir}/libgelektra-4.0.so
702%{_libdir}/girepository-1.0/GElektra-4.0.typelib
703
704%files glib-devel
705%defattr(644,root,root,755)
706%{_datadir}/gir-1.0/GElektra-4.0.gir
707%{_includedir}/elektra/gelektra-*.h
708%{_pkgconfigdir}/gelektra-4.0.pc
709%endif
710
c89b1889
JB
711%if %{with java}
712%files -n java-elektra
713%defattr(644,root,root,755)
a0e8445f
JB
714%{_javadir}/libelektra-1.jar
715%{_javadir}/libelektra.jar
c89b1889
JB
716%endif
717
088942e6
JB
718%if %{with lua}
719%files -n lua-elektra
720%defattr(644,root,root,755)
721%attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
722
723%if %{with glib}
724%files -n lua-elektra-glib
725%defattr(644,root,root,755)
726%dir %{_datadir}/lua/5.2/lgi
727%dir %{_datadir}/lua/5.2/lgi/override
728%{_datadir}/lua/5.2/lgi/override/GElektra.lua
729%endif
730%endif
731
732%if %{with python2}
733%files -n python-elektra
734%defattr(644,root,root,755)
735%attr(755,root,root) %{py_sitedir}/_kdb.so
736%{py_sitedir}/kdb.py[co]
737%endif
738
739%if %{with python3}
740%files -n python3-elektra
741%defattr(644,root,root,755)
742%attr(755,root,root) %{py3_sitedir}/_kdb.so
743%{py3_sitedir}/kdb.py
744%{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
745
746%if %{with glib}
747%files -n python3-elektra-glib
748%defattr(644,root,root,755)
749%{py3_sitedir}/gi/overrides/GElektra.py
750%{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
751%endif
752%endif
This page took 0.173552 seconds and 4 git commands to generate.