]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- up to 3.1.0
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
2acd8ac1 2# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 3# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 4# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 5#
0c2d6b7d 6# Conditional build:
a55ba198
JB
7# - general options:
8%bcond_with tbb # Threading Building Blocks support (everywhere)
9%bcond_with sse # use SSE instructions
10%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
11%bcond_with sse3 # use SSE3 instructions
12%bcond_with ssse3 # use SSSE3 instructions
13%bcond_with sse41 # use SSE4.1 instructions
14%bcond_with sse42 # use SSE4.2 instructions
15%bcond_with avx # use AVX instructions
8d5385eb
JB
16%bcond_without opencl # OpenCL support
17%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
18%bcond_with opencl_amdfft # AMD OpenCL FFT routines
19%bcond_without opengl # OpenGL support
4a401ecc 20%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 21%bcond_without examples # Install examples
b07433c6
JB
22# - bindings
23%bcond_without java # Java binding
a55ba198 24# - highgui options:
b3920a9d 25%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
26%bcond_without gstreamer # GStreamer support in highgui
27%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 28%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 29%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 30%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 31%bcond_without v4l # Video4Linux in highgui
a55ba198 32%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 33%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
34# - other modules
35%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 36
e36ac029 37%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
38%define with_sse 1
39%endif
e36ac029 40%ifarch pentium4 %{x8664} x32
1c9fe580
JB
41%define with_sse2 1
42%endif
901927d3 43Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 44Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 45Name: opencv
33a5389a 46Version: 3.1.0
f753ced4 47Release: 1
901927d3 48Epoch: 1
d5e56e66
JB
49%if %{with unicap} || %{with xine}
50License: GPL (enforced by used libraries), BSD (opencv itself)
51%else
901927d3 52License: BSD
d5e56e66 53%endif
901927d3 54Group: Libraries
200823d5 55Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
33a5389a 56# Source0-md5: 70e1dd07f0aa06606f1bc0e3fa15abd3
452b38e1 57Patch0: %{name}-cflags.patch
809ce413 58Patch5: %{name}-ximea.patch
a4737151 59Patch7: java-ant-sourcelevel.patch
e36ac029 60Patch10: cmake-install-path.patch
200823d5 61URL: http://www.opencv.org/
d5e56e66 62%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 63%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 64BuildRequires: OpenEXR-devel
5df3cf1b 65%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 66%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 67# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 68%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 69%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 70%{?with_java:BuildRequires: ant}
ef4af528
JB
71%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
72%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 73BuildRequires: cmake >= 2.8
0c2d6b7d 74BuildRequires: doxygen
809ce413 75BuildRequires: eigen3 >= 3
b3920a9d 76%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 77%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
74cbdeb2 78BuildRequires: gl2ps-devel
0c2d6b7d 79%if %{with gstreamer}
158e0ccc
JB
80BuildRequires: gstreamer-devel >= 1.0
81BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 82%endif
901927d3 83BuildRequires: jasper-devel
b07433c6 84%{?with_java:BuildRequires: jdk}
158e0ccc 85BuildRequires: libdc1394-devel >= 2
4a401ecc 86%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
87BuildRequires: libjpeg-devel
88BuildRequires: libpng-devel
89BuildRequires: libraw1394-devel
0c2d6b7d 90BuildRequires: libstdc++-devel
901927d3 91BuildRequires: libtiff-devel
148338c5 92BuildRequires: libtool
d5e56e66
JB
93%if %{with unicap}
94BuildRequires: libucil-devel
95BuildRequires: libunicap-devel
96%endif
0c2d6b7d 97BuildRequires: libv4l-devel
af6d2888 98BuildRequires: pkgconfig
158e0ccc
JB
99BuildRequires: python >= 2.0
100BuildRequires: python-devel >= 2.0
0c2d6b7d 101BuildRequires: python-numpy-devel
901927d3 102BuildRequires: rpm-pythonprov
8d499a62 103BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 104BuildRequires: sed >= 4.0
158e0ccc 105BuildRequires: sphinx-pdg
996927aa 106BuildRequires: swig-python
f8e040cc 107%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
108%if %{with vtk}
109BuildRequires: vtk-devel >= 5.8.0
fba97d16 110BuildRequires: vtk-java >= 5.8.0
ae3d975d
AM
111BuildRequires: vtk-tcl >= 5.8.0
112%endif
901927d3 113%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 114BuildRequires: xorg-lib-libX11-devel
452b38e1 115BuildRequires: zlib-devel
4afb606b 116%if %{with qt}
4afb606b
JB
117BuildRequires: QtCore-devel >= 4
118BuildRequires: QtGui-devel >= 4
5df3cf1b 119%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
120BuildRequires: qt4-qmake >= 4
121%else
122BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 123%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 124%endif
da5d1e09 125Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
126BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
158e0ccc 128%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
933de752 129
901927d3
AM
130%description
131OpenCV (Open Source Computer Vision) is a library of programming
132functions mainly aimed at real time computer vision.
133
0c2d6b7d
JB
134Example applications of the OpenCV library are:
135- Human-Computer Interaction (HCI)
136- Object Identification, Segmentation and Recognition
137- Face Recognition
138- Gesture Recognition
139- Motion Tracking
140- Ego Motion, Motion Understanding
141- Structure From Motion (SFM)
142- Stereo and Multi-Camera Calibration and Depth Computation
143- Mobile Robotics.
144
145%description -l pl.UTF-8
146OpenCV (Open Source Computer Vision) to biblioteka funkcji
147przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
148
149Przykładowe zastosowania biblioteki OpenCV to
150- interakcje człowiek-komputer (HCI)
151- identyfikacja, segmentacja i rozpoznawanie obiektów
152- rozpoznawanie twarzy
153- rozpoznawanie gestów
154- śledzenie ruchu
155- rozumienie ruchu
156- SFM (Structure From Motion)
157- kalibracja dwu- i wielokamerowa, obliczanie głębi
158- robotyka ruchu.
901927d3 159
933de752
ER
160%package core
161Summary: OpenCV core libraries
da5d1e09 162Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 163Group: Libraries
da5d1e09 164Conflicts: opencv < 2.4.6.2-1
933de752
ER
165
166%description core
167This package contains the OpenCV C/C++ core libraries.
168
da5d1e09
JB
169%description core -l pl.UTF-8
170Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
171
cf32945e
JB
172%package viz
173Summary: OpenCV viz library (VTK support)
174Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
175Group: Libraries
176Requires: %{name} = %{epoch}:%{version}-%{release}
177
178%description viz
179OpenCV viz library (VTK support).
180
181%description viz -l pl.UTF-8
182Biblioteka OpenCV viz (obsługa VTK).
183
901927d3 184%package devel
0c2d6b7d
JB
185Summary: Header files for OpenCV library
186Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
187Group: Development/Libraries
188Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
189%if %{with vtk}
190Requires: %{name}-viz = %{epoch}:%{version}-%{release}
191%endif
0c2d6b7d 192Obsoletes: opencv-static
901927d3
AM
193
194%description devel
0c2d6b7d 195Header files for OpenCV library.
901927d3 196
0c2d6b7d
JB
197%description devel -l pl.UTF-8
198Pliki nagłówkowe biblioteki OpenCV.
901927d3 199
9141b1e2
ER
200%package doc
201Summary: Manual for OpenCV
202Summary(fr.UTF-8): Documentation pour OpenCV
203Summary(it.UTF-8): Documentazione di OpenCV
204Summary(pl.UTF-8): Podręcznik dla OpenCV
205Group: Documentation
206# noarch subpackages only when building with rpm5
207%if "%{_rpmversion}" >= "5"
208BuildArch: noarch
209%endif
210
211%description doc
212Documentation for OpenCV.
213
214%description doc -l fr.UTF-8
215Documentation pour OpenCV.
216
217%description doc -l it.UTF-8
218Documentazione di OpenCV.
219
220%description doc -l pl.UTF-8
221Dokumentacja do OpenCV.
222
200823d5
ER
223%package examples
224Summary: OpenCV code examples
225Group: Documentation
226%if "%{_rpmversion}" >= "5"
227BuildArch: noarch
228%endif
229
230%description examples
231OpenCV code examples.
232
b07433c6
JB
233%package -n java-opencv
234Summary: OpenCV Java bindings
235Summary(pl.UTF-8): Wiązania Javy do OpenCV
236Group: Libraries/Java
237Requires: %{name} = %{epoch}:%{version}-%{release}
238Requires: jre
239
240%description -n java-opencv
241OpenCV Java bindings.
242
243%description -n java-opencv -l pl.UTF-8
244Wiązania Javy do OpenCV.
245
901927d3
AM
246%package -n python-opencv
247Summary: OpenCV Python bindings
0c2d6b7d
JB
248Summary(pl.UTF-8): Wiązania Pythona do OpenCV
249Group: Libraries/Python
cd1f0136 250Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 251Requires: python-libs
901927d3
AM
252
253%description -n python-opencv
254OpenCV Python bindings.
255
0c2d6b7d
JB
256%description -n python-opencv -l pl.UTF-8
257Wiązania Pythona do OpenCV.
258
901927d3 259%prep
25269a76 260%setup -q
54551f29 261
da67222a 262%undos CMakeLists.txt
54551f29 263
1376dffe 264%patch0 -p1
809ce413 265%patch5 -p1
a4737151 266%patch7 -p1
e36ac029 267%patch10 -p1
148338c5 268
901927d3 269%build
95daeb66
AM
270install -d build
271cd build
ea26b025
ER
272
273# handle cmake & ccache
274# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
275if [[ "%{__cc}" = *ccache* ]]; then
276 cc="%{__cc}"
277 cxx="%{__cxx}"
278 ccache="
279 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
280 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
281 "
282fi
283
0c2d6b7d 284%cmake .. \
ea26b025 285 $ccache \
da5d1e09 286 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
287 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
288 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
289 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
290 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
291 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
292 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 293 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
294%if %{with examples}
295 -DINSTALL_C_EXAMPLES=ON \
296 -DINSTALL_PYTHON_EXAMPLES=ON \
297%endif
b3920a9d 298 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 299 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 300 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
301 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
302 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 303 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 304 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 305 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 306 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 307 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 308 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 309 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 310 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 311 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 312 %{?with_ximea:-DWITH_XIMEA=ON} \
33a5389a
JR
313 %{?with_xine:-DWITH_XINE=ON} \
314 -DWITH_IPP=OFF
54551f29 315
8b9f61f7 316%{__make}
901927d3
AM
317
318%install
319rm -rf $RPM_BUILD_ROOT
95daeb66 320%{__make} -C build install \
901927d3
AM
321 DESTDIR=$RPM_BUILD_ROOT
322
200823d5
ER
323%if %{with examples}
324install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
325mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
326%endif
9141b1e2 327
4bd2eae7 328install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 329cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 330
7545129b
JB
331# disable completeness check incompatible with split packaging
332%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
333
8d499a62
JB
334%py_comp $RPM_BUILD_ROOT%{py_sitedir}
335%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
336%py_postclean
337
b07433c6
JB
338%if %{with java}
339# move to proper directories, create symlink
340install -d $RPM_BUILD_ROOT%{_javadir}
341%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
342sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
343 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
344%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
345rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
346ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
347%endif
348
901927d3
AM
349%clean
350rm -rf $RPM_BUILD_ROOT
351
352%post -p /sbin/ldconfig
353%postun -p /sbin/ldconfig
354
933de752
ER
355%post core -p /sbin/ldconfig
356%postun core -p /sbin/ldconfig
357
485d5dca
JB
358%post viz -p /sbin/ldconfig
359%postun viz -p /sbin/ldconfig
360
b07433c6
JB
361%post -n java-opencv -p /sbin/ldconfig
362%postun -n java-opencv -p /sbin/ldconfig
363
901927d3
AM
364%files
365%defattr(644,root,root,755)
f753ced4 366%attr(755,root,root) %{_bindir}/opencv_annotation
933de752 367%attr(755,root,root) %{_bindir}/opencv_createsamples
933de752 368%attr(755,root,root) %{_bindir}/opencv_traincascade
158e0ccc 369%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
33a5389a 370%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.3.1
158e0ccc 371%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
33a5389a 372%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.3.1
158e0ccc 373%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
33a5389a 374%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.3.1
158e0ccc 375%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
33a5389a 376%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.3.1
158e0ccc 377%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
33a5389a 378%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.3.1
158e0ccc 379%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
33a5389a 380%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.3.1
158e0ccc 381%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
33a5389a 382%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.3.1
452b38e1 383%dir %{_datadir}/OpenCV
452b38e1 384%{_datadir}/OpenCV/haarcascades
385%{_datadir}/OpenCV/lbpcascades
901927d3 386
933de752
ER
387%files core
388%defattr(644,root,root,755)
158e0ccc 389%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
33a5389a 390%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.3.1
158e0ccc 391%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
33a5389a 392%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.3.1
158e0ccc 393%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
33a5389a 394%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.3.1
158e0ccc 395%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
33a5389a 396%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.3.1
158e0ccc 397%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
33a5389a 398%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.3.1
158e0ccc 399%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
33a5389a
JR
400%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.3.1
401%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
402%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.3.1
403%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
404%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.3.1
405%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
406%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.3.1
cf32945e
JB
407
408%if %{with vtk}
409%files viz
410%defattr(644,root,root,755)
158e0ccc 411%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
33a5389a 412%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.3.1
cf32945e 413%endif
933de752 414
901927d3
AM
415%files devel
416%defattr(644,root,root,755)
cf32945e
JB
417# core
418%attr(755,root,root) %{_libdir}/libopencv_core.so
419%attr(755,root,root) %{_libdir}/libopencv_flann.so
420%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
421%attr(755,root,root) %{_libdir}/libopencv_ml.so
422%attr(755,root,root) %{_libdir}/libopencv_photo.so
423%attr(755,root,root) %{_libdir}/libopencv_video.so
424# GUI/extensions (base package)
425%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
cf32945e 426%attr(755,root,root) %{_libdir}/libopencv_features2d.so
cf32945e 427%attr(755,root,root) %{_libdir}/libopencv_highgui.so
cf32945e 428%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
cf32945e
JB
429%attr(755,root,root) %{_libdir}/libopencv_stitching.so
430%attr(755,root,root) %{_libdir}/libopencv_superres.so
cf32945e 431%attr(755,root,root) %{_libdir}/libopencv_videostab.so
33a5389a
JR
432%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so
433%attr(755,root,root) %{_libdir}/libopencv_shape.so
434%attr(755,root,root) %{_libdir}/libopencv_videoio.so
435%{_libdir}/libopencv_ts.a
cf32945e
JB
436# viz
437%if %{with vtk}
438%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 439%endif
901927d3 440%{_includedir}/opencv
509c07dc 441%{_includedir}/opencv2
da5d1e09 442%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 443%{_pkgconfigdir}/opencv.pc
901927d3 444
9141b1e2
ER
445%files doc
446%defattr(644,root,root,755)
447# TODO: probably could rebuild them and package via make install
448%doc doc/*
449
200823d5
ER
450%if %{with examples}
451%files examples
452%defattr(644,root,root,755)
453%{_examplesdir}/%{name}-%{version}
454%endif
455
b07433c6
JB
456%if %{with java}
457%files -n java-opencv
458%defattr(644,root,root,755)
835e0cdd
ER
459%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
460%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
461%{_javadir}/opencv.jar
462%endif
463
901927d3
AM
464%files -n python-opencv
465%defattr(644,root,root,755)
452b38e1 466%attr(755,root,root) %{py_sitedir}/cv2.so
33a5389a 467#%{py_sitedir}/cv.py[co]
This page took 0.129309 seconds and 4 git commands to generate.