]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- initial
[packages/opencv.git] / opencv.spec
CommitLineData
901927d3
AM
1%bcond_with xine
2%define snap pre1
3Summary: A library of programming functions mainly aimed at real time computer vision
4Name: opencv
5Version: 1.1
6Release: 0.%{snap}.1
7Epoch: 1
8License: BSD
9Group: Libraries
10Source0: http://dl.sourceforge.net/opencvlibrary/%{name}-%{version}%{snap}.tar.gz
11# Source0-md5: b147b7cd3c059831c415c5a2bcecdf95
12URL: http://opencv.willowgarage.com
13BuildRequires: autoconf >= 2.53
14BuildRequires: automake
15BuildRequires: ffmpeg-devel
16BuildRequires: jasper-devel
17BuildRequires: libdc1394-devel
18BuildRequires: libjpeg-devel
19BuildRequires: libpng-devel
20BuildRequires: libraw1394-devel
21BuildRequires: libtiff-devel
22BuildRequires: python-devel
23BuildRequires: rpm-pythonprov
24BuildRequires: zlib-devel
25%pyrequires_eq python-libs
26%{?with_xine:BuildRequires: xine-lib-devel}
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30OpenCV (Open Source Computer Vision) is a library of programming
31functions mainly aimed at real time computer vision.
32
33Example applications of the OpenCV library are Human-Computer
34Interaction (HCI); Object Identification, Segmentation and
35Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
36Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
37and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
38
39%package devel
40Summary: Header files and develpment documentation for opencv
41Group: Development/Libraries
42Requires: %{name} = %{epoch}:%{version}-%{release}
43
44%description devel
45Header files and opencv documentation.
46
47%package static
48Summary: Static opencv library
49Group: Development/Libraries
50Requires: %{name}-devel = %{epoch}:%{version}-%{release}
51
52%description static
53This package contains the static library used for development.
54
55%package -n python-opencv
56Summary: OpenCV Python bindings
57Group: Development/Languages/Python
58%pyrequires_eq python
59Requires: %{name} = %{version}-%{release}
60
61%description -n python-opencv
62OpenCV Python bindings.
63
64%prep
65%setup -q -n %{name}-%{version}.0
66
67%build
68%configure \
69%ifarch i686 pentium4 athlon %{x8664}
70 --enable-sse2 \
71%else
72 --disable-sse2 \
73%endif
74 --with-python \
75 --with%{!?with_xine:-out}-xine \
76 --with-ffmpeg \
77 --with-1394libs \
78 --with-v4l \
79 --with-gtk \
80 --without-gstreamer \
81 --without-quicktime
82%{__make}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87%{__make} install \
88 DESTDIR=$RPM_BUILD_ROOT
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%files
97%defattr(644,root,root,755)
98%doc AUTHORS COPYING ChangeLog THANKS TODO
99%doc docs/*.{htm,rtf,png,txt} docs/papers docs/ref
100%attr(755,root,root) %{_bindir}/*
101%attr(755,root,root) %{_libdir}/lib*so.*.*
102%attr(755,root,root) %ghost %{_libdir}/lib*.so.2
103
104%files devel
105%defattr(644,root,root,755)
106%attr(755,root,root) %{_libdir}/lib*.so
107%{_libdir}/lib*.la
108%{_includedir}/opencv
109%{_pkgconfigdir}/*.pc
110
111%files static
112%defattr(644,root,root,755)
113%{_libdir}/lib*.a
114
115%files -n python-opencv
116%defattr(644,root,root,755)
117%dir %{py_sitedir}/opencv
118%attr(755,root,root) %{py_sitedir}/opencv/*.so
119%{py_sitedir}/opencv/*.py[co]
This page took 0.114325 seconds and 4 git commands to generate.