]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- updated to 2.4.10.1
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
2acd8ac1 2# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 3# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 4# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 5#
0c2d6b7d 6# Conditional build:
a55ba198
JB
7# - general options:
8%bcond_with tbb # Threading Building Blocks support (everywhere)
9%bcond_with sse # use SSE instructions
10%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
11%bcond_with sse3 # use SSE3 instructions
12%bcond_with ssse3 # use SSSE3 instructions
13%bcond_with sse41 # use SSE4.1 instructions
14%bcond_with sse42 # use SSE4.2 instructions
15%bcond_with avx # use AVX instructions
8d5385eb
JB
16%bcond_without opencl # OpenCL support
17%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
18%bcond_with opencl_amdfft # AMD OpenCL FFT routines
19%bcond_without opengl # OpenGL support
cf32945e 20%bcond_without gomp # OpenMP support (available when not using tbb)
200823d5 21%bcond_without examples # Install examples
b07433c6
JB
22# - bindings
23%bcond_without java # Java binding
a55ba198 24# - highgui options:
b3920a9d 25%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
26%bcond_without gstreamer # GStreamer support in highgui
27%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 28%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 29%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 30%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 31%bcond_without v4l # Video4Linux in highgui
a55ba198 32%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 33%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
34# - other modules
35%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 36
1c9fe580
JB
37%ifarch pentium3 pentium4 %{x8664}
38%define with_sse 1
39%endif
40%ifarch pentium4 %{x8664}
41%define with_sse2 1
42%endif
901927d3 43Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 44Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 45Name: opencv
158e0ccc
JB
46Version: 2.4.10.1
47Release: 1
901927d3 48Epoch: 1
d5e56e66
JB
49%if %{with unicap} || %{with xine}
50License: GPL (enforced by used libraries), BSD (opencv itself)
51%else
901927d3 52License: BSD
d5e56e66 53%endif
901927d3 54Group: Libraries
200823d5 55Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
158e0ccc 56# Source0-md5: f84af999f45edc829bfda60a13fedbaa
452b38e1 57Patch0: %{name}-cflags.patch
158e0ccc 58Patch1: %{name}-x86.patch
452b38e1 59Patch2: %{name}-unicap-c++.patch
60Patch3: %{name}-c.patch
61Patch4: %{name}-gcc.patch
809ce413 62Patch5: %{name}-ximea.patch
6994c4f7 63Patch6: %{name}-ocl-fft.patch
a4737151 64Patch7: java-ant-sourcelevel.patch
da5d1e09 65Patch8: %{name}-shared.patch
200823d5 66URL: http://www.opencv.org/
d5e56e66 67%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 68%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 69BuildRequires: OpenEXR-devel
5df3cf1b 70%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 71%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 72# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 73%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 74%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 75%{?with_java:BuildRequires: ant}
ef4af528
JB
76%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
77%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 78BuildRequires: cmake >= 2.8
0c2d6b7d 79BuildRequires: doxygen
809ce413 80BuildRequires: eigen3 >= 3
b3920a9d 81%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
da5d1e09 82%{?with_gomp:BuildRequires: gcc-c++ >= 6:4.2}
0c2d6b7d 83%if %{with gstreamer}
158e0ccc
JB
84BuildRequires: gstreamer-devel >= 1.0
85BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 86%endif
901927d3 87BuildRequires: jasper-devel
b07433c6 88%{?with_java:BuildRequires: jdk}
158e0ccc 89BuildRequires: libdc1394-devel >= 2
da5d1e09 90%{?with_gomp:BuildRequires: libgomp-devel}
901927d3
AM
91BuildRequires: libjpeg-devel
92BuildRequires: libpng-devel
93BuildRequires: libraw1394-devel
0c2d6b7d 94BuildRequires: libstdc++-devel
901927d3 95BuildRequires: libtiff-devel
148338c5 96BuildRequires: libtool
d5e56e66
JB
97%if %{with unicap}
98BuildRequires: libucil-devel
99BuildRequires: libunicap-devel
100%endif
0c2d6b7d 101BuildRequires: libv4l-devel
af6d2888 102BuildRequires: pkgconfig
158e0ccc
JB
103BuildRequires: python >= 2.0
104BuildRequires: python-devel >= 2.0
0c2d6b7d 105BuildRequires: python-numpy-devel
901927d3 106BuildRequires: rpm-pythonprov
8d499a62 107BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 108BuildRequires: sed >= 4.0
158e0ccc 109BuildRequires: sphinx-pdg
996927aa 110BuildRequires: swig-python
f8e040cc 111%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
112%if %{with vtk}
113BuildRequires: vtk-devel >= 5.8.0
fba97d16 114BuildRequires: vtk-java >= 5.8.0
ae3d975d
AM
115BuildRequires: vtk-tcl >= 5.8.0
116%endif
901927d3 117%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 118BuildRequires: xorg-lib-libX11-devel
452b38e1 119BuildRequires: zlib-devel
4afb606b 120%if %{with qt}
4afb606b
JB
121BuildRequires: QtCore-devel >= 4
122BuildRequires: QtGui-devel >= 4
5df3cf1b 123%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
124BuildRequires: qt4-qmake >= 4
125%else
126BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 127%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 128%endif
da5d1e09 129Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
130BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
131
158e0ccc 132%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
933de752 133
901927d3
AM
134%description
135OpenCV (Open Source Computer Vision) is a library of programming
136functions mainly aimed at real time computer vision.
137
0c2d6b7d
JB
138Example applications of the OpenCV library are:
139- Human-Computer Interaction (HCI)
140- Object Identification, Segmentation and Recognition
141- Face Recognition
142- Gesture Recognition
143- Motion Tracking
144- Ego Motion, Motion Understanding
145- Structure From Motion (SFM)
146- Stereo and Multi-Camera Calibration and Depth Computation
147- Mobile Robotics.
148
149%description -l pl.UTF-8
150OpenCV (Open Source Computer Vision) to biblioteka funkcji
151przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
152
153Przykładowe zastosowania biblioteki OpenCV to
154- interakcje człowiek-komputer (HCI)
155- identyfikacja, segmentacja i rozpoznawanie obiektów
156- rozpoznawanie twarzy
157- rozpoznawanie gestów
158- śledzenie ruchu
159- rozumienie ruchu
160- SFM (Structure From Motion)
161- kalibracja dwu- i wielokamerowa, obliczanie głębi
162- robotyka ruchu.
901927d3 163
933de752
ER
164%package core
165Summary: OpenCV core libraries
da5d1e09 166Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 167Group: Libraries
da5d1e09 168Conflicts: opencv < 2.4.6.2-1
933de752
ER
169
170%description core
171This package contains the OpenCV C/C++ core libraries.
172
da5d1e09
JB
173%description core -l pl.UTF-8
174Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
175
cf32945e
JB
176%package viz
177Summary: OpenCV viz library (VTK support)
178Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
179Group: Libraries
180Requires: %{name} = %{epoch}:%{version}-%{release}
181
182%description viz
183OpenCV viz library (VTK support).
184
185%description viz -l pl.UTF-8
186Biblioteka OpenCV viz (obsługa VTK).
187
901927d3 188%package devel
0c2d6b7d
JB
189Summary: Header files for OpenCV library
190Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
191Group: Development/Libraries
192Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
193%if %{with vtk}
194Requires: %{name}-viz = %{epoch}:%{version}-%{release}
195%endif
0c2d6b7d 196Obsoletes: opencv-static
901927d3
AM
197
198%description devel
0c2d6b7d 199Header files for OpenCV library.
901927d3 200
0c2d6b7d
JB
201%description devel -l pl.UTF-8
202Pliki nagłówkowe biblioteki OpenCV.
901927d3 203
9141b1e2
ER
204%package doc
205Summary: Manual for OpenCV
206Summary(fr.UTF-8): Documentation pour OpenCV
207Summary(it.UTF-8): Documentazione di OpenCV
208Summary(pl.UTF-8): Podręcznik dla OpenCV
209Group: Documentation
210# noarch subpackages only when building with rpm5
211%if "%{_rpmversion}" >= "5"
212BuildArch: noarch
213%endif
214
215%description doc
216Documentation for OpenCV.
217
218%description doc -l fr.UTF-8
219Documentation pour OpenCV.
220
221%description doc -l it.UTF-8
222Documentazione di OpenCV.
223
224%description doc -l pl.UTF-8
225Dokumentacja do OpenCV.
226
200823d5
ER
227%package examples
228Summary: OpenCV code examples
229Group: Documentation
230%if "%{_rpmversion}" >= "5"
231BuildArch: noarch
232%endif
233
234%description examples
235OpenCV code examples.
236
b07433c6
JB
237%package -n java-opencv
238Summary: OpenCV Java bindings
239Summary(pl.UTF-8): Wiązania Javy do OpenCV
240Group: Libraries/Java
241Requires: %{name} = %{epoch}:%{version}-%{release}
242Requires: jre
243
244%description -n java-opencv
245OpenCV Java bindings.
246
247%description -n java-opencv -l pl.UTF-8
248Wiązania Javy do OpenCV.
249
901927d3
AM
250%package -n python-opencv
251Summary: OpenCV Python bindings
0c2d6b7d
JB
252Summary(pl.UTF-8): Wiązania Pythona do OpenCV
253Group: Libraries/Python
cd1f0136 254Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 255Requires: python-libs
901927d3
AM
256
257%description -n python-opencv
258OpenCV Python bindings.
259
0c2d6b7d
JB
260%description -n python-opencv -l pl.UTF-8
261Wiązania Pythona do OpenCV.
262
901927d3 263%prep
25269a76 264%setup -q
54551f29 265
da67222a 266%undos CMakeLists.txt
1376dffe 267%undos modules/gpu/CMakeLists.txt
54551f29 268
1376dffe 269%patch0 -p1
270%patch1 -p1
29d82ddf 271%patch2 -p1
f8e040cc 272%patch3 -p1
75b912e9 273%patch4 -p1
809ce413 274%patch5 -p1
6994c4f7 275%patch6 -p1
a4737151 276%patch7 -p1
da5d1e09 277%patch8 -p1
148338c5 278
901927d3 279%build
95daeb66
AM
280install -d build
281cd build
ea26b025
ER
282
283# handle cmake & ccache
284# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
285if [[ "%{__cc}" = *ccache* ]]; then
286 cc="%{__cc}"
287 cxx="%{__cxx}"
288 ccache="
289 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
290 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
291 "
292fi
293
0c2d6b7d 294%cmake .. \
ea26b025 295 $ccache \
da5d1e09 296 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
297 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
298 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
299 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
300 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
301 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
302 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 303 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
304%if %{with examples}
305 -DINSTALL_C_EXAMPLES=ON \
306 -DINSTALL_PYTHON_EXAMPLES=ON \
307%endif
b3920a9d 308 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 309 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 310 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
311 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
312 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 313 %{?with_opengl:-DWITH_OPENGL=ON} \
da5d1e09 314 %{?with_gomp:-DWITH_OPENMP=ON} \
1c9fe580 315 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 316 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 317 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 318 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 319 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 320 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 321 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 322 %{?with_ximea:-DWITH_XIMEA=ON} \
d5e56e66 323 %{?with_xine:-DWITH_XINE=ON}
54551f29 324
8b9f61f7 325%{__make}
901927d3
AM
326
327%install
328rm -rf $RPM_BUILD_ROOT
95daeb66 329%{__make} -C build install \
901927d3
AM
330 DESTDIR=$RPM_BUILD_ROOT
331
9141b1e2
ER
332# see -doc package
333%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
200823d5
ER
334%if %{with examples}
335install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
336mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
337%endif
9141b1e2 338
4bd2eae7 339install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 340cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 341
8d499a62
JB
342%py_comp $RPM_BUILD_ROOT%{py_sitedir}
343%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
344%py_postclean
345
b07433c6
JB
346%if %{with java}
347# move to proper directories, create symlink
348install -d $RPM_BUILD_ROOT%{_javadir}
349%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
350sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
351 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
352%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
353rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
354ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
355%endif
356
901927d3
AM
357%clean
358rm -rf $RPM_BUILD_ROOT
359
360%post -p /sbin/ldconfig
361%postun -p /sbin/ldconfig
362
933de752
ER
363%post core -p /sbin/ldconfig
364%postun core -p /sbin/ldconfig
365
485d5dca
JB
366%post viz -p /sbin/ldconfig
367%postun viz -p /sbin/ldconfig
368
b07433c6
JB
369%post -n java-opencv -p /sbin/ldconfig
370%postun -n java-opencv -p /sbin/ldconfig
371
901927d3
AM
372%files
373%defattr(644,root,root,755)
933de752
ER
374%attr(755,root,root) %{_bindir}/opencv_createsamples
375%attr(755,root,root) %{_bindir}/opencv_haartraining
376%attr(755,root,root) %{_bindir}/opencv_performance
377%attr(755,root,root) %{_bindir}/opencv_traincascade
158e0ccc 378%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
da5d1e09 379%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
158e0ccc 380%attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
da5d1e09 381%attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
158e0ccc 382%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
da5d1e09 383%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
158e0ccc 384%attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
cf32945e 385%attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
158e0ccc 386%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
da5d1e09 387%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
158e0ccc 388%attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
da5d1e09 389%attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
158e0ccc 390%attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
cf32945e 391%attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
158e0ccc 392%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
da5d1e09
JB
393%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
394%if %{with opencl}
158e0ccc 395%attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
da5d1e09
JB
396%attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
397%endif
158e0ccc 398%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
da5d1e09 399%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
158e0ccc 400%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
da5d1e09 401%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
158e0ccc 402%attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
cf32945e 403%attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
158e0ccc 404%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
da5d1e09 405%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
452b38e1 406%dir %{_datadir}/OpenCV
452b38e1 407%{_datadir}/OpenCV/haarcascades
408%{_datadir}/OpenCV/lbpcascades
901927d3 409
933de752
ER
410%files core
411%defattr(644,root,root,755)
158e0ccc 412%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
cf32945e 413%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
158e0ccc 414%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
cf32945e 415%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
158e0ccc 416%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
cf32945e 417%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
158e0ccc 418%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
cf32945e 419%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
158e0ccc 420%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
cf32945e 421%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
158e0ccc 422%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
cf32945e
JB
423%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
424
425%if %{with vtk}
426%files viz
427%defattr(644,root,root,755)
158e0ccc 428%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
cf32945e
JB
429%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
430%endif
933de752 431
901927d3
AM
432%files devel
433%defattr(644,root,root,755)
cf32945e
JB
434# core
435%attr(755,root,root) %{_libdir}/libopencv_core.so
436%attr(755,root,root) %{_libdir}/libopencv_flann.so
437%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
438%attr(755,root,root) %{_libdir}/libopencv_ml.so
439%attr(755,root,root) %{_libdir}/libopencv_photo.so
440%attr(755,root,root) %{_libdir}/libopencv_video.so
441# GUI/extensions (base package)
442%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
443%attr(755,root,root) %{_libdir}/libopencv_contrib.so
444%attr(755,root,root) %{_libdir}/libopencv_features2d.so
445%attr(755,root,root) %{_libdir}/libopencv_gpu.so
446%attr(755,root,root) %{_libdir}/libopencv_highgui.so
447%attr(755,root,root) %{_libdir}/libopencv_legacy.so
448%attr(755,root,root) %{_libdir}/libopencv_nonfree.so
449%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
450%if %{with opencl}
451%attr(755,root,root) %{_libdir}/libopencv_ocl.so
452%endif
453%attr(755,root,root) %{_libdir}/libopencv_stitching.so
454%attr(755,root,root) %{_libdir}/libopencv_superres.so
455%attr(755,root,root) %{_libdir}/libopencv_ts.so
456%attr(755,root,root) %{_libdir}/libopencv_videostab.so
457# viz
458%if %{with vtk}
459%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 460%endif
901927d3 461%{_includedir}/opencv
509c07dc 462%{_includedir}/opencv2
da5d1e09 463%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 464%{_pkgconfigdir}/opencv.pc
901927d3 465
9141b1e2
ER
466%files doc
467%defattr(644,root,root,755)
468# TODO: probably could rebuild them and package via make install
469%doc doc/*
470
200823d5
ER
471%if %{with examples}
472%files examples
473%defattr(644,root,root,755)
474%{_examplesdir}/%{name}-%{version}
475%endif
476
b07433c6
JB
477%if %{with java}
478%files -n java-opencv
479%defattr(644,root,root,755)
835e0cdd
ER
480%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
481%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
482%{_javadir}/opencv.jar
483%endif
484
901927d3
AM
485%files -n python-opencv
486%defattr(644,root,root,755)
452b38e1 487%attr(755,root,root) %{py_sitedir}/cv2.so
8d499a62 488%{py_sitedir}/cv.py[co]
This page took 0.194479 seconds and 4 git commands to generate.