]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- up to 3.1.0 auto/th/opencv-3.1.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 16 Mar 2016 19:26:37 +0000 (20:26 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 16 Mar 2016 19:26:37 +0000 (20:26 +0100)
- ts cannot be build as shared without ipp
- no separate ocl library now

no-sysctl.patch [deleted file]
opencv-c.patch [deleted file]
opencv-cmake.patch [deleted file]
opencv-gcc.patch [deleted file]
opencv-ocl-fft.patch [deleted file]
opencv-shared.patch [deleted file]
opencv-unicap-c++.patch [deleted file]
opencv.spec

diff --git a/no-sysctl.patch b/no-sysctl.patch
deleted file mode 100644 (file)
index 8488f79..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-Description: get rid of sysctl includes on Linux
- The 'sysctl' syscall has been strongly deprecated on Linux for ages.
- Currently, on old architectures it will spam syslog whenever used, and on
- newer ones it's missing from the headers altogether.  Opencv has migrated
- away on Linux already, but #include statements were left lingering.
- .
- This patch removes such #includes on non-__APPLE__, unbreaking x32.
-Author: Adam Borowski <kilobyte@angband.pl>
-
---- opencv-2.4.9.1+dfsg.orig/modules/core/src/parallel.cpp
-+++ opencv-2.4.9.1+dfsg/modules/core/src/parallel.cpp
-@@ -56,7 +56,7 @@
-     #include <sys/types.h>
-     #if defined ANDROID
-         #include <sys/sysconf.h>
--    #else
-+    #elif defined __APPLE__
-         #include <sys/sysctl.h>
-     #endif
- #endif
---- opencv-2.4.9.1+dfsg.orig/modules/core/src/system.cpp
-+++ opencv-2.4.9.1+dfsg/modules/core/src/system.cpp
-@@ -163,8 +163,6 @@ std::wstring GetTempFileNameWinRT(std::w
- #include <sys/types.h>
- #if defined ANDROID
- #include <sys/sysconf.h>
--#else
--#include <sys/sysctl.h>
- #endif
- #endif
---- opencv-2.4.9.1+dfsg.orig/modules/highgui/src/cap_ffmpeg_impl.hpp
-+++ opencv-2.4.9.1+dfsg/modules/highgui/src/cap_ffmpeg_impl.hpp
-@@ -145,7 +145,7 @@ extern "C" {
- #if defined WIN32 || defined _WIN32
-     #include <windows.h>
--#elif defined __linux__ || defined __APPLE__
-+#elif defined __APPLE__
-     #include <unistd.h>
-     #include <stdio.h>
-     #include <sys/types.h>
diff --git a/opencv-c.patch b/opencv-c.patch
deleted file mode 100644 (file)
index 52256d1..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- OpenCV-2.2.0/modules/legacy/include/opencv2/legacy/blobtrack.hpp.orig      2010-12-05 04:35:25.000000000 +0100
-+++ OpenCV-2.2.0/modules/legacy/include/opencv2/legacy/blobtrack.hpp   2011-03-09 19:14:52.579414618 +0100
-@@ -47,6 +47,9 @@
- //#if _MSC_VER >= 1200
- #include "opencv2/core/core_c.h"
-+
-+#ifdef __cplusplus
-+
- #include <stdio.h>
- #if _MSC_VER >= 1200 || defined __BORLANDC__
-@@ -943,6 +946,8 @@
- CV_EXPORTS void cvTestSeqAddIntensityVariation(CvTestSeq* pTestSeq, float DI_per_frame, float MinI, float MaxI);
- CV_EXPORTS void cvTestSeqSetFrame(CvTestSeq* pTestSeq, int n);
-+#endif /* __cplusplus */
-+
- #endif
- /* End of file. */
diff --git a/opencv-cmake.patch b/opencv-cmake.patch
deleted file mode 100644 (file)
index 14de6e2..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
---- opencv-2.4.11/samples/gpu/CMakeLists.txt.orig      2015-02-25 13:10:31.000000000 +0100
-+++ opencv-2.4.11/samples/gpu/CMakeLists.txt   2015-05-19 18:35:11.803554049 +0200
-@@ -4,6 +4,15 @@
-                                      opencv_superres)
- ocv_check_dependencies(${OPENCV_GPU_SAMPLES_REQUIRED_DEPS})
-+# remove all matching elements from the list
-+MACRO(list_filterout lst regex)
-+  foreach(item ${${lst}})
-+    if(item MATCHES "${regex}")
-+      list(REMOVE_ITEM ${lst} "${item}")
-+    endif()
-+  endforeach()
-+ENDMACRO()
-+
- if(BUILD_EXAMPLES AND OCV_DEPENDENCIES_FOUND)
-   set(project "gpu")
-   string(TOUPPER "${project}" project_upper)
-@@ -69,15 +78,6 @@
-     endif()
-   ENDMACRO()
--  # remove all matching elements from the list
--  MACRO(list_filterout lst regex)
--    foreach(item ${${lst}})
--      if(item MATCHES "${regex}")
--        list(REMOVE_ITEM ${lst} "${item}")
--      endif()
--    endforeach()
--  ENDMACRO()
--
-   file(GLOB all_samples RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.cpp)
-   if(NOT HAVE_OPENGL)
diff --git a/opencv-gcc.patch b/opencv-gcc.patch
deleted file mode 100644 (file)
index eb8a7f0..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- OpenCV-2.2.0/modules/core/include/opencv2/core/core.hpp.orig       2010-12-05 04:35:24.000000000 +0100
-+++ OpenCV-2.2.0/modules/core/include/opencv2/core/core.hpp    2011-06-28 21:14:32.258435783 +0200
-@@ -56,6 +56,7 @@
- #include <algorithm>
- #include <cmath>
- #include <complex>
-+#include <cstddef>
- #include <map>
- #include <new>
- #include <string>
diff --git a/opencv-ocl-fft.patch b/opencv-ocl-fft.patch
deleted file mode 100644 (file)
index 541bf9f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- OpenCV-2.4.3/modules/ocl/src/fft.cpp.orig  2012-10-23 00:55:11.000000000 +0200
-+++ OpenCV-2.4.3/modules/ocl/src/fft.cpp       2013-02-16 08:52:00.733063588 +0100
-@@ -95,6 +95,8 @@
-             // if not, bake a new one, put it into the planStore and return it.
-             static clAmdFftPlanHandle getPlan(Size _dft_size, int _src_step, int _dst_step, int _flags, FftType _type);
-         };
-+      void fft_setup();
-+      void fft_teardown();
-     }
- }
- bool cv::ocl::FftPlan::started = false;
diff --git a/opencv-shared.patch b/opencv-shared.patch
deleted file mode 100644 (file)
index 8a00e98..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- opencv-2.4.8/modules/ts/CMakeLists.txt.orig        2013-12-27 18:09:18.000000000 +0100
-+++ opencv-2.4.8/modules/ts/CMakeLists.txt     2014-02-12 20:02:41.148482142 +0100
-@@ -4,7 +4,6 @@
-   ocv_module_disable(ts)
- endif()
--set(OPENCV_MODULE_TYPE STATIC)
- set(OPENCV_MODULE_IS_PART_OF_WORLD FALSE)
- ocv_warnings_disable(CMAKE_CXX_FLAGS -Wundef)
diff --git a/opencv-unicap-c++.patch b/opencv-unicap-c++.patch
deleted file mode 100644 (file)
index 30aa8a9..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- OpenCV-2.2.0/modules/highgui/src/cap_unicap.cpp.orig       2010-12-05 04:35:25.000000000 +0100
-+++ OpenCV-2.2.0/modules/highgui/src/cap_unicap.cpp    2011-01-23 21:17:45.126368322 +0100
-@@ -43,10 +43,12 @@
- #include "precomp.hpp"
- #include <unistd.h>
-+#define private privat
- #include <unicap.h>
- extern "C" {
- #include <ucil.h>
- }
-+#undef private
- #ifdef NDEBUG
- #define CV_WARN(message)
index 1accacf7cfe84c6682c3089184b27b0861566fad..18593a8cf6308ae8034aeb0463799f01159109ae 100644 (file)
@@ -43,7 +43,7 @@
 Summary:       A library of programming functions mainly aimed at real time computer vision
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
-Version:       2.4.12.3
+Version:       3.1.0
 Release:       1
 Epoch:         1
 %if %{with unicap} || %{with xine}
@@ -53,17 +53,10 @@ License:    BSD
 %endif
 Group:         Libraries
 Source0:       https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 2496a4a4caf8fecfbfc294fbe6a814b0
+# Source0-md5: 70e1dd07f0aa06606f1bc0e3fa15abd3
 Patch0:                %{name}-cflags.patch
-Patch1:                %{name}-cmake.patch
-Patch2:                %{name}-unicap-c++.patch
-Patch3:                %{name}-c.patch
-Patch4:                %{name}-gcc.patch
 Patch5:                %{name}-ximea.patch
-Patch6:                %{name}-ocl-fft.patch
 Patch7:                java-ant-sourcelevel.patch
-Patch8:                %{name}-shared.patch
-Patch9:                no-sysctl.patch
 Patch10:       cmake-install-path.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
@@ -267,18 +260,10 @@ Wiązania Pythona do OpenCV.
 %setup -q
 
 %undos CMakeLists.txt
-%undos modules/gpu/CMakeLists.txt
 
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 %patch5 -p1
-%patch6 -p1
 %patch7 -p1
-%patch8 -p1
-%patch9 -p1
 %patch10 -p1
 
 %build
@@ -325,7 +310,8 @@ fi
        %{!?with_v4l:-DWITH_V4L=OFF} \
        %{?with_vtk:-DWITH_VTK=ON} \
        %{?with_ximea:-DWITH_XIMEA=ON} \
-       %{?with_xine:-DWITH_XINE=ON}
+       %{?with_xine:-DWITH_XINE=ON} \
+       -DWITH_IPP=OFF
 
 %{__make}
 
@@ -334,8 +320,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# see -doc package
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
 %if %{with examples}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
@@ -381,37 +365,21 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/opencv_annotation
 %attr(755,root,root) %{_bindir}/opencv_createsamples
-%attr(755,root,root) %{_bindir}/opencv_haartraining
-%attr(755,root,root) %{_bindir}/opencv_performance
 %attr(755,root,root) %{_bindir}/opencv_traincascade
 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
-%attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
-%attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
-%attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
-%attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
-%if %{with opencl}
-%attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
-%endif
+%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
-%attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.3.1
 %dir %{_datadir}/OpenCV
 %{_datadir}/OpenCV/haarcascades
 %{_datadir}/OpenCV/lbpcascades
@@ -419,23 +387,29 @@ rm -rf $RPM_BUILD_ROOT
 %files core
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.3.1
 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.3.1
+%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.3.1
+%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.3.1
+%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.3.1
 
 %if %{with vtk}
 %files viz
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
+%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.3.1
 %endif
 
 %files devel
@@ -449,20 +423,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libopencv_video.so
 # GUI/extensions (base package)
 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
-%attr(755,root,root) %{_libdir}/libopencv_contrib.so
 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
-%attr(755,root,root) %{_libdir}/libopencv_gpu.so
 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
-%attr(755,root,root) %{_libdir}/libopencv_legacy.so
-%attr(755,root,root) %{_libdir}/libopencv_nonfree.so
 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
-%if %{with opencl}
-%attr(755,root,root) %{_libdir}/libopencv_ocl.so
-%endif
 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
 %attr(755,root,root) %{_libdir}/libopencv_superres.so
-%attr(755,root,root) %{_libdir}/libopencv_ts.so
 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
+%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so
+%attr(755,root,root) %{_libdir}/libopencv_shape.so
+%attr(755,root,root) %{_libdir}/libopencv_videoio.so
+%{_libdir}/libopencv_ts.a
 # viz
 %if %{with vtk}
 %attr(755,root,root) %{_libdir}/libopencv_viz.so
@@ -494,4 +464,4 @@ rm -rf $RPM_BUILD_ROOT
 %files -n python-opencv
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/cv2.so
-%{py_sitedir}/cv.py[co]
+#%{py_sitedir}/cv.py[co]
This page took 0.043956 seconds and 4 git commands to generate.