]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- rel 4; BR vtk-tcl
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
2acd8ac1 2# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 3# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 4# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 5#
0c2d6b7d 6# Conditional build:
a55ba198
JB
7# - general options:
8%bcond_with tbb # Threading Building Blocks support (everywhere)
9%bcond_with sse # use SSE instructions
10%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
11%bcond_with sse3 # use SSE3 instructions
12%bcond_with ssse3 # use SSSE3 instructions
13%bcond_with sse41 # use SSE4.1 instructions
14%bcond_with sse42 # use SSE4.2 instructions
15%bcond_with avx # use AVX instructions
8d5385eb
JB
16%bcond_without opencl # OpenCL support
17%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
18%bcond_with opencl_amdfft # AMD OpenCL FFT routines
19%bcond_without opengl # OpenGL support
cf32945e 20%bcond_without gomp # OpenMP support (available when not using tbb)
200823d5 21%bcond_without examples # Install examples
b07433c6
JB
22# - bindings
23%bcond_without java # Java binding
a55ba198 24# - highgui options:
b3920a9d 25%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
26%bcond_without gstreamer # GStreamer support in highgui
27%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 28%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 29%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 30%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 31%bcond_without v4l # Video4Linux in highgui
a55ba198 32%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 33%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
34# - other modules
35%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 36
1c9fe580
JB
37%ifarch pentium3 pentium4 %{x8664}
38%define with_sse 1
39%endif
40%ifarch pentium4 %{x8664}
41%define with_sse2 1
42%endif
901927d3 43Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 44Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 45Name: opencv
200823d5 46Version: 2.4.9
ae3d975d 47Release: 4
901927d3 48Epoch: 1
d5e56e66
JB
49%if %{with unicap} || %{with xine}
50License: GPL (enforced by used libraries), BSD (opencv itself)
51%else
901927d3 52License: BSD
d5e56e66 53%endif
901927d3 54Group: Libraries
200823d5
ER
55Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
56# Source0-md5: cc0a8307403ff471f554197401ec0eb9
452b38e1 57Patch0: %{name}-cflags.patch
58Patch1: %{name}-link.patch
59Patch2: %{name}-unicap-c++.patch
60Patch3: %{name}-c.patch
61Patch4: %{name}-gcc.patch
809ce413 62Patch5: %{name}-ximea.patch
6994c4f7 63Patch6: %{name}-ocl-fft.patch
a4737151 64Patch7: java-ant-sourcelevel.patch
da5d1e09 65Patch8: %{name}-shared.patch
200823d5 66URL: http://www.opencv.org/
d5e56e66 67%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 68%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 69BuildRequires: OpenEXR-devel
5df3cf1b 70%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 71%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 72# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 73%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 74%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 75%{?with_java:BuildRequires: ant}
ef4af528
JB
76%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
77%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 78BuildRequires: cmake >= 2.8
0c2d6b7d 79BuildRequires: doxygen
809ce413 80BuildRequires: eigen3 >= 3
b3920a9d 81%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
da5d1e09 82%{?with_gomp:BuildRequires: gcc-c++ >= 6:4.2}
0c2d6b7d
JB
83%if %{with gstreamer}
84BuildRequires: gstreamer-devel >= 0.10
85BuildRequires: gstreamer-plugins-base-devel >= 0.10
86%endif
901927d3 87BuildRequires: jasper-devel
b07433c6 88%{?with_java:BuildRequires: jdk}
901927d3 89BuildRequires: libdc1394-devel
da5d1e09 90%{?with_gomp:BuildRequires: libgomp-devel}
901927d3
AM
91BuildRequires: libjpeg-devel
92BuildRequires: libpng-devel
93BuildRequires: libraw1394-devel
0c2d6b7d 94BuildRequires: libstdc++-devel
901927d3 95BuildRequires: libtiff-devel
148338c5 96BuildRequires: libtool
d5e56e66
JB
97%if %{with unicap}
98BuildRequires: libucil-devel
99BuildRequires: libunicap-devel
100%endif
0c2d6b7d 101BuildRequires: libv4l-devel
af6d2888 102BuildRequires: pkgconfig
b07433c6 103BuildRequires: python
901927d3 104BuildRequires: python-devel
0c2d6b7d 105BuildRequires: python-numpy-devel
901927d3 106BuildRequires: rpm-pythonprov
8d499a62 107BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 108BuildRequires: sed >= 4.0
996927aa 109BuildRequires: swig-python
f8e040cc 110%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
111%if %{with vtk}
112BuildRequires: vtk-devel >= 5.8.0
113BuildRequires: vtk-tcl >= 5.8.0
114%endif
901927d3 115%{?with_xine:BuildRequires: xine-lib-devel}
452b38e1 116BuildRequires: zlib-devel
4afb606b 117%if %{with qt}
4afb606b
JB
118BuildRequires: QtCore-devel >= 4
119BuildRequires: QtGui-devel >= 4
5df3cf1b 120%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
121BuildRequires: qt4-qmake >= 4
122%else
123BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 124%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 125%endif
da5d1e09 126Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
127BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
933de752 129%define sover %(v=%{version}; k=${v#?.?.?}; echo ${v%$k})
835e0cdd 130%define jver %(echo %{version} | tr -d .)
933de752 131
901927d3
AM
132%description
133OpenCV (Open Source Computer Vision) is a library of programming
134functions mainly aimed at real time computer vision.
135
0c2d6b7d
JB
136Example applications of the OpenCV library are:
137- Human-Computer Interaction (HCI)
138- Object Identification, Segmentation and Recognition
139- Face Recognition
140- Gesture Recognition
141- Motion Tracking
142- Ego Motion, Motion Understanding
143- Structure From Motion (SFM)
144- Stereo and Multi-Camera Calibration and Depth Computation
145- Mobile Robotics.
146
147%description -l pl.UTF-8
148OpenCV (Open Source Computer Vision) to biblioteka funkcji
149przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
150
151Przykładowe zastosowania biblioteki OpenCV to
152- interakcje człowiek-komputer (HCI)
153- identyfikacja, segmentacja i rozpoznawanie obiektów
154- rozpoznawanie twarzy
155- rozpoznawanie gestów
156- śledzenie ruchu
157- rozumienie ruchu
158- SFM (Structure From Motion)
159- kalibracja dwu- i wielokamerowa, obliczanie głębi
160- robotyka ruchu.
901927d3 161
933de752
ER
162%package core
163Summary: OpenCV core libraries
da5d1e09 164Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 165Group: Libraries
da5d1e09 166Conflicts: opencv < 2.4.6.2-1
933de752
ER
167
168%description core
169This package contains the OpenCV C/C++ core libraries.
170
da5d1e09
JB
171%description core -l pl.UTF-8
172Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
173
cf32945e
JB
174%package viz
175Summary: OpenCV viz library (VTK support)
176Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
177Group: Libraries
178Requires: %{name} = %{epoch}:%{version}-%{release}
179
180%description viz
181OpenCV viz library (VTK support).
182
183%description viz -l pl.UTF-8
184Biblioteka OpenCV viz (obsługa VTK).
185
901927d3 186%package devel
0c2d6b7d
JB
187Summary: Header files for OpenCV library
188Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
189Group: Development/Libraries
190Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
191%if %{with vtk}
192Requires: %{name}-viz = %{epoch}:%{version}-%{release}
193%endif
0c2d6b7d 194Obsoletes: opencv-static
901927d3
AM
195
196%description devel
0c2d6b7d 197Header files for OpenCV library.
901927d3 198
0c2d6b7d
JB
199%description devel -l pl.UTF-8
200Pliki nagłówkowe biblioteki OpenCV.
901927d3 201
9141b1e2
ER
202%package doc
203Summary: Manual for OpenCV
204Summary(fr.UTF-8): Documentation pour OpenCV
205Summary(it.UTF-8): Documentazione di OpenCV
206Summary(pl.UTF-8): Podręcznik dla OpenCV
207Group: Documentation
208# noarch subpackages only when building with rpm5
209%if "%{_rpmversion}" >= "5"
210BuildArch: noarch
211%endif
212
213%description doc
214Documentation for OpenCV.
215
216%description doc -l fr.UTF-8
217Documentation pour OpenCV.
218
219%description doc -l it.UTF-8
220Documentazione di OpenCV.
221
222%description doc -l pl.UTF-8
223Dokumentacja do OpenCV.
224
200823d5
ER
225%package examples
226Summary: OpenCV code examples
227Group: Documentation
228%if "%{_rpmversion}" >= "5"
229BuildArch: noarch
230%endif
231
232%description examples
233OpenCV code examples.
234
b07433c6
JB
235%package -n java-opencv
236Summary: OpenCV Java bindings
237Summary(pl.UTF-8): Wiązania Javy do OpenCV
238Group: Libraries/Java
239Requires: %{name} = %{epoch}:%{version}-%{release}
240Requires: jre
241
242%description -n java-opencv
243OpenCV Java bindings.
244
245%description -n java-opencv -l pl.UTF-8
246Wiązania Javy do OpenCV.
247
901927d3
AM
248%package -n python-opencv
249Summary: OpenCV Python bindings
0c2d6b7d
JB
250Summary(pl.UTF-8): Wiązania Pythona do OpenCV
251Group: Libraries/Python
cd1f0136 252Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 253Requires: python-libs
901927d3
AM
254
255%description -n python-opencv
256OpenCV Python bindings.
257
0c2d6b7d
JB
258%description -n python-opencv -l pl.UTF-8
259Wiązania Pythona do OpenCV.
260
901927d3 261%prep
25269a76 262%setup -q
54551f29 263
da67222a 264%undos CMakeLists.txt
1376dffe 265%undos modules/gpu/CMakeLists.txt
54551f29 266
1376dffe 267%patch0 -p1
268%patch1 -p1
29d82ddf 269%patch2 -p1
f8e040cc 270%patch3 -p1
75b912e9 271%patch4 -p1
809ce413 272%patch5 -p1
6994c4f7 273%patch6 -p1
a4737151 274%patch7 -p1
da5d1e09 275%patch8 -p1
148338c5 276
901927d3 277%build
95daeb66
AM
278install -d build
279cd build
ea26b025
ER
280
281# handle cmake & ccache
282# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
283if [[ "%{__cc}" = *ccache* ]]; then
284 cc="%{__cc}"
285 cxx="%{__cxx}"
286 ccache="
287 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
288 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
289 "
290fi
291
0c2d6b7d 292%cmake .. \
ea26b025 293 $ccache \
da5d1e09 294 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
295 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
296 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
297 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
298 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
299 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
300 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 301 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
302%if %{with examples}
303 -DINSTALL_C_EXAMPLES=ON \
304 -DINSTALL_PYTHON_EXAMPLES=ON \
305%endif
b3920a9d 306 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 307 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 308 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
309 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
310 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 311 %{?with_opengl:-DWITH_OPENGL=ON} \
da5d1e09 312 %{?with_gomp:-DWITH_OPENMP=ON} \
1c9fe580 313 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 314 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 315 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 316 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 317 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 318 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 319 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 320 %{?with_ximea:-DWITH_XIMEA=ON} \
d5e56e66 321 %{?with_xine:-DWITH_XINE=ON}
54551f29 322
8b9f61f7 323%{__make}
901927d3
AM
324
325%install
326rm -rf $RPM_BUILD_ROOT
95daeb66 327%{__make} -C build install \
901927d3
AM
328 DESTDIR=$RPM_BUILD_ROOT
329
9141b1e2
ER
330# see -doc package
331%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
200823d5
ER
332%if %{with examples}
333install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
334mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
335%endif
9141b1e2 336
4bd2eae7 337install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 338cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 339
8d499a62
JB
340%py_comp $RPM_BUILD_ROOT%{py_sitedir}
341%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
342%py_postclean
343
b07433c6
JB
344%if %{with java}
345# move to proper directories, create symlink
346install -d $RPM_BUILD_ROOT%{_javadir}
347%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
348sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
349 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
350%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
351rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
352ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
353%endif
354
901927d3
AM
355%clean
356rm -rf $RPM_BUILD_ROOT
357
358%post -p /sbin/ldconfig
359%postun -p /sbin/ldconfig
360
933de752
ER
361%post core -p /sbin/ldconfig
362%postun core -p /sbin/ldconfig
363
485d5dca
JB
364%post viz -p /sbin/ldconfig
365%postun viz -p /sbin/ldconfig
366
b07433c6
JB
367%post -n java-opencv -p /sbin/ldconfig
368%postun -n java-opencv -p /sbin/ldconfig
369
901927d3
AM
370%files
371%defattr(644,root,root,755)
933de752
ER
372%attr(755,root,root) %{_bindir}/opencv_createsamples
373%attr(755,root,root) %{_bindir}/opencv_haartraining
374%attr(755,root,root) %{_bindir}/opencv_performance
375%attr(755,root,root) %{_bindir}/opencv_traincascade
376%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.%{sover}
da5d1e09 377%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
933de752 378%attr(755,root,root) %{_libdir}/libopencv_contrib.so.%{sover}
da5d1e09 379%attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
933de752 380%attr(755,root,root) %{_libdir}/libopencv_features2d.so.%{sover}
da5d1e09 381%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
cf32945e
JB
382%attr(755,root,root) %{_libdir}/libopencv_gpu.so.%{sover}
383%attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
933de752 384%attr(755,root,root) %{_libdir}/libopencv_highgui.so.%{sover}
da5d1e09 385%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
933de752 386%attr(755,root,root) %{_libdir}/libopencv_legacy.so.%{sover}
da5d1e09 387%attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
cf32945e
JB
388%attr(755,root,root) %{_libdir}/libopencv_nonfree.so.%{sover}
389%attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
933de752 390%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.%{sover}
da5d1e09
JB
391%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
392%if %{with opencl}
393%attr(755,root,root) %{_libdir}/libopencv_ocl.so.%{sover}
394%attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
395%endif
933de752 396%attr(755,root,root) %{_libdir}/libopencv_stitching.so.%{sover}
da5d1e09 397%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
933de752 398%attr(755,root,root) %{_libdir}/libopencv_superres.so.%{sover}
da5d1e09 399%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
cf32945e
JB
400%attr(755,root,root) %{_libdir}/libopencv_ts.so.%{sover}
401%attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
933de752 402%attr(755,root,root) %{_libdir}/libopencv_videostab.so.%{sover}
da5d1e09 403%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
452b38e1 404%dir %{_datadir}/OpenCV
452b38e1 405%{_datadir}/OpenCV/haarcascades
406%{_datadir}/OpenCV/lbpcascades
901927d3 407
933de752
ER
408%files core
409%defattr(644,root,root,755)
410%attr(755,root,root) %{_libdir}/libopencv_core.so.%{sover}
cf32945e 411%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
933de752 412%attr(755,root,root) %{_libdir}/libopencv_flann.so.%{sover}
cf32945e 413%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
933de752 414%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.%{sover}
cf32945e 415%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
933de752 416%attr(755,root,root) %{_libdir}/libopencv_ml.so.%{sover}
cf32945e 417%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
933de752 418%attr(755,root,root) %{_libdir}/libopencv_photo.so.%{sover}
cf32945e 419%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
933de752 420%attr(755,root,root) %{_libdir}/libopencv_video.so.%{sover}
cf32945e
JB
421%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
422
423%if %{with vtk}
424%files viz
425%defattr(644,root,root,755)
426%attr(755,root,root) %{_libdir}/libopencv_viz.so.%{sover}
427%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
428%endif
933de752 429
901927d3
AM
430%files devel
431%defattr(644,root,root,755)
cf32945e
JB
432# core
433%attr(755,root,root) %{_libdir}/libopencv_core.so
434%attr(755,root,root) %{_libdir}/libopencv_flann.so
435%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
436%attr(755,root,root) %{_libdir}/libopencv_ml.so
437%attr(755,root,root) %{_libdir}/libopencv_photo.so
438%attr(755,root,root) %{_libdir}/libopencv_video.so
439# GUI/extensions (base package)
440%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
441%attr(755,root,root) %{_libdir}/libopencv_contrib.so
442%attr(755,root,root) %{_libdir}/libopencv_features2d.so
443%attr(755,root,root) %{_libdir}/libopencv_gpu.so
444%attr(755,root,root) %{_libdir}/libopencv_highgui.so
445%attr(755,root,root) %{_libdir}/libopencv_legacy.so
446%attr(755,root,root) %{_libdir}/libopencv_nonfree.so
447%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
448%if %{with opencl}
449%attr(755,root,root) %{_libdir}/libopencv_ocl.so
450%endif
451%attr(755,root,root) %{_libdir}/libopencv_stitching.so
452%attr(755,root,root) %{_libdir}/libopencv_superres.so
453%attr(755,root,root) %{_libdir}/libopencv_ts.so
454%attr(755,root,root) %{_libdir}/libopencv_videostab.so
455# viz
456%if %{with vtk}
457%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 458%endif
901927d3 459%{_includedir}/opencv
509c07dc 460%{_includedir}/opencv2
da5d1e09 461%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 462%{_pkgconfigdir}/opencv.pc
901927d3 463
9141b1e2
ER
464%files doc
465%defattr(644,root,root,755)
466# TODO: probably could rebuild them and package via make install
467%doc doc/*
468
200823d5
ER
469%if %{with examples}
470%files examples
471%defattr(644,root,root,755)
472%{_examplesdir}/%{name}-%{version}
473%endif
474
b07433c6
JB
475%if %{with java}
476%files -n java-opencv
477%defattr(644,root,root,755)
835e0cdd
ER
478%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
479%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
480%{_javadir}/opencv.jar
481%endif
482
901927d3
AM
483%files -n python-opencv
484%defattr(644,root,root,755)
452b38e1 485%attr(755,root,root) %{py_sitedir}/cv2.so
8d499a62 486%{py_sitedir}/cv.py[co]
This page took 0.118443 seconds and 4 git commands to generate.