]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- rel 3
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
2acd8ac1 2# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 3# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 4# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 5#
0c2d6b7d 6# Conditional build:
a55ba198
JB
7# - general options:
8%bcond_with tbb # Threading Building Blocks support (everywhere)
9%bcond_with sse # use SSE instructions
10%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
11%bcond_with sse3 # use SSE3 instructions
12%bcond_with ssse3 # use SSSE3 instructions
13%bcond_with sse41 # use SSE4.1 instructions
14%bcond_with sse42 # use SSE4.2 instructions
15%bcond_with avx # use AVX instructions
8d5385eb
JB
16%bcond_without opencl # OpenCL support
17%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
18%bcond_with opencl_amdfft # AMD OpenCL FFT routines
19%bcond_without opengl # OpenGL support
cf32945e 20%bcond_without gomp # OpenMP support (available when not using tbb)
200823d5 21%bcond_without examples # Install examples
b07433c6
JB
22# - bindings
23%bcond_without java # Java binding
a55ba198 24# - highgui options:
b3920a9d 25%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
26%bcond_without gstreamer # GStreamer support in highgui
27%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 28%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 29%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 30%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 31%bcond_without v4l # Video4Linux in highgui
a55ba198 32%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 33%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
34# - other modules
35%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 36
1c9fe580
JB
37%ifarch pentium3 pentium4 %{x8664}
38%define with_sse 1
39%endif
40%ifarch pentium4 %{x8664}
41%define with_sse2 1
42%endif
901927d3 43Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 44Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 45Name: opencv
200823d5 46Version: 2.4.9
ceaf8b75 47Release: 3
901927d3 48Epoch: 1
d5e56e66
JB
49%if %{with unicap} || %{with xine}
50License: GPL (enforced by used libraries), BSD (opencv itself)
51%else
901927d3 52License: BSD
d5e56e66 53%endif
901927d3 54Group: Libraries
200823d5
ER
55Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
56# Source0-md5: cc0a8307403ff471f554197401ec0eb9
452b38e1 57Patch0: %{name}-cflags.patch
58Patch1: %{name}-link.patch
59Patch2: %{name}-unicap-c++.patch
60Patch3: %{name}-c.patch
61Patch4: %{name}-gcc.patch
809ce413 62Patch5: %{name}-ximea.patch
6994c4f7 63Patch6: %{name}-ocl-fft.patch
a4737151 64Patch7: java-ant-sourcelevel.patch
da5d1e09 65Patch8: %{name}-shared.patch
200823d5 66URL: http://www.opencv.org/
d5e56e66 67%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 68%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 69BuildRequires: OpenEXR-devel
5df3cf1b 70%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 71%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 72# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 73%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 74%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 75%{?with_java:BuildRequires: ant}
ef4af528
JB
76%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
77%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 78BuildRequires: cmake >= 2.8
0c2d6b7d 79BuildRequires: doxygen
809ce413 80BuildRequires: eigen3 >= 3
b3920a9d 81%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
da5d1e09 82%{?with_gomp:BuildRequires: gcc-c++ >= 6:4.2}
0c2d6b7d
JB
83%if %{with gstreamer}
84BuildRequires: gstreamer-devel >= 0.10
85BuildRequires: gstreamer-plugins-base-devel >= 0.10
86%endif
901927d3 87BuildRequires: jasper-devel
b07433c6 88%{?with_java:BuildRequires: jdk}
901927d3 89BuildRequires: libdc1394-devel
da5d1e09 90%{?with_gomp:BuildRequires: libgomp-devel}
901927d3
AM
91BuildRequires: libjpeg-devel
92BuildRequires: libpng-devel
93BuildRequires: libraw1394-devel
0c2d6b7d 94BuildRequires: libstdc++-devel
901927d3 95BuildRequires: libtiff-devel
148338c5 96BuildRequires: libtool
d5e56e66
JB
97%if %{with unicap}
98BuildRequires: libucil-devel
99BuildRequires: libunicap-devel
100%endif
0c2d6b7d 101BuildRequires: libv4l-devel
af6d2888 102BuildRequires: pkgconfig
b07433c6 103BuildRequires: python
901927d3 104BuildRequires: python-devel
0c2d6b7d 105BuildRequires: python-numpy-devel
901927d3 106BuildRequires: rpm-pythonprov
8d499a62 107BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 108BuildRequires: sed >= 4.0
996927aa 109BuildRequires: swig-python
f8e040cc 110%{?with_tbb:BuildRequires: tbb-devel}
cf32945e 111%{?with_vtk:BuildRequires: vtk-devel >= 5.8.0}
901927d3 112%{?with_xine:BuildRequires: xine-lib-devel}
452b38e1 113BuildRequires: zlib-devel
4afb606b 114%if %{with qt}
4afb606b
JB
115BuildRequires: QtCore-devel >= 4
116BuildRequires: QtGui-devel >= 4
5df3cf1b 117%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
118BuildRequires: qt4-qmake >= 4
119%else
120BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 121%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 122%endif
da5d1e09 123Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
124BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
933de752 126%define sover %(v=%{version}; k=${v#?.?.?}; echo ${v%$k})
835e0cdd 127%define jver %(echo %{version} | tr -d .)
933de752 128
901927d3
AM
129%description
130OpenCV (Open Source Computer Vision) is a library of programming
131functions mainly aimed at real time computer vision.
132
0c2d6b7d
JB
133Example applications of the OpenCV library are:
134- Human-Computer Interaction (HCI)
135- Object Identification, Segmentation and Recognition
136- Face Recognition
137- Gesture Recognition
138- Motion Tracking
139- Ego Motion, Motion Understanding
140- Structure From Motion (SFM)
141- Stereo and Multi-Camera Calibration and Depth Computation
142- Mobile Robotics.
143
144%description -l pl.UTF-8
145OpenCV (Open Source Computer Vision) to biblioteka funkcji
146przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
147
148Przykładowe zastosowania biblioteki OpenCV to
149- interakcje człowiek-komputer (HCI)
150- identyfikacja, segmentacja i rozpoznawanie obiektów
151- rozpoznawanie twarzy
152- rozpoznawanie gestów
153- śledzenie ruchu
154- rozumienie ruchu
155- SFM (Structure From Motion)
156- kalibracja dwu- i wielokamerowa, obliczanie głębi
157- robotyka ruchu.
901927d3 158
933de752
ER
159%package core
160Summary: OpenCV core libraries
da5d1e09 161Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 162Group: Libraries
da5d1e09 163Conflicts: opencv < 2.4.6.2-1
933de752
ER
164
165%description core
166This package contains the OpenCV C/C++ core libraries.
167
da5d1e09
JB
168%description core -l pl.UTF-8
169Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
170
cf32945e
JB
171%package viz
172Summary: OpenCV viz library (VTK support)
173Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
174Group: Libraries
175Requires: %{name} = %{epoch}:%{version}-%{release}
176
177%description viz
178OpenCV viz library (VTK support).
179
180%description viz -l pl.UTF-8
181Biblioteka OpenCV viz (obsługa VTK).
182
901927d3 183%package devel
0c2d6b7d
JB
184Summary: Header files for OpenCV library
185Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
186Group: Development/Libraries
187Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
188%if %{with vtk}
189Requires: %{name}-viz = %{epoch}:%{version}-%{release}
190%endif
0c2d6b7d 191Obsoletes: opencv-static
901927d3
AM
192
193%description devel
0c2d6b7d 194Header files for OpenCV library.
901927d3 195
0c2d6b7d
JB
196%description devel -l pl.UTF-8
197Pliki nagłówkowe biblioteki OpenCV.
901927d3 198
9141b1e2
ER
199%package doc
200Summary: Manual for OpenCV
201Summary(fr.UTF-8): Documentation pour OpenCV
202Summary(it.UTF-8): Documentazione di OpenCV
203Summary(pl.UTF-8): Podręcznik dla OpenCV
204Group: Documentation
205# noarch subpackages only when building with rpm5
206%if "%{_rpmversion}" >= "5"
207BuildArch: noarch
208%endif
209
210%description doc
211Documentation for OpenCV.
212
213%description doc -l fr.UTF-8
214Documentation pour OpenCV.
215
216%description doc -l it.UTF-8
217Documentazione di OpenCV.
218
219%description doc -l pl.UTF-8
220Dokumentacja do OpenCV.
221
200823d5
ER
222%package examples
223Summary: OpenCV code examples
224Group: Documentation
225%if "%{_rpmversion}" >= "5"
226BuildArch: noarch
227%endif
228
229%description examples
230OpenCV code examples.
231
b07433c6
JB
232%package -n java-opencv
233Summary: OpenCV Java bindings
234Summary(pl.UTF-8): Wiązania Javy do OpenCV
235Group: Libraries/Java
236Requires: %{name} = %{epoch}:%{version}-%{release}
237Requires: jre
238
239%description -n java-opencv
240OpenCV Java bindings.
241
242%description -n java-opencv -l pl.UTF-8
243Wiązania Javy do OpenCV.
244
901927d3
AM
245%package -n python-opencv
246Summary: OpenCV Python bindings
0c2d6b7d
JB
247Summary(pl.UTF-8): Wiązania Pythona do OpenCV
248Group: Libraries/Python
cd1f0136 249Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 250Requires: python-libs
901927d3
AM
251
252%description -n python-opencv
253OpenCV Python bindings.
254
0c2d6b7d
JB
255%description -n python-opencv -l pl.UTF-8
256Wiązania Pythona do OpenCV.
257
901927d3 258%prep
25269a76 259%setup -q
54551f29 260
da67222a 261%undos CMakeLists.txt
1376dffe 262%undos modules/gpu/CMakeLists.txt
54551f29 263
1376dffe 264%patch0 -p1
265%patch1 -p1
29d82ddf 266%patch2 -p1
f8e040cc 267%patch3 -p1
75b912e9 268%patch4 -p1
809ce413 269%patch5 -p1
6994c4f7 270%patch6 -p1
a4737151 271%patch7 -p1
da5d1e09 272%patch8 -p1
148338c5 273
901927d3 274%build
95daeb66
AM
275install -d build
276cd build
ea26b025
ER
277
278# handle cmake & ccache
279# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
280if [[ "%{__cc}" = *ccache* ]]; then
281 cc="%{__cc}"
282 cxx="%{__cxx}"
283 ccache="
284 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
285 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
286 "
287fi
288
0c2d6b7d 289%cmake .. \
ea26b025 290 $ccache \
da5d1e09 291 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
292 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
293 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
294 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
295 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
296 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
297 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 298 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
299%if %{with examples}
300 -DINSTALL_C_EXAMPLES=ON \
301 -DINSTALL_PYTHON_EXAMPLES=ON \
302%endif
b3920a9d 303 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 304 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 305 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
306 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
307 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 308 %{?with_opengl:-DWITH_OPENGL=ON} \
da5d1e09 309 %{?with_gomp:-DWITH_OPENMP=ON} \
1c9fe580 310 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 311 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 312 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 313 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 314 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 315 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 316 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 317 %{?with_ximea:-DWITH_XIMEA=ON} \
d5e56e66 318 %{?with_xine:-DWITH_XINE=ON}
54551f29 319
8b9f61f7 320%{__make}
901927d3
AM
321
322%install
323rm -rf $RPM_BUILD_ROOT
95daeb66 324%{__make} -C build install \
901927d3
AM
325 DESTDIR=$RPM_BUILD_ROOT
326
9141b1e2
ER
327# see -doc package
328%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
200823d5
ER
329%if %{with examples}
330install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
331mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
332%endif
9141b1e2 333
4bd2eae7 334install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 335cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 336
8d499a62
JB
337%py_comp $RPM_BUILD_ROOT%{py_sitedir}
338%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
339%py_postclean
340
b07433c6
JB
341%if %{with java}
342# move to proper directories, create symlink
343install -d $RPM_BUILD_ROOT%{_javadir}
344%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
345sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
346 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
347%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
348rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
349ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
350%endif
351
901927d3
AM
352%clean
353rm -rf $RPM_BUILD_ROOT
354
355%post -p /sbin/ldconfig
356%postun -p /sbin/ldconfig
357
933de752
ER
358%post core -p /sbin/ldconfig
359%postun core -p /sbin/ldconfig
360
485d5dca
JB
361%post viz -p /sbin/ldconfig
362%postun viz -p /sbin/ldconfig
363
b07433c6
JB
364%post -n java-opencv -p /sbin/ldconfig
365%postun -n java-opencv -p /sbin/ldconfig
366
901927d3
AM
367%files
368%defattr(644,root,root,755)
933de752
ER
369%attr(755,root,root) %{_bindir}/opencv_createsamples
370%attr(755,root,root) %{_bindir}/opencv_haartraining
371%attr(755,root,root) %{_bindir}/opencv_performance
372%attr(755,root,root) %{_bindir}/opencv_traincascade
373%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.%{sover}
da5d1e09 374%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
933de752 375%attr(755,root,root) %{_libdir}/libopencv_contrib.so.%{sover}
da5d1e09 376%attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
933de752 377%attr(755,root,root) %{_libdir}/libopencv_features2d.so.%{sover}
da5d1e09 378%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
cf32945e
JB
379%attr(755,root,root) %{_libdir}/libopencv_gpu.so.%{sover}
380%attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
933de752 381%attr(755,root,root) %{_libdir}/libopencv_highgui.so.%{sover}
da5d1e09 382%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
933de752 383%attr(755,root,root) %{_libdir}/libopencv_legacy.so.%{sover}
da5d1e09 384%attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
cf32945e
JB
385%attr(755,root,root) %{_libdir}/libopencv_nonfree.so.%{sover}
386%attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
933de752 387%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.%{sover}
da5d1e09
JB
388%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
389%if %{with opencl}
390%attr(755,root,root) %{_libdir}/libopencv_ocl.so.%{sover}
391%attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
392%endif
933de752 393%attr(755,root,root) %{_libdir}/libopencv_stitching.so.%{sover}
da5d1e09 394%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
933de752 395%attr(755,root,root) %{_libdir}/libopencv_superres.so.%{sover}
da5d1e09 396%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
cf32945e
JB
397%attr(755,root,root) %{_libdir}/libopencv_ts.so.%{sover}
398%attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
933de752 399%attr(755,root,root) %{_libdir}/libopencv_videostab.so.%{sover}
da5d1e09 400%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
452b38e1 401%dir %{_datadir}/OpenCV
452b38e1 402%{_datadir}/OpenCV/haarcascades
403%{_datadir}/OpenCV/lbpcascades
901927d3 404
933de752
ER
405%files core
406%defattr(644,root,root,755)
407%attr(755,root,root) %{_libdir}/libopencv_core.so.%{sover}
cf32945e 408%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
933de752 409%attr(755,root,root) %{_libdir}/libopencv_flann.so.%{sover}
cf32945e 410%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
933de752 411%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.%{sover}
cf32945e 412%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
933de752 413%attr(755,root,root) %{_libdir}/libopencv_ml.so.%{sover}
cf32945e 414%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
933de752 415%attr(755,root,root) %{_libdir}/libopencv_photo.so.%{sover}
cf32945e 416%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
933de752 417%attr(755,root,root) %{_libdir}/libopencv_video.so.%{sover}
cf32945e
JB
418%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
419
420%if %{with vtk}
421%files viz
422%defattr(644,root,root,755)
423%attr(755,root,root) %{_libdir}/libopencv_viz.so.%{sover}
424%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
425%endif
933de752 426
901927d3
AM
427%files devel
428%defattr(644,root,root,755)
cf32945e
JB
429# core
430%attr(755,root,root) %{_libdir}/libopencv_core.so
431%attr(755,root,root) %{_libdir}/libopencv_flann.so
432%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
433%attr(755,root,root) %{_libdir}/libopencv_ml.so
434%attr(755,root,root) %{_libdir}/libopencv_photo.so
435%attr(755,root,root) %{_libdir}/libopencv_video.so
436# GUI/extensions (base package)
437%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
438%attr(755,root,root) %{_libdir}/libopencv_contrib.so
439%attr(755,root,root) %{_libdir}/libopencv_features2d.so
440%attr(755,root,root) %{_libdir}/libopencv_gpu.so
441%attr(755,root,root) %{_libdir}/libopencv_highgui.so
442%attr(755,root,root) %{_libdir}/libopencv_legacy.so
443%attr(755,root,root) %{_libdir}/libopencv_nonfree.so
444%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
445%if %{with opencl}
446%attr(755,root,root) %{_libdir}/libopencv_ocl.so
447%endif
448%attr(755,root,root) %{_libdir}/libopencv_stitching.so
449%attr(755,root,root) %{_libdir}/libopencv_superres.so
450%attr(755,root,root) %{_libdir}/libopencv_ts.so
451%attr(755,root,root) %{_libdir}/libopencv_videostab.so
452# viz
453%if %{with vtk}
454%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 455%endif
901927d3 456%{_includedir}/opencv
509c07dc 457%{_includedir}/opencv2
da5d1e09 458%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 459%{_pkgconfigdir}/opencv.pc
901927d3 460
9141b1e2
ER
461%files doc
462%defattr(644,root,root,755)
463# TODO: probably could rebuild them and package via make install
464%doc doc/*
465
200823d5
ER
466%if %{with examples}
467%files examples
468%defattr(644,root,root,755)
469%{_examplesdir}/%{name}-%{version}
470%endif
471
b07433c6
JB
472%if %{with java}
473%files -n java-opencv
474%defattr(644,root,root,755)
835e0cdd
ER
475%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
476%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
477%{_javadir}/opencv.jar
478%endif
479
901927d3
AM
480%files -n python-opencv
481%defattr(644,root,root,755)
452b38e1 482%attr(755,root,root) %{py_sitedir}/cv2.so
8d499a62 483%{py_sitedir}/cv.py[co]
This page took 0.152054 seconds and 4 git commands to generate.