]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- new ffmpeg headers location
[packages/opencv.git] / opencv.spec
CommitLineData
901927d3
AM
1%bcond_with xine
2%define snap pre1
3Summary: A library of programming functions mainly aimed at real time computer vision
4Name: opencv
5Version: 1.1
6Release: 0.%{snap}.1
7Epoch: 1
8License: BSD
9Group: Libraries
10Source0: http://dl.sourceforge.net/opencvlibrary/%{name}-%{version}%{snap}.tar.gz
11# Source0-md5: b147b7cd3c059831c415c5a2bcecdf95
12URL: http://opencv.willowgarage.com
13BuildRequires: autoconf >= 2.53
14BuildRequires: automake
15BuildRequires: ffmpeg-devel
16BuildRequires: jasper-devel
17BuildRequires: libdc1394-devel
18BuildRequires: libjpeg-devel
19BuildRequires: libpng-devel
20BuildRequires: libraw1394-devel
21BuildRequires: libtiff-devel
22BuildRequires: python-devel
23BuildRequires: rpm-pythonprov
996927aa 24BuildRequires: swig-python
901927d3
AM
25BuildRequires: zlib-devel
26%pyrequires_eq python-libs
27%{?with_xine:BuildRequires: xine-lib-devel}
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31OpenCV (Open Source Computer Vision) is a library of programming
32functions mainly aimed at real time computer vision.
33
34Example applications of the OpenCV library are Human-Computer
35Interaction (HCI); Object Identification, Segmentation and
36Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
37Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
38and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
39
40%package devel
41Summary: Header files and develpment documentation for opencv
42Group: Development/Libraries
43Requires: %{name} = %{epoch}:%{version}-%{release}
44
45%description devel
46Header files and opencv documentation.
47
48%package static
49Summary: Static opencv library
50Group: Development/Libraries
51Requires: %{name}-devel = %{epoch}:%{version}-%{release}
52
53%description static
54This package contains the static library used for development.
55
56%package -n python-opencv
57Summary: OpenCV Python bindings
58Group: Development/Languages/Python
59%pyrequires_eq python
60Requires: %{name} = %{version}-%{release}
61
62%description -n python-opencv
63OpenCV Python bindings.
64
65%prep
66%setup -q -n %{name}-%{version}.0
67
68%build
69%configure \
70%ifarch i686 pentium4 athlon %{x8664}
71 --enable-sse2 \
72%else
73 --disable-sse2 \
74%endif
75 --with-python \
76 --with%{!?with_xine:-out}-xine \
77 --with-ffmpeg \
78 --with-1394libs \
79 --with-v4l \
80 --with-gtk \
81 --without-gstreamer \
82 --without-quicktime
83%{__make}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(644,root,root,755)
99%doc AUTHORS COPYING ChangeLog THANKS TODO
100%doc docs/*.{htm,rtf,png,txt} docs/papers docs/ref
101%attr(755,root,root) %{_bindir}/*
102%attr(755,root,root) %{_libdir}/lib*so.*.*
103%attr(755,root,root) %ghost %{_libdir}/lib*.so.2
104
105%files devel
106%defattr(644,root,root,755)
107%attr(755,root,root) %{_libdir}/lib*.so
108%{_libdir}/lib*.la
109%{_includedir}/opencv
110%{_pkgconfigdir}/*.pc
111
112%files static
113%defattr(644,root,root,755)
114%{_libdir}/lib*.a
115
116%files -n python-opencv
117%defattr(644,root,root,755)
118%dir %{py_sitedir}/opencv
119%attr(755,root,root) %{py_sitedir}/opencv/*.so
120%{py_sitedir}/opencv/*.py[co]
This page took 0.087144 seconds and 4 git commands to generate.