]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
BR gl2ps-devel
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
2acd8ac1 2# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 3# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 4# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 5#
0c2d6b7d 6# Conditional build:
a55ba198
JB
7# - general options:
8%bcond_with tbb # Threading Building Blocks support (everywhere)
9%bcond_with sse # use SSE instructions
10%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
11%bcond_with sse3 # use SSE3 instructions
12%bcond_with ssse3 # use SSSE3 instructions
13%bcond_with sse41 # use SSE4.1 instructions
14%bcond_with sse42 # use SSE4.2 instructions
15%bcond_with avx # use AVX instructions
8d5385eb
JB
16%bcond_without opencl # OpenCL support
17%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
18%bcond_with opencl_amdfft # AMD OpenCL FFT routines
19%bcond_without opengl # OpenGL support
4a401ecc 20%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 21%bcond_without examples # Install examples
b07433c6
JB
22# - bindings
23%bcond_without java # Java binding
a55ba198 24# - highgui options:
b3920a9d 25%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
26%bcond_without gstreamer # GStreamer support in highgui
27%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 28%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 29%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 30%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 31%bcond_without v4l # Video4Linux in highgui
a55ba198 32%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 33%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
34# - other modules
35%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 36
e36ac029 37%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
38%define with_sse 1
39%endif
e36ac029 40%ifarch pentium4 %{x8664} x32
1c9fe580
JB
41%define with_sse2 1
42%endif
901927d3 43Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 44Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 45Name: opencv
f753ced4
ER
46Version: 2.4.12.3
47Release: 1
901927d3 48Epoch: 1
d5e56e66
JB
49%if %{with unicap} || %{with xine}
50License: GPL (enforced by used libraries), BSD (opencv itself)
51%else
901927d3 52License: BSD
d5e56e66 53%endif
901927d3 54Group: Libraries
200823d5 55Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
f753ced4 56# Source0-md5: 2496a4a4caf8fecfbfc294fbe6a814b0
452b38e1 57Patch0: %{name}-cflags.patch
dadee467 58Patch1: %{name}-cmake.patch
452b38e1 59Patch2: %{name}-unicap-c++.patch
60Patch3: %{name}-c.patch
61Patch4: %{name}-gcc.patch
809ce413 62Patch5: %{name}-ximea.patch
6994c4f7 63Patch6: %{name}-ocl-fft.patch
a4737151 64Patch7: java-ant-sourcelevel.patch
da5d1e09 65Patch8: %{name}-shared.patch
f9e8f4ea 66Patch9: no-sysctl.patch
e36ac029 67Patch10: cmake-install-path.patch
200823d5 68URL: http://www.opencv.org/
d5e56e66 69%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 70%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 71BuildRequires: OpenEXR-devel
5df3cf1b 72%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 73%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 74# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 75%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 76%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 77%{?with_java:BuildRequires: ant}
ef4af528
JB
78%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
79%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 80BuildRequires: cmake >= 2.8
0c2d6b7d 81BuildRequires: doxygen
809ce413 82BuildRequires: eigen3 >= 3
b3920a9d 83%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 84%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
74cbdeb2 85BuildRequires: gl2ps-devel
0c2d6b7d 86%if %{with gstreamer}
158e0ccc
JB
87BuildRequires: gstreamer-devel >= 1.0
88BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 89%endif
901927d3 90BuildRequires: jasper-devel
b07433c6 91%{?with_java:BuildRequires: jdk}
158e0ccc 92BuildRequires: libdc1394-devel >= 2
4a401ecc 93%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
94BuildRequires: libjpeg-devel
95BuildRequires: libpng-devel
96BuildRequires: libraw1394-devel
0c2d6b7d 97BuildRequires: libstdc++-devel
901927d3 98BuildRequires: libtiff-devel
148338c5 99BuildRequires: libtool
d5e56e66
JB
100%if %{with unicap}
101BuildRequires: libucil-devel
102BuildRequires: libunicap-devel
103%endif
0c2d6b7d 104BuildRequires: libv4l-devel
af6d2888 105BuildRequires: pkgconfig
158e0ccc
JB
106BuildRequires: python >= 2.0
107BuildRequires: python-devel >= 2.0
0c2d6b7d 108BuildRequires: python-numpy-devel
901927d3 109BuildRequires: rpm-pythonprov
8d499a62 110BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 111BuildRequires: sed >= 4.0
158e0ccc 112BuildRequires: sphinx-pdg
996927aa 113BuildRequires: swig-python
f8e040cc 114%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
115%if %{with vtk}
116BuildRequires: vtk-devel >= 5.8.0
fba97d16 117BuildRequires: vtk-java >= 5.8.0
ae3d975d
AM
118BuildRequires: vtk-tcl >= 5.8.0
119%endif
901927d3 120%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 121BuildRequires: xorg-lib-libX11-devel
452b38e1 122BuildRequires: zlib-devel
4afb606b 123%if %{with qt}
4afb606b
JB
124BuildRequires: QtCore-devel >= 4
125BuildRequires: QtGui-devel >= 4
5df3cf1b 126%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
127BuildRequires: qt4-qmake >= 4
128%else
129BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 130%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 131%endif
da5d1e09 132Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
133BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
134
158e0ccc 135%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
933de752 136
901927d3
AM
137%description
138OpenCV (Open Source Computer Vision) is a library of programming
139functions mainly aimed at real time computer vision.
140
0c2d6b7d
JB
141Example applications of the OpenCV library are:
142- Human-Computer Interaction (HCI)
143- Object Identification, Segmentation and Recognition
144- Face Recognition
145- Gesture Recognition
146- Motion Tracking
147- Ego Motion, Motion Understanding
148- Structure From Motion (SFM)
149- Stereo and Multi-Camera Calibration and Depth Computation
150- Mobile Robotics.
151
152%description -l pl.UTF-8
153OpenCV (Open Source Computer Vision) to biblioteka funkcji
154przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
155
156Przykładowe zastosowania biblioteki OpenCV to
157- interakcje człowiek-komputer (HCI)
158- identyfikacja, segmentacja i rozpoznawanie obiektów
159- rozpoznawanie twarzy
160- rozpoznawanie gestów
161- śledzenie ruchu
162- rozumienie ruchu
163- SFM (Structure From Motion)
164- kalibracja dwu- i wielokamerowa, obliczanie głębi
165- robotyka ruchu.
901927d3 166
933de752
ER
167%package core
168Summary: OpenCV core libraries
da5d1e09 169Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 170Group: Libraries
da5d1e09 171Conflicts: opencv < 2.4.6.2-1
933de752
ER
172
173%description core
174This package contains the OpenCV C/C++ core libraries.
175
da5d1e09
JB
176%description core -l pl.UTF-8
177Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
178
cf32945e
JB
179%package viz
180Summary: OpenCV viz library (VTK support)
181Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
182Group: Libraries
183Requires: %{name} = %{epoch}:%{version}-%{release}
184
185%description viz
186OpenCV viz library (VTK support).
187
188%description viz -l pl.UTF-8
189Biblioteka OpenCV viz (obsługa VTK).
190
901927d3 191%package devel
0c2d6b7d
JB
192Summary: Header files for OpenCV library
193Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
194Group: Development/Libraries
195Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
196%if %{with vtk}
197Requires: %{name}-viz = %{epoch}:%{version}-%{release}
198%endif
0c2d6b7d 199Obsoletes: opencv-static
901927d3
AM
200
201%description devel
0c2d6b7d 202Header files for OpenCV library.
901927d3 203
0c2d6b7d
JB
204%description devel -l pl.UTF-8
205Pliki nagłówkowe biblioteki OpenCV.
901927d3 206
9141b1e2
ER
207%package doc
208Summary: Manual for OpenCV
209Summary(fr.UTF-8): Documentation pour OpenCV
210Summary(it.UTF-8): Documentazione di OpenCV
211Summary(pl.UTF-8): Podręcznik dla OpenCV
212Group: Documentation
213# noarch subpackages only when building with rpm5
214%if "%{_rpmversion}" >= "5"
215BuildArch: noarch
216%endif
217
218%description doc
219Documentation for OpenCV.
220
221%description doc -l fr.UTF-8
222Documentation pour OpenCV.
223
224%description doc -l it.UTF-8
225Documentazione di OpenCV.
226
227%description doc -l pl.UTF-8
228Dokumentacja do OpenCV.
229
200823d5
ER
230%package examples
231Summary: OpenCV code examples
232Group: Documentation
233%if "%{_rpmversion}" >= "5"
234BuildArch: noarch
235%endif
236
237%description examples
238OpenCV code examples.
239
b07433c6
JB
240%package -n java-opencv
241Summary: OpenCV Java bindings
242Summary(pl.UTF-8): Wiązania Javy do OpenCV
243Group: Libraries/Java
244Requires: %{name} = %{epoch}:%{version}-%{release}
245Requires: jre
246
247%description -n java-opencv
248OpenCV Java bindings.
249
250%description -n java-opencv -l pl.UTF-8
251Wiązania Javy do OpenCV.
252
901927d3
AM
253%package -n python-opencv
254Summary: OpenCV Python bindings
0c2d6b7d
JB
255Summary(pl.UTF-8): Wiązania Pythona do OpenCV
256Group: Libraries/Python
cd1f0136 257Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 258Requires: python-libs
901927d3
AM
259
260%description -n python-opencv
261OpenCV Python bindings.
262
0c2d6b7d
JB
263%description -n python-opencv -l pl.UTF-8
264Wiązania Pythona do OpenCV.
265
901927d3 266%prep
25269a76 267%setup -q
54551f29 268
da67222a 269%undos CMakeLists.txt
1376dffe 270%undos modules/gpu/CMakeLists.txt
54551f29 271
1376dffe 272%patch0 -p1
dadee467 273%patch1 -p1
29d82ddf 274%patch2 -p1
f8e040cc 275%patch3 -p1
75b912e9 276%patch4 -p1
809ce413 277%patch5 -p1
6994c4f7 278%patch6 -p1
a4737151 279%patch7 -p1
da5d1e09 280%patch8 -p1
f9e8f4ea 281%patch9 -p1
e36ac029 282%patch10 -p1
148338c5 283
901927d3 284%build
95daeb66
AM
285install -d build
286cd build
ea26b025
ER
287
288# handle cmake & ccache
289# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
290if [[ "%{__cc}" = *ccache* ]]; then
291 cc="%{__cc}"
292 cxx="%{__cxx}"
293 ccache="
294 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
295 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
296 "
297fi
298
0c2d6b7d 299%cmake .. \
ea26b025 300 $ccache \
da5d1e09 301 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
302 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
303 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
304 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
305 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
306 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
307 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 308 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
309%if %{with examples}
310 -DINSTALL_C_EXAMPLES=ON \
311 -DINSTALL_PYTHON_EXAMPLES=ON \
312%endif
b3920a9d 313 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 314 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 315 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
316 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
317 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 318 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 319 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 320 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 321 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 322 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 323 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 324 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 325 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 326 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 327 %{?with_ximea:-DWITH_XIMEA=ON} \
d5e56e66 328 %{?with_xine:-DWITH_XINE=ON}
54551f29 329
8b9f61f7 330%{__make}
901927d3
AM
331
332%install
333rm -rf $RPM_BUILD_ROOT
95daeb66 334%{__make} -C build install \
901927d3
AM
335 DESTDIR=$RPM_BUILD_ROOT
336
9141b1e2
ER
337# see -doc package
338%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
200823d5
ER
339%if %{with examples}
340install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
341mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
342%endif
9141b1e2 343
4bd2eae7 344install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 345cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 346
7545129b
JB
347# disable completeness check incompatible with split packaging
348%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
349
8d499a62
JB
350%py_comp $RPM_BUILD_ROOT%{py_sitedir}
351%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
352%py_postclean
353
b07433c6
JB
354%if %{with java}
355# move to proper directories, create symlink
356install -d $RPM_BUILD_ROOT%{_javadir}
357%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
358sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
359 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
360%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
361rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
362ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
363%endif
364
901927d3
AM
365%clean
366rm -rf $RPM_BUILD_ROOT
367
368%post -p /sbin/ldconfig
369%postun -p /sbin/ldconfig
370
933de752
ER
371%post core -p /sbin/ldconfig
372%postun core -p /sbin/ldconfig
373
485d5dca
JB
374%post viz -p /sbin/ldconfig
375%postun viz -p /sbin/ldconfig
376
b07433c6
JB
377%post -n java-opencv -p /sbin/ldconfig
378%postun -n java-opencv -p /sbin/ldconfig
379
901927d3
AM
380%files
381%defattr(644,root,root,755)
f753ced4 382%attr(755,root,root) %{_bindir}/opencv_annotation
933de752
ER
383%attr(755,root,root) %{_bindir}/opencv_createsamples
384%attr(755,root,root) %{_bindir}/opencv_haartraining
385%attr(755,root,root) %{_bindir}/opencv_performance
386%attr(755,root,root) %{_bindir}/opencv_traincascade
158e0ccc 387%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
da5d1e09 388%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
158e0ccc 389%attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
da5d1e09 390%attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
158e0ccc 391%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
da5d1e09 392%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
158e0ccc 393%attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
cf32945e 394%attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
158e0ccc 395%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
da5d1e09 396%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
158e0ccc 397%attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
da5d1e09 398%attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
158e0ccc 399%attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
cf32945e 400%attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
158e0ccc 401%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
da5d1e09
JB
402%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
403%if %{with opencl}
158e0ccc 404%attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
da5d1e09
JB
405%attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
406%endif
158e0ccc 407%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
da5d1e09 408%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
158e0ccc 409%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
da5d1e09 410%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
158e0ccc 411%attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
cf32945e 412%attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
158e0ccc 413%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
da5d1e09 414%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
452b38e1 415%dir %{_datadir}/OpenCV
452b38e1 416%{_datadir}/OpenCV/haarcascades
417%{_datadir}/OpenCV/lbpcascades
901927d3 418
933de752
ER
419%files core
420%defattr(644,root,root,755)
158e0ccc 421%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
cf32945e 422%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
158e0ccc 423%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
cf32945e 424%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
158e0ccc 425%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
cf32945e 426%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
158e0ccc 427%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
cf32945e 428%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
158e0ccc 429%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
cf32945e 430%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
158e0ccc 431%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
cf32945e
JB
432%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
433
434%if %{with vtk}
435%files viz
436%defattr(644,root,root,755)
158e0ccc 437%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
cf32945e
JB
438%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
439%endif
933de752 440
901927d3
AM
441%files devel
442%defattr(644,root,root,755)
cf32945e
JB
443# core
444%attr(755,root,root) %{_libdir}/libopencv_core.so
445%attr(755,root,root) %{_libdir}/libopencv_flann.so
446%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
447%attr(755,root,root) %{_libdir}/libopencv_ml.so
448%attr(755,root,root) %{_libdir}/libopencv_photo.so
449%attr(755,root,root) %{_libdir}/libopencv_video.so
450# GUI/extensions (base package)
451%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
452%attr(755,root,root) %{_libdir}/libopencv_contrib.so
453%attr(755,root,root) %{_libdir}/libopencv_features2d.so
454%attr(755,root,root) %{_libdir}/libopencv_gpu.so
455%attr(755,root,root) %{_libdir}/libopencv_highgui.so
456%attr(755,root,root) %{_libdir}/libopencv_legacy.so
457%attr(755,root,root) %{_libdir}/libopencv_nonfree.so
458%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
459%if %{with opencl}
460%attr(755,root,root) %{_libdir}/libopencv_ocl.so
461%endif
462%attr(755,root,root) %{_libdir}/libopencv_stitching.so
463%attr(755,root,root) %{_libdir}/libopencv_superres.so
464%attr(755,root,root) %{_libdir}/libopencv_ts.so
465%attr(755,root,root) %{_libdir}/libopencv_videostab.so
466# viz
467%if %{with vtk}
468%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 469%endif
901927d3 470%{_includedir}/opencv
509c07dc 471%{_includedir}/opencv2
da5d1e09 472%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 473%{_pkgconfigdir}/opencv.pc
901927d3 474
9141b1e2
ER
475%files doc
476%defattr(644,root,root,755)
477# TODO: probably could rebuild them and package via make install
478%doc doc/*
479
200823d5
ER
480%if %{with examples}
481%files examples
482%defattr(644,root,root,755)
483%{_examplesdir}/%{name}-%{version}
484%endif
485
b07433c6
JB
486%if %{with java}
487%files -n java-opencv
488%defattr(644,root,root,755)
835e0cdd
ER
489%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
490%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
491%{_javadir}/opencv.jar
492%endif
493
901927d3
AM
494%files -n python-opencv
495%defattr(644,root,root,755)
452b38e1 496%attr(755,root,root) %{py_sitedir}/cv2.so
8d499a62 497%{py_sitedir}/cv.py[co]
This page took 0.149584 seconds and 4 git commands to generate.