]> git.pld-linux.org Git - packages/thunderbird.git/blame - thunderbird.spec
- added clang bcond
[packages/thunderbird.git] / thunderbird.spec
CommitLineData
c4ddd260 1# TODO:
283702b9 2# - build with system mozldap
210a9feb 3# - fix startup crash "TypeError: a is null"
c4ddd260 4#
44be9ed4 5# Conditional builds
8b3db612 6%bcond_with tests # enable tests (whatever they check)
210a9feb 7%bcond_without gtk3 # GTK+ 3.x instead of 2.x
44be9ed4 8%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 9%bcond_without lightning # disable Sunbird/Lightning calendar
506cce80 10%bcond_without official # official Thunderbird branding
765a3a27 11%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
a97d3356
JR
12# - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
13%bcond_with shared_js # shared libmozjs library [broken]
99b97bc4 14%bcond_with system_icu # build with system ICU (disabled due to crashes with system icu 58.2)
19f2dc46 15%bcond_with clang # build using Clang/LLVM
88149483 16
f4114a7f 17%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
18%undefine crashreporter
19%endif
20
8b3db612 21%define nspr_ver 4.13.1
5b7bcd89 22%define nss_ver 3.28.5
44be9ed4 23
7d981f69
ER
24# The actual sqlite version (see RHBZ#480989):
25%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
7d981f69 26
cae5b55b
JR
27Summary: Thunderbird - email client
28Summary(pl.UTF-8): Thunderbird - klient poczty
29Name: thunderbird
962f00cb 30Version: 52.3.0
1e1b81a7 31Release: 1
3366507a 32License: MPL v2.0
2d289b25 33Group: X11/Applications/Mail
cae5b55b 34Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/%{name}-%{version}.source.tar.xz
962f00cb 35# Source0-md5: 5841ee1a70423b9385110c82b78bef47
dd12359d
JR
36Source1: %{name}.desktop
37Source2: %{name}.sh
38Patch0: prefs.patch
39Patch1: no-subshell.patch
40Patch2: enable-addons.patch
210a9feb 41Patch3: mozilla-1245783.patch
cae5b55b 42URL: http://www.mozilla.org/projects/thunderbird/
51a3b6db 43BuildRequires: alsa-lib-devel
ea3df35f 44BuildRequires: autoconf2_13 >= 2.13
51a3b6db 45BuildRequires: bzip2-devel
e820c55e
JB
46BuildRequires: cairo-devel >= 1.10
47BuildRequires: dbus-glib-devel >= 0.60
5b7bcd89 48BuildRequires: fontconfig-devel >= 2.7.0
44be9ed4 49BuildRequires: freetype-devel >= 1:2.1.8
ea3df35f 50BuildRequires: glib2-devel >= 1:2.22
99b97bc4
JR
51%{!?with_gtk3:BuildRequires: gtk+2-devel >= 2:2.18.0}
52%{?with_gtk3:BuildRequires: gtk+3-devel >= 3.4.0}
5e9bb798 53BuildRequires: hunspell-devel
d0b96b40 54BuildRequires: libevent-devel
5b7bcd89 55BuildRequires: libffi-devel > 3.0.9
99b97bc4 56%{?with_system_icu:BuildRequires: libicu-devel >= 58.1}
51a3b6db 57BuildRequires: libiw-devel
e82da7a1 58# requires libjpeg-turbo implementing at least libjpeg 6b API
44be9ed4 59BuildRequires: libjpeg-devel >= 6b
e82da7a1 60BuildRequires: libjpeg-turbo-devel
ea3df35f 61BuildRequires: libpng-devel >= 2:1.6.25
44be9ed4 62BuildRequires: libstdc++-devel
5b7bcd89 63BuildRequires: libvpx-devel >= 1.5.0
d0b96b40 64BuildRequires: mozldap-devel
f4114a7f
ER
65BuildRequires: nspr-devel >= 1:%{nspr_ver}
66BuildRequires: nss-devel >= 1:%{nss_ver}
62096d2c 67BuildRequires: pango-devel >= 1:1.22.0
e820c55e 68BuildRequires: perl-base >= 1:5.6
5b7bcd89 69BuildRequires: pixman-devel >= 0.19.2
1c62cadb 70BuildRequires: pkgconfig
ea3df35f 71BuildRequires: python >= 1:2.7
cae5b55b 72BuildRequires: python-virtualenv
44be9ed4 73BuildRequires: sed >= 4.0
5b7bcd89 74BuildRequires: sqlite3-devel >= 3.17.0
1c62cadb 75BuildRequires: startup-notification-devel >= 0.8
ffb12c8e 76BuildRequires: virtualenv
ea3df35f
JB
77BuildRequires: xorg-lib-libX11-devel
78BuildRequires: xorg-lib-libXcomposite-devel
79BuildRequires: xorg-lib-libXdamage-devel
44be9ed4 80BuildRequires: xorg-lib-libXext-devel
ea3df35f 81BuildRequires: xorg-lib-libXfixes-devel
44be9ed4 82BuildRequires: xorg-lib-libXt-devel
ea3df35f
JB
83%ifarch %{ix86} %{x8664}
84BuildRequires: yasm >= 1.0.1
85%endif
1c62cadb 86BuildRequires: zip
ea3df35f
JB
87BuildRequires: zlib-devel >= 1.2.3
88Requires(post): mktemp >= 1.5-18
89Requires: dbus-glib >= 0.60
90Requires: glib2 >= 1:2.22
99b97bc4
JR
91%{!?with_gtk3:Requires: gtk+2 >= 2:2.18.0}
92%{?with_gtk3:Requires: gtk+3 >= 3.4.0}
ea3df35f 93Requires: libpng >= 2:1.6.25
5b7bcd89 94Requires: libvpx >= 1.5.0
44be9ed4 95Requires: myspell-common
f4114a7f
ER
96Requires: nspr >= 1:%{nspr_ver}
97Requires: nss >= 1:%{nss_ver}
62096d2c 98Requires: pango >= 1:1.22.0
4b6bc367 99Requires: sqlite3 >= %{sqlite_build_version}
ea3df35f 100Requires: startup-notification >= 0.8
e82da7a1 101Requires: libjpeg-turbo
99b97bc4 102Obsoletes: icedove
44be9ed4 103Obsoletes: mozilla-thunderbird
104Obsoletes: mozilla-thunderbird-dictionary-en-US
cae5b55b 105Conflicts: thunderbird-lang-resources < %{version}
44be9ed4 106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
9e366f18
AM
108%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
109
cae5b55b 110# firefox/thunderbird/seamonkey provide their own versions
44be9ed4 111%define _noautoprovfiles %{_libdir}/%{name}/components
99b97bc4 112
fb7d4f06 113# we don't want these to satisfy packages depending on xulrunner
6f32f966 114%define _noautoprov libmozalloc.so libmozjs.so libxul.so
44be9ed4 115# and as we don't provide them, don't require either
6f32f966 116%define _noautoreq libmozalloc.so libmozjs.so libxul.so
44be9ed4 117
7a5e9406 118%define topdir %{_builddir}/thunderbird-%{version}
9e7875fc
ER
119%define objdir %{topdir}/obj-%{_target_cpu}
120
44be9ed4 121%description
cae5b55b 122Thunderbird is an open-source, fast and portable email client.
44be9ed4 123
124%description -l pl.UTF-8
cae5b55b 125Thunderbird jest mającym otwarte źródła, szybkim i przenośnym klientem
6b327de6 126poczty.
44be9ed4 127
6578c165 128%package addon-lightning
cae5b55b
JR
129Summary: An integrated calendar for Thunderbird
130Summary(pl.UTF-8): Zintegrowany kalendarz dla Thunderbird
6578c165 131License: MPL 1.1 or GPL v2+ or LGPL v2.1+
132Group: Applications/Networking
133Requires: %{name} = %{version}-%{release}
99b97bc4 134Obsoletes: icedove-addon-lightning
6578c165 135
136%description addon-lightning
cae5b55b 137Lightning is an calendar extension to Thunderbird email client.
6578c165 138
139%description addon-lightning -l pl.UTF-8
cae5b55b 140Lightning to rozszerzenie do klienta poczty Thunderbird dodające
6578c165 141funkcjonalność kalendarza.
142
44be9ed4 143%prep
cae5b55b 144%setup -q
dd12359d
JR
145%patch0 -p1
146%patch1 -p1
f53f9bcd 147%patch2 -p1
dd12359d 148%patch3 -p1
d0b96b40 149
44be9ed4 150%build
fbac75ca 151cat << EOF > .mozconfig
9e7875fc 152mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 153
19f2dc46
JR
154%if %{with clang}
155export CC="clang"
156export CXX="clang++"
157%else
158export CC="%{__cc}"
159export CXX="%{__cxx}"
160%endif
161export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
162export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64"
163
765a3a27
ER
164%if %{with crashreporter}
165export MOZ_DEBUG_SYMBOLS=1
166%endif
167
59c5a0e8 168# Options for 'configure' (same as command-line options).
44be9ed4 169ac_add_options --prefix=%{_prefix}
44be9ed4 170%if %{?debug:1}0
59c5a0e8 171ac_add_options --disable-optimize
44be9ed4 172ac_add_options --enable-debug
173ac_add_options --enable-debug-modules
59c5a0e8
SP
174ac_add_options --enable-debugger-info-modules
175ac_add_options --enable-crash-on-assert
44be9ed4 176%else
177ac_add_options --disable-debug
59c5a0e8 178ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 179%endif
88149483 180ac_add_options --disable-strip
210a9feb 181ac_add_options --disable-install-strip
44be9ed4 182%if %{with tests}
183ac_add_options --enable-tests
210a9feb 184ac_add_options --enable-mochitest
44be9ed4 185%else
186ac_add_options --disable-tests
187%endif
3366507a
JB
188%if %{with lightning}
189ac_add_options --enable-calendar
44be9ed4 190%else
3366507a 191ac_add_options --disable-calendar
44be9ed4 192%endif
765a3a27
ER
193%if %{with crashreporter}
194ac_add_options --enable-crashreporter
195%else
59c5a0e8 196ac_add_options --disable-crashreporter
765a3a27 197%endif
99b97bc4 198#ac_add_options --disable-elf-hack
8b3db612 199ac_add_options --disable-gconf
3366507a 200ac_add_options --disable-gnomeui
8b3db612 201ac_add_options --disable-necko-wifi
88149483 202ac_add_options --disable-updater
8b3db612 203ac_add_options --enable-alsa
3366507a 204ac_add_options --enable-application=mail
ea3df35f 205ac_add_options --enable-chrome-format=omni
3366507a
JB
206ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
207ac_add_options --enable-gio
208%if %{with ldap}
209ac_add_options --enable-ldap
3366507a
JB
210%else
211ac_add_options --disable-ldap
212%endif
ea3df35f
JB
213%{?with_official:ac_add_options --enable-official-branding}
214ac_add_options --enable-readline
a97d3356 215%{?with_shared_js:ac_add_options --enable-shared-js}
88149483 216ac_add_options --enable-startup-notification
44be9ed4 217ac_add_options --enable-system-cairo
210a9feb 218ac_add_options --enable-system-ffi
5e9bb798 219ac_add_options --enable-system-hunspell
7d981f69 220ac_add_options --enable-system-sqlite
210a9feb 221ac_add_options --enable-url-classifier
3366507a
JB
222ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
223ac_add_options --with-distribution-id=org.pld-linux
88149483
ER
224ac_add_options --with-pthreads
225ac_add_options --with-system-bz2
99b97bc4 226ac_add_options --with%{!?with_system_icu:out}-system-icu
44be9ed4 227ac_add_options --with-system-jpeg
d0b96b40
JR
228ac_add_options --with-system-libevent
229ac_add_options --with-system-libvpx
44be9ed4 230ac_add_options --with-system-nspr
231ac_add_options --with-system-nss
232ac_add_options --with-system-png
233ac_add_options --with-system-zlib
210a9feb 234ac_add_options --with-x
44be9ed4 235EOF
236
d0b96b40 237mkdir -p %{objdir}/config
7a5e9406 238ln -sf %{topdir}/mozilla/config/*.mk %{objdir}/config
d0b96b40 239
90e998ba 240%{__make} -j1 -f client.mk build \
210a9feb
JR
241 AUTOCONF=/usr/bin/autoconf2_13 \
242 MOZ_MAKE_FLAGS="%{_smp_mflags}"
44be9ed4 243
765a3a27
ER
244%if %{with crashreporter}
245# create debuginfo for crash-stats.mozilla.com
246%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
247%endif
248
44be9ed4 249%install
250rm -rf $RPM_BUILD_ROOT
99b97bc4 251install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/plugins,%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 252
9e7875fc 253cd %{objdir}
ecf04393 254%{__make} -C mail/installer stage-package \
44be9ed4 255 DESTDIR=$RPM_BUILD_ROOT \
d0b96b40 256 installdir=%{_libdir}/%{name} \
44be9ed4 257 PKG_SKIP_STRIP=1
258
cae5b55b 259cp -a dist/thunderbird/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
d0b96b40 260
9b40a2c3 261# Enable crash reporter for Thunderbird application
765a3a27
ER
262%if %{with crashreporter}
263%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
264
265# Add debuginfo for crash-stats.mozilla.com
51a3b6db 266install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
3a30e2d7 267cp -a dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
268%endif
269
99b97bc4
JR
270%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{name}
271cp -p dist/thunderbird/chrome/icons/default/default48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
78c9ef4f 272cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
c6ec3c1c 273
99b97bc4
JR
274# use system dict
275%{__rm} -rv $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 276ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
99b97bc4 277ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
e6bc19b3 278
99b97bc4
JR
279# move arch independant ones to datadir
280mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
281mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
282mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
283ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
284ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
285ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
52fc61e6 286
283702b9 287# mozldap
d0b96b40
JR
288%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
289%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
283702b9 290
99b97bc4
JR
291# remove unecessary stuff
292%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/removed-files
293
44be9ed4 294%clean
295rm -rf $RPM_BUILD_ROOT
296
297%pretrans
298if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
299 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
300fi
99b97bc4 301for d in chrome defaults icons isp modules res; do
44be9ed4 302 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
303 install -d %{_datadir}/%{name}
304 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
305 fi
306done
307exit 0
308
e8f4ba81 309%post
99b97bc4
JR
310%update_desktop_database_post
311# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
312# dangerous if you run this with sudo with keep_env += HOME
313# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
314export HOME=$(mktemp -d)
315unset TMPDIR TMP || :
316umask 022
317%{_libdir}/%{name}/thunderbird -register
318rm -rf $HOME
319
320%postun
321%update_desktop_database_postun
e8f4ba81 322
44be9ed4 323%files
324%defattr(644,root,root,755)
99b97bc4 325%attr(755,root,root) %{_bindir}/%{name}
44be9ed4 326%dir %{_libdir}/%{name}
99b97bc4
JR
327%dir %{_libdir}/%{name}/plugins
328
329%if %{with gtk3}
330%dir %{_libdir}/%{name}/gtk2
331%attr(755,root,root) %{_libdir}/%{name}/gtk2/libmozgtk.so
332%attr(755,root,root) %{_libdir}/%{name}/libmozgtk.so
333%endif
334%attr(755,root,root) %{_libdir}/%{name}/liblgpllibs.so
335%{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
210a9feb 336%attr(755,root,root) %{_libdir}/%{name}/libmozsandbox.so
99b97bc4 337%attr(755,root,root) %{_libdir}/%{name}/libxul.so
73d54cb2
JB
338%attr(755,root,root) %{_libdir}/%{name}/*.sh
339%attr(755,root,root) %{_libdir}/%{name}/*-bin
99b97bc4 340%attr(755,root,root) %{_libdir}/%{name}/plugin-container
cae5b55b 341%attr(755,root,root) %{_libdir}/%{name}/thunderbird
99b97bc4
JR
342
343%{_libdir}/%{name}/application.ini
344%{_libdir}/%{name}/blocklist.xml
a367af64 345%{_libdir}/%{name}/dependentlibs.list
99b97bc4 346%{_libdir}/%{name}/omni.ja
73d54cb2 347%{_libdir}/%{name}/platform.ini
210a9feb
JR
348%{!?with_system_icu:%{_libdir}/%{name}/icudt58l.dat}
349
350%dir %{_libdir}/%{name}/fonts
351%{_libdir}/%{name}/fonts/EmojiOneMozilla.ttf
44be9ed4 352
765a3a27
ER
353%if %{with crashreporter}
354%attr(755,root,root) %{_libdir}/%{name}/crashreporter
355%{_libdir}/%{name}/crashreporter.ini
356%{_libdir}/%{name}/Throbber-small.gif
357%endif
358
44be9ed4 359%dir %{_libdir}/%{name}/extensions
99b97bc4
JR
360%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
361
362%dir %{_libdir}/%{name}/distribution
363%dir %{_libdir}/%{name}/distribution/extensions
364
365# symlinks
366%{_libdir}/%{name}/chrome
367%{_libdir}/%{name}/defaults
368%{_libdir}/%{name}/dictionaries
369%{_libdir}/%{name}/hyphenation
370%{_libdir}/%{name}/isp
6578c165 371
99b97bc4
JR
372%{_pixmapsdir}/*.png
373%{_desktopdir}/*.desktop
52fc61e6 374
99b97bc4
JR
375%dir %{_datadir}/%{name}
376%{_datadir}/%{name}/chrome
377%{_datadir}/%{name}/defaults
378%{_datadir}/%{name}/isp
d0b96b40 379
6578c165 380%if %{with lightning}
381%files addon-lightning
382%defattr(644,root,root,755)
3a30e2d7
JR
383%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
384%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/app.ini
385%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.jar
386%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
387%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
388%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
389%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
3a30e2d7
JR
390%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
391%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*manifest
392%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
393%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
394%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
395%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones
396%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones/zones.json
6578c165 397%endif
This page took 0.132517 seconds and 4 git commands to generate.