]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- remove cmake install directory arch dependant hackery
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
2acd8ac1 2# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 3# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 4# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 5#
0c2d6b7d 6# Conditional build:
a55ba198
JB
7# - general options:
8%bcond_with tbb # Threading Building Blocks support (everywhere)
9%bcond_with sse # use SSE instructions
10%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
11%bcond_with sse3 # use SSE3 instructions
12%bcond_with ssse3 # use SSSE3 instructions
13%bcond_with sse41 # use SSE4.1 instructions
14%bcond_with sse42 # use SSE4.2 instructions
15%bcond_with avx # use AVX instructions
8d5385eb
JB
16%bcond_without opencl # OpenCL support
17%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
18%bcond_with opencl_amdfft # AMD OpenCL FFT routines
19%bcond_without opengl # OpenGL support
cf32945e 20%bcond_without gomp # OpenMP support (available when not using tbb)
200823d5 21%bcond_without examples # Install examples
b07433c6
JB
22# - bindings
23%bcond_without java # Java binding
a55ba198 24# - highgui options:
b3920a9d 25%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
26%bcond_without gstreamer # GStreamer support in highgui
27%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 28%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 29%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 30%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 31%bcond_without v4l # Video4Linux in highgui
a55ba198 32%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 33%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
34# - other modules
35%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 36
e36ac029 37%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
38%define with_sse 1
39%endif
e36ac029 40%ifarch pentium4 %{x8664} x32
1c9fe580
JB
41%define with_sse2 1
42%endif
901927d3 43Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 44Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 45Name: opencv
158e0ccc
JB
46Version: 2.4.10.1
47Release: 1
901927d3 48Epoch: 1
d5e56e66
JB
49%if %{with unicap} || %{with xine}
50License: GPL (enforced by used libraries), BSD (opencv itself)
51%else
901927d3 52License: BSD
d5e56e66 53%endif
901927d3 54Group: Libraries
200823d5 55Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
158e0ccc 56# Source0-md5: f84af999f45edc829bfda60a13fedbaa
452b38e1 57Patch0: %{name}-cflags.patch
158e0ccc 58Patch1: %{name}-x86.patch
452b38e1 59Patch2: %{name}-unicap-c++.patch
60Patch3: %{name}-c.patch
61Patch4: %{name}-gcc.patch
809ce413 62Patch5: %{name}-ximea.patch
6994c4f7 63Patch6: %{name}-ocl-fft.patch
a4737151 64Patch7: java-ant-sourcelevel.patch
da5d1e09 65Patch8: %{name}-shared.patch
f9e8f4ea 66Patch9: no-sysctl.patch
e36ac029 67Patch10: cmake-install-path.patch
200823d5 68URL: http://www.opencv.org/
d5e56e66 69%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 70%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 71BuildRequires: OpenEXR-devel
5df3cf1b 72%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 73%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 74# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 75%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 76%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 77%{?with_java:BuildRequires: ant}
ef4af528
JB
78%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
79%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 80BuildRequires: cmake >= 2.8
0c2d6b7d 81BuildRequires: doxygen
809ce413 82BuildRequires: eigen3 >= 3
b3920a9d 83%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
da5d1e09 84%{?with_gomp:BuildRequires: gcc-c++ >= 6:4.2}
0c2d6b7d 85%if %{with gstreamer}
158e0ccc
JB
86BuildRequires: gstreamer-devel >= 1.0
87BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 88%endif
901927d3 89BuildRequires: jasper-devel
b07433c6 90%{?with_java:BuildRequires: jdk}
158e0ccc 91BuildRequires: libdc1394-devel >= 2
da5d1e09 92%{?with_gomp:BuildRequires: libgomp-devel}
901927d3
AM
93BuildRequires: libjpeg-devel
94BuildRequires: libpng-devel
95BuildRequires: libraw1394-devel
0c2d6b7d 96BuildRequires: libstdc++-devel
901927d3 97BuildRequires: libtiff-devel
148338c5 98BuildRequires: libtool
d5e56e66
JB
99%if %{with unicap}
100BuildRequires: libucil-devel
101BuildRequires: libunicap-devel
102%endif
0c2d6b7d 103BuildRequires: libv4l-devel
af6d2888 104BuildRequires: pkgconfig
158e0ccc
JB
105BuildRequires: python >= 2.0
106BuildRequires: python-devel >= 2.0
0c2d6b7d 107BuildRequires: python-numpy-devel
901927d3 108BuildRequires: rpm-pythonprov
8d499a62 109BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 110BuildRequires: sed >= 4.0
158e0ccc 111BuildRequires: sphinx-pdg
996927aa 112BuildRequires: swig-python
f8e040cc 113%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
114%if %{with vtk}
115BuildRequires: vtk-devel >= 5.8.0
fba97d16 116BuildRequires: vtk-java >= 5.8.0
ae3d975d
AM
117BuildRequires: vtk-tcl >= 5.8.0
118%endif
901927d3 119%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 120BuildRequires: xorg-lib-libX11-devel
452b38e1 121BuildRequires: zlib-devel
4afb606b 122%if %{with qt}
4afb606b
JB
123BuildRequires: QtCore-devel >= 4
124BuildRequires: QtGui-devel >= 4
5df3cf1b 125%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
126BuildRequires: qt4-qmake >= 4
127%else
128BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 129%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 130%endif
da5d1e09 131Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
132BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
133
158e0ccc 134%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
933de752 135
901927d3
AM
136%description
137OpenCV (Open Source Computer Vision) is a library of programming
138functions mainly aimed at real time computer vision.
139
0c2d6b7d
JB
140Example applications of the OpenCV library are:
141- Human-Computer Interaction (HCI)
142- Object Identification, Segmentation and Recognition
143- Face Recognition
144- Gesture Recognition
145- Motion Tracking
146- Ego Motion, Motion Understanding
147- Structure From Motion (SFM)
148- Stereo and Multi-Camera Calibration and Depth Computation
149- Mobile Robotics.
150
151%description -l pl.UTF-8
152OpenCV (Open Source Computer Vision) to biblioteka funkcji
153przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
154
155Przykładowe zastosowania biblioteki OpenCV to
156- interakcje człowiek-komputer (HCI)
157- identyfikacja, segmentacja i rozpoznawanie obiektów
158- rozpoznawanie twarzy
159- rozpoznawanie gestów
160- śledzenie ruchu
161- rozumienie ruchu
162- SFM (Structure From Motion)
163- kalibracja dwu- i wielokamerowa, obliczanie głębi
164- robotyka ruchu.
901927d3 165
933de752
ER
166%package core
167Summary: OpenCV core libraries
da5d1e09 168Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 169Group: Libraries
da5d1e09 170Conflicts: opencv < 2.4.6.2-1
933de752
ER
171
172%description core
173This package contains the OpenCV C/C++ core libraries.
174
da5d1e09
JB
175%description core -l pl.UTF-8
176Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
177
cf32945e
JB
178%package viz
179Summary: OpenCV viz library (VTK support)
180Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
181Group: Libraries
182Requires: %{name} = %{epoch}:%{version}-%{release}
183
184%description viz
185OpenCV viz library (VTK support).
186
187%description viz -l pl.UTF-8
188Biblioteka OpenCV viz (obsługa VTK).
189
901927d3 190%package devel
0c2d6b7d
JB
191Summary: Header files for OpenCV library
192Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
193Group: Development/Libraries
194Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
195%if %{with vtk}
196Requires: %{name}-viz = %{epoch}:%{version}-%{release}
197%endif
0c2d6b7d 198Obsoletes: opencv-static
901927d3
AM
199
200%description devel
0c2d6b7d 201Header files for OpenCV library.
901927d3 202
0c2d6b7d
JB
203%description devel -l pl.UTF-8
204Pliki nagłówkowe biblioteki OpenCV.
901927d3 205
9141b1e2
ER
206%package doc
207Summary: Manual for OpenCV
208Summary(fr.UTF-8): Documentation pour OpenCV
209Summary(it.UTF-8): Documentazione di OpenCV
210Summary(pl.UTF-8): Podręcznik dla OpenCV
211Group: Documentation
212# noarch subpackages only when building with rpm5
213%if "%{_rpmversion}" >= "5"
214BuildArch: noarch
215%endif
216
217%description doc
218Documentation for OpenCV.
219
220%description doc -l fr.UTF-8
221Documentation pour OpenCV.
222
223%description doc -l it.UTF-8
224Documentazione di OpenCV.
225
226%description doc -l pl.UTF-8
227Dokumentacja do OpenCV.
228
200823d5
ER
229%package examples
230Summary: OpenCV code examples
231Group: Documentation
232%if "%{_rpmversion}" >= "5"
233BuildArch: noarch
234%endif
235
236%description examples
237OpenCV code examples.
238
b07433c6
JB
239%package -n java-opencv
240Summary: OpenCV Java bindings
241Summary(pl.UTF-8): Wiązania Javy do OpenCV
242Group: Libraries/Java
243Requires: %{name} = %{epoch}:%{version}-%{release}
244Requires: jre
245
246%description -n java-opencv
247OpenCV Java bindings.
248
249%description -n java-opencv -l pl.UTF-8
250Wiązania Javy do OpenCV.
251
901927d3
AM
252%package -n python-opencv
253Summary: OpenCV Python bindings
0c2d6b7d
JB
254Summary(pl.UTF-8): Wiązania Pythona do OpenCV
255Group: Libraries/Python
cd1f0136 256Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 257Requires: python-libs
901927d3
AM
258
259%description -n python-opencv
260OpenCV Python bindings.
261
0c2d6b7d
JB
262%description -n python-opencv -l pl.UTF-8
263Wiązania Pythona do OpenCV.
264
901927d3 265%prep
25269a76 266%setup -q
54551f29 267
da67222a 268%undos CMakeLists.txt
1376dffe 269%undos modules/gpu/CMakeLists.txt
54551f29 270
1376dffe 271%patch0 -p1
272%patch1 -p1
29d82ddf 273%patch2 -p1
f8e040cc 274%patch3 -p1
75b912e9 275%patch4 -p1
809ce413 276%patch5 -p1
6994c4f7 277%patch6 -p1
a4737151 278%patch7 -p1
da5d1e09 279%patch8 -p1
f9e8f4ea 280%patch9 -p1
e36ac029 281%patch10 -p1
148338c5 282
901927d3 283%build
95daeb66
AM
284install -d build
285cd build
ea26b025
ER
286
287# handle cmake & ccache
288# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
289if [[ "%{__cc}" = *ccache* ]]; then
290 cc="%{__cc}"
291 cxx="%{__cxx}"
292 ccache="
293 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
294 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
295 "
296fi
297
0c2d6b7d 298%cmake .. \
ea26b025 299 $ccache \
da5d1e09 300 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
301 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
302 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
303 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
304 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
305 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
306 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 307 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
308%if %{with examples}
309 -DINSTALL_C_EXAMPLES=ON \
310 -DINSTALL_PYTHON_EXAMPLES=ON \
311%endif
b3920a9d 312 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 313 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 314 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
315 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
316 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 317 %{?with_opengl:-DWITH_OPENGL=ON} \
da5d1e09 318 %{?with_gomp:-DWITH_OPENMP=ON} \
1c9fe580 319 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 320 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 321 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 322 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 323 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 324 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 325 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 326 %{?with_ximea:-DWITH_XIMEA=ON} \
d5e56e66 327 %{?with_xine:-DWITH_XINE=ON}
54551f29 328
8b9f61f7 329%{__make}
901927d3
AM
330
331%install
332rm -rf $RPM_BUILD_ROOT
95daeb66 333%{__make} -C build install \
901927d3
AM
334 DESTDIR=$RPM_BUILD_ROOT
335
9141b1e2
ER
336# see -doc package
337%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
200823d5
ER
338%if %{with examples}
339install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
340mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
341%endif
9141b1e2 342
4bd2eae7 343install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 344cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 345
7545129b
JB
346# disable completeness check incompatible with split packaging
347%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
348
8d499a62
JB
349%py_comp $RPM_BUILD_ROOT%{py_sitedir}
350%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
351%py_postclean
352
b07433c6
JB
353%if %{with java}
354# move to proper directories, create symlink
355install -d $RPM_BUILD_ROOT%{_javadir}
356%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
357sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
358 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
359%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
360rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
361ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
362%endif
363
901927d3
AM
364%clean
365rm -rf $RPM_BUILD_ROOT
366
367%post -p /sbin/ldconfig
368%postun -p /sbin/ldconfig
369
933de752
ER
370%post core -p /sbin/ldconfig
371%postun core -p /sbin/ldconfig
372
485d5dca
JB
373%post viz -p /sbin/ldconfig
374%postun viz -p /sbin/ldconfig
375
b07433c6
JB
376%post -n java-opencv -p /sbin/ldconfig
377%postun -n java-opencv -p /sbin/ldconfig
378
901927d3
AM
379%files
380%defattr(644,root,root,755)
933de752
ER
381%attr(755,root,root) %{_bindir}/opencv_createsamples
382%attr(755,root,root) %{_bindir}/opencv_haartraining
383%attr(755,root,root) %{_bindir}/opencv_performance
384%attr(755,root,root) %{_bindir}/opencv_traincascade
158e0ccc 385%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
da5d1e09 386%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
158e0ccc 387%attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
da5d1e09 388%attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
158e0ccc 389%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
da5d1e09 390%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
158e0ccc 391%attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
cf32945e 392%attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
158e0ccc 393%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
da5d1e09 394%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
158e0ccc 395%attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
da5d1e09 396%attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
158e0ccc 397%attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
cf32945e 398%attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
158e0ccc 399%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
da5d1e09
JB
400%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
401%if %{with opencl}
158e0ccc 402%attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
da5d1e09
JB
403%attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
404%endif
158e0ccc 405%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
da5d1e09 406%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
158e0ccc 407%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
da5d1e09 408%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
158e0ccc 409%attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
cf32945e 410%attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
158e0ccc 411%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
da5d1e09 412%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
452b38e1 413%dir %{_datadir}/OpenCV
452b38e1 414%{_datadir}/OpenCV/haarcascades
415%{_datadir}/OpenCV/lbpcascades
901927d3 416
933de752
ER
417%files core
418%defattr(644,root,root,755)
158e0ccc 419%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
cf32945e 420%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
158e0ccc 421%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
cf32945e 422%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
158e0ccc 423%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
cf32945e 424%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
158e0ccc 425%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
cf32945e 426%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
158e0ccc 427%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
cf32945e 428%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
158e0ccc 429%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
cf32945e
JB
430%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
431
432%if %{with vtk}
433%files viz
434%defattr(644,root,root,755)
158e0ccc 435%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
cf32945e
JB
436%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
437%endif
933de752 438
901927d3
AM
439%files devel
440%defattr(644,root,root,755)
cf32945e
JB
441# core
442%attr(755,root,root) %{_libdir}/libopencv_core.so
443%attr(755,root,root) %{_libdir}/libopencv_flann.so
444%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
445%attr(755,root,root) %{_libdir}/libopencv_ml.so
446%attr(755,root,root) %{_libdir}/libopencv_photo.so
447%attr(755,root,root) %{_libdir}/libopencv_video.so
448# GUI/extensions (base package)
449%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
450%attr(755,root,root) %{_libdir}/libopencv_contrib.so
451%attr(755,root,root) %{_libdir}/libopencv_features2d.so
452%attr(755,root,root) %{_libdir}/libopencv_gpu.so
453%attr(755,root,root) %{_libdir}/libopencv_highgui.so
454%attr(755,root,root) %{_libdir}/libopencv_legacy.so
455%attr(755,root,root) %{_libdir}/libopencv_nonfree.so
456%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
457%if %{with opencl}
458%attr(755,root,root) %{_libdir}/libopencv_ocl.so
459%endif
460%attr(755,root,root) %{_libdir}/libopencv_stitching.so
461%attr(755,root,root) %{_libdir}/libopencv_superres.so
462%attr(755,root,root) %{_libdir}/libopencv_ts.so
463%attr(755,root,root) %{_libdir}/libopencv_videostab.so
464# viz
465%if %{with vtk}
466%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 467%endif
901927d3 468%{_includedir}/opencv
509c07dc 469%{_includedir}/opencv2
da5d1e09 470%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 471%{_pkgconfigdir}/opencv.pc
901927d3 472
9141b1e2
ER
473%files doc
474%defattr(644,root,root,755)
475# TODO: probably could rebuild them and package via make install
476%doc doc/*
477
200823d5
ER
478%if %{with examples}
479%files examples
480%defattr(644,root,root,755)
481%{_examplesdir}/%{name}-%{version}
482%endif
483
b07433c6
JB
484%if %{with java}
485%files -n java-opencv
486%defattr(644,root,root,755)
835e0cdd
ER
487%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
488%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
489%{_javadir}/opencv.jar
490%endif
491
901927d3
AM
492%files -n python-opencv
493%defattr(644,root,root,755)
452b38e1 494%attr(755,root,root) %{py_sitedir}/cv2.so
8d499a62 495%{py_sitedir}/cv.py[co]
This page took 0.246463 seconds and 4 git commands to generate.