]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- remove cmake install directory arch dependant hackery
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
3 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
4 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
5 #
6 # Conditional build:
7 # - general options:
8 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
9 %bcond_with     sse             # use SSE instructions
10 %bcond_with     sse2            # use SSE2 instructions
11 %bcond_with     sse3            # use SSE3 instructions
12 %bcond_with     ssse3           # use SSSE3 instructions
13 %bcond_with     sse41           # use SSE4.1 instructions
14 %bcond_with     sse42           # use SSE4.2 instructions
15 %bcond_with     avx             # use AVX instructions
16 %bcond_without  opencl          # OpenCL support
17 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
18 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
19 %bcond_without  opengl          # OpenGL support
20 %bcond_without  gomp            # OpenMP support (available when not using tbb)
21 %bcond_without  examples        # Install examples
22 # - bindings
23 %bcond_without  java            # Java binding
24 # - highgui options:
25 %bcond_without  ffmpeg          # FFMpeg support in highgui
26 %bcond_without  gstreamer       # GStreamer support in highgui
27 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
28 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
29 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
30 %bcond_with     unicap          # Unicap support in highgui (GPL)
31 %bcond_without  v4l             # Video4Linux in highgui
32 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
33 %bcond_with     xine            # XINE support in highgui (GPL)
34 # - other modules
35 %bcond_without  vtk             # VTK library support (opencv_viz module)
36
37 %ifarch pentium3 pentium4 %{x8664} x32
38 %define         with_sse        1
39 %endif
40 %ifarch pentium4 %{x8664} x32
41 %define         with_sse2       1
42 %endif
43 Summary:        A library of programming functions mainly aimed at real time computer vision
44 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
45 Name:           opencv
46 Version:        2.4.10.1
47 Release:        1
48 Epoch:          1
49 %if %{with unicap} || %{with xine}
50 License:        GPL (enforced by used libraries), BSD (opencv itself)
51 %else
52 License:        BSD
53 %endif
54 Group:          Libraries
55 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
56 # Source0-md5:  f84af999f45edc829bfda60a13fedbaa
57 Patch0:         %{name}-cflags.patch
58 Patch1:         %{name}-x86.patch
59 Patch2:         %{name}-unicap-c++.patch
60 Patch3:         %{name}-c.patch
61 Patch4:         %{name}-gcc.patch
62 Patch5:         %{name}-ximea.patch
63 Patch6:         %{name}-ocl-fft.patch
64 Patch7:         java-ant-sourcelevel.patch
65 Patch8:         %{name}-shared.patch
66 Patch9:         no-sysctl.patch
67 Patch10:        cmake-install-path.patch
68 URL:            http://www.opencv.org/
69 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
70 %{?with_opencl:BuildRequires:   OpenCL-devel}
71 BuildRequires:  OpenEXR-devel
72 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
73 %{?with_opengl:BuildRequires:   OpenGL-devel}
74 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
75 %{?with_openni:BuildRequires:   OpenNI-devel}
76 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
77 %{?with_java:BuildRequires:     ant}
78 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
79 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
80 BuildRequires:  cmake >= 2.8
81 BuildRequires:  doxygen
82 BuildRequires:  eigen3 >= 3
83 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
84 %{?with_gomp:BuildRequires:     gcc-c++ >= 6:4.2}
85 %if %{with gstreamer}
86 BuildRequires:  gstreamer-devel >= 1.0
87 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
88 %endif
89 BuildRequires:  jasper-devel
90 %{?with_java:BuildRequires:     jdk}
91 BuildRequires:  libdc1394-devel >= 2
92 %{?with_gomp:BuildRequires:     libgomp-devel}
93 BuildRequires:  libjpeg-devel
94 BuildRequires:  libpng-devel
95 BuildRequires:  libraw1394-devel
96 BuildRequires:  libstdc++-devel
97 BuildRequires:  libtiff-devel
98 BuildRequires:  libtool
99 %if %{with unicap}
100 BuildRequires:  libucil-devel
101 BuildRequires:  libunicap-devel
102 %endif
103 BuildRequires:  libv4l-devel
104 BuildRequires:  pkgconfig
105 BuildRequires:  python >= 2.0
106 BuildRequires:  python-devel >= 2.0
107 BuildRequires:  python-numpy-devel
108 BuildRequires:  rpm-pythonprov
109 BuildRequires:  rpmbuild(macros) >= 1.606
110 BuildRequires:  sed >= 4.0
111 BuildRequires:  sphinx-pdg
112 BuildRequires:  swig-python
113 %{?with_tbb:BuildRequires:      tbb-devel}
114 %if %{with vtk}
115 BuildRequires:  vtk-devel >= 5.8.0
116 BuildRequires:  vtk-java >= 5.8.0
117 BuildRequires:  vtk-tcl >= 5.8.0
118 %endif
119 %{?with_xine:BuildRequires:     xine-lib-devel}
120 BuildRequires:  xorg-lib-libX11-devel
121 BuildRequires:  zlib-devel
122 %if %{with qt}
123 BuildRequires:  QtCore-devel >= 4
124 BuildRequires:  QtGui-devel >= 4
125 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
126 BuildRequires:  qt4-qmake >= 4
127 %else
128 BuildRequires:  gtk+2-devel >= 2.0
129 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
130 %endif
131 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
132 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
133
134 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
135
136 %description
137 OpenCV (Open Source Computer Vision) is a library of programming
138 functions mainly aimed at real time computer vision.
139
140 Example applications of the OpenCV library are:
141 - Human-Computer Interaction (HCI)
142 - Object Identification, Segmentation and Recognition
143 - Face Recognition
144 - Gesture Recognition
145 - Motion Tracking
146 - Ego Motion, Motion Understanding
147 - Structure From Motion (SFM)
148 - Stereo and Multi-Camera Calibration and Depth Computation
149 - Mobile Robotics.
150
151 %description -l pl.UTF-8
152 OpenCV (Open Source Computer Vision) to biblioteka funkcji
153 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
154
155 Przykładowe zastosowania biblioteki OpenCV to
156 - interakcje człowiek-komputer (HCI)
157 - identyfikacja, segmentacja i rozpoznawanie obiektów
158 - rozpoznawanie twarzy
159 - rozpoznawanie gestów
160 - śledzenie ruchu
161 - rozumienie ruchu
162 - SFM (Structure From Motion)
163 - kalibracja dwu- i wielokamerowa, obliczanie głębi
164 - robotyka ruchu.
165
166 %package core
167 Summary:        OpenCV core libraries
168 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
169 Group:          Libraries
170 Conflicts:      opencv < 2.4.6.2-1
171
172 %description core
173 This package contains the OpenCV C/C++ core libraries.
174
175 %description core -l pl.UTF-8
176 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
177
178 %package viz
179 Summary:        OpenCV viz library (VTK support)
180 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
181 Group:          Libraries
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183
184 %description viz
185 OpenCV viz library (VTK support).
186
187 %description viz -l pl.UTF-8
188 Biblioteka OpenCV viz (obsługa VTK).
189
190 %package devel
191 Summary:        Header files for OpenCV library
192 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
193 Group:          Development/Libraries
194 Requires:       %{name} = %{epoch}:%{version}-%{release}
195 %if %{with vtk}
196 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
197 %endif
198 Obsoletes:      opencv-static
199
200 %description devel
201 Header files for OpenCV library.
202
203 %description devel -l pl.UTF-8
204 Pliki nagłówkowe biblioteki OpenCV.
205
206 %package doc
207 Summary:        Manual for OpenCV
208 Summary(fr.UTF-8):      Documentation pour OpenCV
209 Summary(it.UTF-8):      Documentazione di OpenCV
210 Summary(pl.UTF-8):      Podręcznik dla OpenCV
211 Group:          Documentation
212 # noarch subpackages only when building with rpm5
213 %if "%{_rpmversion}" >= "5"
214 BuildArch:      noarch
215 %endif
216
217 %description doc
218 Documentation for OpenCV.
219
220 %description doc -l fr.UTF-8
221 Documentation pour OpenCV.
222
223 %description doc -l it.UTF-8
224 Documentazione di OpenCV.
225
226 %description doc -l pl.UTF-8
227 Dokumentacja do OpenCV.
228
229 %package examples
230 Summary:        OpenCV code examples
231 Group:          Documentation
232 %if "%{_rpmversion}" >= "5"
233 BuildArch:      noarch
234 %endif
235
236 %description examples
237 OpenCV code examples.
238
239 %package -n java-opencv
240 Summary:        OpenCV Java bindings
241 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
242 Group:          Libraries/Java
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244 Requires:       jre
245
246 %description -n java-opencv
247 OpenCV Java bindings.
248
249 %description -n java-opencv -l pl.UTF-8
250 Wiązania Javy do OpenCV.
251
252 %package -n python-opencv
253 Summary:        OpenCV Python bindings
254 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
255 Group:          Libraries/Python
256 Requires:       %{name} = %{epoch}:%{version}-%{release}
257 Requires:       python-libs
258
259 %description -n python-opencv
260 OpenCV Python bindings.
261
262 %description -n python-opencv -l pl.UTF-8
263 Wiązania Pythona do OpenCV.
264
265 %prep
266 %setup -q
267
268 %undos CMakeLists.txt
269 %undos modules/gpu/CMakeLists.txt
270
271 %patch0 -p1
272 %patch1 -p1
273 %patch2 -p1
274 %patch3 -p1
275 %patch4 -p1
276 %patch5 -p1
277 %patch6 -p1
278 %patch7 -p1
279 %patch8 -p1
280 %patch9 -p1
281 %patch10 -p1
282
283 %build
284 install -d build
285 cd build
286
287 # handle cmake & ccache
288 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
289 if [[ "%{__cc}" = *ccache* ]]; then
290         cc="%{__cc}"
291         cxx="%{__cxx}"
292         ccache="
293         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
294         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
295         "
296 fi
297
298 %cmake .. \
299         $ccache \
300         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
301         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
302         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
303         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
304         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
305         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
306         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
307         -DBUILD_NEW_PYTHON_SUPPORT=ON \
308 %if %{with examples}
309         -DINSTALL_C_EXAMPLES=ON \
310         -DINSTALL_PYTHON_EXAMPLES=ON \
311 %endif
312         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
313         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
314         %{?with_opencl:-DWITH_OPENCL=ON} \
315         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
316         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
317         %{?with_opengl:-DWITH_OPENGL=ON} \
318         %{?with_gomp:-DWITH_OPENMP=ON} \
319         %{?with_openni:-DWITH_OPENNI=ON} \
320         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
321         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
322         %{?with_tbb:-DWITH_TBB=ON} \
323         %{?with_unicap:-DWITH_UNICAP=ON} \
324         %{!?with_v4l:-DWITH_V4L=OFF} \
325         %{?with_vtk:-DWITH_VTK=ON} \
326         %{?with_ximea:-DWITH_XIMEA=ON} \
327         %{?with_xine:-DWITH_XINE=ON}
328
329 %{__make}
330
331 %install
332 rm -rf $RPM_BUILD_ROOT
333 %{__make} -C build install \
334         DESTDIR=$RPM_BUILD_ROOT
335
336 # see -doc package
337 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
338 %if %{with examples}
339 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
340 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
341 %endif
342
343 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
344 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
345
346 # disable completeness check incompatible with split packaging
347 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
348
349 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
350 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
351 %py_postclean
352
353 %if %{with java}
354 # move to proper directories, create symlink
355 install -d $RPM_BUILD_ROOT%{_javadir}
356 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
357 sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
358         $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
359 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
360 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
361 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
362 %endif
363
364 %clean
365 rm -rf $RPM_BUILD_ROOT
366
367 %post   -p /sbin/ldconfig
368 %postun -p /sbin/ldconfig
369
370 %post   core -p /sbin/ldconfig
371 %postun core -p /sbin/ldconfig
372
373 %post   viz -p /sbin/ldconfig
374 %postun viz -p /sbin/ldconfig
375
376 %post   -n java-opencv -p /sbin/ldconfig
377 %postun -n java-opencv -p /sbin/ldconfig
378
379 %files
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_bindir}/opencv_createsamples
382 %attr(755,root,root) %{_bindir}/opencv_haartraining
383 %attr(755,root,root) %{_bindir}/opencv_performance
384 %attr(755,root,root) %{_bindir}/opencv_traincascade
385 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
386 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
387 %attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
388 %attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
389 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
390 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
391 %attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
392 %attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
393 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
394 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
395 %attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
396 %attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
397 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
398 %attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
399 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
400 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
401 %if %{with opencl}
402 %attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
403 %attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
404 %endif
405 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
406 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
407 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
408 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
409 %attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
411 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
412 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
413 %dir %{_datadir}/OpenCV
414 %{_datadir}/OpenCV/haarcascades
415 %{_datadir}/OpenCV/lbpcascades
416
417 %files core
418 %defattr(644,root,root,755)
419 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
420 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
421 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
423 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
424 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
425 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
426 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
427 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
429 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
430 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
431
432 %if %{with vtk}
433 %files viz
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
436 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
437 %endif
438
439 %files devel
440 %defattr(644,root,root,755)
441 # core
442 %attr(755,root,root) %{_libdir}/libopencv_core.so
443 %attr(755,root,root) %{_libdir}/libopencv_flann.so
444 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so
445 %attr(755,root,root) %{_libdir}/libopencv_ml.so
446 %attr(755,root,root) %{_libdir}/libopencv_photo.so
447 %attr(755,root,root) %{_libdir}/libopencv_video.so
448 # GUI/extensions (base package)
449 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
450 %attr(755,root,root) %{_libdir}/libopencv_contrib.so
451 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
452 %attr(755,root,root) %{_libdir}/libopencv_gpu.so
453 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
454 %attr(755,root,root) %{_libdir}/libopencv_legacy.so
455 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so
456 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
457 %if %{with opencl}
458 %attr(755,root,root) %{_libdir}/libopencv_ocl.so
459 %endif
460 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
461 %attr(755,root,root) %{_libdir}/libopencv_superres.so
462 %attr(755,root,root) %{_libdir}/libopencv_ts.so
463 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
464 # viz
465 %if %{with vtk}
466 %attr(755,root,root) %{_libdir}/libopencv_viz.so
467 %endif
468 %{_includedir}/opencv
469 %{_includedir}/opencv2
470 %{_datadir}/OpenCV/OpenCV*.cmake
471 %{_pkgconfigdir}/opencv.pc
472
473 %files doc
474 %defattr(644,root,root,755)
475 # TODO: probably could rebuild them and package via make install
476 %doc doc/*
477
478 %if %{with examples}
479 %files examples
480 %defattr(644,root,root,755)
481 %{_examplesdir}/%{name}-%{version}
482 %endif
483
484 %if %{with java}
485 %files -n java-opencv
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
488 %{_javadir}/opencv-%{jver}.jar
489 %{_javadir}/opencv.jar
490 %endif
491
492 %files -n python-opencv
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{py_sitedir}/cv2.so
495 %{py_sitedir}/cv.py[co]
This page took 0.103912 seconds and 4 git commands to generate.